source: projects/specs/branches/6/l/lshw/lshw-vl.spec @ 6364

Revision 6364, 4.8 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild or update packages

Line 
1Summary: Hardware information listing tool
2Summary(ja): ハードウェア情報表示ツール
3Name:    lshw
4Version: B.02.16
5Release: 1%{?_dist_release}
6License: GPLv2
7Group:   Applications/System
8URL:     http://ezix.org/project/wiki/HardwareLiSter
9Source0: http://www.ezix.org/software/files/%{name}-%{version}.tar.gz
10Source1: lshw.desktop
11Source2: lshw.consolehelper
12Source3: lshw.pam
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15BuildRequires: sqlite3-devel
16
17%description
18lshw (Hardware Lister) is a small tool to provide detailed informaton on
19the hardware configuration of the machine. It can report exact memory
20configuration, firmware version, mainboard configuration, CPU version and
21speed, cache configuration, bus speed, etc. on DMI-capable x86 systems
22and on some PowerPC machines (PowerMac G4 is known to work).
23
24Information can be output in plain text, XML or HTML.
25
26%package gui
27Summary:  Graphical hardware lister
28Summary(ja): グラフィカルなハードウエア情報表示ツール
29Group:    Applications/System
30Requires: usermode
31Requires: %{name} = %{version}-%{release}
32BuildRequires: gtk2-devel >= 2.4
33BuildRequires: desktop-file-utils
34
35%description gui
36Graphical frontend for the hardware lister (lshw) tool.
37If desired, hardware information can be saved to file in
38plain, XML or HTML format.
39
40%prep
41%setup -q -n %{name}-%{version}
42
43%{__sed} -i 's|-g -Wall -g|%{optflags}|' src/Makefile
44%{__sed} -i 's|-g -Wall -Os|%{optflags}|' src/core/Makefile
45%{__sed} -i 's|-g -Wall -Os|%{optflags}|' src/gui/Makefile
46%{__sed} -i 's|LDFLAGS= -Os -s|LDFLAGS=|' src/gui/Makefile
47
48%build
49%{__make} %{?_smp_mflags} SBINDIR="%{_sbindir}" gui
50
51# Replace copyrighted icons
52pushd src
53%{__make} nologo
54
55%install
56%{__rm} -rf %{buildroot}
57%{__make} install              \
58        DESTDIR="%{buildroot}" \
59        PREFIX="%{_prefix}"    \
60        SBINDIR="%{_sbindir}"  \
61        MANDIR="%{_mandir}"    \
62        INSTALL="%{__install} -p"
63
64%{__make} install-gui          \
65        DESTDIR="%{buildroot}" \
66        PREFIX="%{_prefix}"    \
67        SBINDIR="%{_sbindir}"  \
68        MANDIR="%{_mandir}"    \
69        INSTALL="%{__install} -p"
70
71%{__ln_s} -f gtk-lshw %{buildroot}%{_sbindir}/lshw-gui
72
73# desktop icon
74%{__install} -D -m 0644 -p ./src/gui/artwork/logo.svg \
75     %{buildroot}%{_datadir}/pixmaps/%{name}-logo.svg
76
77desktop-file-install --vendor ""  \
78  --dir %{buildroot}%{_datadir}/applications %{SOURCE1}
79
80# consolehelper
81%{__install} -d %{buildroot}%{_bindir}
82%{__ln_s} -f consolehelper %{buildroot}%{_bindir}/%{name}-gui
83%{__install} -D -m 0644 %{SOURCE2} \
84   %{buildroot}%{_sysconfdir}/security/console.apps/%{name}-gui
85%{__install} -D -m 0644 %{SOURCE3} \
86   %{buildroot}%{_sysconfdir}/pam.d/%{name}-gui
87
88%clean
89%{__rm} -rf %{buildroot}
90
91%files
92%defattr(-, root, root, -)
93%doc COPYING README docs/*
94%doc %{_mandir}/man1/lshw.1*
95%{_sbindir}/%{name}
96%dir %{_datadir}/%{name}
97%{_datadir}/%{name}/*.txt
98%{_datadir}/%{name}/*.ids
99
100%files gui
101%defattr(-, root, root, -)
102%doc COPYING
103%config(noreplace) %{_sysconfdir}/pam.d/%{name}-gui
104%config(noreplace) %{_sysconfdir}/security/console.apps/%{name}-gui
105%{_bindir}/%{name}-gui
106%{_sbindir}/gtk-%{name}
107%{_sbindir}/%{name}-gui
108%{_datadir}/%{name}/artwork
109%{_datadir}/%{name}/ui/gtk-%{name}.ui
110%{_datadir}/pixmaps/%{name}-logo.svg
111%{_datadir}/applications/%{name}.desktop
112
113%changelog
114* Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> B.02.16-1
115- update to B.02.16
116- add BuildRequires: sqlite3-devel
117
118* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> B.02.13-1
119- new upstream release
120
121* Sun Dec 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> B.02.12.01-0vl1
122- initial build for Vine Linux
123
124* Mon Nov  5 2007 Terje Rosten <terjeros@phys.ntnu.no> - B.02.12.01-1
125- B.02.12.01
126- Replace trademark icons
127
128* Tue Aug 14 2007 Terje Rosten <terjeros@phys.ntnu.no> - B.02.11.01-3
129- Move desktop and pam config to files
130- Simplify build
131
132* Tue Aug 07 2007 Terje Rosten <terjeros@phys.ntnu.no> - B.02.11.01-2
133- Remove trademarks
134
135* Mon Aug 06 2007 Terje Rosten <terjeros@phys.ntnu.no> - B.02.11.01-1
136- B.02.11.01
137
138* Sun Aug 05 2007 Terje Rosten <terjeros@phys.ntnu.no> - B.02.11-3
139- Move artwork to gui subpackage
140- Implement consolehelper support
141
142* Sat Aug 04 2007 Terje Rosten <terjeros@phys.ntnu.no> - B.02.11-2
143- License is GPLv2 (only)
144- Fix ui %%description
145
146* Wed Aug 01 2007 Terje Rosten <terjeros@phys.ntnu.no> - B.02.11-1
147- Follow upstream version scheme
148
149* Wed Jul 25 2007 Terje Rosten <terjeros@phys.ntnu.no> - 2.11-1
150- 2.11
151
152* Wed Jun 27 2007 Terje Rosten <terjeros@phys.ntnu.no> - 2.10-2
153- minor fixes
154- add patch to avoid stripping
155- add desktop file
156- strip changelog
157- move from sbin to bin
158- new url
159
160* Wed Feb 14 2007 Dag Wieers <dag@wieers.com> - 2.10-1 - 4876+/dag
161- Updated to release B.02.10.
162
163* Tue Dec 21 2004 Dag Wieers <dag@wieers.com> - 2.0-1
164- Initial package. (using DAR)
165
Note: See TracBrowser for help on using the repository browser.