source: projects/specs/branches/6/l/lpr/lpr-vl.spec @ 521

Revision 521, 7.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A utility that manages print jobs.
2Name: lpr
3Version: 0.50
4Release: 7vl3
5Copyright: distributable
6Group: System Environment/Daemons
7Source: lpr-%{PACKAGE_VERSION}.tar.gz
8Patch: lpd.init-export-lang.diff
9Prereq: /sbin/chkconfig
10BuildRoot: /var/tmp/%{name}-root
11
12Summary(ja): ¥×¥ê¥ó¥È¥¸¥ç¥Ö´ÉÍý¥æ¡¼¥Æ¥£¥ê¥Æ¥£
13
14Vendor: Project Vine
15Distribution: Vine Linux
16
17%description
18The lpr package provides the basic system utility for managing
19printing services.  Lpr manages print queues, sends print jobs to
20local and remote printers and accepts print jobs from remote clients.
21
22If you will be printing from your system, you'll need to install the
23lpr package.
24
25%prep
26%setup -q
27%patch -p0 -b .vine
28
29%build
30
31%ifarch alpha
32# we shouldn't need this with more recent glibc's, but lpq kills remote
33# lpd w/o it
34make RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Dgetline=get_line"
35%else
36make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
37%endif
38
39%install
40rm -rf $RPM_BUILD_ROOT
41mkdir -p $RPM_BUILD_ROOT/usr/{bin,sbin,man/man1,man/man5,man/man8}
42
43%ifarch alpha
44# we shouldn't need this with more recent glibc's, but lpq kills remote
45# lpd w/o it and there seems to be a mistake in lpr's makefiles somewhere
46make RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Dgetline=get_line" DESTDIR=$RPM_BUILD_ROOT install
47%else
48make DESTDIR=$RPM_BUILD_ROOT install
49%endif
50chmod -x $RPM_BUILD_ROOT/usr/man/*/*
51
52mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
53install -m755 lpd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/lpd
54( cd $RPM_BUILD_ROOT
55mkdir -p ./etc/rc.d/{rc0.d,rc1.d,rc2.d,rc3.d,rc4.d,rc5.d,rc6.d}
56  ln -sf ../init.d/lpd ./etc/rc.d/rc0.d/K60lpd
57  ln -sf ../init.d/lpd ./etc/rc.d/rc1.d/K60lpd
58  ln -sf ../init.d/lpd ./etc/rc.d/rc2.d/S60lpd
59  ln -sf ../init.d/lpd ./etc/rc.d/rc3.d/S60lpd
60  ln -sf ../init.d/lpd ./etc/rc.d/rc5.d/S60lpd
61  ln -sf ../init.d/lpd ./etc/rc.d/rc6.d/K60lpd
62  mkdir -p ./var/spool/lpd
63)
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%post
69/sbin/chkconfig --add lpd
70
71%preun
72if [ $1 = 0 ]; then
73   /sbin/chkconfig --del lpd
74fi
75
76%files
77%defattr(-,root,root)
78%attr(6555,root,lp) /usr/bin/lpq
79%attr(6555,root,lp) /usr/bin/lpr
80%attr(6555,root,lp) /usr/bin/lprm
81/usr/bin/lptest
82/usr/man/man1/lpq.1*
83/usr/man/man1/lpr.1*
84/usr/man/man1/lprm.1*
85/usr/man/man1/lptest.1*
86/usr/man/man5/printcap.5*
87/usr/man/man8/lpc.8*
88/usr/man/man8/lpd.8*
89/usr/man/man8/pac.8*
90%attr(2755,root,lp) /usr/sbin/lpc
91/usr/sbin/lpd
92/usr/sbin/lpf
93/usr/sbin/pac
94%attr(0775,root,daemon) %dir /var/spool/lpd
95%config /etc/rc.d/init.d/lpd
96%config(missingok) /etc/rc.d/rc0.d/K60lpd
97%config(missingok) /etc/rc.d/rc1.d/K60lpd
98%config(missingok) /etc/rc.d/rc2.d/S60lpd
99%config(missingok) /etc/rc.d/rc3.d/S60lpd
100%config(missingok) /etc/rc.d/rc5.d/S60lpd
101%config(missingok) /etc/rc.d/rc6.d/K60lpd
102
103%changelog
104* Sat Jan  6 2001 Jun Nishii <jun@vinelinux.org>
105- 0.50-7vl3
106- merge lpd.init-export-lang.diff ([vine-users:030229]) instead of lpd.init-vine.diff
107  tnanks Masami Ashida <Masami.Ashida@mb7.seikyou.ne.jp for the bug report
108  and thanks Yasuhide OOMORI <dasen@icntv.ne.jp> for the patch
109
110* Tue Dec 19 2000 Shoji Matsumoto <shom@vinelinux.org>
111- add lpd.init-vine.diff
112
113* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
114- Eratta from RHSA
115
116* Mon Oct  2 2000 Crutcher Dunnavant <crutcher@redhat.com>
117- Fixed bug #11740
118- Which was causing deadlocks in the queue in some situations.
119- Still possible, though much less likely.
120
121* Mon Sep 25 2000 Crutcher Dunnavant <crutcher@redhat.com>
122- Fixed a format string bug in lpd/printjob.c
123
124* Wed Aug 16 2000 Crutcher Dunnavant <crutcher@redhat.com>
125- fixed some evil in lpd/printjob.c that treated unspeced command lines
126- in the control file as print job files. (print was the default case)
127- this keeps lpd from screaming error messages/email when smatter lpd
128- servers talk to it.
129
130* Mon Feb 14 2000 Bernhard Rosenkraenzer <bero@redhat.com>
131- Fix interoperability with MacOS client (Bug #7593)
132
133* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
134- Remove executable bit from lpq man page (Bug #9035)
135- deal with rpm compressing man pages
136
137* Mon Jan 24 2000 Bill Nottingham <notting@redhat.com>
138- you're saying core dumps in the spooldir are a bad idea?
139
140* Tue Jan 18 2000 Bill Nottingham <notting@redhat.com>
141- *sigh*
142
143* Thu Jan  6 2000 Bill Nottingham <notting@redhat.com>
144- more security fixes
145
146* Tue Nov  7 1999 Bill Nottingham <notting@redhat.com>
147- add a 'custom' parameter 'Z' to cf files (GOMEZ@slib.fr)
148
149* Fri Oct 22 1999 Bill Nottingham <notting@redhat.com>
150- oops. slightly overzealous in dropping ids.
151
152* Tue Oct 19 1999 Bill Nottingham <notting@redhat.com>
153- fix a stupid typo.
154
155* Fri Oct 15 1999 Bill Nottingham <notting@redhat.com>
156- fix some security issues.
157
158* Fri Oct  8 1999 Bill Nottingham <notting@redhat.com>
159- squash multiple copies bug, hopefully permanently...
160
161* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
162- chkconfig --del on %preun, not %postun
163
164* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
165- fix suppress headers on remote printers
166
167* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
168- initscript munging
169
170* Mon Aug  2 1999 Bill Nottingham <notting@redhat.com>
171- fix multiple copy remote printing
172
173* Thu Jul 29 1999 Bill Nottingham <notting@redhat.com>
174- add lp group when exec()ing filter, so .config file with passwords
175  can be non-world-readable...
176
177* Mon Jul 12 1999 Bill Nottingham <notting@redhat.com>
178- fix possible core dumps in lpc (ms@bee.de, #3776)
179
180* Wed Jun 23 1999 Bill Nottingham <notting@redhat.com>
181- add lp= capability support (#3683)
182
183* Thu Jun 17 1999 Bill Nottingham <notting@redhat.com>
184- fixes for job removal (#2676)
185
186* Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
187- fix for RS capability (#3217)
188
189* Mon May 10 1999 Bill Nottingham <notting@redhat.com>
190- RFC 1179 compliance actually works now...
191
192* Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
193- make lpr RFC 1179 compliant
194
195* Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
196- increase buffer length for filenames (bug #1676)
197
198* Fri Mar 19 1999 Bill Nottingham <notting@redhat.com>
199- change man page to show that -r -s is not supported (bug #717)
200
201* Mon Feb 15 1999 Bill Nottingham <notting@redhat.com>
202- security patch from Chris Evans
203- fix for remote but not local users (originally from Kevin Sochacki)
204
205* Mon Feb  8 1999 Bill Nottingham <notting@redhat.com>
206- build for 6.0 tree
207
208* Thu Oct  1 1998 Bill Nottingham <notting@redhat.com>
209- don't ignore SIGCHLD in filters
210
211* Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
212- build root.
213
214* Fri Jun 26 1998 Jeff Johnson <jbj@redhat.com>
215- bring printjob up-to-date (fix problem #564)
216
217* Thu Apr 23 1998 Michael K. Johnson <johnsonm@redhat.com>
218- enhanced initscript
219
220* Thu Apr 23 1998 Erik Troan <ewt@redhat.com>
221- included new rmjob security fix from BSD
222
223* Sat Apr 18 1998 Erik Troan <ewt@redhat.com>
224- included rmjob patches from BSD
225
226* Fri Feb 27 1998 Otto Hammersmith <otto@redhat.com>
227- increased buffer for hostname from 32 to 1024, plenty big enough now.
228
229* Wed Oct 29 1997 Donnie Barnes <djb@redhat.com>
230- added chkconfig support
231- changed the initscript name from lpd.init to lpd (all links, too)
232
233* Mon Oct 27 1997 Michael Fulbright <msf@redhat.com>
234- Fixed print filters to change to printer's UID so root-squashing wont bite us
235
236* Wed Oct  8 1997 Michael Fulbright <msf@redhat.com>
237- Fixed nasty error in getprent() and forked lpd's in startup() which
238  caused the printcap file to be read incorrectly.
239- added #include <string.h> as needed to make compile cleaner. 
240
241* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
242- changes for glibc 2.0.4
243
244* Tue Apr 22 1997 Michael Fulbright <msf@redhat.com>
245- moved to v. 0.17, then 0.18 (!)
246- Fixed bug on Alpha/glibc when printing to a remote queue via a filter
247
248* Fri Mar 28 1997 Michael Fulbright <msf@redhat.com>
249- Moved version up to 0.16
250- Added input filter support for remote queues
251
252* Wed Mar 05 1997 Erik Troan <ewt@redhat.com>
253- Incorporated filter patch into main sources
254- Removed RCS logs from source tar file
255- Added patched from David Mosberger to fix __ivaliduser on Alpha's
256- added -Dgetline=get_line for old glibcs (this means alpha)
Note: See TracBrowser for help on using the repository browser.