source: projects/specs/branches/6/l/loudmouth/loudmouth-vl.spec @ 1988

Revision 1988, 7.3 KB checked in by owa, 13 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%define with_ssl   1
2%define gnutls_ver 1.4.0
3
4Summary:        Loudmouth is a Jabber programming library written in C
5
6Name:           loudmouth
7Version:        1.4.3
8Release: 2%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.loudmouth-project.org/
13Source0:        http://ftp.imendio.com/pub/imendio/%{name}/src/%{name}-%{version}.tar.bz2
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  glib2-devel >= 2.4.0
18BuildRequires:  check-devel
19BuildRequires:  libidn-devel
20BuildRequires:  libasyncns-devel
21%if %{with_ssl}
22BuildRequires:  gnutls-devel >= %{gnutls_ver}
23%endif
24
25
26%description
27Loudmouth is a lightweight and easy-to-use C library for programming
28with the Jabber protocol. It's designed to be easy to get started with
29and yet extensible to let you do anything the Jabber protocol allows.
30
31
32%package devel
33Summary:        Development files for %{name}
34Summary(ja):    Development files for %{name}
35Group:          Development/Libraries
36Requires:       %{name} = %{version}-%{release}
37Requires:       glib2-devel
38Requires:       libidn-devel
39Requires:       pkgconfig
40%if %{with_ssl}
41Requires:       gnutls-devel
42%endif
43
44
45%description devel
46The %{name}-devel package contains libraries and header files for
47developing applications that use %{name}.
48
49
50%prep
51%setup -q
52
53
54%build
55%configure --enable-static=no   \
56           --with-asyncns=yes   \
57%if %{with_ssl}
58           --with-ssl=gnutls
59%else
60           --with-ssl=no
61%endif
62
63make %{?_smp_mflags}
64
65
66%install
67rm -rf $RPM_BUILD_ROOT
68make install DESTDIR=$RPM_BUILD_ROOT
69find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
70
71# Copy the files from the tarball to avoid the IDs generated by gtk-doc being
72# different on different builds
73mkdir -p $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/%{name}/
74cp -a docs/reference/html/* $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/%{name}/
75
76
77%check
78make check
79
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84
85%post -p /sbin/ldconfig
86
87
88%postun -p /sbin/ldconfig
89
90
91%files
92%defattr(-,root,root,-)
93%doc ChangeLog NEWS README COPYING
94%{_libdir}/libloudmouth*.so.*
95
96
97%files devel
98%defattr(-,root,root,-)
99%{_libdir}/libloudmouth*.so
100%{_libdir}/pkgconfig/%{name}-1.0.pc
101%{_includedir}/%{name}-1.0
102%{_datadir}/gtk-doc/html/%{name}
103
104
105%changelog
106* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.4.3-2
107- rebuilt with rpm-4.8.1 for pkg-config
108
109* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.3-1
110- Update to 1.4.3
111- build with new gnutls
112
113* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-1
114- initial build for Vine Linux
115
116* Thu Aug 28 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.2-1
117- Update to 1.4.2.
118- Enable libasyncns support.
119
120* Sat Aug  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.1-1
121- Update to 1.4.1.
122
123* Wed Jun 25 2008 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
124- rebuild with new gnutls
125
126* Tue Jun 10 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.0-1
127- Update to 1.4.0.
128
129* Wed Apr  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.3.4-1
130- Update to 1.3.4.
131- Run check test.
132- Bump min version needed for gnutls-devel.
133- Drop stream-error.patch. Fixed upstream.
134- Drop eai-nodata.patch. Fixed upstream.
135- Drop connect-fail-sync.patch. Fixed upstream.
136- Drop connect-fail-async patch. Fixed upstream.
137- Update URL & Source URL.
138- Don't generate the gtk-doc docs, and use the ones in the tarball
139  to avoid having different files in different builds, fixes
140  multilib problems (#342551)
141
142* Thu Feb 21 2008 Owen Taylor <otaylor@redhat.com> - 1.3.3-4
143- Fix build with recent GNU libc
144
145* Thu Feb  7 2008 Owen Taylor <otaylor@redhat.com> - 1.3.3-3
146- Add patches fixing reentrancy problems on connection failure
147
148* Wed Jan 30 2008 Owen Taylor <otaylor@redhat.com> - 1.3.3-2
149- Add back stream-error patch, it wasn't fixed in the 1.3 branch
150
151* Fri Jan 18 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.3.3-1
152- Update to 1.3.3.
153- Drop reconnect-failure patch.
154- Drop gnutls compression patch. fixed upstream.
155
156* Thu Nov 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-6
157- Ugh.  Let's acutally use a valid e-mail addy.
158
159* Thu Nov 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-5
160- Add patch to use gnutls compression.
161
162* Mon Nov 12 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-4
163- Add reconnect-failure patch. Thanks to Robert McQueen.
164
165* Tue Aug 21 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-3
166- Rebuild.
167
168* Sun Aug  5 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-2
169- Update license tag.
170
171* Sun Jun 10 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-1
172- Update to 1.2.3.
173- Drop stream-error patch. fixed upstream.
174
175* Wed May 16 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-3
176- Add patch to fix stream error.
177
178* Tue May 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-2
179- Drop BR on libtasn1-devel.
180
181* Mon May 14 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-1
182- Update to 1.2.2.
183
184* Sat Feb 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.1-2
185- Fix typo.
186
187* Sat Feb 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.1-1
188- Update to 1.2.1.
189
190* Tue Feb 20 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-3
191- Add necessary requires to devel package. D'Oh!
192
193* Tue Feb 20 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-2
194- Add BR on libidn-devel.
195- Specify which ssl implementation to use.
196
197* Mon Feb  5 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-1
198- Update to 1.2.0.
199- Drop mono config option since it's been dropped from the tarball.
200
201* Mon Sep 11 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.5-2
202- Change source to .gz.
203
204* Mon Sep 11 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.5-1
205- Update to 1.0.5.
206
207* Tue Aug 29 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.4-3
208- Rebuild for FC6.
209- Simplify devel description.
210
211* Thu Jun 29 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.4-2
212- Update to 1.0.4.
213- Add devel requires on pkgconfig.
214- Drop reentrancy patch, fixed upstream.
215
216* Thu Jun 15 2006 Jeremy Katz <katzj@redhat.com> - 1.0.3-5
217- rebuild for new gnutls
218
219* Fri May 26 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.3-4
220- Add patch to fix some reentrancy crashes.  (Thanks, Havoc)
221
222* Wed Apr  5 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.3-3
223- Update to 1.0.3.
224- Add BR for gnutls-devel to devel package.
225- Disable static libs.
226- Add BR for check-devel.
227
228* Thu Feb 16 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-6
229- Remove unnecessary BR (libgcrypt-devel).
230
231* Mon Feb 13 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-5
232- rebuilt for new gcc4.1 snapshot and glibc changes
233
234* Mon Dec 26 2005 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-4
235- Rebuild.
236
237* Wed Aug 31 2005 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-3
238- Update to 1.0.1.
239
240* Sun Aug 14 2005 Brian Pepple <bdpepple@ameritech.net> - 1.0-2
241- Update to 1.0.
242
243* Mon Aug  8 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-5
244- Rebuild due to new gnutls.
245
246* Sat Jul 30 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-4
247- Fix description.
248
249* Fri May 13 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-2
250- Add dist tag.
251
252* Fri May 13 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-1
253- Update to 0.9.
254
255* Thu May  5 2005 Brian Pepple <bdpepple@ameritech.net> - 0.17.2-3
256- Adde glib2-devel requires.
257
258* Thu May  5 2005 Brian Pepple <bdpepple@ameritech.net> - 0.17.2-2
259- added %%{_includedir}.
260- Add libgcrypt-devel BR.
261
262* Sun May  1 2005 Brian Pepple <bdpepple@ameritech.net> - 0.17.2-1
263- Initial Fedora build.
264
Note: See TracBrowser for help on using the repository browser.