source: projects/specs/branches/6/l/lincity-ng/lincity-ng-vl.spec @ 5467

Revision 5467, 4.0 KB checked in by munepi, 12 years ago (diff)

updated lincity-ng-vl.spec

Line 
1%define alias_ttf /usr/share/fonts/TrueType-vlgothic/VL-PGothic-Regular.ttf
2
3%define name lincity-ng
4%define version 2.0
5%define release 5%{?_dist_release}
6Summary: City Simulation Game
7Summary(ja): 都市シミュレーションゲーム
8Name: %{name}
9Version: %{version}
10Release: %{release}
11Source: http://download.berlios.de/%{name}/%{name}-%{version}.tar.bz2
12License: GNU General Public License
13Group: Applications/Games
14URL: http://lincity-ng.berlios.de/
15
16Requires: TrueType-vlgothic
17Requires: SDL, SDL_image, SDL_mixer, SDL_ttf, SDL_gfx,
18Requires: zlib, libxml2, physfs
19BuildRequires: SDL-devel, SDL_image-devel, SDL_mixer-devel,
20BuildRequires: SDL_ttf-devel, SDL_gfx-devel,
21BuildRequires: mesa-libGL-devel, mesa-libGLU-devel
22BuildRequires: zlib-devel, libxml2-devel, physfs-devel,
23BuildRequires: jam, vorbis-tools
24BuildRequires: desktop-file-utils
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26
27%description
28LinCity-NG is a City Simulation Game. It is a polished and improved
29version of the old LinCity game. Within the scope of the GoTM
30project at happypenguin.org we create a new iso-3d graphics engine
31together with completely redone modern gui.
32
33%description
34LinCity-NG は都市シミュレーションゲームです。
35以前の LinCity を精錬し、改善されたバージョンです。
36
37
38%prep
39%setup -q
40sed -i "s/CFLAGS += -O3 -g -Wall/CFLAGS += $RPM_OPT_FLAGS/" Jamrules
41sed -i "s/CXXFLAGS += -O3 -g -Wall/CXXFLAGS += $RPM_OPT_FLAGS/" Jamrules
42
43%build
44#./autogen.sh
45# export CFLAGS="$RPM_OPT_FLAGS -fstack-protector" \
46#     CXXFLAGS="$RPM_OPT_FLAGS -fstack-protector"
47%configure
48jam
49
50%install
51%{__rm} -rf ${RPM_BUILD_ROOT}
52jam -s DESTDIR=${RPM_BUILD_ROOT} install
53
54### to convert the sounds
55for i in ${RPM_BUILD_ROOT}%{_datadir}/%{name}/sounds/*.wav; do
56    oggenc --quiet $i && rm $i
57done
58
59# font alias
60pushd $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
61ln -s %alias_ttf sans-ja_JP.ttf
62popd
63
64%clean
65%{__rm} -rf ${RPM_BUILD_ROOT}
66
67
68%check
69%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/lincity-ng.desktop
70
71
72%post
73if [ -x %{_bindir}/update-desktop-database ] ; then
74%{_bindir}/update-desktop-database %{_datadir}/applications
75fi
76
77%postun
78if [ -x %{_bindir}/update-desktop-database ] ; then
79%{_bindir}/update-desktop-database %{_datadir}/applications
80fi
81
82
83%files
84%defattr(-,root,root)
85%doc %{_datadir}/doc/%{name}-%{version}
86%{_bindir}/lincity-ng
87%{_datadir}/pixmaps/*
88%{_datadir}/applications/lincity-ng.desktop
89%{_datadir}/lincity-ng
90
91%changelog
92* Tue Jan 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0-5
93- rebuild
94
95* Mon Sep 20 2010 IWAI, Masaharu <iwai@alib.jp> 2.0-4
96- build with SDL_gfx 2.0.22
97- add BuildRequires: mesa-libGLU-devel
98- validating desktop file in %%check section
99- add %%post and %%postun sections for desktop file
100 - add BuildRequires: desktop-file-utils
101
102* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2.0-3
103- added Japanese Summary and description
104
105* Fri May 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.0-2
106- added Requires: TrueType-vlgothic
107- corrected symbolic link to sans-ja_JP.ttf
108
109* Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-1
110- new upstream release.
111- changed Group to Applications/Games
112
113* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.2-1vl5
114- new upstream release.
115- applied new versioning policy
116
117* Wed Jan 02 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-0vl2
118- rebuilt for VineSeed
119
120* Thu Sep 06 2007 Atsushi SHICHI <ats777@gmail.com> 1.1.1-0vl1
121- new upstream release.
122- update Source:.
123- add "BuildRequires: XOrg-gl-devel".
124
125* Mon Sep 3 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.1.0-0vl1
126- initial build for Vine Linux 4.1
127- add BuildRequires: vorbis-tools to convert the sounds
128
129* Sun Dec 11 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0.2-0vlmp1
130- minor version up
131
132* Sun Jul 24 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0.1-0vlmp1
133- minor version up
134
135* Fri Jun 24 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0-0vlmp1
136- initial build for Vine Linux 3.2
137
138
139# end of file
Note: See TracBrowser for help on using the repository browser.