source: projects/specs/branches/6/l/lilypond/lilypond-vl.spec @ 883

Revision 883, 15.7 KB checked in by owa, 14 years ago (diff)

updated lilypond and old libs

Line 
1%define buildinfo yes
2%define name lilypond
3%define iconsdir /usr/share/pixmaps
4%define infodir %{_infodir}/%{name}
5Summary:        A typesetting system for music notation
6Summary(ja):楽譜作成プログラム
7Group:          Applications/Publishing
8Name:           %{name}
9#Version:       2.4.5
10Version:        2.12.3
11Release:        1%{?_dist_release}
12License:        GPLv2
13URL:            http://www.lilypond.org/
14Source0:        http://download.linuxaudio.org/lilypond/sources/v2.12/%{name}-%{version}.tar.gz
15Patch0:         lilypond-platex-2.4.5.patch
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18## from fc11
19Patch10:        lilypond-2.11.65-python26.patch
20Patch12:        lilypond-2.21.2-gcc44-relocate.patch
21Patch13:        lilypond-consts.patch
22
23BuildRequires: t1utils ImageMagick-devel gettext tetex
24BuildRequires: gcc-c++
25BuildRequires: bison flex m4
26BuildRequires: python-devel >= 2.4.0
27BuildRequires: mftrace >= 1.1.19
28Buildrequires: texinfo >= 4.8
29BuildRequires: guile-devel >= 1.8
30BuildRequires: ghostscript >= 8.15
31BuildRequires: pango-devel >= 1.12.0
32
33BuildRequires: potrace >= 1.3
34BuildRequires: netpbm-progs
35BuildRequires: xdvik
36BuildRequires: ec-fonts-mftraced
37Buildrequires: which
38BuildRequires: glibc-devel groff
39BuildRequires: fontforge
40
41Requires: chkfontpath
42
43%description
44LilyPond is a music typesetter.  It produces beautiful sheet music using a
45high level description file as input.  Lilypond is part of the GNU project.
46 
47LilyPond is split into two packages.  The package "lilypond" provides the
48core package, containing the utilities for converting the music source
49(.ly) files into printable output.  The package "lilypond-documentation"
50provides the full documentation, example .ly files for various features and
51the Mutopia project files (musical equivalent of the Gutenberg project - see
52http://www.mutopiaproject.org for details).
53 
54If you are new to lilypond, you will almost certainly want to install the
55"lilypond-documentation" package in addition to the "lilypond" package.
56
57%description -l ja
58LilyPond は GNU プロジェクトで開発されている楽譜作成ソフトです。高解像度の
59とてもきれいな楽譜を作ることができます。
60
61LiLyPond は2つのパッケージにわかれています。"lilypond"パッケージがメインパッ
62ケージ"で、楽譜ソースファイル(.ly)を印刷可能な形式に変換するプログラムが入っ
63てます。tex, html等に簡単に楽譜を挿入するための lilypond-book コマンドもあり
64ます.(Vine用パッケージでは,platexでの利用も可能に変更してあります.)
65
66"lilypond-documentation" にはマニュアルやいろいろなサンプルファイル(.ly)、
67Mutopiaプロジェクトによるいつくかのファイルが入ってます。Mutopia プロジェクト
68(musical equivalent of the Gutenberg project)については
69http://www.mutopiaproject.orgを見てください。
70
71%package -n liblilypond
72Summary: Lilypond libraries
73Summary(ja): Lilypond ライブラリ
74Group: System Environment/Libraries
75Requires: lilypond >= %{version}
76
77%description -n liblilypond
78Lilypond libs
79
80%package documentation
81Summary: LilyPond documentation, examples and Mutopia files.
82Summary(ja): LilyPond のマニュアル, サンプル,Mutopiaファイル
83Group: Applications/Documentation
84Requires: %{name}
85
86%description documentation
87The documentation of LilyPond, both in HTML and PostScript, along with
88example input files and the files from the Mutopia project.
89
90%description documentation -l ja
91LiLyPond のマニュアルです.HTML ,PostScript, PDF の形式のものがあります.
92サンプルや Mutopiaプロジェクトによるファイルも入ってます.
93
94%prep
95rm -rf $RPM_BUILD_ROOT
96
97%setup -q
98#%patch -p1
99
100# from fc11
101%patch10 -p0
102%patch12 -p0
103#%patch13 -p1
104
105%build
106##@ # DO NOT use % { configure } , it hardcodes all paths, runs libtool,
107##@ # so we can't do make prefixix=/tmp/ install.
108##@
109##@ # In fact, do not take out the spaces between % and { in the above comment,
110##@ # because RPM will gladly do a substitution anyway.
111##@ ./configure \
112##@     --disable-checking \
113##@     --prefix=%{_prefix} \
114##@     --libdir=%{_libdir} \
115##@     --includedir=%{_includedir} \
116##@     --enable-optimising \
117##@     ;
118##@
119##@ %{__make} all
120##@ %{__make} web
121##@ %{__make} -C Documentation/user omf
122
123%configure --without-kpathsea --disable-checking --with-ncsb-dir=%{_datadir}/fonts/default/Type1
124%{__make}
125
126
127%install
128%{__rm} -rf %{buildroot}
129make install DESTDIR=$RPM_BUILD_ROOT package_infodir=%{_infodir} vimdir=%{_datadir}/vim/vim72
130chmod +x $RPM_BUILD_ROOT%{_libdir}/%{name}/%{version}/python/midi.so
131
132# Symlink lilypond-init.el in emacs' site-start.d directory
133pushd $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
134mkdir site-start.d
135ln -s ../lilypond-init.el site-start.d
136popd
137
138# Change encoding to UTF8
139pushd $RPM_BUILD_ROOT%{_infodir}
140iconv -f iso-8859-1 -t utf-8 music-glossary.info > music-glossary.info.utf8
141mv music-glossary.info.utf8 music-glossary.info
142sed -e s,lilypond/,, -i *.info
143popd
144
145
146##@ %{makeinstall} MAKE_PFA_FILES=1 local_lilypond_libdir=%{buildroot}/%{_libdir}/%{name}/%{version}
147##@ ########## install emacs els
148##@ %{__mkdir} -p %{buildroot}%{_datadir}/emacs/site-lisp/site-start.d
149##@ %{__install} -m 644 elisp/lilypond-init.el %{buildroot}%{_datadir}/emacs/site-lisp/site-start.d
150##@
151##@ ######### gzip mans
152##@ %{__gzip} -9fn %{buildroot}%{_mandir}/man1/*
153##@
154##@ ########## install profiles
155##@ #mkdir -p $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d
156##@ #cp buildscripts/out/lilypond-profile $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.sh
157##@ #cp buildscripts/out/lilypond-login $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.csh
158##@
159##@ ########## move items to texmf dir
160##@ %define texmfdir %{buildroot}/usr/share/texmf/
161##@ mkdir -p %{texmfdir}/{tex,dvips,fonts}
162##@
163##@ pushd %{buildroot}%{_datadir}/%{name}/%{version}/
164##@ for d in dvips tex; do
165##@     mv $d %{texmfdir}/$d/lilypond
166##@ done
167##@
168##@ for d in afm source tfm; do
169##@     mkdir %{texmfdir}/fonts/$d
170##@     mv fonts/$d %{texmfdir}/fonts/$d/lilypond
171##@ done
172##@ popd
173##@
174##@ ########## install docs
175##@ %{__make} prefix="%{buildroot}%{_prefix}" \
176##@           infodir="%{buildroot}%{_infodir}" \
177##@           webdir="%{buildroot}%{_docdir}/lilypond-documentation-%{version}/" web-install
178##@
179##@ %{__rm} -f %{buildroot}/%{_infodir}/dir
180##@ %{__gzip} -9fn `find %{buildroot}%{_infodir}/ -name '*.info'`
181##@
182##@ ########## install icons
183##@ install -d $RPM_BUILD_ROOT/%{iconsdir}
184##@ install -m 644 Documentation/pictures/out-www/lelie-logo.png $RPM_BUILD_ROOT/%{iconsdir}/%{name}.png
185
186
187%clean
188%{__rm} -rf %{buildroot}
189
190
191%post
192##@ touch /tmp/.lilypond-install
193##@ %{__rm} `find /var/lib/texmf -name 'feta*pk' -or -name 'feta*tfm' -or -name 'parmesan*pk' -or -name 'parmesan*tfm' -print` /tmp/.lilypond-install
194##@ /sbin/install-info %{_infodir}/lilypond/lilypond.info.gz %{_infodir}/dir
195##@ /sbin/install-info %{_infodir}/lilypond/music-glossary.info.gz %{_infodir}/dir
196##@ if [ -x /usr/bin/texhash ]; then /usr/bin/env - /usr/bin/texhash 2> /dev/null ;fi
197##@ if [ -x /usr/bin/updmap ]; then /usr/bin/env - /usr/bin/updmap 2> /dev/null;fi
198##@ /usr/X11R6/bin/mkfontdir %{_datadir}/lilypond/%{version}/fonts/type1/
199##@ /usr/sbin/chkfontpath -q --add=%{_datadir}/lilypond/%{version}/fonts/type1/
200/sbin/install-info --info-dir=%{_infodir} %{_infodir}/lilypond.info || :
201/sbin/install-info --info-dir=%{_infodir} %{_infodir}/music-glossary.info || :
202
203
204%preun
205##@ if [ $1 = 0 ] ; then
206##@   if [ -f /usr/share/lilypond/%{version}/ls-R ]; then
207##@     %{__rm} -f /usr/share/lilypond/%{version}/ls-R
208##@   fi
209##@ fi
210##@ if [ $1 = 0 ]; then
211##@     /sbin/install-info --delete %{_infodir}/lilypond/lilypond.info.gz %{_infodir}/dir
212##@     /sbin/install-info --delete %{_infodir}/lilypond/music-glossary.info.gz %{_infodir}/dir
213##@ fi
214##@ if [ -x /usr/bin/chkfontpath ] ; then
215##@     chkfontpath --remove=%{_datadir}/lilypond/%{version}/fonts/type1/
216##@ fi
217if [ "$1" = "0" ]; then
218  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/lilypond.info || :
219  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/music-glossary.info || :
220fi
221
222
223##@ %postun
224##@ # %{clean_menus}
225##@ if [ -x /usr/bin/texhash ] ;then /usr/bin/env - /usr/bin/texhash 2> /dev/null;fi
226##@ if [ -x /usr/bin/updmap ] ;then /usr/bin/env - /usr/bin/updmap 2> /dev/null;fi
227##@ if [ -x /usr/bin/scrollkeeper-update ] ;then /usr/bin/env - /usr/bin/scrollkeeper-update 2> /dev/null;fi
228##@
229##@ %post documentation
230##@ if [ -x /usr/bin/scrollkeeper-update ] ; then
231##@     scrollkeeper-update
232##@ fi
233##@
234##@ %postun documentation
235##@ if [ -x /usr/bin/scrollkeeper-update ] ; then
236##@     scrollkeeper-update
237##@ fi
238
239
240%files
241%defattr(-, root, root)
242%doc AUTHORS.txt COPYING DEDICATION INSTALL.txt NEWS.txt README.txt
243%doc ROADMAP THANKS
244%{_datadir}/emacs/site-lisp/site-start.d/%{name}-init.el
245%{_datadir}/emacs/site-lisp/lilypond*
246%{_bindir}/*
247%{_infodir}/*
248%{_mandir}/man1/*
249%{_datadir}/%{name}/%{version}/
250%{_datadir}/locale/*/LC_MESSAGES/lilypond.mo
251%{_datadir}/vim/vim*
252
253%files -n liblilypond
254%defattr(-,root,root)
255%{_libdir}/%{name}/%{version}/python/*.so
256
257%files documentation
258%defattr(-, root, root)
259%{_docdir}/*
260%{_datadir}/omf/lilypond/%{version}
261
262
263%changelog
264* Thu Apr 22 2010 Shu KONNO <owa@bg.wakwak.com> 2.12.3-1
265- updated LilyPond to 2.12.3
266- applied new versioning policy, spec in utf-8
267- dropt Patch0: lilypond-platex-2.4.5.patch
268- imported patch from fc11
269        Patch10: lilypond-2.11.65-python26.patch
270        Patch12: lilypond-2.21.2-gcc44-relocate.patch
271        Patch13: lilypond-consts.patch
272- replaced build, install, pre/post scripts (from fc11)
273
274* Sun Jul  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.5-0vl2
275- rebuilt for VineSeed
276
277* Sat Mar 12 2005 Jun NISHII <jun@vinelinux.org> 2.4.5-0vl1
278- build on Vine 3.1
279
280* Wed Mar 24 2004 Jun Nishii <jun@vinelinux.org> 2.0.3-0vl1
281- build for Vine Linux
282- many fixes in post/postun scripts
283
284* Fri Mar 12 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.30-1thac
285- Updated to latest devel release
286
287* Wed Mar 10 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.29-1thac
288- Updated to latest devel release
289
290* Wed Feb 25 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.27-1thac
291- Updated to latest devel release
292
293* Thu Feb 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.25-1thac
294- Updated to latest devel release
295
296* Tue Feb 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.24-1thac
297- Updated to latest devel release
298
299* Fri Feb 13 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.21-1thac
300- Updated to latest devel release
301- Built against latest pfaedit-040211 and mftrace-1.0.27
302- Added requirement for potrace
303
304* Mon Feb 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.20-1thac
305- Updated to latest devel release
306
307* Tue Jan 27 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.15-1thac
308- Updated to latest devel release
309
310* Sat Jan 24 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.14-1thac
311- Updated to latest devel release
312
313* Mon Jan 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.12-1thac
314- Updated to latest devel release
315
316* Sun Jan 18 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.11-1thac
317- Updated to latest devel release
318
319* Sat Jan 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.10-1thac
320- Updated to latest devel release
321
322* Thu Jan 15 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.9-1thac
323- Updated to latest devel release
324
325* Fri Jan 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.8-1thac
326- Updated to latest devel release
327
328* Tue Jan 06 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.7-1thac
329- Updated to latest devel release
330
331* Mon Jan 05 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.6-1thac
332- Updated to latest devel release
333
334* Fri Jan 02 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.4-1thac
335- Updated to latest devel release
336
337* Sun Dec 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.3-1thac
338- Updated to latest devel release
339
340* Sun Dec 21 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.2-1thac
341- Updated to latest devel release
342
343* Thu Dec 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.1-1thac
344- Updated to latest devel release
345
346* Thu Oct 30 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-2thac
347- Rebuilt for Mandrake 9.2
348
349* Fri Oct 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-1thac
350- Updated to latest devel release
351
352* Mon Oct 06 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.1-1thac
353- Updated to latest devel release
354
355* Thu Sep 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.0-1thac
356- Updated to latest devel release
357- removed lilypond-words
358
359* Tue Sep 23 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.9-1thac
360- Updated to latest devel release
361- fixed lilypond.word install
362
363* Wed Sep 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.6-1thac
364- Updated to latest devel release
365
366* Thu Sep 11 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.5-1thac
367- Updated to latest devel release
368- Built against pyton2.3
369
370* Sun Sep 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.4-1thac
371- Updated to latest devel release
372
373* Sun Aug 31 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.3-1thac
374- Updated to latest devel release
375
376* Thu Aug 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.2-1thac
377- Updated to latest devel release
378
379* Wed Aug 27 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.1-1thac
380- Updated to latest devel release
381- Changed naming to differ from Mandrake cooker
382
383* Mon Aug 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-3mdk
384- Fixed documentation path
385- Added some of Heikki Johannes Junes suggestions
386
387* Sun Aug 24 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-2mdk
388- Added Heikki Johannes Junes fix for confilcting PHP variable
389  out=/dev/vc/ by adding unset out before compiling
390- Compiled with recent guile = 1.6.4 and mftrace = 1.0.17
391- Changed icon to lilypond.png
392- Added menu and icons again
393
394* Thu Aug 23 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.8.1-1mdk
395- removed menu and icons, sync with redhat-spec
396
397* Thu Jun 12 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.23-1mdk
398- refreshed dependencies and file list.
399
400* Sat Feb 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.7.12-1mdk
401- Built for Mandrake 9.1
402
403* Fri Dec 01 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.9-1mdk
404- set menu-items to lilypond-info and lilypond-documentation.
405
406* Fri Nov 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.8-4mdk
407- add pre/post-dependencies and menus with icon from source.
408
409* Fri Oct 28 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.4-1mdk
410- info, commented menu
411
412* Fri Aug 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.6.0-1mdk
413- Adapted from lilypond.redhat.skel and skeleton found in Mandrake's RPM-docs.
414- TODO: info (?) and dependencies.
415
416* Fri Jun 01 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.4.2-1mdk
417- updated by Michael Brown <mbrown@linux-mandrake.com> :
418        - Upgraded to 1.4.2
419        - Changed URL
420        - Removed /etc/profile.d scripts: all TeX bits are now located properly
421        - Rearranged documentation
422        - Tidied spec file
423        - Updated README.first
424
425* Mon Feb 26 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.3.129-1mdk
426- added in contribs by Michael Brown <mbrown@fensystems.co.uk> :
427        - Removed info files completely (couldn't get info reader to read them)
428        - TODO: Get this to work at some point (in the meantime, use documentation in lilypond-extras)
429
430* Sat Feb 17 2001 Michael Brown <mbrown@fensystems.co.uk>
431- Moved TeX font folders into the system TeX tree (this ensures that the /var/lib/texmf font cache is used instead of current folder)
432- Added mktexlsr to post-install and post-uninstall scripts
433- Patched scripts in /etc/profile.d to reflect changes to font locations
434- Added QuickStart guide and Points to note sections to README.first (well worth reading)
435- Fixed install-info and uninstall-info sections to use Mandrake's RPM macros :-)
436
437* Tue Feb 13 2001 Michael Brown <mbrown@fensystems.co.uk>
438- First Mandrake package
439- spec file heavily adapted from PowerPC contribs.
440- Note HTML documentation may contain duff links and may be incomplete.  Lots of warnings appear when building HTML docs.
441- PostScript documentation is duplicated (how do you get an rpm package to contain a symlink?)
442- Created README.first file
Note: See TracBrowser for help on using the repository browser.