source: projects/specs/branches/6/l/lighttpd/lighttpd-vl.spec @ 2653

Revision 2653, 11.5 KB checked in by Takemikaduchi, 13 years ago (diff)

eog-plugins,perl-Net_SSLeay,hdf5: new upstream release, others: rebuild with openssl-1.0.0c

Line 
1%define webroot /var/www/lighttpd
2
3Summary: Lightning fast webserver with light system requirements
4Summary(ja): 少ないシステムリソースで動く超高速なウェブサーバ
5Name: lighttpd
6Version: 1.4.22
7Release: 2%{?_dist_release}
8License: BSD
9Group: System Environment/Daemons
10URL: http://www.lighttpd.net/
11Source0: http://www.lighttpd.net/download/lighttpd-%{version}.tar.bz2
12Source1: lighttpd.logrotate
13Source2: php.d-lighttpd.ini
14Source3: lighttpd.init
15Source10: index.html
16Source11: http://www.lighttpd.net/favicon.ico
17Source13: http://www.lighttpd.net/light_button.png
18Source14: http://www.lighttpd.net/light_logo.png
19Patch0: lighttpd-1.4.20-defaultconf.patch
20BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21Requires(pre): shadow-utils
22Requires(post): chkconfig
23Requires(preun): chkconfig
24Requires(postun): chkconfig
25BuildRequires: openssl-devel, pcre-devel, bzip2-devel, zlib-devel, gcc-c++
26%{?_with_ldap:BuildRequires: openldap-devel}
27BuildRequires: gamin-devel
28BuildRequires: gdbm-devel
29BuildRequires: lua-devel
30
31%description
32Secure, fast, compliant and very flexible web-server which has been optimized
33for high-performance environments. It has a very low memory footprint compared
34to other webservers and takes care of cpu-load. Its advanced feature-set
35(FastCGI, CGI, Auth, Output-Compression, URL-Rewriting and many more) make
36it the perfect webserver-software for every server that is suffering load
37problems.
38
39Available rpmbuild rebuild options :
40--with : memcache webdavprops ldap
41--without: lua
42
43%package mod_mysql_vhost
44Summary: Virtual host module for lighttpd that uses a MySQL database
45Group: System Environment/Daemons
46Requires: %{name} = %{version}
47BuildRequires: mysql-devel
48
49%description mod_mysql_vhost
50Virtual host module for lighttpd that uses a MySQL database.
51
52
53%package fastcgi
54Summary: FastCGI module and spawning helper for lighttpd and PHP configuration
55Group: System Environment/Daemons
56Requires: %{name} = %{version}
57
58%description fastcgi
59This package contains the spawn-fcgi helper for lighttpd's automatic spawning
60of local FastCGI programs. Included is also a PHP .ini file to change a few
61defaults needed for correct FastCGI behavior.
62Note that for FastCGI to work with PHP, you will most likely need to find a
63tweaked PHP package (--enable-fastcgi and --enable-discard-path added) or
64recompile PHP yourself.
65
66
67%prep
68%setup -q
69%patch0 -p1 -b .defaultconf
70
71
72%build
73%configure \
74    --libdir="%{_libdir}/lighttpd" \
75    --with-mysql \
76    %{?_with_ldap:--with-ldap} \
77    --with-openssl \
78    --with-fam \
79    --with-gdbm \
80    %{?_with_memcache:--with-memcache} \
81    %{?_with_webdavprops:--with-webdav-props} \
82    %{?_with_webdavlocks:--with-webdav-locks} \
83    %{?!_without_lua:--with-lua}
84%{__make}
85
86
87%install
88%{__rm} -rf %{buildroot}
89%{__make} install DESTDIR=%{buildroot}
90
91# Install included init script and sysconfig entry
92%{__install} -D -p -m 0755 doc/rc.lighttpd.redhat \
93    %{buildroot}%{_sysconfdir}/rc.d/init.d/lighttpd
94%{__install} -D -p -m 0644 doc/sysconfig.lighttpd \
95    %{buildroot}%{_sysconfdir}/sysconfig/lighttpd
96
97# Install (*patched above*) sample config file
98%{__install} -D -p -m 0640 doc/lighttpd.conf \
99    %{buildroot}%{_sysconfdir}/lighttpd/lighttpd.conf
100
101# Install our own logrotate entry
102%{__install} -D -p -m 0644 %{SOURCE1} \
103    %{buildroot}%{_sysconfdir}/logrotate.d/lighttpd
104
105# Install our own php.d ini file
106%{__install} -D -p -m 0644 %{SOURCE2} \
107    %{buildroot}%{_sysconfdir}/php.d/lighttpd.ini
108
109# Install our own init script
110%{__install} -D -p -m 0755 %{SOURCE3} \
111    %{buildroot}%{_sysconfdir}/rc.d/init.d/lighttpd
112
113# Install our own default web page and images
114%{__mkdir_p} %{buildroot}%{webroot}
115%{__install} -p -m 0644 %{SOURCE10} %{SOURCE11} %{SOURCE13} \
116    %{SOURCE14} \
117    %{buildroot}%{webroot}/
118
119# Install empty log directory to include
120%{__mkdir_p} %{buildroot}%{_var}/log/lighttpd
121
122# Install empty run directory to include (for the example fastcgi socket)
123%{__mkdir_p} %{buildroot}%{_var}/run/lighttpd
124
125
126%clean
127%{__rm} -rf %{buildroot}
128
129
130%pre
131/usr/sbin/useradd -s /sbin/nologin -M -r -d %{webroot} \
132    -c "lighttpd web server" lighttpd &>/dev/null || :
133
134%post
135/sbin/chkconfig --add lighttpd
136
137%preun
138if [ $1 -eq 0 ]; then
139  /sbin/service lighttpd stop &>/dev/null || :
140  /sbin/chkconfig --del lighttpd
141fi
142
143%postun
144if [ $1 -ge 1 ]; then
145    /sbin/service lighttpd condrestart &>/dev/null || :
146fi
147
148
149%files
150%defattr(-, root, root, 0755)
151%doc AUTHORS ChangeLog COPYING README
152%doc doc/*.txt doc/lighttpd.conf doc/lighttpd.user
153%dir %{_sysconfdir}/lighttpd/
154%config(noreplace) %{_sysconfdir}/lighttpd/lighttpd.conf
155%config(noreplace) %{_sysconfdir}/logrotate.d/lighttpd
156%config(noreplace) %{_sysconfdir}/sysconfig/lighttpd
157%{_sysconfdir}/rc.d/init.d/lighttpd
158%{_sbindir}/lighttpd
159%{_sbindir}/lighttpd-angel
160%{_libdir}/lighttpd/
161%exclude %{_libdir}/lighttpd/*.la
162%exclude %{_libdir}/lighttpd/mod_fastcgi.so
163%exclude %{_libdir}/lighttpd/mod_mysql_vhost.so
164%{_mandir}/man1/lighttpd.1*
165%attr(0750, lighttpd, lighttpd) %{_var}/log/lighttpd/
166%{webroot}/
167
168%files mod_mysql_vhost
169%defattr(-, root, root, 0755)
170%doc doc/mysqlvhost.txt
171%dir %{_libdir}/lighttpd/
172%{_libdir}/lighttpd/mod_mysql_vhost.so
173
174%files fastcgi
175%defattr(-, root, root, 0755)
176%doc doc/fastcgi*.txt
177%config(noreplace) %{_sysconfdir}/php.d/lighttpd.ini
178%{_bindir}/spawn-fcgi
179%dir %{_libdir}/lighttpd/
180%{_libdir}/lighttpd/mod_fastcgi.so
181%{_mandir}/man1/spawn-fcgi.1*
182
183
184%changelog
185* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.22-2
186- rebuild with openssl-1.0.0c
187
188* Fri Jun 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
189- new upstream release
190- build with lua, add BR: lua-devel
191- update init script
192
193* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.20-2
194- rebuilt with MySQL-5.1.34.
195
196* Wed Oct 08 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.20-1
197- updated to 1.4.20 release with many bug/security fixes, including:
198  - CVE-2008-4298: fix memory leak in request header handling
199  - CVE-2008-4360: fix mod_userdir information disclosure
200  - CVE-2008-4359: fix bypassing rewrite/redirect rules with encoded urls
201  - CVE-2008-1531: fix DoS of ssl connections
202- modified Patch0 for version 1.4.20
203- add %{_sbindir}/lighttpd-angel to the filelist
204
205* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.16-1vl5
206- applied new versioning policy, spec in utf-8
207
208* Tue Jul 31 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.16-0vl1
209- new upstream release
210
211* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.13-0vl1
212- initial build for Vine Linux
213
214* Wed Oct 11 2006 Matthias Saou <http://freshrpms.net/> 1.4.13-1
215- Update to 1.4.13, which contains the previous fix.
216
217* Tue Oct  3 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-3
218- Include fix for segfaults (lighttpd bug #876, changeset 1352).
219
220* Mon Sep 25 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-1
221- Update to 1.4.12 final.
222
223* Fri Sep 22 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-0.1.r1332
224- Update to latest 1.4.12 pre-release, fixes SSL issues and other bugs.
225- Update powered_by_fedora.png to the new logo.
226
227* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 1.4.11-2
228- FC6 rebuild.
229
230* Thu Mar  9 2006 Matthias Saou <http://freshrpms.net/> 1.4.11-1
231- Update to 1.4.11.
232
233* Mon Mar  6 2006 Matthias Saou <http://freshrpms.net/> 1.4.10-2
234- FC5 rebuild.
235
236* Wed Feb  8 2006 Matthias Saou <http://freshrpms.net/> 1.4.10-1
237- Update to 1.4.10.
238- Remove now included fix.
239
240* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 1.4.9-2
241- Add mod_fastcgi-fix patch to fix crash on backend overload.
242
243* Mon Jan 16 2006 Matthias Saou <http://freshrpms.net/> 1.4.9-1
244- Update to 1.4.9.
245
246* Wed Nov 23 2005 Matthias Saou <http://freshrpms.net/> 1.4.8-1
247- Update to 1.4.8.
248
249* Fri Nov  4 2005 Matthias Saou <http://freshrpms.net/> 1.4.7-1
250- Update to 1.4.7.
251
252* Wed Oct 12 2005 Matthias Saou <http://freshrpms.net/> 1.4.6-1
253- Update to 1.4.6.
254
255* Mon Oct  3 2005 Matthias Saou <http://freshrpms.net/> 1.4.5-1
256- Update to 1.4.5.
257- Disable gamin/fam support for now, it does not work.
258
259* Tue Sep 27 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-3
260- Update to current SVN to check if it fixes the remaining load problems.
261
262* Wed Sep 21 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-2
263- Patch to SVN 722 revision : Fixes a crash in mod_mysql_vhost and a problem
264  with keepalive and certain browsers.
265
266* Mon Sep 19 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-1
267- Update to 1.4.4 final.
268- Enable ldap auth, gdbm and gamin/fam support by default.
269
270* Thu Sep 15 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-0
271- Update to 1.4.4 pre-release (fixes another fastcgi memleak).
272- Enable lua (cml module) by default.
273- Add --with-webdav-props conditional option.
274
275* Tue Sep 13 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-2
276- Include lighttpd-1.4.3-stat_cache.patch to fix memleak.
277
278* Fri Sep  2 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-1.1
279- Rearrange the included index.html to include the new logo, button and
280  favicon from lighttpd.net.
281
282* Fri Sep  2 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-1
283- Update to 1.4.3.
284- No longer override libdir at make install stage, use DESTDIR instead, as
285  the resulting binary would now have referenced to %%{buildroot} :-(
286
287* Tue Aug 30 2005 Matthias Saou <http://freshrpms.net/> 1.4.2-1
288- Update to 1.4.2.
289
290* Mon Aug 22 2005 Matthias Saou <http://freshrpms.net/> 1.4.1-1
291- Update to 1.4.1.
292
293* Sun Aug 21 2005 Matthias Saou <http://freshrpms.net/> 1.4.0-1
294- Update to 1.4.0.
295- Add conditional of gamin, gdbm, memcache and lua options.
296
297* Mon Aug  1 2005 Matthias Saou <http://freshrpms.net/> 1.3.16-2
298- Update to 1.3.16, rebuild.
299
300* Mon Jul 18 2005 Matthias Saou <http://freshrpms.net/> 1.3.15-1
301- Update to 1.3.15.
302
303* Mon Jun 20 2005 Matthias Saou <http://freshrpms.net/> 1.3.14-1
304- Update to 1.3.14.
305
306* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.3.13-5
307- rebuild on all arches
308
309* Mon Apr  4 2005 Matthias Saou <http://freshrpms.net/> 1.3.13-4
310- Change signal sent from the logrotate script from USR1 to HUP, as that's the
311  correct one.
312
313* Fri Apr  1 2005 Michael Schwendt <mschwendt[AT]users.sf.net> 1.3.13-2
314- Include /etc/lighttpd directory.
315
316* Sun Mar  6 2005 Matthias Saou <http://freshrpms.net/> 1.3.13-1
317- Update to 1.3.13.
318
319* Wed Mar  2 2005 Matthias Saou <http://freshrpms.net/> 1.3.12-1
320- Update to 1.3.12.
321- Remove obsolete empty_cgi_handler patch.
322
323* Tue Mar  1 2005 Matthias Saou <http://freshrpms.net/> 1.3.11-2
324- Add missing defattr to sub-packages (#150018).
325
326* Mon Feb 21 2005 Matthias Saou <http://freshrpms.net/> 1.3.11-0
327- Update to 1.3.11.
328- Remove cleanconf and init.d patches (merged upstream).
329- Add empty_cgi_handler patch.
330
331* Fri Feb 18 2005 Matthias Saou <http://freshrpms.net/> 1.3.10-0
332- Split off -fastcgi sub-package.
333- Include php.d entry to set sane FastCGI defaults.
334
335* Wed Feb 16 2005 Matthias Saou <http://freshrpms.net/> 1.3.10-0
336- Spec file cleanup for freshrpms.net/Extras.
337- Compile OpenSSL support unconditionally.
338- Put modules in a subdirectory of libdir.
339- Don't include all of libdir's content to avoid debuginfo content.
340- Add optional LDAP support.
341- Add patch to change the default configuration.
342- Add dedicated lighttpd user/group creation.
343- Add logrotate entry.
344- Include a nice little default page for the default setup.
345- Split off mod_mysql_vhost sub-package, get dep only there.
346- Use webroot in /srv by default.
347- Exclude .la files, I doubt anyone will need them.
348
349* Thu Sep 30 2004 <jan@kneschke.de> 1.3.1
350- upgraded to 1.3.1
351
352* Tue Jun 29 2004 <jan@kneschke.de> 1.2.3
353- rpmlint'ed the package
354- added URL
355- added (noreplace) to start-script
356- change group to Networking/Daemon (like apache)
357
358* Sun Feb 23 2003 <jan@kneschke.de>
359- initial version
360
Note: See TracBrowser for help on using the repository browser.