source: projects/specs/branches/6/l/lam/lam-vl.spec @ 6939

Revision 6939, 6.6 KB checked in by Takemikaduchi, 12 years ago (diff)

thunderbird: new upstream release,
others: rebuild

Line 
1#
2# Copyright (c) 2001-2003 The Trustees of Indiana University. 
3#                         All rights reserved.
4# Copyright (c) 1998-2001 University of Notre Dame.
5#                         All rights reserved.
6# Copyright (c) 1994-1998 The Ohio State University. 
7#                         All rights reserved.
8#
9# This file is part of the LAM/MPI software package.  For license
10# information, see the LICENSE file in the top level directory of the
11# LAM/MPI source distribution.
12#
13# $Id: lam-generic.spec,v 1.3 2003/05/30 22:08:07 jsquyres Exp $
14#
15%define _sysconfdir /etc/lam
16%define _romiodocdir /usr/share/lam/doc
17Summary: LAM/MPI (Local Area Multicomputer) programming environment
18Summary(ja): MPIメッセージパッシング形式の並列アプリケーション作成環境
19Name: lam
20Version: 7.1.4
21Release: 2%{?_dist_release}
22License: BSD
23Group: Development/Libraries
24Source: lam-%{version}.tar.gz
25Patch: lam-helppath.patch
26URL: http://www.lam-mpi.org/
27ExcludeArch: ia64
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: gcc-gfortran
30Provides: mpi
31Vendor: Project Vine
32Distribution: Vine Linux
33
34%description
35LAM (Local Area Multicomputer) is an MPI programming environment and
36development system for heterogeneous computers on a network. With
37LAM/MPI, a dedicated cluster or an existing network computing
38infrastructure can act as one parallel computer solving one problem.
39LAM/MPI is considered to be "cluster friendly", in that it offers
40daemon-based process startup/control as well as fast client-to-client
41message passing protocols.  LAM/MPI can use TCP/IP and/or shared
42memory for message passing (different RPMs are supplied for this --
43see the main LAM web site for details).
44
45LAM features a full implementation of MPI-1 (with the exception that
46LAM does not support cancelling of sends), and much of MPI-2.
47Compliant applications are source code portable between LAM/MPI and
48any other implementation of MPI.  In addition to providing a
49high-quality implementation of the MPI standard, LAM/MPI offers
50extensive monitoring capabilities to support debugging.  Monitoring
51happens on two levels.  First, LAM/MPI has the hooks to allow a
52snapshot of process and message status to be taken at any time during
53an application run.  This snapshot includes all aspects of
54synchronization plus datatype maps/signatures, communicator group
55membership, and message contents (see the XMPI application on the main
56LAM web site).  On the second level, the MPI library is instrumented
57to produce a cummulative record of communication, which can be
58visualized either at runtime or post-mortem.
59
60
61%prep
62%setup -q
63
64# Otherwise, this directory shows up on security reports
65chmod -R o-w $RPM_BUILD_DIR/lam-%{version}
66
67
68%build
69%configure \
70        --with-rpi=usysv \
71        --with-fc=gfortran \
72        --enable-shared \
73        --enable-static \
74        --sysconfdir=%{_sysconfdir} \
75
76make %{?_smp_mflags} all
77
78
79%install
80rm -rf $RPM_BUILD_ROOT
81%makeinstall
82
83rm -f $RPM_BUILD_ROOT/usr/include/mpi++.h
84ln -s mpi2c++/mpi++.h $RPM_BUILD_ROOT/usr/include/mpi++.h
85
86# Rename the ROMIO doc files so that we can install them in the same
87# doc root later, and not overwrite LAM's doc files.
88
89for file in README README_LAM COPYRIGHT; do
90        mv $RPM_BUILD_DIR/lam-%{version}/romio/$file \
91                $RPM_BUILD_DIR/lam-%{version}/romio/romio-$file
92done
93mv $RPM_BUILD_DIR/lam-%{version}/romio/doc/users-guide.ps.gz \
94        $RPM_BUILD_DIR/lam-%{version}/romio/doc/romio-users-guide.ps.gz
95
96# remove unused files
97rm -f $RPM_BUILD_ROOT/%{_libdir}/lib*.la
98
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103
104%files
105%defattr(-,root,root)
106%doc LICENSE HISTORY INSTALL README
107%doc examples
108%doc doc/*.pdf
109# Need to fix ROMIO install script to install its docs in the Right place
110%doc %{_romiodocdir}
111%config %{_sysconfdir}
112%{_bindir}/*
113%{_mandir}/*/*
114%{_includedir}/*
115%{_libdir}/lam
116%{_libdir}/*.a
117%{_libdir}/*.so
118%{_libdir}/*.so.*
119#%{_datadir}/lam/lam-shell-setup.*
120#%{_datadir}/lam/lam_module.tcl
121
122
123%changelog
124* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.1.4-2
125- rebuild with Vine6.1 environment
126
127* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 7.1.4-1vl5
128- fixed typo of last changelog release number
129- removed lib*.la
130
131* Sun Aug 24 2008 Shu KONNO <owa@bg.wakwak.com> 7.1.4-0.1vl5
132- applied new versioning policy, spec in utf-8
133- updated lam to 7.1.4
134- added japanese summary
135
136* Sun Dec 30 2007 Shu KONNO <owa@bg.wakwak.com> 7.0-1vl2
137- updated gcc-g77 to gcc-gfortran in BuildRequires
138- added "--with-fc=gfortran" to %%configure
139
140* Thu Aug 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.0-1vl1
141- based on new upstream
142  (http://www.lam-mpi.org/download/files/lam-7.0-1.src.rpm)
143- rebuild with new toolchains
144
145* Thu Dec 21 2000 Jun Nishii <jun@vinelinux.org>
146- 6.3.3b47-1vl2
147- build with gcc
148
149* Thu Dec 21 2000 Jun Nishii <jun@vinelinux.org>
150- 6.3.3b47-1vl1
151- use macros for spec
152- correct path of helpfile
153
154* Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
155- 6.3.3b47
156
157* Thu Aug 17 2000 Trond Eivind Glomsrød <teg@redhat.com>
158- 6.3.3b28, which should match the release. One known
159  problem on SCO, otherwise none. This includes
160  fixing some programs which didn't work in the
161  last build.
162 
163* Thu Jul 27 2000 Harald Hoyer <harald@redhat.com>
164- fixed the install process, that the lam tools have the
165  right path set. make all;make DESTDIR install is
166  our friend.
167
168* Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
169- a new and better world without dirty tricks necesarry.
170  All hail the 6.3.3beta (beta 20 - all my requests and
171  patches seem to be in now :)
172
173* Fri Jun 16 2000 Trond Eivind Glomsrød <teg@redhat.com>
174- substituted some old dirty tricks for new ones to make
175  it build. More needed.
176- Removed C++ (won't build) and ROMIO (who cares) support
177
178* Thu Jun 15 2000 Trond Eivind Glomsrød <teg@redhat.com>
179- ugly tricks to make it use %%{_mandir}
180- patch to make it build with current compiler and glibc
181- don't build on IA64
182
183* Tue Apr 25 2000 Trond Eivind Glomsrød <teg@redhat.com>
184- changed RPI to usysv - this should be good for
185  (clusters of) SMPs.
186
187* Wed Mar 28 2000 Harald Hoyer <harald@redhat.com>
188- patched scheme Makefile
189
190* Tue Mar 28 2000 Harald Hoyer <harald@redhat.com>
191- new subminor version
192- patched Makefile to build otb daemons, to satisfy conf.otb and build all
193  stuff
194
195* Sat Mar 04 2000 Cristian Gafton <gafton@redhat.com>
196- fixed the whole tree the hard way - get into each Makefile and fix
197  brokeness on a case by case basis. Traces of Buildroot should be
198  erradicated by now.
199
200* Thu Mar 02 2000 Cristian Gafton <gafton@redhat.com>
201- put back the mpi2c++ stuff.
202
203* Tue Feb 29 2000 Cristian Gafton <gafton@redhat.com>
204- take out the mpi2c++ in a separate package
205
206* Fri Feb 04 2000 Cristian Gafton <gafton@redhat.com>
207- first version of the package
Note: See TracBrowser for help on using the repository browser.