source: projects/specs/branches/6/k/knemo/knemo-vl.spec @ 1407

Revision 1407, 5.4 KB checked in by inagaki, 14 years ago (diff)

NEW: kaffeine, kde-partitionmanager, knemo, yakuake

Line 
1Name:             knemo
2Summary:          A KDE network monitoring tool
3Summary(ja):      KDE 用ネットワーク監視ツール
4Version:          0.6.3
5Release:          2%{?_dist_release}
6
7Group:            Applications/Internet
8License:          GPLv2+
9URL:              http://extragear.kde.org/apps/knemo/
10Source0:          http://kde-apps.org/CONTENT/content-files/12956-%{name}-%{version}.tar.bz2
11
12BuildRoot:        %{_tmppath}/%{name}-%{version}-root
13BuildRequires:    cmake desktop-file-utils gettext
14BuildRequires:    kdelibs4-devel wireless-tools-devel libnl-devel
15
16%description
17KNemo displays for every network interface an icon in the systray. Tooltips
18and an info dialog provide further information about the interface. Passive
19popups inform about interface changes. A traffic plotter is also integrated.
20It polls the network interface status every second using the ifconfig, route
21and iwconfig tools.
22
23%prep
24%setup -q
25
26%build
27mkdir -p %{_target_platform}
28pushd %{_target_platform}
29unset QTDIR || : ; . /etc/profile.d/qt4.sh
30%{cmake} \
31    -DCMAKE_BUILD_TYPE=release \
32    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
33    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
34    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
35    -DLEGACY_TRAY_ICON=true \
36    ..
37popd
38
39make %{?_smp_mflags} -C %{_target_platform}
40
41%install
42rm -rf $RPM_BUILD_ROOT
43make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
44
45%find_lang %{name}
46%find_lang kcm_%{name}
47cat kcm_%{name}.lang >> %{name}.lang
48
49%check
50desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/kde4/%{name}.desktop
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%post
56touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
57
58%postun
59if [ $1 -eq 0 ] ; then
60  touch --no-create %{_datadir}/icons/hicolor &> /dev/null
61  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
62fi
63
64%posttrans
65gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
66
67
68%files -f %{name}.lang
69%defattr(-,root,root,-)
70%doc AUTHORS ChangeLog COPYING README TODO
71%{_bindir}/%{name}
72%{_libdir}/kde4/kcm_knemo.so
73%{_datadir}/kde4/apps/%{name}
74%{_datadir}/applications/kde4/%{name}.desktop
75%{_datadir}/kde4/services/kcm_knemo.desktop
76%{_datadir}/autostart/%{name}.desktop
77%{_datadir}/icons/hicolor/*/apps/%{name}*
78%{_datadir}/icons/hicolor/22x22/status/%{name}*
79
80%changelog
81* Tue Jul 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.3-2
82- Initial build for Vine Linux
83
84* Tue Jun 15 2010 Alexey Kurov <nucleo@fedoraproject.org> - 0.6.3-1
85- update to 0.6.3
86
87* Sat Apr 10 2010 Alexey Kurov <nucleo@fedoraproject.org> - 0.6.2-2
88- disabled new KStatusNotifierItem for now (kde#226650)
89
90* Fri Apr  9 2010 Alexey Kurov <nucleo@fedoraproject.org> - 0.6.2-1
91- update to 0.6.2
92
93* Mon Jan 18 2010 Alexey Kurov <nucleo@fedoraproject.org> - 0.6.1-2
94- update to 0.6.1
95
96* Fri Dec  4 2009 Alexey Kurov <nucleo@fedoraproject.org> - 0.6.0-1
97- update to 0.6.0
98
99* Thu Nov 19 2009 Alexey Kurov <nucleo@fedoraproject.org> - 0.5.80-2
100- rebuild (qt-4.6.0-rc1, fc13+)
101
102* Fri Nov  6 2009 Alexey Kurov <nucleo@fedoraproject.org> - 0.5.80-1
103- update to 0.5.80 (0.6.0 beta1)
104- drop xdg-utils references
105- removed Requires net-tools wireless-tools
106
107* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.2-2
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
109
110* Wed Apr  1 2009 Alexey Kurov <nucleo@fedoraproject.org> - 0.5.2-1
111- Update to version 0.5.2
112- Fixed spec License and URL fields
113
114* Tue Mar 17 2009 Alexey Kurov <nucleo@fedoraproject.org> - 0.5.1-5
115- Upstream update from git.mehercule.net
116
117* Thu Mar  5 2009 Alexey Kurov <nucleo@fedoraproject.org> - 0.5.1-1
118- Update to version 0.5.1
119
120* Wed Feb 25 2009 Alexey Kurov <nucleo@fedoraproject.org> - 0.5.0-3
121- Update to version 0.5.0 for KDE4
122
123* Tue Apr 17 2007 Francois Aucamp <faucamp@csir.co.za> - 0.4.7-1
124- Update to version 0.4.7
125- Removed unnecessary desktop-file-install statements (KDE-specific desktop
126  files)
127- Removed desktop file patch - desktop file "Keywords" keys used internally
128  by KDE
129- Added "OnlyShowIn=KDE" to kcm desktop file
130- Removed unnecessary BuildRequires: qt-devel desktop-file-utils
131- Simplified %%post and %%postun scriplets
132- Use RPM_BUILD_ROOT variable format consistently
133
134* Wed Sep 13 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.3-2
135- Rebuilt for FC6
136
137* Sun Aug  6 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.3-1
138- New upstream version
139
140* Mon Jun 26 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.2-1
141- Upstream update
142- Fixes crashing when you click in panel icon (bz #196576)
143- ifconfig and iwconfig are now in both Requires and
144  BuildRequires (it checks while building too)
145
146* Tue Jun 13 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.1-2
147- ifconfig and iwconfig are now in Requires section instead
148  of BuildRequires. They are runtime dependencies. Thanks to
149  Kevin Kofler for pointing this.
150
151* Mon Jun 12 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.1-1
152- Upstream update
153
154* Tue May 30 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.0-4
155- Created BuildRequires for the ifconfig and iwconfig commands,
156  as knemo utilizes it for monitoring.
157- Removed addition of categories in desktop-file-install command
158
159* Thu May 25 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.0-3
160- Removed vendor option from desktop-file-install (no renaming)
161
162* Sat May 20 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.0-2
163- Installed .desktop files now use desktop-file-install
164
165* Sat May 20 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.0-1
166- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.