source: projects/specs/branches/6/k/kmid2/kmid2-vl.spec @ 2776

Revision 2776, 6.2 KB checked in by inagaki, 13 years ago (diff)

upload: kdiff3, kphotoalbum
NEW: drumstick, kmid2, ktorrent

Line 
1%if %{?_dist_release} == "vl5"
2%define kde KDE4
3%else
4%define kde KDE
5%endif
6
7Name:           kmid2
8Summary:        A MIDI/karaoke player for %{kde}
9Summary(ja):    %{kde} 向け MIDI/カラオケプレーヤー
10Version:        2.3.0
11Release:        4%{?_dist_release}
12
13Group:          Applications/Multimedia
14# GPLv2+ for the code and the MMA examples, CC-BY-SA for the MIDI examples
15License:        GPLv2+ and CC-BY-SA
16URL:            http://userbase.kde.org/KMid2
17
18Source0:        http://downloads.sourceforge.net/project/%{name}/%{version}/kmid-%{version}.tar.bz2
19
20# http://websvn.kde.org/?revision=1134129&view=revision
21# Fix a crash in the ALSA backend due to reloadDeviceList (kde#240394)
22Patch0:         kmid-2.3.0-kde#240394.patch
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25
26BuildRequires:  kdelibs4-devel
27#BuildRequires:  kde-filesystem
28BuildRequires:  cmake
29BuildRequires:  alsa-lib-devel
30BuildRequires:  drumstick-devel >= 0.3
31BuildRequires:  gettext
32BuildRequires:  desktop-file-utils
33
34#{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api}}
35#{?_kde4_version:Requires: kdelibs4%{?_isa} >= %{_kde4_version}}
36Requires:       oxygen-icon-theme
37Requires:       drumstick >= 0.3
38Requires:       %{name}-libs = %{version}-%{release}
39
40Obsoletes:      kmid < 2.0-1
41Provides:       kmid = %{version}-%{release}
42
43%description
44KMid2 is a MIDI/karaoke file player, with configurable midi mapper, real
45Session Management, drag & drop, customizable fonts, etc. It has a very
46nice interface which let you easily follow the tune while changing the
47color of the lyrics.
48It supports output through external synthesizers, AWE, FM and GUS cards.
49It also has a keyboard view to see the notes played by each instrument.
50
51%package libs
52Summary:        Runtime libraries for %{name}
53Summary(ja):    %{name} のランタイムライブラリ
54Group:          System Environment/Libraries
55License:        GPLv2+
56
57#{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api}}
58#{?_kde4_version:Requires: kdelibs4%{?_isa} >= %{_kde4_version}}
59
60%description libs
61%{summary}.
62
63%package devel
64Summary:        Development files for %{name}
65Summary(ja):    %{name} の開発用ファイル
66Group:          Development/Libraries
67License:        GPLv2+
68
69Requires:       %{name}-libs = %{version}-%{release}
70
71Obsoletes:      kmid-devel < 2.0-1
72Provides:       kmid-devel = %{version}-%{release}
73
74%description devel
75%{summary}.
76
77%prep
78%setup -q -n kmid-%{version}
79# zap bundled copy of drumstick to guarantee it's never used
80rm -rf drumstick
81%patch0 -p0 -b .kde#240394
82
83
84%build
85mkdir -p %{_target_platform}
86pushd %{_target_platform}
87unset QTDIR || : ; . /etc/profile.d/qt4.sh
88%cmake \
89    -DCMAKE_BUILD_TYPE=release \
90    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
91    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
92    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
93    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
94    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
95    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
96    ..
97popd
98
99make %{?_smp_mflags} -C %{_target_platform}
100
101
102%install
103rm -rf %{buildroot}
104make install DESTDIR=%{buildroot} -C %{_target_platform}
105desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/kmid.desktop
106%find_lang kmid
107
108%clean
109rm -rf %{buildroot}
110
111
112%post
113touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
114update-desktop-database &> /dev/null || :
115
116%postun
117update-desktop-database &> /dev/null || :
118if [ $1 -eq 0 ] ; then
119    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
120    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
121fi
122
123%posttrans
124gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
125
126%post libs -p /sbin/ldconfig
127%postun libs -p /sbin/ldconfig
128
129
130%files -f kmid.lang
131%defattr(-,root,root,-)
132%doc ChangeLog COPYING README TODO
133%{_bindir}/kmid
134%{_datadir}/kde4/apps/kmid/
135%{_datadir}/applications/kde4/kmid.desktop
136%{_datadir}/config.kcfg/*
137%{_datadir}/kde4/services/*
138%{_datadir}/kde4/servicetypes/*
139%{_datadir}/icons/hicolor/*/apps/*
140%{_libdir}/kde4/*
141%doc %{_docdir}/HTML/*/kmid/
142
143%files libs
144%defattr(-,root,root,-)
145%{_libdir}/libkmidbackend.so.*
146
147%files devel
148%defattr(-,root,root,-)
149%{_libdir}/libkmidbackend.so
150%{_includedir}/kde4/kmid/
151
152
153%changelog
154* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.3.0-4
155- removed --with-kde from %%find_lang
156
157* Sun Jan 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.3.0-3
158- Initial build for Vine Linux
159
160* Fri May 28 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 2.3.0-2
161- Fix crash in ALSA backend due to reloadDeviceList (kde#240394, upstream patch)
162
163* Fri May 28 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 2.3.0-1
164- Update to 2.3.0 (new versioning scheme)
165- BR drumstick-devel >= 0.3
166- Requires: drumstick >= 0.3
167- Drop obsolete drumstick-version patch
168- Examples now partly CC-BY-SA, partly GPLv2+ (instead of CC-BY)
169- Use _kde4_version macro
170- Add -devel and -libs subpackages
171- Package COPYING
172
173* Tue Feb 09 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.1-2
174- Requires: drumstick >= 0.2.99-0.3
175
176* Tue Feb 09 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.1-1
177- Update to 0.2.1
178- Drop upstreamed timidity-pulseaudio patch
179- Drop dont-translate-output-names patch, should not be needed anymore
180- BR drumstick-devel >= 0.2.99-0.3 (0.2.1 needs the 20100208 snapshot)
181- relax drumstick version check in CMakeLists.txt as 0.3 is not out yet
182
183* Fri Feb 05 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.0-3
184- Don't translate output names, breaks autospawning sequencers
185
186* Sun Jan 31 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.0-2
187- Support PulseAudio when autospawning TiMidity++ (-OO -opulse switches)
188
189* Sun Jan 31 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.0-1
190- Update to 0.2.0
191- The examples with copyright issues have been dropped by upstream
192- BR drumstick-devel instead of aseqmm-devel
193
194* Wed Jan 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-4
195- Fix the kde4-config output parsing for 4.4 ("KDE Development Platform:")
196
197* Wed Jan 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-3
198- Correctly require at least the kdelibs version used for building
199
200* Wed Jan 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-2
201- Remove nonsense Requires: kdelibs4 >= %%{version}, as %%{version} is 0.1.1
202
203* Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-1
204- First Fedora package, replaces kmid
Note: See TracBrowser for help on using the repository browser.