source: projects/specs/branches/6/k/keyutils/keyutils-vl.spec @ 3090

Revision 3090, 6.5 KB checked in by inagaki, 13 years ago (diff)

update: cadaver, keyutils

Line 
1%define vermajor 1
2%define version %{vermajor}.2
3%define libdir /%{_lib}
4%define usrlibdir %{_prefix}/%{_lib}
5%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
6
7Summary: Linux Key Management Utilities
8Summary(ja): Linux 鍵管理ユーティリティ
9Name: keyutils
10Version: %{version}
11Release: 4%{?_dist_release}
12License: GPL/LGPL
13Group: System Environment/Base
14ExclusiveOS: Linux
15URL: http://people.redhat.com/~dhowells/keyutils/
16
17Source0: http://people.redhat.com/~dhowells/keyutils/keyutils-%{version}.tar.bz2
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: glibc-kernheaders >= 2.4-9.1.92
21
22%description
23Utilities to control the kernel key management facility and to provide
24a mechanism by which the kernel call back to userspace to get a key
25instantiated.
26
27%package libs
28Summary: Key utilities library
29Summary(ja): 鍵管理ユーティリティのライブラリ
30Group: System Environment/Libraries
31
32%description libs
33This package provides a wrapper library for the key management facility system
34calls.
35
36%package libs-devel
37Summary: Development package for building linux key management utilities
38Summary(ja): Linux 鍵管理ユーティリティの開発ファイル
39Group: Development/Libraries
40Requires: %{name}-libs = %{version}-%{release}
41
42%description libs-devel
43This package provides headers and libraries for building key utilities.
44
45%package -n compat32-%{name}-libs
46Summary: Key utilities library
47Summary(ja): 鍵管理ユーティリティのライブラリ
48Group: System Environment/Libraries
49Requires: %{name}-libs = %{version}-%{release}
50
51%description -n compat32-%{name}-libs
52This package provides a wrapper library for the key management facility system
53calls.
54
55%package -n compat32-%{name}-libs-devel
56Summary: Development package for building linux key management utilities
57Summary(ja): Linux 鍵管理ユーティリティの開発ファイル
58Group: Development/Libraries
59Requires: compat32-%{name}-libs = %{version}-%{release}
60Requires: %{name}-libs-devel = %{version}-%{release}
61
62%description -n compat32-%{name}-libs-devel
63This package provides headers and libraries for building key utilities.
64
65%prep
66%setup -q
67
68%build
69make \
70        NO_ARLIB=1 \
71        LIBDIR=%{libdir} \
72        USRLIBDIR=%{usrlibdir} \
73        RELEASE=.%{release} \
74        NO_GLIBC_KEYERR=1 \
75        CFLAGS="-Wall $RPM_OPT_FLAGS"
76
77%install
78rm -rf $RPM_BUILD_ROOT
79make \
80        NO_ARLIB=1 \
81        DESTDIR=$RPM_BUILD_ROOT \
82        LIBDIR=%{libdir} \
83        USRLIBDIR=%{usrlibdir} \
84        install
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%post libs -p /sbin/ldconfig
90%postun libs -p /sbin/ldconfig
91
92%post -n compat32-%{name}-libs -p /sbin/ldconfig
93%postun -n compat32-%{name}-libs -p /sbin/ldconfig
94
95%files
96%defattr(-,root,root,-)
97%doc README LICENCE.GPL
98/sbin/*
99/bin/*
100/usr/share/keyutils
101%{_mandir}/man1/*
102%{_mandir}/man5/*
103%{_mandir}/man8/*
104%config(noreplace) /etc/*
105
106%files libs
107%defattr(-,root,root,-)
108%doc LICENCE.LGPL
109%{libdir}/libkeyutils-%{version}.so
110%{libdir}/libkeyutils.so.%{vermajor}
111
112%files libs-devel
113%defattr(-,root,root,-)
114%{usrlibdir}/libkeyutils.so
115%{_includedir}/*
116%{_mandir}/man3/*
117
118# compat32
119%if %{build_compat32}
120%files -n compat32-%{name}-libs
121%defattr(-,root,root,-)
122%{libdir}/libkeyutils-%{version}.so
123%{libdir}/libkeyutils.so.%{vermajor}
124
125%files -n compat32-%{name}-libs-devel
126%defattr(-,root,root,-)
127%{usrlibdir}/libkeyutils.so
128%endif
129
130%changelog
131* Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2-4
132- rebuilt with new toolchains
133
134* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-3
135- added compat32 package for x86_64 arch support
136
137* Sat Feb 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2-2
138- changed libs subpackage's Group to System Environment/Libraries
139- changed devel subpackage's Group to Development/Libraries
140
141* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
142- initial build for Vine Linux
143
144* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2-3
145- Autorebuild for GCC 4.3
146
147* Tue Aug 22 2006 David Howells <dhowells@redhat.com> - 1.2-1
148- Remove syscall manual pages (section 2) to man-pages package [BZ 203582]
149- Don't write to serial port in debugging script
150
151* Mon Jun 5 2006 David Howells <dhowells@redhat.com> - 1.1-4
152- Call ldconfig during (un)installation.
153
154* Fri May 5 2006 David Howells <dhowells@redhat.com> - 1.1-3
155- Don't include the release number in the shared library filename
156- Don't build static library
157
158* Fri May 5 2006 David Howells <dhowells@redhat.com> - 1.1-2
159- More bug fixes from Fedora reviewer.
160
161* Thu May 4 2006 David Howells <dhowells@redhat.com> - 1.1-1
162- Fix rpmlint errors
163
164* Mon Dec 5 2005 David Howells <dhowells@redhat.com> - 1.0-2
165- Add build dependency on glibc-kernheaders with key management syscall numbers
166
167* Tue Nov 29 2005 David Howells <dhowells@redhat.com> - 1.0-1
168- Add data pipe-in facility for keyctl request2
169
170* Mon Nov 28 2005 David Howells <dhowells@redhat.com> - 1.0-1
171- Rename library and header file "keyutil" -> "keyutils" for consistency
172- Fix shared library version naming to same way as glibc.
173- Add versioning for shared library symbols
174- Create new keyutils-libs package and install library and main symlink there
175- Install base library symlink in /usr/lib and place in devel package
176- Added a keyutils archive library
177- Shorten displayed key permissions list to just those we actually have
178
179* Thu Nov 24 2005 David Howells <dhowells@redhat.com> - 0.3-4
180- Add data pipe-in facilities for keyctl add, update and instantiate
181
182* Fri Nov 18 2005 David Howells <dhowells@redhat.com> - 0.3-3
183- Added stdint.h inclusion in keyutils.h
184- Made request-key.c use request_key() rather than keyctl_search()
185- Added piping facility to request-key
186
187* Thu Nov 17 2005 David Howells <dhowells@redhat.com> - 0.3-2
188- Added timeout keyctl option
189- request_key auth keys must now be assumed
190- Fix keyctl argument ordering for debug negate line in request-key.conf
191
192* Thu Jul 28 2005 David Howells <dhowells@redhat.com> - 0.3-1
193- Must invoke initialisation from perror() override in libkeyutils
194- Minor UI changes
195
196* Wed Jul 20 2005 David Howells <dhowells@redhat.com> - 0.2-2
197- Bump version to permit building in main repositories.
198
199* Mon Jul 12 2005 David Howells <dhowells@redhat.com> - 0.2-1
200- Don't attempt to define the error codes in the header file.
201- Pass the release ID through to the makefile to affect the shared library name.
202
203* Mon Jul 12 2005 David Howells <dhowells@redhat.com> - 0.1-3
204- Build in the perror() override to get the key error strings displayed.
205
206* Mon Jul 12 2005 David Howells <dhowells@redhat.com> - 0.1-2
207- Need a defattr directive after each files directive.
208
209* Mon Jul 12 2005 David Howells <dhowells@redhat.com> - 0.1-1
210- Package creation.
Note: See TracBrowser for help on using the repository browser.