source: projects/specs/branches/6/k/kdoc/kdoc-vl.spec @ 521

Revision 521, 4.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define DATE 20020415
2%define sourcedir stable/%{version}/distribution/tar/generic/source
3%define is_release 1
4%define beta %{nil}
5Version: 2.0a54
6%define rel 1%{?_dist_release}
7%if "%{beta}" != ""
8%define VER %{version}%{beta}
9%else
10%define VER %{version}
11%endif
12
13Name: kdoc
14Summary: KDOC -- C++ and IDL Source Documentation System
15%if %{is_release}
16Source: ftp://ftp.kde.org/pub/kde/%{sourcedir}/kdoc-%{VER}.tar.bz2
17%else
18Source: ftp://ftp.kde.org/pub/kde/%{sourcedir}/kdoc-%{DATE}.tar.bz2
19%endif
20Release: %{rel}
21Epoch: 1
22Group: Development/Tools
23License: GPL
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: perl >= 5.6.1 autoconf automake15
27BuildRequires: qt-devel
28Requires: perl >= 5.6.1
29BuildArch: noarch
30
31%description
32Documentation tools for the K Desktop Environment.
33KDOC creates cross-referenced documentation for C++ and CORBA IDL libraries
34directly from the source. Documentation can be embedded in special doc
35comments in the source.
36
37%prep
38%if %{is_release}
39%setup -q -n %{name}-%{VER}
40%else
41%setup -q -n %{name}
42%endif
43
44# Workaround for legacy auto* tools
45[ -x /usr/bin/autoconf-2.5? ] && ln -s /usr/bin/autoconf-2.5? autoconf
46[ -x /usr/bin/autoheader-2.5? ] && ln -s /usr/bin/autoheader-2.5? autoheader
47[ -x /usr/bin/aclocal-1.5 ] && ln -s /usr/bin/aclocal-1.5 aclocal
48[ -x /usr/bin/automake-1.5 ] && ln -s /usr/bin/automake-1.5 automake
49export PATH=`pwd`:$PATH
50# End workaround
51
52make -f Makefile.cvs
53
54%build
55export KDEDIR=/usr
56. /etc/profile.d/qt.sh
57if [ -x /usr/bin/getconf ]; then
58  CPUS=`getconf _NPROCESSORS_ONLN`
59fi
60if test "x$CPUS" = "x" -o "x$CPUS" = "x0"; then
61  CPUS=1
62fi
63CXXFLAGS="$RPM_OPT_FLAGS -I%{_includedir}/kde" %configure
64make -j $CPUS CXXFLAGS="$RPM_OPT_FLAGS -DNO_DEBUG -DNDEBUG"
65
66%install
67rm -rf $RPM_BUILD_ROOT
68make DESTDIR="$RPM_BUILD_ROOT" install
69
70rm -rf docs
71cp -a $RPM_BUILD_ROOT/usr/share/doc/kdoc docs
72rm -rf $RPM_BUILD_ROOT%{_docdir}
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%files
78%defattr(-,root,root)
79%doc COPYING docs/*
80%{_bindir}/*
81%dir %{_datadir}/kdoc
82%{_datadir}/kdoc/*
83%{_mandir}/*/*
84
85%changelog
86* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0a54-1
87- applied new versioning policy
88- added BuildRequires: qt-devel
89
90* Sun Oct 22 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0a54-0vl2
91- changed Group to Development/Tools
92
93* Mon May 20 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0a54-0vl1
94- Update to 2.0a54
95- Epoch: 1
96- change Summary and description
97
98* Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
99- Update to 2.2.2
100
101* Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
102- Update to 2.2.1
103- Delete Epoch
104- Add BuildPrereq and Requires
105- Build for VineSeed
106
107* Mon Aug  6 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-1
108- 2.2 final
109
110* Wed Jun 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
111- 2.2 beta 1
112
113* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
114- 2.1-respin
115
116* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
117- 2.1
118
119* Sun Feb 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
120- Update
121
122* Tue Nov 28 2000 Bernhard Rosenkraenzer <bero@redhat.com>
123- 2.0.1
124
125* Wed Nov  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
126- Update to current CVS, this should finally be able to generate the kdelibs
127  docs
128
129* Fri Oct 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
130- Update to KDE_2_0_BRANCH, now that the ".0 release" bugs are fixed.
131- Fix build on 6.x systems
132
133* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
134- 2.0 final
135
136* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
137- 2.0rc2
138- clean up spec file
139
140* Tue Jul 18 2000 Trond Eivind Glomsrxd <teg@redhat.com>
141- drop icon (glint is obsolete)
142- "License" replaces "Copyright"
143- use %%docdir
144- different releasenumber scheme, the old one can't be used
145  for tools and makes fixing specfiles hard
146
147* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
148- SMPify
149- Don't hardcode QTDIR
150
151* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
152- new snapshot
153
154* Tue Jun 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
155- Fix build if %%{_mandir} = /usr/man
156
157* Sun Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
158- new snapshot
159- FHSify
160
161* Mon Apr  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
162- fix compatibility with perl 5.6.0
163
164* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
165- new snapshot
166- remove renaming to kdoc2 etc, move to /usr
167
168* Wed Mar 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
169- New snapshot
170- Make gzipped man pages optional
171
172* Tue Feb  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
173- handle compressed man pages
174- new snapshot
175
176* Wed Jan 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
177- fix up the makekde2doc script (add missing semicolon)
178
179* Thu Jan  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
180- new snapshot
181- get ready for powertools 6.2
182- make it a noarch package; it's just perl scripts
183
184* Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.de>
185- initial RPM
Note: See TracBrowser for help on using the repository browser.