source: projects/specs/branches/6/k/kdevplatform/kdevplatform-vl.spec @ 4232

Revision 4232, 5.2 KB checked in by inagaki, 13 years ago (diff)

update: kdevplatform, kdevelop

Line 
1%if %{?_dist_release} != "vl5"
2%define kde KDE
3%else
4%define kde KDE4
5%endif
6
7Name:           kdevplatform
8Summary:        Libraries for use by %{kde} development tools
9Summary(ja):    %{kde} 開発ツールが使用するライブラリ
10Version:        1.2.3
11Release:        1%{?_dist_release}
12
13Group:          Development/Tools
14License:        GPLv2
15URL:            http://www.kdevelop.org/
16
17Source0:        ftp://ftp.kde.org/pub/kde/stable/kdevelop/4.2.0/src/kdevplatform-%{version}.tar.bz2
18Source1:        ftp://ftp.kde.org/pub/kde/stable/kdevelop/4.2.0/src/kdevplatform-%{version}.md5sum
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  libboost-devel
22BuildRequires:  gettext
23BuildRequires:  kdelibs4-devel >= 4.6
24BuildRequires:  kdesdk4-devel >= 4.6
25BuildRequires:  pcre-devel
26BuildRequires:  subversion-devel
27BuildRequires:  apr-util-devel
28BuildRequires:  soprano-devel
29
30Requires: %{name}-libs = %{version}-%{release}
31Requires(postun): gtk2
32Requires(posttrans): gtk2
33
34%description
35%{kde} Development platform, the foundations upon which
36KDevelop and Quanta are built.
37
38%package libs
39Summary: Runtime libraries for %{name}
40Summary(ja): %{name} のランタイムライブラリ
41Group:   System Environment/Libraries
42Requires: kdelibs4
43
44%description libs
45%{summary}.
46
47%package devel
48Summary:  Developer files for %{name}
49Summary(ja): %{name} の開発用ファイル
50Group:    Development/Libraries
51Requires: %{name}-libs = %{version}-%{release}
52Requires: libboost-devel
53Requires: commoncpp2-devel
54Requires: kdelibs4-devel
55Requires: subversion-devel
56
57%description devel
58%{summary}.
59
60
61%prep
62%setup -q -n kdevplatform-%{version}
63
64
65%build
66mkdir -p %{_target_platform}
67pushd %{_target_platform}
68unset QTDIR || : ; . /etc/profile.d/qt4.sh
69%cmake \
70    -DCMAKE_BUILD_TYPE=release \
71    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
72    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
73    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
74    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
75    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
76    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
77    ..
78popd
79
80make %{?_smp_mflags} -C %{_target_platform}
81
82
83%install
84rm -rf %{buildroot}
85
86make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
87
88%find_lang %{name} --all-name --with-kde
89
90
91%clean
92rm -rf %{buildroot}
93
94
95%post
96touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
97
98%posttrans
99gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
100
101%postun
102if [ $1 -eq 0 ] ; then
103    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
104    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
105fi
106
107%post libs -p /sbin/ldconfig
108
109%postun libs -p /sbin/ldconfig
110
111
112%files -f %{name}.lang
113%defattr(-,root,root,-)
114%doc COPYING.PLUGINS COPYING.SRC
115%{_datadir}/kde4/apps/kdev*/
116%{_datadir}/kde4/services/*.desktop
117%{_datadir}/kde4/servicetypes/*.desktop
118%{_datadir}/icons/hicolor/*/*/*
119
120%files libs
121%defattr(-,root,root,-)
122%{_libdir}/lib*.so.*
123%{_libdir}/kde4/*.so
124
125%files devel
126%defattr(-,root,root,-)
127%{_libdir}/lib*.so
128%{_includedir}/kde4/kdevplatform/
129%{_libdir}/cmake/kdevplatform/
130
131
132%changelog
133* Sat Jun 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.3-1
134- new upstream release
135
136* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.0-2
137- add BuildRequires: soprano-devel
138
139* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
140- new upstream release
141
142* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.1.2-1
143- new upstream release
144- added Japanese summary
145
146* Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-3
147- removed R: kdevplatform from libs package
148
149* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-2
150- Initial build for Vine Linux
151
152* Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-1
153- kdevplatform-1.0.0
154
155* Sat Apr 17 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.10.2-1
156- kdevplatform-0.10.2
157
158* Thu Apr 08 2010 Rex Dieter <rdieter@fedoraproject.org. - 0.10.0-1
159- kdevplatform-0.10.0
160
161* Mon Mar 08 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.99-1
162- kdevplatform-0.9.99
163
164* Mon Feb 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.98-1
165- kdevplatform-0.9.98
166
167* Sat Jan 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.97-2
168- rebuild (boost)
169- BR: kdelibs4-devel
170
171* Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> 0.9.97-1
172- kdevplatform-0.9.97
173- kdevplatform: file conflict with kdelibs (FindKDevPlatform.cmake) (#541690)
174
175* Sun Nov 22 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.95-0.6.20091015svn1035382
176- rebuild (fc13+, qt-4.6.0-rc1)
177
178* Thu Oct 15 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.5.20091015svn1035382
179- New snapshot
180
181* Sun Oct 11 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.4.beta5
182- Fix finding Kompare includes
183
184* Tue Sep 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.3.beta5
185- Use official release
186
187* Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.2
188- Add icon scriptlets
189
190* Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.1
191- Update tarball
192
193* Fri May 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.93-0.1
194- 1.0 Beta 3
195
196* Sat Feb 21 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.91-0.2.20090221svn929301
197- Post KDevplatform 1.0 Beta 1 snapshot
198
199* Fri Jan 09 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.85-1
200- 0.9.85 snapshot
Note: See TracBrowser for help on using the repository browser.