source: projects/specs/branches/6/k/kdepim/kdepim-vl.spec @ 4216

Revision 4216, 22.1 KB checked in by inagaki, 13 years ago (diff)

updated: KDE SC 4.6.4

Line 
1Name: kdepim
2Summary: PIM (Personal Information Manager) for KDE
3Summary(ja): KDE の個人情報管理(PIM)アプリケーション集
4Version: 4.6.0
5Release: 1%{?_dist_release}
6
7Group: Applications/Productivity
8License: GPLv2
9URL: http://pim.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdepim-%{version}.tar.bz2
12
13Patch0:  kdepim-4.1.80-libqgpgme-link-fix.patch
14# http://bugzilla.redhat.com/show_bug.cgi?id=496988
15Patch1:  kdepim-4.3.1-kmail-saveAttachments.patch
16## upstream
17
18# KDE.org patches
19# KDE.gr.jp patches
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: akonadi-devel
23BuildRequires: bison flex
24BuildRequires: libboost-devel
25BuildRequires: cyrus-sasl-devel
26BuildRequires: desktop-file-utils
27BuildRequires: grantlee-devel
28BuildRequires: gnokii-devel
29BuildRequires: gpgme-devel
30BuildRequires: kdepimlibs-devel >= %{version}
31#BuildRequires: kdelibs-experimental-devel
32BuildRequires: libassuan-devel
33BuildRequires: libical-devel
34BuildRequires: libindicate-qt-devel
35BuildRequires: libXpm-devel libXScrnSaver-devel
36# TODO: libmapi from http://www.openchange.org/
37#BuildRequires: libmapi-devel
38BuildRequires: libxslt-devel
39# libmal currently not used, recheck with kdepim-4.3
40BuildRequires: pilot-link-devel >= 0.12.4
41BuildRequires: python-devel
42BuildRequires: soprano-devel
43BuildRequires: qca2-devel
44BuildRequires: zlib-devel
45Requires: %{name}-libs = %{version}-%{release}
46Requires: kdepim-runtime >= %{version}
47
48Obsoletes: kdepim4 < %{version}-%{release}
49Provides: kdepim4 = %{version}-%{release}
50
51Conflicts: kdepim3
52Conflicts: kdeutils3
53
54%description
55A PIM (Personal Information Manager) for KDE.
56
57What it is
58----------
59* kmail: email client
60* knode: newsreader
61* knotes: sticky notes for the desktop
62* kontact: integrated PIM management
63* korganizer: journal, appointments, events, todos
64%{?_with_pilot_link:* kpilot: HotSync® software for Palm OS® devices}
65
66%package libs
67Summary: %{name} runtime libraries
68Summary(ja): %{name} のラインタイムライブラリ
69Group:   System Environment/Libraries
70Requires: kdelibs4 >= %{version}
71
72%description libs
73%{summary}.
74
75%package devel
76Summary: Development files for kdepim
77Summary(ja): %{name} の開発用ファイル
78Group: Development/Libraries
79Requires: %{name}-libs = %{version}-%{release}
80Requires: kdelibs4-devel
81Obsoletes: kdepim4-devel < %{version}-%{release}
82Provides:  kdepim4-devel = %{version}-%{release}
83Conflicts: kdepim3-devel
84
85%description devel
86Development files for %{name}.
87Install %{name}-devel if you want to write or compile %{name} plugins.
88
89%prep
90%setup -q -n kdepim-%{version}
91%patch0 -p1 -b .libqgpgme-link-fix
92#patch1 -p0 -b .kmail-saveAttachments
93
94%build
95mkdir -p %{_target_platform}
96pushd %{_target_platform}
97unset QTDIR || : ; . /etc/profile.d/qt4.sh
98%cmake \
99    -DCMAKE_BUILD_TYPE=release \
100    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
101    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
102    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
103    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
104    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
105    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
106    ..
107popd
108
109make %{?_smp_mflags} -C %{_target_platform}
110
111%install
112rm -rf $RPM_BUILD_ROOT
113make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
114
115# make symlinks relative
116mkdir -p $RPM_BUILD_ROOT%{_docdir}/HTML/en/common
117pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en
118for i in *; do
119    if [ -d $i -a -L $i/common ]; then
120        rm -f $i/common
121        ln -nfs ../common $i
122    fi
123done
124popd
125
126%check
127for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
128    desktop-file-validate $f
129done
130
131%post
132touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
133touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
134
135%posttrans
136gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
137gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
138update-desktop-database -q &> /dev/null ||:
139
140%postun
141if [ $1 -eq 0 ] ; then
142  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
143  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
144  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
145  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
146  update-desktop-database -q &> /dev/null ||:
147fi
148
149%post libs -p /sbin/ldconfig
150
151%postun libs -p /sbin/ldconfig
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%files
157%defattr(-,root,root)
158%{_bindir}/*
159#{_libdir}/libkpilot_*.so
160%{_libdir}/kde4/*.so
161%{_libdir}/kde4/imports/*
162%{_libdir}/strigi/*.so
163%{_libdir}/akonadi/*
164%{_datadir}/akonadi/*
165%{_datadir}/applications/kde4/*.desktop
166%{_datadir}/kde4/apps/akregator
167%{_datadir}/kde4/apps/akregator_sharemicroblog_plugin/*.rc
168%{_datadir}/kde4/apps/akonadiconsole/*
169%{_datadir}/kde4/apps/blogilo/*
170%{_datadir}/kde4/apps/desktoptheme/*
171%{_datadir}/kde4/apps/kaddressbook
172%{_datadir}/kde4/apps/kaddressbook-mobile
173%{_datadir}/kde4/apps/kalarm
174%{_datadir}/kde4/apps/kconf_update/*
175%{_datadir}/kde4/apps/kdepimwidgets
176%{_datadir}/kde4/apps/kjots
177%{_datadir}/kde4/apps/kleopatra
178%{_datadir}/kde4/apps/kmail
179%{_datadir}/kde4/apps/kmail-mobile
180%{_datadir}/kde4/apps/kmailcvt
181%{_datadir}/kde4/apps/kmail2
182%{_datadir}/kde4/apps/knode
183%{_datadir}/kde4/apps/knotes
184#{_datadir}/kde4/apps/konsolekalendar
185%{_datadir}/kde4/apps/kontact
186%{_datadir}/kde4/apps/kontact-touch
187%{_datadir}/kde4/apps/kontactsummary
188%{_datadir}/kde4/apps/korgac
189%{_datadir}/kde4/apps/korganizer
190%{_datadir}/kde4/apps/korganizer-mobile
191#{_datadir}/kde4/apps/kpilot
192%{_datadir}/kde4/apps/ktimetracker
193%{_datadir}/kde4/apps/kwatchgnupg
194#{_datadir}/kde4/apps/libkdepim
195%{_datadir}/kde4/apps/libkleopatra
196%{_datadir}/kde4/apps/libmessageviewer
197%{_datadir}/kde4/apps/messagelist
198%{_datadir}/kde4/apps/messageviewer
199%{_datadir}/kde4/apps/mobileui
200%{_datadir}/kde4/apps/notes-mobile
201%{_datadir}/kde4/apps/tasks-mobile
202%{_datadir}/dbus-1/interfaces/*.xml
203%{_datadir}/autostart/*
204#{_datadir}/akonadi/*
205%{_datadir}/config/*
206%{_datadir}/config.kcfg/*
207%{_datadir}/icons/hicolor/*/*/*
208%{_datadir}/icons/oxygen/*/*/*
209%{_datadir}/kde4/services/*
210%{_datadir}/kde4/servicetypes/*
211%doc %{_docdir}/HTML/*/*
212%{_mandir}/man1/*
213
214%files libs
215%defattr(-,root,root)
216%{_libdir}/lib*.so.*
217%{_libdir}/kde4/plugins/designer/*.so
218%{_datadir}/locale/*/LC_MESSAGES/*
219
220%files devel
221%defattr(-,root,root)
222#{_includedir}/kde4/*
223%{_libdir}/lib*.so
224#exclude %{_libdir}/libkpilot_*.so
225
226%changelog
227* Wed Jun 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
228- new upstream release
229- added BR: grantlee-devel
230
231* Sat May 21 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.11.1-1
232- new upstream release
233
234* Fri Feb 18 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.10-1
235- new upstream release
236- added BR: libindicate-qt-devel
237
238* Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.6-1
239- new upstream release
240- built with rpm-4.8.1
241
242* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-2
243- rebuilt for VineSeed
244
245* Mon Jul  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
246- new upstream release
247- added Conflicts: kdepim3, kdeutils3
248
249* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
250- new upstream release
251
252* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
253- new upstream release
254
255* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
256- new upstream release
257
258* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
259- new upstream release
260- built with new toolchain
261
262* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
263- new upstream release
264
265* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
266- new upstream release
267- dropped Patch100 (merged into upstream)
268- used %%cmake macro
269
270* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
271- new upstream release
272
273* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
274- applied new versioning policy, spec in UTF-8
275- added Japnaese summary
276
277* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
278- rebuild for VineSeed
279
280* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
281- new upstream release
282
283* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
284- rebuild for VineSeed
285
286* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
287- new upstream release
288- remove all patches
289
290* Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
291- new upstream release
292- add Patch0, 1 , 2 and 3
293
294* Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
295- added --with-qt-libraries and --enable-libsuffix option
296
297* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
298- rebuild for VineSeed
299
300* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
301- new upstream release
302
303* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
304- rebuild with pilot-link-0.12.0-0vl1
305
306* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
307- rebuild for VineSeed
308
309* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
310- new upstream release
311
312* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
313- rebuild for VineSeed
314
315* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
316- new upstream release
317
318* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
319- rebuild for VineSeed
320
321* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
322- new upstream release
323
324* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
325- rebuild for VineSeed
326
327* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
328- new upstream release
329- delete BuildPrereq: libmal-devel and Requires: libmal
330
331* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
332- rebuild for VineSeed
333
334* Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
335- new upstream release
336
337* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
338- new upstream release
339
340* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
341- new upstream release
342- delete all patches
343- add Requires: kdeaccessibility  >= %%{version}
344- add --enable-indexlib to configure option
345
346* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
347- new upstream release
348- remove Patch0
349- add Patch0 - Patch1
350
351* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
352- rebuild for VineSeed
353
354* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
355- new upstream release
356- remove Patch0
357- add BuildPrereq: gpgme-devel >= 0.4.5
358- add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
359
360* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
361- rebuild for VineSeed
362- add --disable-rpath to configure option
363
364* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
365- new upstream release (delete old patch and add new security patch)
366- use %%{?_smp_mflags} for make option
367
368* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
369- rebuild for VineSeed
370
371* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
372- new upstream release
373- add patch0
374
375* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
376- new upstream release (3.4.0-rc1)
377
378* Tue Feb  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
379- new upstream release
380
381* Wed Feb  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
382- new upstream release
383
384* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
385- rebuild for VineSeed
386
387* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
388- new upstream release
389
390* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
391- source upgrade
392- update %%files
393- all sub-packages are integrated into main package (exclude devel)
394
395* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
396- rebuild with qt32
397
398* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
399- source upgrade
400- remove lines about vine26
401
402* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
403- source upgrade
404- update %%files
405
406* Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
407- source upgrade
408- update %%description
409- add Obsoletes: kdenetwork < 3.2.0
410
411* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
412- rebuild for VineSeedPlus
413
414* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
415- source upgrade
416- build for VinePlus/2.6
417- (VinePlus/2.6) BuildPrereq: autoconf258
418- remove Patch
419
420* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
421- build for VineSeed with new toolchain and qt-3.2.3
422- add configure option --with-xinerama --enable-final
423
424* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
425- rebuild with qt-3.2.1-0.26vl3
426
427* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
428- rebuild with qt-3.2.1-0vl3
429
430* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
431- build with gcc-3.2.3
432
433* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
434- source upgrade
435- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
436
437* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
438- rebuild for Vine2.6
439
440* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
441- source upgrade
442- change spec to build with gcc295
443- change make option for SMP and add script
444- add BuildPrereq: libmal-devel
445- add Requires: libmal for pilot
446
447* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
448- source upgrade
449- remove Patch800 (included in this source)
450- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
451
452* Sat Apr  5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
453- source upgrade
454- change spec to build both VineSeed and Vine2.5/2.6
455- revised description and files section
456- remove source900
457- add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
458- add patch800 (Kdeveloper:02753)
459
460* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
461- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
462
463* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
464- source upgrade
465
466* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
467- rebuild with qt-3.0.5-0vl1
468- BuildPrereq: autoconf253 objprelink2
469
470* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
471- source upgrade
472
473* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
474- source upgrade
475- add BuildPrereq: autoconf252 automake15
476
477* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
478- merged with rawhide 3.0.1-1
479- change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
480- add Requires: for each package
481- There is Vine's previous changes, hacked for Vine
482 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
483  - build for VineSeed
484  - delete Epoch
485  - objprelink (i386 only)
486
487* Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
488- 3.0.1
489- fixed bug #67303
490
491* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
492- automated rebuild
493
494* Thu May 23 2002 Tim Powers <timp@redhat.com>
495- automated rebuild
496
497* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
498- Rename libraries
499
500* Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
501- Fix #61901
502
503* Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
504- final
505
506* Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
507- Update
508- Fix build on ia64
509
510* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
511- Update, fixes korganizer (#50006)
512
513* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
514- Update to get rid of abbrowser (moved to kdebase)
515
516* Thu Feb 22 2001 Than Ngo <than@redhat.com>
517- add missing ldconfig in %post anf %postun again
518- clean up specfile
519
520* Wed Feb 21 2001 Than Ngo <than@redhat.com>
521- 2.1-respin
522- fix dangling symlink
523- remove excludearch ia64, some hacks to build on ia64
524
525* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
526- 2.1
527
528* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
529- Update
530
531* Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
532- Update
533
534* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
535- Update to CVS
536- Enable building kpilot
537- Obsolete kpilot
538- Don't exclude ia64, use -O0 on ia64
539- Disable building kpilot on ia64 (compiler breakage)
540
541* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
542- 2.0 final
543
544* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
545- 2.0
546
547* Sun Oct  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
548- new CVS
549- fix installation of fonts
550
551* Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
552- new CVS snapshot
553- fix up spec file
554
555* Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
556- get rid of the 3d-screensavers package - now that qt-GL is part of qt,
557  there's no need to keep them separate to avoid the dependency.
558
559* Mon Aug 21 2000 Than Ngo <than@redhat.com>
560- fix gnome-session so that KDE2 can be started from gdm
561- pam/kde2 instead pam/kde to avoid problem with KDE1
562- don't requires qt-GL, It's now in qt
563
564* Sun Aug 20 2000 Than Ngo <than@redhat.com>
565- fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
566  at the same time
567- add missing ldconfig in %post anf %postun
568- fix for reading config files in /etc/X11/xdm, add Xsession to requires
569
570* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
571- Fix keytable in konsole (Bug #15682)
572
573* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
574- rebuild, now that kdelibs2 works on alpha
575- use the same ugly hack to get kdebase to compile
576- remove ksysguard on alpha (even more compiler problems)
577
578* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
579- new snapshot (fixed libGL detection in CVS)
580
581* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
582- move to /usr/lib/kde2
583- new snapshot
584
585* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
586- fix the --xdmdir arg to be correct (oops)
587
588* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
589- move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
590
591* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
592- new snapshot
593- some fixes to spec file
594
595* Tue Jul 18 2000 Than Ngo <than@redhat.de>
596- rebuilt against glibc-2.1.92-14, gcc-2.96-40
597
598* Sun Jul 16 2000 Than Ngo <than@redhat.de>
599- use new snapshot
600- disable Motif
601
602* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
603- use gcc 2.96
604- new snapshot
605
606* Sun Jul  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
607- Epoch 3
608- Update to current
609- Use egcs++
610
611* Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
612- Update (I put the fixes directly to CVS rather than collecting them
613  in the spec)
614
615* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
616- remove man2html; we get that from man
617- new snapshot
618
619* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
620- new snapshot
621- ExcludeArch ia64 for now
622- remove gnome .desktop file, we get it from gnome-core now.
623
624* Wed Apr  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
625- remove dependency on xpm (now in XFree86)
626
627* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
628- new snapshot
629- move it to /usr, where it belongs
630
631* Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
632- Build the OpenGL screensavers, and move them to a separate package
633- Improve the spec file (BuildPrereqs etc.)
634
635* Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
636- remove patch #3 (obsoleted by kwin)
637
638* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
639- 2.0 CVS snapshot
640- fix compilation
641
642* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
643- clean up files in /tmp from startkde
644- mark doc files as such
645
646* Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
647- start autorun if present in startkde
648- check for configured soundcard before running sound services
649
650* Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
651- made kdelnks display Name property if they are of type Link
652
653* Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
654- moved png handling here (from kdelibs)
655- changed low color icon directory name to locolor
656
657* Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
658- added optional session management to logout dialog
659- include GNOME menus
660
661* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
662- added link to /etc/X11/applnk, .directory file
663- included lowcolor icon sub-package
664- enable .desktop file access
665
666* Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
667- customized startkde script to set up user environment if not present.
668- mention kthememgr in description.
669
670* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
671- upgraded to 1.1.2 release
672- kvt is back
673- kde icon included
674- linux console fonts included
675
676* Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
677- PAM console logout problem solved.
678
679* Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
680- now includes screensaver password security fix
681
682* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
683- snapshot, includes kde 1.1.1 + fixes
684- kvt removed for security reasons.  It is a steaming pile of...
685
686* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
687- last snapshot before release
688
689* Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
690- today's snapshot makes kfm a bit nicer and some other fixes
691- moved default rc files to kdesupport
692
693* Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
694- SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
695
696* Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
697- built with today's snapshot -- had to rebuild to fix pam problems.
698
699* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
700- new snapshot fixes mimetype video/x-flic problem
701
702* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
703- latest stable snapshot
704
705* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
706- removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
707- this previous connection and autoselect kdebase for upgrade).
708
709* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
710- moved gdm patch
711
712* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
713- added gdm session control file
714
715* Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
716- added pam-console stuff to kde pam file
717
718* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
719- Injected new description and group.
720
721* Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
722- upgraded to KDE 1.1 final.
723
724* Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
725- updated macros for RPM 3.0, removed red hat logo.
726
727* Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
728- re-merged from Duncan Haldane's stuff
Note: See TracBrowser for help on using the repository browser.