source: projects/specs/branches/6/k/kdegames3/kdegames3-vl.spec @ 2773

Revision 2773, 15.5 KB checked in by inagaki, 13 years ago (diff)

update: akonadi, grantlee, kdegames3, kde-l10n, kde-i18n-ja, oxygen-icon-theme
NEW: grantlee

Line 
1%define make_cvs 1
2
3# These games are already in KDE 4.
4%define donotcompilelist katomic kbattleship kblackbox kbounce kgoldrunner kjumpingcube klines klickety kmahjongg kmines knetwalk kolf konquest kpat kreversi ksame kshisen kspaceduel ktron ktuberling kwin4 lskat
5
6Name: kdegames3
7Summary: KDE Games not ported to KDE 4
8Summary(ja): KDE 4 に移植されていない KDE ゲーム集
9Version: 3.5.10
10Release: 2%{?_dist_release}
11
12License: GPLv2
13Group: Applications/Games
14URL: http://www.kde.org/
15
16Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdegames-%{version}.tar.bz2
17Patch0: kdegames-3.5.10-trademarks.patch
18# fix build with make_cvs enabled and autoconf >= 2.64
19Patch1: arts-acinclude.patch
20# fix FTBFS with the new stricter ld in F13 (#565113)
21Patch2: kdegames-3.5.10-ftbfs.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: kdelibs3-devel >= %{version}
25BuildRequires: zlib-devel libpng-devel libjpeg-devel
26%if %{make_cvs}
27BuildRequires: automake libtool
28%endif
29Requires: kdelibs3 >= %{version}
30Requires: hicolor-icon-theme
31
32%description
33Games and gaming libraries for KDE which have not been ported to KDE 4 yet.
34Included with this package are: atlantik, kasteroids, kbackgammon, kboxpush,
35kenolaba, kfouleggs, kpoker, ksirtet, ksmiletris, ksnake.
36
37
38%package devel
39Summary: Development files for kdegames3
40Summary(ja): kdegames3 の開発用ファイル
41Group: Development/Libraries
42License: LGPLv2
43Requires: %{name} = %{version}-%{release}
44Requires: kdelibs3-devel >= %{version}
45
46%description devel
47Development files for the KDE gaming libraries.
48Install kdegames-devel if you wish to develop or compile games for the
49KDE desktop.
50
51%prep
52%setup -q -n kdegames-%{version}
53%patch0 -p1
54%patch1 -p1 -b .autoconf
55%patch2 -p1 -b .ftbfs
56
57export DO_NOT_COMPILE="%{donotcompilelist}"
58%if %{make_cvs}
59# hack/fix for newer automake
60  sed -iautomake -e 's|automake\*1.10\*|automake\*1.1[0-5]\*|' admin/cvs.sh
61  make -f admin/Makefile.common cvs
62%endif
63
64%build
65unset QTDIR || : ; . /etc/profile.d/qt.sh
66export DO_NOT_COMPILE="%{donotcompilelist}"
67
68%configure \
69    --with-qt-libraries=$QTDIR/lib \
70    --enable-new-ldflags \
71    --disable-dependency-tracking \
72    --disable-rpath \
73    --enable-final \
74    --disable-debug \
75    --disable-warnings \
76    --includedir=%{_includedir}/kde \
77    --disable-setgid
78
79make %{?_smp_mflags}
80
81%install
82rm -rf $RPM_BUILD_ROOT
83
84export DO_NOT_COMPILE="%{donotcompilelist}"
85make DESTDIR=$RPM_BUILD_ROOT install
86
87# locales
88%find_lang %{name} || touch %{name}.lang
89HTML_DIR=$(kde-config --expandvars --install html)
90if [ -d $RPM_BUILD_ROOT$HTML_DIR ]; then
91for lang_dir in $RPM_BUILD_ROOT$HTML_DIR/* ; do
92  if [ -d $lang_dir ]; then
93    # remove documentation for games we don't ship
94    pushd $lang_dir
95      for i in *; do
96        case "%{donotcompilelist}" in
97          *$i*)
98            # $i is listed in %{donotcompilelist}, zap
99            [ -d $i ] && rm -rf $i
100          ;;
101        esac
102      done
103      rm -rf kdegames-apidocs
104    popd
105    lang=$(basename $lang_dir)
106    echo "%lang($lang) $HTML_DIR/$lang/*" >> %{name}.lang
107    # replace absolute symlinks with relative ones
108    pushd $lang_dir
109      for i in *; do
110        [ -d $i -a -L $i/common ] && ln -nsf ../common $i/common
111      done
112    popd
113  fi
114done
115fi
116
117# rpmdocs
118for dir in atlantik k* ; do
119  case "%{donotcompilelist}" in
120    *$dir*)
121      # $dir is listed in %{donotcompilelist}, skip
122    ;;
123    *)
124      for file in AUTHORS ChangeLog README TODO ; do
125        test -s  "$dir/$file" && install -p -m644 -D "$dir/$file" "rpmdocs/$dir/$file"
126      done
127    ;;
128  esac
129done
130
131# remove libkdegames devel stuff, not used by anything and conflicts with KDE 4
132rm -rf $RPM_BUILD_ROOT%{_includedir}/kde/k* $RPM_BUILD_ROOT%{_libdir}/libkdegames.so
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%post
138/sbin/ldconfig
139for f in crystalsvg hicolor ; do
140  touch --no-create %{_datadir}/icons/$f 2> /dev/null ||:
141  gtk-update-icon-cache -q %{_datadir}/icons/$f 2> /dev/null ||:
142done
143update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
144
145%postun
146/sbin/ldconfig
147for f in crystalsvg hicolor ; do
148  touch --no-create %{_datadir}/icons/$f 2> /dev/null ||:
149  gtk-update-icon-cache -q %{_datadir}/icons/$f 2> /dev/null ||:
150done
151update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
152
153%files
154%defattr(-,root,root)
155%doc %{_datadir}/doc/HTML/en/*
156%{_bindir}/*
157%{_libdir}/lib*.so.*
158%{_libdir}/lib*.la
159%{_libdir}/kde3/*
160%{_datadir}/applications/kde/*.desktop
161%{_datadir}/apps/*
162%{_datadir}/config.kcfg/*
163%{_datadir}/icons/crystalsvg/*/*/*
164%{_datadir}/icons/hicolor/*/*/*
165%{_datadir}/services/*
166
167%files devel
168%defattr(-,root,root)
169%{_includedir}/kde/*
170%{_libdir}/lib*.so
171
172
173%changelog
174* Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-2
175- dropt klickety
176
177* Sun Mar 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-1
178- updated to 3.5.10 based on FC
179- built with new toolchain
180
181* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-2
182- renamed kdegames3
183
184* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
185- applied new versioning policy, spec in UTF-8
186
187* Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
188- rebuild for VineSeed
189
190* Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
191- new upstream release
192
193* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
194- rebuild for VineSeed
195
196* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
197- new upstream release
198
199* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
200- new upstream release
201
202* Sun Oct 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
203- added --with-qt-libraries and --enable-libsuffix option
204
205* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
206- rebuild for VineSeed
207
208* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
209- new upstream release
210
211* Mon Sep 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-0vl3
212- changed Group to Applications/Games
213- added Japanese summary
214
215* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
216- rebuild for VineSeed
217
218* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
219- new upstream release
220
221* Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
222- rebuild for VineSeed
223
224* Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
225- new upstream release
226
227* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
228- rebuild for VineSeed
229
230* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
231- new upstream release
232
233* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
234- rebuild for VineSeed
235
236* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
237- new upstream release
238
239* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
240- rebuild for VineSeed
241
242* Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
243- new upstream release
244
245* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
246- new upstream release
247
248* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
249- new upstream release
250
251* Wed Sep 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
252- new upstream release
253
254* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
255- rebuild for VineSeed
256
257* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
258- new upstream release
259
260* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
261- build for VineSeed
262- add --disable-rpath to configure option
263
264* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
265- new upstream release
266- use %%{?_smp_mflags} for make option
267
268* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
269- rebuild for VineSeed
270
271* Mon Mar 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
272- new upstream release
273
274* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
275- new upstream release (3.4.0-rc1)
276- update %%files
277
278* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
279- rebuild for VineSeed
280
281* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
282- source upgrade
283- build for Vine Linux 3.1
284
285* Thu Oct 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
286- source upgrade
287
288* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
289- rebuild with qt32
290
291* Sun Jun  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
292- source upgrade
293- remove lines about vine26
294- add URL: http://www.kde.org/
295
296* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
297- source upgrade
298
299* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
300- move *.so to main package
301
302* Tue Mar  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
303- source upgrade
304
305* Thu Feb  5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
306- source upgrade
307
308* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
309- rebuild for VineSeedPlus
310
311* Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
312- source upgrade
313- build for VinePlus/2.6
314- (VinePlus/2.6) BuildPrereq: autoconf258
315
316* Fri Dec 26 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
317- build for VineSeed with new toolchain and qt-3.2.3
318
319* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
320- rebuild with qt-3.2.1-0.26vl3
321
322* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
323- rebuild with qt-3.2.1-0vl3
324
325* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
326- source upgrade
327- build with gcc-3.2.3
328
329* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
330- source upgrade
331- change spec to build with gcc295
332- change make option for SMP and add script
333
334* Tue Jun 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
335- change spec to build with g++-2.95.3
336
337* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
338- source upgrade
339- built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
340
341* Sat Mar 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
342- source upgrade
343- change spec to build both VineSeed and Vine2.5/2.6
344
345* Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0vl1
346- source upgrade to 3.1-stable
347
348* Mon Jan 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0.rc7vl1
349- source upgrade to 3.1rc7
350- stop using objprelink2, it does not work with gcc3
351- change spec to make monolithic package only
352- move %{_libdir}/*.la and %{_libdir}/*.so to devel package
353- add %{_libdir}/kde3/*
354- cleanup spec
355
356* Sun Dec 29 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.5a-0vl1
357- source upgrade
358
359* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
360- objprelink2 support only ix86 (add %ifarch %{ix86} ... )
361- add Prereq: ldconfig
362- add Requires: XFree86-libs XFree86-gl freetype2 libjpeg libmng libpng zlib
363- add Requires: qt >= 3.0.5 arts >= 1:1.0.4 kdelibs >= %{version}
364
365* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
366- source upgrade
367- BuildPrereq: autoconf253 objprelink2
368
369* Mon Sep 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
370- source upgrade
371
372* Fri Jul  5 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
373- source upgrade
374
375* Fri Jun  7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-0vl1
376- source update to 3.0.1
377
378* Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
379- source update to 3.0
380- add configure option `--with-xinerama --enable-final'
381- add kbounce
382
383* Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
384- merged with rawhide 3.0.0-0.cvs20020306.1
385- source update to cvs-20020329
386- add BuildPrereq: autoconf252 automake15
387- There is Vine's previous changes, hacked for Vine
388 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
389  - update to 2.2.2
390 -- Fri Nov 30 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
391  - Delete Epoch
392  - Change BuildRequires and Requires
393  - objprelink (i386 only)
394  - Build for VineSeed
395
396* Wed Mar  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
397- Fix packaging glitch in monolithic version
398
399* Tue Mar  5 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020305.1
400- Make splits a buildtime option (off by default) on request
401
402* Mon Jan  7 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020107.1
403- Update to work with latest kdelibs changes
404
405* Wed Dec 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011226.1
406- Update
407- Add missing %{_bindir}/kbattleship
408
409* Sat Dec 15 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011215.1
410- Update
411- Split into several packages (one package per game)
412
413* Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
414- Update
415- Work around ia64 breakages
416- Add build requirements (#48977)
417
418* Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
419- Fix problem when changing the card type (Bug #28824)
420
421* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
422- 2.1-respin
423
424* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
425- 2.1
426
427* Sun Feb 11 2001 Than Ngo <than@redhat.com>
428- don't use make -j CPU, it's broken
429
430* Thu Feb  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
431- Run ldconfig in %%post and %%postun to make libkdegames happy
432- Replace absolute symlinks with relative symlinks (#24787)
433
434* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
435- Update
436- includedir=/usr/include/kde,
437  now that libkdegames installs kcarddeck.h
438
439* Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
440- Get rid of the gcc bug workaround, it's no longer needed
441
442* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
443- Update
444- Don't exclude ia64
445
446* Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
447- Update to HEAD
448
449* Sat Oct 28 2000 Bernhard Rosenkraenzer <bero@redhat.com>
450- Update to KDE_2_0_BRANCH, now that the ".0 release" bugs are fixed.
451
452* Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
453- 2.0 final
454
455* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
456- 2.0
457
458* Mon Oct  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
459- new CVS
460- work around g++ bugs (in kjumpingcube)
461
462* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
463- 1.93
464
465* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
466- new version
467
468* Wed Jul 19 2000 Than Ngo <than@redhat.de>
469- fix docdir
470- rebuild 16 July snapshot
471
472* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
473- SMPify
474- don't hardcode QTDIR
475
476* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
477- use gcc 2.96
478- new snapshot
479
480* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
481- new snapshot
482- ExcludeArch ia64 for now
483
484* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
485- new snapshot
486- move it to /usr, where it belongs
487
488* Fri Oct 22 1999 Bernhard Rosenkraenzer <bero@redhat.de>
489- 2.0 snapshot
490
491* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
492- mark doc files as such
493
494* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
495- 1.1.2 release.
496
497* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
498- snapshot, includes kde 1.1.1 + fixes
499
500* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
501- last snapshot before release
502- ripped out asteroids and sirtet
503
504* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
505- latest stable snapshot
506
507* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
508- Injected new description and group.
509
510* Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
511- upgraded to KDE 1.1 final.
512
513* Fri Feb 05 1999 Preston Brown <pbrown@redhat.com>
514- rebuilt for new libstdc++ etc.
515
516* Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
517- re-merged updates from Duncan Haldane, change /opt/kde --> /usr
518
Note: See TracBrowser for help on using the repository browser.