source: projects/specs/branches/6/k/kdebase-runtime/kdebase-runtime-vl.spec @ 4216

Revision 4216, 26.3 KB checked in by inagaki, 13 years ago (diff)

updated: KDE SC 4.6.4

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.6.4
7Release:       1%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdebase-runtime-%{version}.tar.bz2
15Source1:       khelpcenter.desktop
16
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18Patch2:        kdebase-runtime-4.2.85-knetattach.patch
19Patch3:        kdebase-runtime-4.1.1-iconthemes-inherit.patch
20Patch5:        kdebase-runtime-4.3.1-manpath.patch
21# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
22Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
23Patch7:        kdebase-runtime-4.5.3-htsearch.patch
24# Launch compiz via compiz-manager so we get window decorations and
25# other such decadent luxuries (AdamW 2011/01)
26Patch8:        kdebase-runtime-4.5.95-compiz.patch
27
28## 4.6 Upstream patches
29
30Provides:  kdebase4-runtime = %{version}-%{release}
31Obsoletes: kdebase4-runtime < %{version}-%{release}
32
33# knotify4 provides dbus service org.freedesktop.Notifications too
34Provides: desktop-notification-daemon
35
36Requires: kdepimlibs >= %{version}
37Requires: eject
38Requires: %{name}-libs = %{version}-%{release}
39Requires: %{name}-flags = %{version}-%{release}
40# KHelpcenter requires htdig for building search indices
41Requires: htdig
42
43BuildRoot:     %{_tmppath}/%{name}-%{version}-root
44BuildRequires: alsa-lib-devel
45BuildRequires: attica-devel >= 0.1.4
46BuildRequires: bzip2-devel
47BuildRequires: chrpath
48BuildRequires: clucene-core-devel
49BuildRequires: exiv2-devel
50BuildRequires: kdelibs4-devel >= %{version}
51BuildRequires: kdepimlibs-devel >= %{version}
52BuildRequires: libcanberra-devel
53BuildRequires: libsmbclient-devel
54BuildRequires: libssh-devel >= 0.4.2
55BuildRequires: libXpm-devel
56BuildRequires: libXScrnSaver-devel
57BuildRequires: OpenEXR-devel
58BuildRequires: openslp-devel
59BuildRequires: openssl-devel
60BuildRequires: pkgconfig
61BuildRequires: polkit-qt-devel
62BuildRequires: pulseaudio-libs-devel
63BuildRequires: qimageblitz-devel
64BuildRequires: shared-desktop-ontologies-devel >= 0.5.0
65BuildRequires: soprano-devel >= 2.5.63
66BuildRequires: xine-lib-devel libxcb-devel
67BuildRequires: xorg-x11-font-utils
68BuildRequires: xorg-x11-proto-devel
69BuildRequires: xz-devel
70BuildRequires: zlib-devel
71
72%if %{?_dist_release} == "vl5"
73Conflicts: kdebase3
74%endif
75# some items moved -workspace -> -runtime
76Conflicts: kdebase-workspace < 4.5.80
77
78%description
79Core runtime for KDE 4.
80
81%description -l ja
82KDE 4 の中心となるランタイム部分です.
83
84%package devel
85Summary:  Developer files for %{name}
86Summary(ja): %{name} の開発用ファイル
87Group:    Development/Libraries
88Requires: %{name}-libs = %{version}-%{release}
89
90%description devel
91%{summary}.
92
93%description -l ja devel
94%{name} の開発用ファイルです.
95
96%package libs
97Summary: Runtime libraries for %{name}
98Summary(ja): %{name} のランタイムライブラリ
99Group:   System Environment/Libraries
100Requires: kdelibs4 >= %{version}
101Requires: kdepimlibs >= %{version}
102# cagibi is runtime dep, a dbus service
103Requires: cagibi
104
105%description libs
106%{summary}.
107
108%description -l ja libs
109%{name} のランタイムライブラリです.
110
111%package flags
112Summary: Geopolitical flags
113Group: User Interface/Desktops
114Requires: %{name}-libs = %{version}-%{release}
115
116%description flags
117%{summary}.
118
119
120%prep
121%setup -q -n kdebase-runtime-%{version}
122
123%patch1 -p1 -b .searchproviders-shortcuts
124%patch2 -p1 -b .knetattach
125%patch3 -p1 -b .iconthemes-inherit
126%patch6 -p1 -b .home_onlyshowin_kde
127%patch7 -p1 -b .htsearch
128%patch8 -p1 -b .config
129
130
131%build
132mkdir -p %{_target_platform}
133pushd %{_target_platform}
134unset QTDIR || : ; . /etc/profile.d/qt4.sh
135%cmake \
136    -DCMAKE_BUILD_TYPE=release \
137    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
138    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
139    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
140    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
141    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
142    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
143    ..
144popd
145
146make %{?_smp_mflags} -C %{_target_platform}
147
148
149%install
150rm -rf $RPM_BUILD_ROOT
151
152make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
153
154# kdesu symlink
155ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
156
157# omit hicolor index.theme, use one from hicolor-icon-theme
158rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
159
160# remove country flags because some people/countries forbid some other
161# people/countries' flags :-(
162%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
163
164# install this service for KDE 3 applications too
165mkdir $RPM_BUILD_ROOT%{_datadir}/services
166ln -s %{_datadir}/kde4/services/khelpcenter.desktop \
167      $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
168
169# FIXME: -devel type files, omit for now
170rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
171
172# rpaths
173# use chrpath hammer for now, find better patching solutions later -- Rex
174chrpath --list   $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so ||:
175chrpath --delete $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so
176
177%clean
178rm -rf $RPM_BUILD_ROOT
179
180%post
181touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
182touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
183
184%posttrans
185gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
186gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
187update-desktop-database -q &> /dev/null ||:
188update-mime-database %{_datadir}/mime &> /dev/null
189
190%postun
191if [ $1 -eq 0 ] ; then
192    touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
193    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
194    gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
195    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
196    update-desktop-database -q &> /dev/null ||:
197    update-mime-database %{_datadir}/mime &> /dev/null
198fi
199
200%post libs -p /sbin/ldconfig
201%postun libs -p /sbin/ldconfig
202
203
204%files
205%defattr(-,root,root,-)
206%{_sysconfdir}/dbus-1/system.d/*
207%{_sysconfdir}/xdg/menus/kde-information.menu
208%{_bindir}/*
209# omit ksvgtopng which kdelibs3 includes
210%if %{?_dist_release} == "vl5"
211%exclude %{_bindir}/ksvgtopng
212%endif
213%{_datadir}/kde4/apps/*
214%exclude %{_datadir}/kde4/apps/cmake/
215%{_datadir}/config/*.knsrc
216%{_datadir}/autostart/nepomukserver.desktop
217%{_datadir}/config.kcfg/
218%{_datadir}/dbus-1/interfaces/*
219%{_datadir}/dbus-1/services/*
220%{_datadir}/dbus-1/system-services/*
221%{_datadir}/icons/default.kde4
222%{_datadir}/kde4/services/*
223%{_datadir}/kde4/servicetypes/*
224%{_datadir}/mime/packages/network.xml
225%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
226%{_datadir}/sounds/*
227%{_libdir}/kconf_update_bin/*
228%{_libdir}/libkdeinit4_*.so
229%{_libdir}/kde4/kcm_*.so
230%{_libdir}/kde4/kded_*.so
231%{_libexecdir}/kde4/drkonqi
232#{_libexecdir}/kde4/installdbgsymbols.sh
233%{_libexecdir}/kde4/kcmremotewidgetshelper
234%{_libexecdir}/kde4/kdeeject
235%{_libexecdir}/kde4/kdesu
236%attr(2755,root,nobody) %{_libexecdir}/kde4/kdesud
237%{_libexecdir}/kde4/kdontchangethehostname
238%{_libexecdir}/kde4/khc_docbookdig.pl
239%{_libexecdir}/kde4/khc_htdig.pl
240%{_libexecdir}/kde4/khc_htsearch.pl
241%{_libexecdir}/kde4/khc_indexbuilder
242%{_libexecdir}/kde4/khc_mansearch.pl
243%{_libexecdir}/kde4/kioexec
244%{_libexecdir}/kde4/knetattach
245%{_mandir}/man1/*
246%{_mandir}/man8/*
247%{_datadir}/icons/hicolor/*/*/*
248%{_docdir}/HTML/en/*
249%{_datadir}/applications/kde4/Help.desktop
250%{_datadir}/applications/kde4/knetattach.desktop
251%{_datadir}/applications/kde4/nepomukbackup.desktop
252%{_datadir}/config/kshorturifilterrc
253%{_datadir}/desktop-directories/*.directory
254%{_datadir}/emoticons/kde4/
255%{_datadir}/locale/l10n/
256%{_datadir}/locale/currency/
257%{_datadir}/ontology/kde/
258%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
259%{_datadir}/services/khelpcenter.desktop
260
261%files devel
262%defattr(-,root,root,-)
263%{_includedir}/*
264%{_libdir}/libnepomuksync.so
265%{_datadir}/kde4/apps/cmake/modules/*.cmake
266
267%files libs
268%defattr(-,root,root,-)
269%{_libdir}/attica_kde.so
270%{_libdir}/libknotifyplugin.so
271%{_libdir}/libkwalletbackend.so.*
272%{_libdir}/libmolletnetwork.so.*
273%{_libdir}/libnepomukcommon.so
274%{_libdir}/libnepomuksync.so.*
275%{_libdir}/kde4/*.so
276%{_libdir}/kde4/imports/
277# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
278%exclude %{_libdir}/kde4/kcm_*.so
279%exclude %{_libdir}/kde4/kded_*.so
280%{_libdir}/kde4/plugins/phonon_platform/
281
282%files flags
283%defattr(-,root,root,-)
284%{_datadir}/locale/l10n/*/flag.png
285
286
287%changelog
288* Tue Jun 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
289- new upstream release
290
291* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-2
292- rebuilt with libsmbclient-3.5.8
293
294* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
295- new upstream release
296
297* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-2
298- added BR: libXpm-devel
299
300* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-1
301- new upstream release
302- added devel subpackage
303
304* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
305- new upstream release
306- updated summary
307- dropt Patch100
308
309* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
310- new upstream release
311- added Patch100 from Fedora
312  - backport to fix the freeze of kded on first use of the network:/kio-slave
313
314* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
315- new upstream release
316- added Conflicts: kdebase3 at Vine Linux 5
317
318* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
319- new upstream release
320
321* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
322- rebuilt with exiv2-0.19
323
324* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
325- new upstream release
326
327* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
328- new upstream release
329
330* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
331- new upstream release
332- built with new toolchain
333
334* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
335- new upstream release
336
337* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
338- new upstream release
339
340* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
341- new upstream release
342- used %%cmake macro
343
344* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
345- Initial build for Vine Linux
346
347* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
348- respin
349
350* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
351- 4.3.0
352
353* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
354- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
355
356* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
357- 4.3rc3
358
359* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
360- respin (soprano-2.3.0)
361- License: LGPLv2+
362
363* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
364- 4.3rc2
365
366* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
367- drop unneeded BR: ImageMagick (#509241)
368
369* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
370- don't start nepomuk server unconditionally (#487322)
371
372* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
373- 4.3rc1
374
375* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
376- KDE-4.3 beta2 (4.2.90)
377
378* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
379- Drop old Fedora < 8 conditionals
380
381* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
382- file conflicts with kdepim
383
384* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
385- KDE 4.3 beta 1
386
387* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
388- fix persistent systray notifications (#485796)
389
390* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
391- -flags subpkg
392- koji/noarch hacks dropped
393
394* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
395- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
396
397* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
398- KDE 4.2.2
399
400* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
401- flags subpkg (not enabled)
402- optimize scriptlets
403
404* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
405- fix PulseAudio cmake detection
406
407* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
408- 4.2.1
409
410* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
411- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
412
413* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
414- #486059 -  missing dependency on htdig
415
416* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
417- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
418
419* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
420- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
421
422* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
423- own %%_kde4_datadir/locale/l10n/
424
425* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
426- respun tarball
427
428* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
429- Files not trashed to the correct location in Dolphin/Konqueror
430  (#481598, kdebug#178479)
431- omit --with-samba crud
432
433* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
434- 4.2.0
435- +BR: pulseaudio-libs-devel xine-lib-devel
436- -BR: giflib-devel pcre-devel
437
438* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
439- tarball respin
440- drop extraneous deps (that are in kdelibs)
441
442* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
443- 4.2rc1
444
445* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
446- include %%_bindir/kdesu symlink
447
448* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
449- 4.2beta2
450
451* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
452- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
453  and should be in a -devel package if it gets shipped)
454
455* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
456- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
457
458* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
459- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
460
461* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
462- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
463
464* Fri Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
465- 4.1.80
466- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
467- BR cmake >= 2.6.2
468- Use 'make install/fast'
469- Drop subpkg phonon-backend-xine and related file entries: this has to be
470  part of phonon now that it moved there
471- Drop xine-lib-devel BR
472- Add libkwalletbackend to files list
473- Drop _default_patch_fuzz 2
474
475* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
476- apply upstream patch to fix X crash when disabling compositing
477
478* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
479- 4.1.3
480
481* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
482- apply upstream patch, kioexec processes never terminate
483
484* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
485- fix broken audio-backend-jack.svgz
486
487* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
488- add missing icons
489
490* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
491- make VERBOSE=1
492- respin against new(er) kde-filesystem
493- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
494
495* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
496- 4.1.2
497
498* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
499- fix inherit issue in iconthemes, preview icons
500  do not show
501
502* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
503- fix #460710, knetattach is kio_remote's wizard program, don't show
504  it in the menu.
505
506* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
507- 4.1.1
508
509* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
510- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
511
512* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
513- crash fix when stopping a service that is not yet initialized
514
515* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
516- don't remove autostart directory on F8- (does not conflict, fixes build
517  failure due to nepomukserver.desktop listed in filelist but not found)
518
519* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
520- 4.1.0
521
522* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
523- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
524
525* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
526- 4.0.99
527
528* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
529- respin
530
531* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
532- -phonon-backend-xine: new subpkg
533
534* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
535- 4.0.98
536
537* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
538- 4.0.85
539
540* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
541- 4.0.84
542
543* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
544- 4.0.83 (beta2)
545
546* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
547- 4.0.82
548
549* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
550- add searchproviders-shortcuts for redhat bugzilla
551
552* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
553- 4.1 beta 1
554
555* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
556- BR new minimum version of soprano-devel
557
558* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
559- update to 4.0.72 (4.1 alpha 1)
560- drop upstreamed deinterlace-crash patch
561- drop khelpcenter patch (fixed upstream)
562- update Phonon PulseAudio patch
563- drop Fedora 7 support
564- update file list
565
566* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
567- omit conflicting icons (kde3_desktop=1 case)
568
569* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
570- oxygen-icon-theme: build noarch
571
572* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
573- %%post/%%postun: hicolor icon theme scriptlets
574
575* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
576- only omit hicolor index.theme (#439374)
577
578* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
579- fix khelpcenter, search plugins/settings in correct path (#443016)
580
581* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
582- respin (at f13's request)
583
584* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
585- pulseaudio patch (use as default, if available)
586
587* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
588- don't crash if we don't have deinterlacing support in xine-lib (#440299)
589
590* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
591- rebuild for the new %%{_kde4_buildtype}
592
593* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
594- update file list for _kde4_libexecdir
595
596* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
597- 4.0.3
598
599* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
600- don't own %%_kde4_docdir/HTML/en/
601
602* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
603- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
604- include noarch build hooks (not enabled)
605
606* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
607- BR libxcb-devel everywhere (including F7)
608
609* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
610- if building for a KDE 4 desktop, include the khelpcenter.desktop service
611  description for KDE 3 here so help works in KDE 3 apps
612
613* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
614- 4.0.2
615
616* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
617- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
618
619* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
620- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
621  (kio_smb itself is already GPLv2+)
622
623* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
624- 4.0.1
625
626* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
627- respun tarball
628
629* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
630- update to 4.0.0
631- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
632
633* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
634- kde-3.97.0
635
636* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
637- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
638
639* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
640- build without libxcb in F7 as we STILL don't have it (see #373361)
641
642* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
643- no longer set kde3_desktop on F9
644- update file list for !kde3_desktop (Sebastian Vahl)
645- don't ship country flags even for full version (as in kdebase 3)
646
647* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
648- kde-3.96.2
649
650* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
651- kde-3.96.1
652
653* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
654- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
655
656* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
657- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
658
659* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
660- kde-3.96.0
661
662* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
663- kdebase-runtime-3.95.2
664
665* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
666- kdebase-runtime-3.95.0
667
668* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
669- Provides: oxygen-icon-theme ...
670
671* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
672- patch dolphin.desktop to get Dolphin to start from the menu
673
674* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
675- update to 3.94.0
676
677* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
678- don't make this the default kdebase on F9 yet
679- drop ExcludeArch: ppc64 (#300601)
680
681* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
682- ExcludeArch: ppc64 (#300601)
683- update description
684
685* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
686- add missing BR alsa-lib-devel
687
688* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
689- remove files which conflict with KDE 3
690- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
691- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
692
693* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
694- update to 3.93.0
695- drop kde4home patch (no longer applied)
696- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
697- remove kdebase-kdm Obsoletes/Provides (for the same reason)
698- remove KDM (and KDM session) setup code (for the same reason)
699- remove rss-glx conflict (Plasma is now in kdebase-workspace)
700- remove redhat-startkde patch (startkde is now in kdebase-workspace)
701- remove kde4-opt.sh (all the code in it is commented out)
702- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
703- remove bogus BRs on automake and libtool
704- remove workspace-only BRs
705- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
706- remove workspace files and directories
707- handle icons (moved from kdelibs4)
708- add mkdir %%{buildroot} in %%install
709
710* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
711- use macros.kde4
712- License: GPLv2
713
714* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
715- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
716- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
717- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
718
719* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
720- consolekit_kdm patch (#228111, kde#147790)
721- update startkde patch
722
723* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
724- kde-3.92 (kde-4-beta1)
725
726* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
727- fix startkde
728- add env/shutdown directory
729
730* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
731- kde4.desktop: fix session Name
732
733* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
734- cleanup/fix kde4.desktop
735- kdepimlibs4->kdepimlibs
736
737* Thu Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
738- fix %%_sysconfdir for %%_prefix != /usr case.
739
740* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
741- updated kde4home.diff
742- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
743
744* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
745- kde-3.91.0
746- CMAKE_BUILD_TYPE=debug
747
748* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
749- specfile cleanup (%%prefix issues mostly)
750
751* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
752- update to 3.90.1
753- bump cmake BR to 2.4.5 as required upstream now
754- don't set execute bits by hand anymore, cmake has been fixed
755- use multilibs in /opt/kde4
756- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
757- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
758  in case we want to drop the Rs on these from kdelibs4-devel
759- consistently add all BRs as -devel Rs, not just almost all, until we can
760  figure out which, if any, are really needed
761- BR libsmbclient-devel instead of samba on F>=7, EL>=6
762
763* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
764- restore minimum version requirement for cmake
765- build against libxklavier on EL5
766- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
767
768* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
769- +eXecute perms for %%{_prefix}/lib/*
770
771* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
772- rebuild for patched FindKDE4Internal.cmake
773
774* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
775- update to 3.80.3
776- update and improve parallel-installability patch
777- drop obsolete joydevice.h patch
778- remove translations of "KDE" without the "4" from kde4.desktop
779- resync BR and -devel Requires
780- don't set LD_LIBRARY_PATH
781- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
782- fix missing underscore in _datadir
783- install kde4.desktop in install, not prep
784- fix invalid syntax in kde4.desktop
785
786* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
787- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
788- compiling with QA_RPATHS=0x0003; export QA_RPATHS
789
790* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
791- parallel build support
792- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
793- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
794- spec file cleanups and added clean up in %%install
795- fixed PATH for libkdecore.so.5; cannot open shared object file;
796- added Logitech mouse support
797- added dbus-devel, hal-devel and more as BR
798- fixed broken joydevice.h - Kevin Kofler
799- added file kde4.desktop
800
801* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
802- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
803- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.