source: projects/specs/branches/6/k/kbd/kbd-vl.spec @ 521

Revision 521, 12.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
2Summary(ja): コンソール(キーボードや仮想ターミナル等)を設定するツール群
3Name: kbd
4Version: 1.12
5Release: 21%{?_dist_release}
6License: GPL
7Group: System Environment/Base
8Source0: ftp://ftp.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.bz2
9Source1: ftp://ftp.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.bz2.sign
10#Source2: kbdrate.apps
11#Source3: kbdrate.pam
12Source4: kbd-latsun-fonts.tar.bz2
13Requires: pam >= 0.66-4, /etc/pam.d/system-auth, usermode
14BuildRequires: bison, flex, gettext
15BuildRoot: %{_tmppath}/%{name}-root
16Patch0: kbd-1.12-sparc.patch
17Patch1: kbd-1.08-compose.patch
18Patch2: kbd-1.08-terminal.patch
19Patch3: kbd-1.08-rukbd.patch
20Patch4: kbd-1.12-setfont-man.patch
21Patch5: kbd-1.12-Meta_utf8.patch
22Patch6: kbd-1.12-nostrip.patch
23Patch7: kbd-1.12-alias.patch
24Patch8: kbd-1.12-dir.patch
25Patch9: kbd-1.12-no-user-map.patch
26Patch10: kbd-1.12-resizecon-man.patch
27Patch11: kbd-1.12-gr-el.patch
28Patch12: kbd-1.12-keycodes-man.patch
29Obsoletes: console-tools open
30Provides: console-tools open
31Conflicts: util-linux < 2.11r-9
32Prereq: initscripts >= 5.86-1
33ExcludeArch: s390 s390x
34
35%description
36The %{name} package contains tools for managing a Linux
37system's console's behavior, including the keyboard, the screen
38fonts, the virtual terminals and font files.
39
40%prep
41
42%setup -q -a 4
43%patch0 -p1 -b .sparc
44%patch1 -p1
45%patch2 -p1 -b .terminal
46%patch3 -p1
47%patch4 -p1 -b .man
48%patch5 -p1 -b .Meta_utf8
49%patch6 -p1 -b .nostrip
50%patch7 -p1 -b .alias
51%patch8 -p1 -b .dir
52%patch9 -p1 -b .no-user-map
53%patch10 -p1 -b .resizecon-man
54%patch11 -p1 -b .gr-el
55%patch12 -p1 -b .keycodes-man
56
57# 7-bit maps are obsolete; so are non-euro maps
58pushd data/keymaps/i386
59mv qwerty/fi.map qwerty/fi-old.map
60cp qwerty/fi-latin9.map qwerty/fi.map
61cp qwerty/pt-latin9.map qwerty/pt.map
62cp qwerty/sv-latin1.map qwerty/se-latin1.map
63
64mv azerty/fr.map azerty/fr-old.map
65cp azerty/fr-latin9.map azerty/fr.map
66
67cp azerty/fr-latin9.map azerty/fr-latin0.map # legacy alias
68popd
69
70# Default to latarcyrheb-sun16 font for unicode
71perl -pi -e 's/LatArCyrHeb-16/latarcyrheb-sun16/' src/unicode_start
72
73%build
74export OLD_PO_FILE_INPUT=yes
75
76# We don't use % {configure} because the ./configure included here does not
77# understand most of the options.
78CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
79./configure --prefix=%{_prefix} --datadir=/lib/kbd --mandir=%{_mandir}
80
81# Override CFLAGS because this configure ignores them anyway, and LDFLAGS
82# because it defaults to -s, but that's a build policy decision.
83make CFLAGS="$RPM_OPT_FLAGS" LDFLAGS=
84
85%install
86rm -rf $RPM_BUILD_ROOT
87
88# Basic install.
89make install DESTDIR=$RPM_BUILD_ROOT
90
91# The rhpl keyboard layout table is indexed by kbd layout names, so we need a
92# Korean keyboard
93ln -s us.map.gz $RPM_BUILD_ROOT/lib/kbd/keymaps/i386/qwerty/ko.map.gz
94
95# Move binaries which we use before /usr is mounted from %{_bindir} to /bin.
96for binary in setfont dumpkeys kbd_mode unicode_start unicode_stop ; do
97  mv $RPM_BUILD_ROOT%{_bindir}/$binary $RPM_BUILD_ROOT/bin
98done
99
100# Some microoptimization
101sed -i -e 's,\<kbd_mode\>,/bin/kbd_mode,g;s,\<setfont\>,/bin/setfont,g' \
102        $RPM_BUILD_ROOT/bin/unicode_start
103
104
105# Set up kbdrate to be userhelpered.
106#mkdir -p $RPM_BUILD_ROOT%{_sbindir}
107#mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps
108#mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
109#mv $RPM_BUILD_ROOT%{_bindir}/kbdrate $RPM_BUILD_ROOT%{_sbindir}
110#ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/kbdrate
111#install -c -m644 %{SOURCE2} \
112#       $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps/kbdrate
113#install -c -m644 %{SOURCE3} \
114#       $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/kbdrate
115rm -f %{buildroot}/%{_bindir}/kbdrate
116
117# Link open to openvt
118ln -s openvt $RPM_BUILD_ROOT%{_bindir}/open
119
120%find_lang %{name}
121
122%clean
123[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
124
125%triggerun -- kbd < 1.08-10.2
126/sbin/chkconfig --del keytable || :
127
128%files -f %{name}.lang
129%defattr(-,root,root)
130%doc CHANGES CREDITS README doc/kbd.FAQ*.html doc/font-formats/*.html doc/utf/utf*
131/bin/*
132%{_bindir}/*
133%{_mandir}/*/*
134/lib/kbd
135
136%changelog
137* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.12-21vl5
138- applied new versioning policy, spec in utf-8
139
140* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-21vl1
141- initial build for Vine Linux based on Fedora package.
142
143* Tue Jan  9 2007 Miloslav Trmac <mitr@redhat.com> - 1.12-21
144- Add a "ko" (Korean) keyboard layout, equivalent to the "us" layout
145  Resolves: #220151
146
147* Thu Dec  7 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-20
148- Document that setkeycodes doesn't affect USB keyboards and that the kernel
149  doesn't provide the raw scan codes by default
150  Resolves: #211803
151
152* Tue Oct 31 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-19
153- Ship "el" translation instead of the obsolete "gr" translation
154  Resolves: #210749
155- Fix %% quoting in %%changelog
156
157* Fri Sep 29 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-18
158- Add a missing tilde to U+00E3 in latarcyrheb-sun16.psfu (#204470)
159
160* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 1.12-17
161- Obsoletes/Provides open
162- Create a symlink from open to openvt
163
164* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.12-16.1
165- rebuild
166
167* Sun Jul  9 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-16
168- Don't include <asm/kbdio.h> on SPARC (#198040, patch by Dennis Gilmore
169  <dennis@ausil.us>)
170
171* Mon May 29 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-15
172- Fix missing BuildRequires (#193406)
173
174* Mon Mar 27 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-14
175- Don't install resizecons.8 on non-x86 (#186877, patch by Keiichi Mori
176  <kmori@redhat.com>)
177
178* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.12-13.2
179- bump again for double-long bug on ppc(64)
180
181* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.12-13.1
182- rebuilt for new gcc4.1 snapshot and glibc changes
183
184* Fri Jan 20 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-13
185- Fix build with new coreutils
186- Hardcode paths in unicode_start to avoid a few file lookups (#178329)
187- Drop unnecessary Prereq: sed mktemp
188
189* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
190- rebuilt
191
192* Thu Dec  1 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-12
193- Don't reload the keymap in unicode_start (#172425)
194
195* Fri Nov 11 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-11
196- Don't ship character set lists (they are already in glibc-common) and an
197  obsolete copy of kbd.FAQ
198
199* Fri May 20 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-10
200- Don't attempt to open directories as source files (#141634, original patch by
201  Paul Nasrat)
202
203* Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-9
204- Fix another violation of C aliasing rules (#157720, patch by Jan Kratochvil)
205
206* Sat Mar 12 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-8
207- Fix violation of C aliasing rules (#150440)
208
209* Sun Mar  6 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-7
210- Don't run ldconfig
211- Don't strip executables
212
213* Fri Mar  4 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-6
214- Rebuild with gcc4
215
216* Sun Feb 20 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-5
217- Put "Meta_acute" back in German keymaps, just ignore it in (loadkeys -u)
218  (patch by Jochen Schmitt)
219- Don't ship patch backup files, simpler way
220
221* Sat Feb 19 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-4
222- Don't ship a patch backup file
223- Mention in setfont.8 that 512-glyph fonts reduce the number of available
224  colors (#140935, patch by Dmitry Butskoj)
225- Remove "Meta_acute" from German keymaps (#143124)
226- Make the %%triggerun script condition more precise, ignore failure of the
227  script
228
229* Mon Feb 14 2005 Adrian Havill <havill@redhat.com>
230- rebuilt
231
232* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
233- rebuilt
234
235* Thu Feb 26 2004 Adrian Havill <havill@redhat.com>
236- update to 1.12
237
238* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
239- rebuilt
240
241* Wed Jan 14 2004 Bill Nottingham <notting@redhat.com> 1.08-12
242- remove speakup patch at request of author
243
244* Fri Oct 10 2003 Bill Nottingham <notting@redhat.com> 1.08-11
245- remove keytable init script (#106783)
246
247* Tue Aug 12 2003 Adrian Havill <havill@rtedhat.com> 1.08-10.1
248- bump for RHEL
249
250* Tue Aug 12 2003 Adrian Havill <havill@rtedhat.com> 1.08-10
251- apply the rukbd patch (#78218)
252
253* Thu Jul 31 2003 Adrian Havill <havill@redhat.com> 1.08-9
254- don't print "plus before..." warnings about non-supported capslock
255  in unimode <Andries.Brouwer@cwi.nl> (#81855)
256
257* Wed Jul 30 2003 Adrian Havill <havill@redhat.com> 1.08-8
258- replaced Russian keyboard map with working UTF-8 equivalent (#79338)
259
260* Thu Jul 24 2003 Adrian Havill <havill@redhat.com> 1.08-7
261- make euro/latin-9 the default instead of latin-1 and 7-bit (#97013)
262- fix swedish keymap; se, not sv (#88791)
263- add fr-latin0 legacy alias of fr-latin-9 (#88324)
264- add ".map" ext to filename param of init script (#90562)
265
266* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
267- rebuilt
268
269* Thu Mar 06 2003 Florian La Roche <Florian.LaRoche@redhat.de>
270- build new rpm
271
272* Fri Feb 21 2003 Florian La Roche <Florian.LaRoche@redhat.de>
273- ExcludeArch mainframe
274
275* Thu Jan 30 2003 Bill Nottingham <notting@redhat.com> 1.08-4
276- remove condrestart from initscript
277
278* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
279- rebuilt
280
281* Fri Dec  6 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-2
282- only output terminal unicode init sequence if both stdout and stderr are
283  connected to terminals, so that it doesn't show up when script outputs
284  get piped to files
285
286* Fri Nov 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-1
287- update to 1.08
288- drop updates which went mainline
289
290* Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-27
291- add detached signature
292- remove directory names from PAM configuration so that the same config file
293  can be used for any arch on multilib systems
294
295* Wed Sep  4 2002 Bill Nottingham <notting@redhat.com> 1.06-26
296- don't munge /etc/sysconfig/i18n
297
298* Tue Sep  3 2002 Bill Nottingham <notting@redhat.com> 1.06-25
299- don't run setsysfont in upgrade trigger on console-tools
300
301* Thu Aug 29 2002 Jakub Jelinek <jakub@redhat.com> 1.06-24
302- use cyr-sun16 cyrillic chars in latarcyrheb-sun16 font
303  instead of old LatArCyrHeb-16 chars
304- add Euro character to latarcyrheb-sun16
305- use latarcyrheb-sun16 by default in unicode_start script
306
307* Tue Aug 27 2002 Jakub Jelinek <jakub@redhat.com> 1.06-23
308- add back lat[02]-sun16 fonts plus latarcyrheb-sun16 font
309
310* Thu Aug 22 2002 Karsten Hopp <karsten@redhat.de>
311- needs to conflict with older util-linux packages
312  (kbdrate moved between packages)
313
314* Tue Aug 13 2002 Bill Nottingham <notting@redhat.com> 1.06-21
315- remove Evil Hack in favor of slightly-less-evil-hack in initscripts
316
317* Tue Jul  9 2002 Bill Nottingham <notting@redhat.com> 1.06-20
318- fix speakup keymap names
319
320* Tue Jul 09 2002 Phil Knirsch <pknirsch@redhat.com> 1.06-19
321- Evil hack to make setfont work correctly on all consoles (#68018)
322
323* Thu Jun 27 2002 Bill Nottingham <notting@redhat.com> 1.06-18
324- move unicode_stop to /bin too
325- fix path to loadkeys in keytable.init
326- add in speakup keymaps
327
328* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
329- automated rebuild
330
331* Tue Jun 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-16
332- fix incorrect path in console.apps configuration file
333
334* Thu May 30 2002 Bill Nottingham <notting@redhat.com> 1.06-14
335- move some more stuff to /bin (unicode_start and dependencies)
336
337* Thu May 23 2002 Tim Powers <timp@redhat.com>
338- automated rebuild
339
340* Mon Feb 25 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-12
341- Rebuild in new environment
342
343* Wed Jan 30 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-11
344- Oops, actually list the pam files in %%files
345
346* Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-10
347- Add and consolehelper'ify kbdrate
348
349* Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-9
350- Re-remove kbdrate
351
352* Thu Jan 24 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-7
353- Fix build in current environment
354- Get rid of kbdrate, it's in util-linux these days
355
356* Wed Jul 18 2001 Matt Wilson <msw@redhat.com>
357- added a patch (Patch4) that allows --tty= in setfont
358- modified patch not to break translations
359
360* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-4
361- Add cyrillic patches from leon@geon.donetsk.ua (#47144)
362
363* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-3
364- Fix "Alt+AltGr=Compose" in qwertz-keyboards
365
366* Mon Jun 25 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-2
367- Fix "make install" and init script (#45327)
368
369* Sat Jun 16 2001 Than Ngo <than@redhat.com>
370- update to 1.0.6
371- use %%{_tmppath}
372- use find_lang
373- support new gettext
374- remove some patch files, which are included in 1.0.6
375- fix to use RPM_OPT_FLAGS
376
377* Thu May  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.05-3
378- Fix up resizecons
379
380* Wed May  2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.05-2
381- Build everything, obsoletes console-tools
382- s/Copyright:/License:/
383- License is GPL, not just distributable
384- Add our compose mappings from old console-tools
385- Add triggerpostun -- console-tools magic to get sane fonts and mappings
386
387* Tue Apr 17 2001 Erik Troan <ewt@redhat.com>
388- initial packaging for kbdrate
Note: See TracBrowser for help on using the repository browser.