source: projects/specs/branches/6/j/junit/junit-vl.spec @ 6363

Revision 6363, 8.4 KB checked in by inagaki, 12 years ago (diff)

update: ant, hal-cups-utils, junit, qt4

Line 
1# Copyright (c) 2000-2005, JPackage Project
2# All rights reserved.
3#
4# Redistribution and use in source and binary forms, with or without
5# modification, are permitted provided that the following conditions
6# are met:
7#
8# 1. Redistributions of source code must retain the above copyright
9#    notice, this list of conditions and the following disclaimer.
10# 2. Redistributions in binary form must reproduce the above copyright
11#    notice, this list of conditions and the following disclaimer in the
12#    documentation and/or other materials provided with the
13#    distribution.
14# 3. Neither the name of the JPackage Project nor the names of its
15#    contributors may be used to endorse or promote products derived
16#    from this software without specific prior written permission.
17#
18# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
19# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
20# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
21# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
22# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
23# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
24# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
25# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
26# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
27# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
28# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
29#
30
31%define _with_gcj_support 1
32
33%define gcj_support %{?_with_gcj_support:1}%{!?_with_gcj_support:%{?_without_gcj_support:0}%{!?_without_gcj_support:%{?_gcj_support:%{_gcj_support}}%{!?_gcj_support:0}}}
34
35Name:           junit
36Summary:        Java regression test package
37Version:        3.8.2
38Release:        8%{?dist}
39
40License:        CPL
41URL:            http://www.junit.org/
42Group:          Development/Tools
43
44# http://osdn.dl.sourceforge.net/junit/junit3.8.2.zip
45Source0:        junit3.8.2.zip
46Source1:        junit3.8.2-build.xml
47
48BuildRoot:      %{_tmppath}/%{name}-%{version}-root
49BuildRequires:  ant
50BuildRequires:  jpackage-utils >= 0:1.6
51%if ! %{gcj_support}
52Buildarch:     noarch
53%endif
54
55%if %{gcj_support}
56BuildRequires:          java-gcj-compat-devel
57Requires(post):         java-gcj-compat
58Requires(postun):       java-gcj-compat
59%endif
60
61%description
62JUnit is a regression testing framework written by Erich Gamma and Kent
63Beck. It is used by the developer who implements unit tests in Java.
64JUnit is Open Source Software, released under the IBM Public License and
65hosted on SourceForge.
66
67%package manual
68Group:          Documentation
69Summary:        Manual for %{name}
70
71%description manual
72Documentation for %{name}.
73
74#%package javadoc
75#Group:          Documentation
76#Summary:        Javadoc for %{name}
77#
78#%description javadoc
79#Javadoc for %{name}.
80
81%package demo
82Group:          Development/Libraries
83Summary:        Demos for %{name}
84Requires:       %{name} = %{version}-%{release}
85
86%if %{gcj_support}
87BuildRequires:          java-gcj-compat-devel
88Requires(post):         java-gcj-compat
89Requires(postun):       java-gcj-compat
90%endif
91
92%description demo
93Demonstrations and samples for %{name}.
94
95%prep
96%setup -q -n %{name}%{version}
97# extract sources
98#jar xf src.jar
99#rm -f src.jar
100#cp %{SOURCE1} build.xml
101
102%build
103#ant dist
104
105%install
106rm -rf $RPM_BUILD_ROOT
107# jars
108install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
109install -m 644 %{name}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
110(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}*; do ln -sf ${jar} ${jar/-%{version}/}; done)
111# javadoc
112#install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
113#cp -pr %{name}%{version}/javadoc/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
114# demo
115install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}/demo/junit # Not using %name for last part because it is
116                                                                # part of package name
117cp -pr %{name}/* $RPM_BUILD_ROOT%{_datadir}/%{name}/demo/junit
118
119%if %{gcj_support}
120rm -rf aot-compile-rpm
121# these --exclude options work around an aot-compile-rpm problem with test.jar
122%{_bindir}/aot-compile-rpm --exclude usr/share/junit/demo --exclude usr/share/junit/demo/junit/tests/runner/test.jar
123%endif
124
125#ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post
131%if %{gcj_support}
132if [ -x %{_bindir}/rebuild-gcj-db ]
133then
134  %{_bindir}/rebuild-gcj-db
135fi
136%endif
137
138%postun
139%if %{gcj_support}
140if [ -x %{_bindir}/rebuild-gcj-db ]
141then
142  %{_bindir}/rebuild-gcj-db
143fi
144%endif
145
146%files
147%defattr(0644,root,root,0755)
148%doc README.html
149%{_javadir}/*
150
151%if %{gcj_support}
152%dir %{_libdir}/gcj/%{name}
153%attr(-,root,root) %{_libdir}/gcj/%{name}/junit-3.8.2.jar.*
154%endif
155
156%files manual
157%defattr(0644,root,root,0755)
158%doc doc/*
159
160#files javadoc
161#defattr(0644,root,root,0755)
162#doc %{_javadocdir}/%{name}-%{version}
163#doc %{_javadocdir}/%{name}
164
165%files demo
166%defattr(0644,root,root,0755)
167%{_datadir}/%{name}
168
169%changelog
170* Sat Jun 16 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.8.2-8
171- rebuilt with rpm-4.8.1-3
172
173* Wed Sep  1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.8.2-7
174- Initial build for Vine Linux
175
176* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.2-6.4
177- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
178
179* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.2-5.4
180- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
181
182* Wed Jul  9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.8.2-4.4
183- drop repotag
184
185* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.8.2-4jpp.3
186- Autorebuild for GCC 4.3
187
188* Thu Sep 20 2007 Deepak Bhole <dbhole@redhat.com> - 3.8.2-3jpp.3
189- Fix location of stylesheet for javadocs
190
191* Thu Sep 20 2007 Deepak Bhole <dbhole@redhat.com> - 3.8.2-3jpp.2
192- Rebuild for ppc32 execmem issue and new build-id
193
194* Mon Feb 12 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 3.8.2-3jpp.1.fc7
195- Add dist tag
196
197* Mon Feb 12 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 3.8.2-3jpp.1
198- Committed on behalf of Tania Bento <tbento@redhat.com>
199- Update per Fedora review process
200- Resolves rhbz#225954
201
202* Thu Aug 10 2006 Deepak Bhole <dbhole@redhat.com> -  0:3.8.2-3jpp.1
203- Added missing requirements.
204
205* Thu Aug 10 2006 Karsten Hopp <karsten@redhat.de> 0:3.8.2-2jpp_3fc
206- Require(post/postun): coreutils
207
208* Sun Jun 23 2006 Deepak Bhole <dbhole@redhat.com> -  0:3.8.2-2jpp_2fc
209- Rebuilt.
210
211* Sat Jun 22 2006 Deepak Bhole <dbhole@redhat.com> -  0:3.8.2-2jpp_1fc
212- Upgrade to 3.8.2
213- Added conditional native compilation.
214- Fix path where demo is located.
215
216* Mon Mar 03 2006 Ralph Apel <r.apel at r-apel.de> - 0:3.8.2-1jpp
217- First JPP-1.7 release
218
219* Sun Aug 23 2004 Randy Watler <rwatler at finali.com> - 0:3.8.1-4jpp
220- Rebuild with ant-1.6.2
221* Fri May 09 2003 David Walluck <david@anti-microsoft.org> 0:3.8.1-3jpp
222- update for JPackage 1.5
223
224* Fri Mar 21 2003 Nicolas Mailhot <Nicolas.Mailhot (at) JPackage.org> 3.8.1-2jpp
225- For jpackage-utils 1.5
226
227* Fri Sep 06 2002 Henri Gomez <hgomez@users.sourceforge.net> 3.8.1-1jpp
228- 3.8.1
229
230* Sun Sep 01 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.8-2jpp
231- used original zip file
232
233* Thu Aug 29 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.8-1jpp
234- 3.8
235- group, vendor and distribution tags
236
237* Sat Jan 19 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-6jpp
238- versioned dir for javadoc
239- no dependencies for manual and javadoc packages
240- stricter dependency for demo package
241- additional sources in individual archives
242- section macro
243
244* Sat Dec 1 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-5jpp
245- javadoc in javadoc package
246
247* Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 3.7-4jpp
248- fixed previous releases ...grrr
249
250* Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 3.7-3jpp
251- added jpp extension
252- removed packager tag
253
254* Sun Sep 30 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-2jpp
255- first unified release
256- s/jPackage/JPackage
257
258* Mon Sep 17 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-1mdk
259- 3.7
260- vendor tag
261- packager tag
262- s/Copyright/License/
263- truncated description to 72 columns in spec
264- spec cleanup
265- used versioned jar
266- moved demo files to %%{_datadir}/%%{name}
267
268* Sat Feb 17 2001 Guillaume Rousse <g.rousse@linux-mandrake.com> 3.5-1mdk
269- first Mandrake release
Note: See TracBrowser for help on using the repository browser.