source: projects/specs/branches/6/j/js/js-vl.spec @ 5648

Revision 5648, 10.0 KB checked in by Takemikaduchi, 12 years ago (diff)

arpscan, aslookup, audacity, black-box, bookview, bumprace, gimp-help, js: new upstream release
libsrtp, gstreamer-filters: new package
others: rebuild

Line 
1#% global hgdate 51702867d932
2
3Summary:                JavaScript interpreter and libraries
4Name:           js
5Version:                1.8.5
6Release:                1%{?hgdate:.hg%{hgdate}}%{?_dist_release}
7# The sources are triple licensed, but when we link against readline which is
8# GPL, the result can only be GPL.
9%if 0%{?_without_readline:1}
10License:                GPLv2+ or LGPLv2+ or MPLv1.1
11%else
12License:                GPLv2+
13%endif
14Group:          Development/Languages
15URL:                    http://www.mozilla.org/js/
16Source0:                http://ftp.mozilla.org/pub/mozilla.org/js/js185-1.0.0.tar.gz
17Patch0:                 js-1.8.5-64bit-big-endian.patch
18Patch1:                 js-1.8.5-secondary-jit.patch
19Patch2:                 js185-destdir.patch
20Patch3:                 js-1.8.5-configure.patch
21Provides:               libjs = %{version}-%{release}
22BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
23Buildrequires:  nspr-devel >= 4.7, python, zip
24Buildrequires:  readline-devel, ncurses-devel, autoconf213
25Epoch:          1
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30%description
31JavaScript is the Netscape-developed object scripting language used in millions
32of web pages and server applications worldwide. Netscape's JavaScript is a
33superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
34with only mild differences from the published standard.
35
36
37%package devel
38Summary: Header files, libraries and development documentation for %{name}
39Group: Development/Libraries
40Requires: %{name} = %{epoch}:%{version}-%{release}
41Requires: pkgconfig
42Requires: ncurses-devel readline-devel
43Provides: libjs-devel = %{version}-%{release}
44
45%description devel
46This package contains the header files, static libraries and development
47documentation for %{name}. If you like to develop programs using %{name},
48you will need to install %{name}-devel.
49
50
51%prep
52# All patches come from old version and maintainer. I think it is Fedora related only
53%setup -q -n %{name}-%{version}
54%patch0 -p2 -b .64bit-big-endian
55%patch1 -p2 -b .secondary-jit
56%patch2 -p0 -b .destdir
57%patch3 -p1 -b .version
58cd js
59
60# Rm parts with spurios licenses, binaries
61# Some parts under BSD (but different suppliers): src/assembler
62#rm -rf src/assembler src/yarr/yarr src/yarr/pcre src/yarr/wtf src/v8-dtoa
63rm -rf src/ctypes/libffi src/t src/tests/src/jstests.jar src/tracevis src/v8
64
65pushd src
66autoconf-2.13
67%configure \
68    --with-system-nspr \
69    --enable-threadsafe \
70%if 0%{!?_without_readline:1}
71        --enable-readline \
72%endif
73
74popd
75
76# Create pkgconfig file
77%{__cat} > libjs.pc << 'EOF'
78prefix=%{_prefix}
79exec_prefix=%{_prefix}
80libdir=%{_libdir}
81includedir=%{_includedir}
82
83Name: libjs
84Description: JS library
85Requires: nspr >= 4.7
86Version: %{version}
87Libs: -L${libdir} -ljs
88Cflags: -DXP_UNIX=1 -DJS_THREADSAFE=1 -I${includedir}/js
89EOF
90
91
92%build
93cd js
94%{__make} %{?_smp_mflags} -C src
95
96%install
97cd js
98%{__make} -C src install DESTDIR=%{buildroot}
99# We don't want this
100%{__rm} -f %{buildroot}%{_bindir}/js-config
101%{__install} -m 0755 src/jscpucfg src/shell/js %{buildroot}%{_bindir}/
102%{__rm} -rf %{buildroot}%{_libdir}/*.a
103%{__rm} -rf %{buildroot}%{_libdir}/*.la
104
105%{__install} -m 0644 src/js*.h src/prmjtime.h src/js.msg src/*.tbl %{buildroot}%{_includedir}/
106
107# For compatibility
108# XXX do we really need libjs?!?!?!
109pushd %{buildroot}%{_libdir}
110%{__ln_s} libmozjs185.so.1.0 libmozjs.so.1
111%{__ln_s} libmozjs185.so.1.0 libjs.so.1
112%{__ln_s} libmozjs185.so libmozjs.so
113%{__ln_s} libmozjs185.so libjs.so
114popd
115
116%{__install} -m 0644 libjs.pc %{buildroot}%{_libdir}/pkgconfig/
117
118%clean
119%{__rm} -rf %{buildroot}
120
121
122%post -p /sbin/ldconfig
123
124%postun -p /sbin/ldconfig
125
126
127%files
128%defattr(-,root,root,-)
129%doc js/src/README.html
130%{_bindir}/js
131%{_libdir}/*.so.*
132
133%files devel
134%defattr(-,root,root,-)
135%{_bindir}/jscpucfg
136%{_libdir}/pkgconfig/*.pc
137%{_libdir}/*.so
138%{_includedir}/js
139%{_includedir}/js*.h
140%{_includedir}/*.tbl
141%{_includedir}/js.msg
142%{_includedir}/prmjtime.h
143
144%changelog
145* Sun Aug 14 2011 Yoji TOYODA <Yoji TOYODA> - 1:1.8.5-1
146- add Patch3 (js-1.8.5-configure.patch)
147- merge spec file with fedora package
148
149  * Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.70-1
150  - new upstream release
151  - applied new versioning policy
152  - removed no longer provided perlconnect parts.
153
154  * Mon Jun  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60-2vl1
155  - initial build for Vine Linux
156
157
158* Thu Jun 23 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1:1.8.5-7
159- Make build system more proper (bz#710837), thanks to Jasper St. Pierre.
160- Add missing header prmjtime.h (bz#709955), thanks to Jim Meyering.
161- Merge Colin Walters build changes http://www.spinics.net/lists/fedora-devel/msg153214.html (1:1.8.5-6)
162
163* Wed Jun 22 2011 Colin Walters <walters@verbum.org> - 1:1.8.5-6
164- Include mozjs185.pc, clean up build
165- Based on work from Christopher Aillon <caillon@redhat.com>
166- Switch to using make install DESTDIR=, instead of hardcoding build rules.
167- Add DESTDIR= patch from GNOME 3.2 jhbuild
168- Make mozjs185 the canonical target for both libmozjs and libmozjs185.
169
170* Fri May 27 2011 Dan Horák <dan[at]danny.cz> - 1.8.5-5
171- add secondary arch patches from xulrunner
172
173* Tue Apr 12 2011 Christopher Aillon <caillon@redhat.com> - 1.8.5-4
174- devel subpackage needs to ask for the newly added epoch
175
176* Tue Apr 12 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-3
177- Add Epoch: 1 to allow update of 1.70-13 version.
178
179* Sat Apr 9 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-2
180- Correct symlink to provide backward capabiliies libjs.so.1
181
182* Wed Apr 6 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-1
183- Update to release.
184- Remove unneeded anymore patches.
185- Add backward capability symlink.
186
187* Sat Feb 12 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-0.hg51702867d932
188- Build version 1.8.5 by update request - BZ#676441 from Firefox 4.0 mercurial repository.
189- Gone -DJS_C_STRINGS_ARE_UTF8
190- Add BR autoconf213, change build system to use configure.
191- Adopt patch0 (js-1.7.0-make.patch -> js-1.8.5-make.patch)
192- Adopt patch1 (js-shlib.patch -> js-1.8.5-shlib.patch)
193- Remove Patch2 (js-1.5-va_copy.patch) and Patch3 (js-ldflags.patch)
194- Add BR python, zip.
195
196* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.70-13
197- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
198
199* Wed Jun 16 2010 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-12
200- Add UTF-8 support (add -DJS_C_STRINGS_ARE_UTF8 ) by request Peter Halliday: BZ#576585
201
202* Mon Jun 14 2010 Dan Horák <dan[at]danny.cz> - 1.70-11
203- updated the va_copy patch for s390
204
205* Mon Jan 25 2010 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-10
206- Remove static library from -devel - %%{_libdir}/*.a (bz#556057) to meet guidelines.
207
208* Sun Aug 2 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-8
209- Reformat spec with tabs.
210- By report of Thomas Sondergaard (BZ#511162) Add -DXP_UNIX=1 -DJS_THREADSAFE=1 flags and nspr requires into libjs.pc
211
212* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.70-7
213- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
214
215* Fri May 29 2009 Dan Horak <dan[at]danny.cz> 1.70-6
216- update the va_copy patch for s390x
217
218* Thu Apr  9 2009 Matthias Saou <http://freshrpms.net/> 1.70-5
219- Update description (#487903).
220
221* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
222- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
223
224* Wed Jun  4 2008 Jon McCann <jmccann@redhat.com> - 1.70-3
225- Add two missing files (#449715)
226
227* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-2
228- Rebuild for perl 5.10 (again)
229
230* Sun Feb  3 2008 Matthias Saou <http://freshrpms.net/> 1.70-1
231- Update to 1.7.0, as 1.70 to avoid introducing an epoch for now...
232- Remove no longer provided perlconnect parts.
233
234* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.60-6
235- BR: perl(ExtUtils::Embed)
236
237* Sun Jan 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.60-5
238- rebuild for new perl
239
240* Wed Aug 22 2007 Matthias Saou <http://freshrpms.net/> 1.60-4
241- Rebuild for new BuildID feature.
242
243* Mon Aug  6 2007 Matthias Saou <http://freshrpms.net/> 1.60-3
244- Update License field.
245- Add perl(ExtUtils::MakeMaker) build requirement to pull in perl-devel.
246
247* Fri Feb  2 2007 Matthias Saou <http://freshrpms.net/> 1.60-2
248- Include jsopcode.tbl and js.msg in devel (#235481).
249- Install static lib mode 644 instead of 755.
250
251* Fri Feb  2 2007 Matthias Saou <http://freshrpms.net/> 1.60-1
252- Update to 1.60.
253- Rebuild in order to link against ncurses instead of termcap (#226773).
254- Add ncurses-devel build requirement and patch s/termcap/ncurses/ in.
255- Change mode of perl library from 555 to 755 (#224603).
256
257* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 1.5-6
258- Fix pkgconfig file (#204232 & dupe #204236).
259
260* Mon Jul 24 2006 Matthias Saou <http://freshrpms.net/> 1.5-5
261- FC6 rebuild.
262- Enable JS_THREADSAFE in the build (#199696), add patch and nspr build req.
263
264* Mon Mar  6 2006 Matthias Saou <http://freshrpms.net/> 1.5-4
265- FC5 rebuild.
266
267* Thu Feb  9 2006 Matthias Saou <http://freshrpms.net/> 1.5-3
268- Rebuild for new gcc/glibc.
269
270* Mon Jan 30 2006 Matthias Saou <http://freshrpms.net/> 1.5-2
271- Fix .pc file.
272
273* Thu Jan 26 2006 Matthias Saou <http://freshrpms.net/> 1.5-1
274- Update to 1.5.0 final.
275- Spec file cleanups.
276- Move docs from devel to main, since we need the license there.
277- Remove no longer needed js-perlconnect.patch.
278- Update js-1.5-va_copy.patch.
279- Include a pkgconfig file (#178993).
280
281* Tue Apr 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.rc6a.6
282- Link shared lib with libperl.
283
284* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
285- rebuilt
286
287* Mon Feb 14 2005 David Woodhouse <dwmw2@infradead.org> - 1.5-0.rc6a.4
288- Take js-va_copy.patch out of %%ifarch x86_64 so it fixes the PPC build too
289
290* Sun Feb 13 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 1.5-0.rc6a.3
291- Add js-va_copy.patch to fix x86_64; Patch was found in a Mandrake srpm
292
293* Sat Dec 11 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.rc6a.2
294- Include perlconnect.
295- Include readline support, rebuild using "--without readline" to disable.
296- Add libjs* provides for upstream compatibility.
297- Install header files in %%{_includedir} instead of %%{_includedir}/js.
298
299* Tue Jun 15 2004 Matthias Saou <http://freshrpms.net> 1.5-0.rc6a
300- Update to 1.5rc6a.
301
302* Tue Mar 02 2004 Dag Wieers <dag@wieers.com> - 1.5-0.rc6
303- Initial package. (using DAR)
304
Note: See TracBrowser for help on using the repository browser.