source: projects/specs/branches/6/j/jline/jline-vl.spec @ 6265

Revision 6265, 4.7 KB checked in by inagaki, 12 years ago (diff)

update: jline, rhino

Line 
1# Copyright (c) 2000-2005, JPackage Project
2# All rights reserved.
3#
4# Redistribution and use in source and binary forms, with or without
5# modification, are permitted provided that the following conditions
6# are met:
7#
8# 1. Redistributions of source code must retain the above copyright
9#    notice, this list of conditions and the following disclaimer.
10# 2. Redistributions in binary form must reproduce the above copyright
11#    notice, this list of conditions and the following disclaimer in the
12#    documentation and/or other materials provided with the
13#    distribution.
14# 3. Neither the name of the JPackage Project nor the names of its
15#    contributors may be used to endorse or promote products derived
16#    from this software without specific prior written permission.
17#
18# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
19# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
20# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
21# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
22# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
23# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
24# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
25# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
26# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
27# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
28# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
29#
30
31Name:           jline
32Summary:        Java library for reading and editing user input in console applications
33Version:        1.0
34Release:        1%{?_dist_release}
35
36License:        BSD
37URL:            http://jline.sf.net/
38Group:          Development/Libraries
39
40Source0:        http://download.sourceforge.net/sourceforge/jline/jline-%{version}.zip
41Source1:        CatalogManager.properties
42Source2:        jline-build.xml
43
44BuildRoot:      %{_tmppath}/%{name}-%{version}-root
45BuildArch:      noarch
46BuildRequires:  jpackage-utils >= 1.7
47
48Requires:       bash
49# for /bin/stty
50Requires:       coreutils
51Requires:       jpackage-utils
52
53%description
54JLine is a java library for reading and editing user input in console
55applications. It features tab-completion, command history, password
56masking, customizable keybindings, and pass-through handlers to use to
57chain to other console applications.
58
59
60%prep
61%setup -q -n %{name}-%{version}
62
63%build
64
65%install
66rm -rf $RPM_BUILD_ROOT
67# jars
68install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
69install -m 644 %{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/
70
71(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}*; do \
72ln -sf ${jar} ${jar/-%{version}/}; done)
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%files
78%defattr(0644,root,root,0755)
79%doc LICENSE.txt
80%{_javadir}/%{name}.jar
81%{_javadir}/%{name}-%{version}.jar
82
83%changelog
84* Tue May 29 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0-1
85- updated to 1.0
86
87* Wed Sep  1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.94-1
88- Initial build for VineLinux
89
90* Mon Mar  8 2010 Peter Lemenkov <lemenkov@gmail.com> - 0:0.9.94-0.6
91- Added missing Requires: jpackage-utils (%%{_javadir} and %%{_javadocdir})
92
93* Tue Jan 12 2010 Alexander Kurtakov <akurtako@redhat.com> 0:0.9.94-0.5
94- Fix BRs.
95- Drop gcj_support.
96
97* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:0.9.94-0.4
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
99
100* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:0.9.94-0.3
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
102
103* Wed Jul  9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:9.94-0.2
104- drop repotag
105
106* Mon Mar 24 2008 Matt Wringe <mwringe@redhat.com> - 0:9.94-0jpp.1
107- Update to 0.9.94 (BZ #436204)
108
109* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:0.9.9-2jpp.1
110- Autorebuild for GCC 4.3
111
112* Tue Mar 06 2007 Matt Wringe <mwringe@redhat.com> - 0:0.9.9-1jpp.1
113- Add option to build with ant.
114- Fix various rpmlint issues
115- Specify proper license
116
117* Thu May 04 2006 Alexander Kurtakov <akurtkov at gmail.com> - 0:0.9.9-1jpp
118- Upgrade to 0.9.9
119
120* Thu May 04 2006 Ralph Apel <r.apel at r-apel.de> - 0:0.9.5-1jpp
121- Upgrade to 0.9.5
122- First JPP-1.7 release
123
124* Mon Apr 25 2005 Fernando Nasser <fnasser@redhat.com> - 0:0.9.1-1jpp
125- Upgrade to 0.9.1
126- Disable attempt to include external jars
127
128* Mon Apr 25 2005 Fernando Nasser <fnasser@redhat.com> - 0:0.8.1-3jpp
129- Changes to use locally installed DTDs
130- Do not try and access sun site for linking javadoc
131
132* Sun Aug 23 2004 Randy Watler <rwatler at finali.com> - 0:0.8.1-2jpp
133- Rebuild with ant-1.6.2
134
135* Mon Jan 26 2004 David Walluck <david@anti-microsoft.org> 0:0.8.1-1jpp
136- release
Note: See TracBrowser for help on using the repository browser.