source: projects/specs/branches/6/j/java_cup/java_cup-vl.spec @ 6266

Revision 6266, 7.6 KB checked in by inagaki, 12 years ago (diff)

update: java_cup, sinjdoc

Line 
1# Copyright (c) 2000-2005, JPackage Project
2# All rights reserved.
3#
4# Redistribution and use in source and binary forms, with or without
5# modification, are permitted provided that the following conditions
6# are met:
7#
8# 1. Redistributions of source code must retain the above copyright
9#    notice, this list of conditions and the following disclaimer.
10# 2. Redistributions in binary form must reproduce the above copyright
11#    notice, this list of conditions and the following disclaimer in the
12#    documentation and/or other materials provided with the
13#    distribution.
14# 3. Neither the name of the JPackage Project nor the names of its
15#    contributors may be used to endorse or promote products derived
16#    from this software without specific prior written permission.
17#
18# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
19# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
20# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
21# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
22# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
23# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
24# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
25# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
26# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
27# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
28# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
29#
30
31%define pkg_version     11a
32%define section         free
33##VINE##define with_bootstrap  0
34%define with_bootstrap  1
35
36Name:           java_cup
37Summary:        LALR Parser Generator for Java
38Version:        0.11a
39Release:        6%{?_dist_release}
40
41Group:          Development/Tools
42License:        BSD and LGPLv2
43URL:            http://www2.cs.tum.edu/projects/cup/
44
45#svn export -r 21 https://www2.in.tum.de/repos/cup/develop/ java_cup-0.11a
46#tar cjf java_cup-0.11a.tar.bz2 java_cup-0.11a/
47Source0:        java_cup-0.11a.tar.bz2
48Source1:        java_cup-pom.xml
49Patch0:         %{name}-build.patch
50
51BuildArch:      noarch
52BuildRoot:      %{_tmppath}/%{name}-%{version}-root
53BuildRequires:  ant
54BuildRequires:  jpackage-utils >= 1.5
55#BuildRequires: jflex
56%if !%{with_bootstrap}
57BuildRequires:  java_cup >= 0.11a
58%endif
59# we still need openjdk for javadoc
60BuildRequires:  java-1.6.0-openjdk-devel
61
62%description
63java_cup is a LALR Parser Generator for Java
64
65%package javadoc
66Summary:        Javadoc for java_cup
67Group:          Applications/Documentation
68
69%description javadoc
70Javadoc for java_cup
71
72%package manual
73Summary:        Documentation for java_cup
74Group:          Applications/Documentation
75
76%description manual
77Documentation for java_cup.
78
79%prep
80%setup -q
81%patch0 -b .sav
82cp %{SOURCE1} pom.xml
83
84# remove all binary files
85find . -name "*.class" -exec rm -f {} \;
86
87%if !%{with_bootstrap}
88# remove prebuilt JFlex
89rm -rf java_cup-0.11a/bin/JFlex.jar
90
91# remove prebuilt java_cup, if not bootstrapping
92rm -rf java_cup-0.11a/bin/java-cup-11.jar
93%endif
94
95%build
96%if !%{with_bootstrap}
97export CLASSPATH=$(build-classpath java_cup java_cup-runtime jflex)
98%endif
99
100ant
101find . -name parser.cup -exec rm {} \;
102ant javadoc
103
104%install
105rm -rf $RPM_BUILD_ROOT
106
107# jar
108install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
109install -m 644 dist/java-cup-%{pkg_version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
110install -m 644 dist/java-cup-%{pkg_version}-runtime.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-runtime-%{version}.jar
111(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}*; do \
112ln -sf ${jar} ${jar/-%{version}/}; done)
113
114# javadoc
115install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
116cp -pr dist/javadoc/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
117(cd $RPM_BUILD_ROOT%{_javadocdir} && ln -sf %{name}-%{version} %{name})
118
119#add_to_maven_depmap java_cup java_cup %{version} JPP java_cup
120
121# poms
122install -d -m 755 %{buildroot}%{_mavenpomdir}
123install -pm 644 pom.xml \
124    %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129#post
130#update_maven_depmap
131
132#postun
133#update_maven_depmap
134
135%files
136%defattr(0644,root,root,0755)
137%doc changelog.txt
138%{_javadir}/*
139%{_mavenpomdir}/*
140#{_mavendepmapfragdir}/*
141
142%files manual
143%defattr(0644,root,root,0755)
144%doc manual.html
145
146%files javadoc
147%defattr(0644,root,root,0755)
148%doc %{_javadocdir}/%{name}-%{version}
149%doc %{_javadocdir}/%{name}
150
151%changelog
152* Sat Jun  2 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11a-6
153- rebuilt with rpm-4.8.1-3
154- updated URL
155
156* Sat Sep  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11a-5
157- Initial build for Vine Linux
158
159* Mon Feb 15 2010 Alexander Kurtakov <akurtako@redhat.com> 1:0.11a-4
160- Add maven pom and depmap.
161
162* Wed Jan 20 2010 Alexander Kurtakov <akurtako@redhat.com> 1:0.11a-3
163- Fix bootstrap.
164
165* Sun Jan 17 2010 Miloš Jakubíček <xjakub@fi.muni.cz> - 1:0.11a-2
166- Rebuilt in non-bootstrap mode (removed all prebuilt jars).
167- Added BR: jflex and java_cup >= 1:0.11a for non-bootstrap mode
168- Remove unnecessary R(post,postun): coreutils
169
170* Fri Jan 8 2010 Alexander Kurtakov <akurtako@redhat.com> 1:0.11a-1
171- Update to 0.11a.
172- Drop gcj_support.
173
174* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.10k-3
175- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
176
177* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.10k-2
178- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
179
180* Tue Jul 15 2008 Lubomir Rintel <lkundrak@v3.sk> - 1:0.10k-1
181- Fix the version to match upstream, so that FEver can be used
182
183* Wed Jul  9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1:0.10-0.k.6.3
184- drop repotag
185
186* Sun Feb 17 2008 Lubomir Kundrak <lkundrak@redhat.com> - 1:0.10-0.k.6jpp.2
187- Ant task
188- Clean up to satisfy QA script and rpmlint
189
190* Fri Aug 04 2006 Vivek Lakshmanan <vivekl@redhat.com> - 1:0.10-0.k.6jpp.1
191- Re-sync with latest version from JPP.
192- Partially adopt new naming convention.
193
194* Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 1:0.10-0.k.5jpp_2fc
195- Rebuilt
196
197* Thu Jul 20 2006 Vivek Lakshmanan <vivekl@redhat.com> - 1:0.10-0.k.5jpp_1fc
198- Re-sync with latest version from JPP.
199
200* Wed Jul 19 2006 Vivek Lakshmanan <vivekl@redhat.com> - 1:0.10-0.k.4jpp_1fc
201- Conditional native compilation for GCJ.
202
203* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:0.10-0.k.1jpp_10fc
204- rebuild
205
206* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 1:0.10-0.k.1jpp_9fc
207- stop scriptlet spew
208
209* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1:0.10-0.k.1jpp_8fc
210- bump again for double-long bug on ppc(64)
211
212* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1:0.10-0.k.1jpp_7fc
213- rebuilt for new gcc4.1 snapshot and glibc changes
214
215* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1:0.10-0.k.1jpp_6fc
216- rebuilt again
217
218* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
219- rebuilt
220
221* Tue Jul 19 2005 Gary Benson <gbenson@redhat.com> 1:0.10-0.k.1jpp_5fc
222- Build on ia64, ppc64, s390 and s390x.
223- Switch to aot-compile-rpm.
224
225* Tue Jun 28 2005 Gary Benson <gbenson@redhat.com> 1:0.10-0.k.1jpp_4fc
226- BC-compile.
227
228* Tue Jun 21 2005 Gary Benson <gbenson@redhat.com> 1:0.10-0.k.1jpp_3fc
229- Remove classes from the tarball.
230
231* Thu Nov  4 2004 Gary Benson <gbenson@redhat.com> 1:0.10-0.k.1jpp_2fc
232- Build into Fedora.
233
234* Thu Mar  4 2004 Frank Ch. Eigler <fche@redhat.com> 1:0.10-0.k.1jpp_1rh
235- RH vacuuming
236
237* Thu Jan 22 2004 David Walluck <david@anti-microsoft.org> 1:0.10-0.k.1jpp
238- fix version/release (bump epoch)
239- change License tag from Free to BSD-style
240- add Distribution tag
241- really update for JPackage 1.5
242
243* Wed Mar 26 2003 Paul Nasrat <pauln@truemesh.com> 0.10k-1jpp
244- for jpackage-utils 1.5
245- New spec reverse engineered from binary rpms
Note: See TracBrowser for help on using the repository browser.