source: projects/specs/branches/6/j/jasper/jasper-vl.spec @ 10648

Revision 10648, 7.5 KB checked in by tomop, 8 years ago (diff)

jasper-1.900.1-11

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:        jasper
4Summary:     implementation of the JPEG-2000 standard, Part 1
5Version:     1.900.1
6Release:     11%{?_dist_release}
7
8Group:       Applications/Graphics
9License:     Modified BSD (see LICENSE)
10URL:         http://www.ece.uvic.ca/~mdadams/jasper/
11
12Source:      %{name}-%{version}.zip
13
14Patch1: jasper-1.701.0-GL.patch
15# autoconf/automake bits of patch1
16Patch2: jasper-1.701.0-GL-ac.patch
17# CVE-2007-2721 (bug #240397)
18# borrowed from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=413041;msg=88
19Patch3: patch-libjasper-stepsizes-overflow.diff
20# borrowed from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=469786
21Patch4: jpc_dec.c.patch
22# OpenBSD hardening patches addressing couple of possible integer overflows
23# during the memory allocations
24# https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2008-3520
25Patch5: jasper-1.900.1-CVE-2008-3520.patch
26# https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2008-3522
27Patch6: jasper-1.900.1-CVE-2008-3522.patch
28# add pkg-config support
29Patch7: jasper-pkgconfig.patch
30
31Patch8: jasper-1.900.1-CVE-2011-4516-CVE-2011-4517-CERT-VU-887409.patch
32
33Patch9: jasper-CVE-2014-9029.patch
34Patch10: jasper-CVE-2014-8137.patch
35Patch11: jasper-CVE-2014-8138.patch
36
37# Issues found by static analysis of code
38Patch110: jasper-1.900.1-Coverity-BAD_SIZEOF.patch
39Patch111: jasper-1.900.1-Coverity-CHECKED_RETURN.patch
40Patch112: jasper-1.900.1-Coverity-FORWARD_NULL.patch
41Patch113: jasper-1.900.1-Coverity-NULL_RETURNS.patch
42Patch114: jasper-1.900.1-Coverity-RESOURCE_LEAK.patch
43Patch115: jasper-1.900.1-Coverity-UNREACHABLE.patch
44Patch116: jasper-1.900.1-Coverity-UNUSED_VALUE.patch
45
46# from debian
47Patch1000: 09-CVE-2016-1577.patch
48Patch1001: 10-CVE-2016-2089.patch
49Patch1002: 11-CVE-2016-2116.patch
50
51BuildRoot:   %{_tmppath}/%{name}-%{version}-root
52BuildRequires: autoconf automake libtool
53BuildRequires: freeglut-devel
54BuildRequires: libGLU-devel
55BuildRequires: libjpeg-devel
56BuildRequires: pkgconfig
57
58Requires:    %{name}-libs = %{version}-%{release}
59
60Vendor:       Project Vine
61Distribution: Vine Linux
62
63%description
64JasPer is a collection of software (i.e., a library and application
65programs) for the coding and manipulation of images.  This software
66can handle image data in a variety of formats.  One such format
67supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
68
69%package devel
70Summary:     Include Files and Documentation for jasper
71Group:       Development/Libraries
72Requires:    %{name}-libs = %{version}-%{release}
73Requires:    libjpeg-devel
74
75%description devel
76This package contains libjasper, a library implementing the JPEG-2000
77image compression standard Part 1.
78
79%package libs
80Summary: Runtime libraries for %{name}
81Group:   System Environment/Libraries
82
83%description libs
84This package contains runtime libraries for JasPer.
85
86# compat32
87%package -n compat32-%{name}-devel
88Summary:     Include Files and Documentation for jasper
89Group:       Development/Libraries
90Requires:    %{name}-libs = %{version}-%{release}
91Requires:    compat32-libjpeg-devel
92
93%description -n compat32-%{name}-devel
94This package contains libjasper, a library implementing the JPEG-2000
95image compression standard Part 1.
96
97%package -n compat32-%{name}-libs
98Summary: Runtime libraries for %{name}
99Group:   System Environment/Libraries
100
101%description -n compat32-%{name}-libs
102This package contains runtime libraries for JasPer.
103
104
105%prep
106%setup -q -n %{name}-%{version}
107
108%patch1 -p1 -b .GL
109%patch2 -p1 -b .GL-ac
110%patch3 -p1 -b .CVE-2007-2721
111%patch4 -p1 -b .jpc_dec_assertion
112%patch5 -p1 -b .CVE-2008-3520
113%patch6 -p1 -b .CVE-2008-3522
114%patch7 -p1 -b .pkgconfig
115%patch8 -p1 -b .CVE-2011-4516-4517
116%patch9 -p1 -b .CVE-2014-9029
117%patch10 -p1 -b .CVE-2014-8137-variant2
118%patch11 -p1 -b .CVE-2014-8138
119
120%patch110 -p1 -b .BAD_SIZEOF
121%patch111 -p1 -b .CHECKED_RETURN
122%patch112 -p1 -b .FORWARD_NULL
123%patch113 -p1 -b .NULL_RETURNS
124%patch114 -p1 -b .RESOURCE_LEAK
125%patch115 -p1 -b .UNREACHABLE
126%patch116 -p1 -b .UNUSED_VALUE
127
128%patch1000 -p1 -b .CVE-2016-1577
129%patch1001 -p1 -b .CVE-2016-2089
130%patch1002 -p1 -b .CVE-2016-2116
131
132autoreconf --verbose --force --install
133
134%build
135CFLAGS="%{optflags} -fno-strict-overflow" \
136%configure --enable-shared --disable-static
137
138make %{?_smp_mflags}
139
140%install
141[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
142make install DESTDIR=$RPM_BUILD_ROOT
143
144# remove .la
145rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
146
147%clean
148[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
149
150%post libs -p /sbin/ldconfig
151
152%postun libs -p /sbin/ldconfig
153
154%post -n compat32-%{name}-libs -p /sbin/ldconfig
155
156%postun -n compat32-%{name}-libs -p /sbin/ldconfig
157
158%files
159%defattr(-,root,root)
160%{!?_licensedir:%global license %%doc}
161%license COPYRIGHT LICENSE
162%doc ChangeLog INSTALL NEWS README doc
163%{_bindir}/*
164%{_mandir}/man1/*
165
166%files libs
167%defattr(-,root,root)
168%{_libdir}/libjasper*.so.*
169
170%files devel
171%defattr(-,root,root)
172%{_includedir}/jasper
173%{_libdir}/libjasper*.so
174%{_libdir}/pkgconfig/jasper.pc
175
176# compat32
177%if %{build_compat32}
178%files -n compat32-%{name}-libs
179%defattr(-,root,root)
180%{_libdir}/libjasper*.so.*
181
182%files -n compat32-%{name}-devel
183%defattr(-,root,root)
184%{_libdir}/libjasper*.so
185%{_libdir}/pkgconfig/jasper.pc
186%endif
187
188%changelog
189* Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-11
190- added Patch1000-1002 to fix CVE-2016-{1577,2089,2116}.
191
192* Wed Dec 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-10
193- imported all patches from RawHide.
194
195* Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.900.1-9
196- rebuild with libpng-1.6.12
197
198* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
199- rebuilt with current VineSeed
200
201* Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
202- added compat32 subpackage for x86_64 arch support.
203
204* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
205- splited out runtime library to sub package
206- enable opengl again, add BuildRequires: freeglut-devel
207
208* Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
209- remove .la
210- add --disable-static to configure option
211
212* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
213- added Patch0 from VinePlus/4.0
214  * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
215  - add patch100 for fix CVE-2007-2721
216  - add Vendor/Distributin Tag
217
218* Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
219- remove BuildPrereq: freeglut-devel and Requires freeglut
220- add --disable-opengl to configure option
221
222* Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
223- add BuildPreReq: unzip (used in the %%pre section)
224
225* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
226- new upstream release
227
228* Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
229- new upstream release
230- changed Group to System Environment/Libraries
231- added --mandir=%{_mandir}
232- added %post and %postun section
233
234* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
235- added --libdir=%{_libdir} configure option
236
237* Tue Sep  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
238- build with freeglut
239- change BuildPrereq and Requires
240
241* Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
242- new upstream version (jasper-1.701.0)
243
244* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
245- rebuild for VineSeedPlus
246
247* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
248- source upgrade
249- change spec to build for VineLinux
250
251* Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
252- spec file created
Note: See TracBrowser for help on using the repository browser.