source: projects/specs/branches/6/i/iproute/iproute-vl.spec @ 3648

Revision 3648, 16.1 KB checked in by daisuke, 13 years ago (diff)

iproute: update to 2.6.38.1, build with iptables, add BR: iptables-devel,

Line 
1##%define date_version 070710
2%define cbq_version v0.7.3
3
4Summary: Advanced IP routing and network device configuration tools
5Summary(ja): IP ルーティング,ネットワークデバイスの設定ツール
6Name: iproute
7Version: 2.6.38.1
8Release: 1%{?_dist_release}
9Group: Applications/System
10Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}.tar.bz2
11URL:    http://linux-net.osdl.org/index.php/Iproute2
12Patch0: man-pages.patch
13Patch1: iproute2-2.6.29-kernel.patch
14Patch2: iproute2-ss050901-opt_flags.patch
15Patch3: iproute2-2.6.25-segfault.patch
16Patch4: iproute2-sharepath.patch
17Patch5: iproute2-2.6.31-tc_modules.patch
18Patch6: iproute2-2.6.29-IPPROTO_IP_for_SA.patch
19Patch7: iproute2-example-cbq-service.patch
20Patch8: iproute2-2.6.35-print-route.patch
21Patch9: iproute2-print-route-u32.patch
22Patch10:iproute2-2.6.33-create-peer-veth-without-a-name.patch
23
24# VINE
25Patch100: iproute2-2.6.15-platex.patch
26
27License: GPLv2+
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
29BuildRequires: flex psutils db4-devel bison
30BuildRequires: iptables-devel >= 1.4.10
31Requires: iptables >= 1.4.10
32
33%description
34The iproute package contains networking utilities (ip and rtmon, for
35example) which are designed to use the advanced networking
36capabilities of the Linux 2.4.x and 2.6.x kernel.
37
38%description -l ja
39このiprouteパッケージには、カーネル 2.4.x または 2.6.x の進歩した
40ネットワーク技術を使うように設計された、ネットワーキングユーティリ
41ティが収録されています(例えばipやrtmonなどが収録されています)。
42
43
44%package devel
45Summary: Libraries, includes, etc. to develop iptables
46Summary(ja): iproute の開発用ライブラリ,ヘッダファイル
47Group: Development/Libraries
48Requires: %{name} = %{version}
49
50%description devel
51Libraries, include files, etc you can use to develop iproute2.
52
53
54%prep
55%setup -q -n iproute2-%{version}
56%patch0 -p1
57sed -i "s/_VERSION_/%{version}/" man/man8/ss.8
58%patch1 -p1 -b .kernel
59%patch2 -p1 -b .opt_flags
60%patch3 -p1 -b .seg
61%patch4 -p1 -b .share
62%patch5 -p1 -b .ipt
63%patch6 -p1 -b .ipproto
64%patch7 -p1 -b .fix_cbq
65%patch8 -p1 -b .print-route
66%patch9 -p1 -b .print-route-u32
67%patch10 -p1 -b .peer-veth-without-name
68
69%patch100 -p1 -b .platex
70
71
72%build
73export LIBDIR=%{_libdir}
74export IPT_LIB_DIR=/%_lib}/xtables
75make %{?_smp_mflags}
76
77%install
78[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
79
80mkdir -p $RPM_BUILD_ROOT/sbin \
81        $RPM_BUILD_ROOT%{_sbindir} \
82        $RPM_BUILD_ROOT%{_mandir}/man8 \
83        $RPM_BUILD_ROOT/%{_sysconfdir}/iproute2 \
84        $RPM_BUILD_ROOT%{_datadir}/tc \
85        $RPM_BUILD_ROOT%{_libdir}/tc \
86        $RPM_BUILD_ROOT%{_libdir}/iproute2 \
87        $RPM_BUILD_ROOT%{_includedir}/iproute2
88
89install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc $RPM_BUILD_ROOT/sbin
90install -m 755 misc/ss misc/nstat misc/rtacct misc/lnstat misc/arpd $RPM_BUILD_ROOT%{_sbindir}
91#netem is static
92#install -m 755 tc/q_netem.so $RPM_BUILD_ROOT%{_libdir}/tc
93#install -m 755 tc/q_atm.so $RPM_BUILD_ROOT%{_libdir}/tc
94install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_datadir}/tc
95install -m 644 man/man8/*.8 $RPM_BUILD_ROOT/%{_mandir}/man8
96rm -r $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
97iconv -f latin1 -t utf8 < man/man8/ss.8 > $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
98install -m 755 examples/cbq.init-%{cbq_version} $RPM_BUILD_ROOT/sbin/cbq
99install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq
100
101install -m 644 lib/lib*.a $RPM_BUILD_ROOT%{_libdir}/iproute2
102install -m 644 include/*.h $RPM_BUILD_ROOT%{_includedir}/iproute2
103
104install -m 644 etc/iproute2/* $RPM_BUILD_ROOT%{_sysconfdir}/iproute2
105
106cp -f etc/iproute2/* $RPM_BUILD_ROOT/%{_sysconfdir}/iproute2
107rm -rf $RPM_BUILD_ROOT/%{_libdir}/debug/*
108
109#create example avpkt file
110cat <<EOF > $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq/cbq-0000.example
111DEVICE=eth0,10Mbit,1Mbit
112RATE=128Kbit
113WEIGHT=10Kbit
114PRIO=5
115RULE=192.168.1.0/24
116EOF
117
118cat <<EOF > $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq/avpkt
119AVPKT=3000
120EOF
121
122
123%clean
124[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
125
126
127%files
128%defattr(-,root,root,-)
129%dir %{_sysconfdir}/iproute2
130%doc README.decnet README.iproute2+tc RELNOTES README.distribution README.lnstat
131%doc iproute2-%{version}/examples
132/sbin/*
133%{_mandir}/man8/*
134%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/*
135%{_sbindir}/*
136%dir %{_datadir}/tc
137%{_datadir}/tc/*
138%dir %{_libdir}/tc/
139#%{_libdir}/tc/*
140%dir %{_sysconfdir}/sysconfig/cbq
141%config(noreplace) %{_sysconfdir}/sysconfig/cbq/*
142
143
144%files devel
145%defattr(-,root,root)
146%{_libdir}/iproute2/lib*.a
147%dir %{_includedir}/iproute2
148%{_includedir}/iproute2/*.h
149
150
151%changelog
152* Fri Apr 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.38-1
153- update to 2.6.38.1
154- build with iptables-1.4.10
155- add BR: iptables-devel
156
157* Mon Apr 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.31-5
158- don't build/include documents. (almost same as man pages...)
159- remove BR: texlive ,linuxdoc-tools
160
161* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.6.31-4
162- rebuilt with rpm-4.8.1-3
163
164* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-3
165- rebuilt with gcc-4.4.3-3 on ppc
166
167* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-2
168- rebuilt with rpm-4.8.0-3 (on ppc)
169
170* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.31-1
171- new upstream release
172  - import patches from fedora package
173- build with db4-4.8
174
175* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.25-2
176- updated to 2.6.25 based on 2.6.25-1 from Fedora
177- build with db4-4.6.21
178- keep Patch100 from 2.6.16-1vl5
179-changelogs for previous Vine package as follows:
180  - Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.6.16-1
181  - apply new versioning policy.
182
183  - Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.16-0vl1
184  - updated to 2.6.16 and merged several patches from FC 2.6.16-6
185    (Patch10 not applied until VineSeed kernel goes higher versions)
186  - rebuilt with new toolchain and db4-4.3.x
187
188  - Fri Sep 15 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.15-0vl2
189  - added Patch5 to make documents without errors
190
191  - Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.15-0vl1
192  - update to 2.6.15-060110
193
194  - Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl3
195  - added BuildRequires: linuxdoc-tools
196
197  - Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl2
198  - lib*.a is moved to %{_libdir}/iproute2 (ad-hoc?)
199
200  - Sun Jun  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl1
201  - new upstream release
202  - changed Group: of devel package
203  - applyed patches from Fedora development
204    - Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
205    - Took tons of manpages from debian, much more complete (#123952).
206  - added Japanese translation from spec translation project :-)
207
208  - Sun Mar 23 2003 Takeru INOUE <takeru.inoue@gamma.ocn.ne.jp>
209  - 2.2.4-14vl2
210  - rename package name iproute to iproute2
211  - rebuild development version
212
213* Mon Apr 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.25-1
214- update
215- remove patch for backward compatibility
216- add patch for AEAD compatibility
217
218* Thu Feb 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-4
219- add creating ps file again. Fix was done in texlive
220
221* Wed Feb  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-3
222- rebuild without tetex files. It isn't working in rawhide yet. Added
223        new source for ps files.
224- #431179 backward compatibility for previous iproute versions
225
226* Mon Jan 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-2
227- rebuild with fix tetex and linuxdoc-tools -> manual pdf
228- clean unnecessary patches
229- add into spec *.so objects, new BR linux-atm-libs-devel
230
231* Tue Oct 31 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-1
232- new version from upstrem 2.3.23
233
234* Tue Oct 23 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-5
235- move files from /usr/lib/tc to /usr/share/tc
236- remove listing files twice
237
238* Fri Aug 30 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-3
239- package review #225903
240
241* Mon Aug 27 2007 Jeremy Katz <katzj@redhat.com> - 2.6.22-2
242- rebuild for new db4
243
244* Wed Jul 11 2007 Radek Vokál <rvokal@redhat.com> - 2.6.22-1
245- upgrade to 2.6.22
246
247* Mon Mar 19 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-2
248- fix broken tc-pfifo man page (#232891)
249
250* Thu Mar 15 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-1
251- upgrade to 2.6.20
252
253* Fri Dec 15 2006 Radek Vokál <rvokal@redhat.com> - 2.6.19-1
254- upgrade to 2.6.19
255
256* Mon Dec 11 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-5
257- fix snapshot version
258
259* Fri Dec  1 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-4
260- spec file cleanup
261- one more rebuilt against db4
262
263* Thu Nov 16 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-3
264- fix defective manpage for tc-pfifo (#215399)
265
266* Mon Nov 13 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-2
267- rebuilt against new db4
268
269* Tue Oct  3 2006 Radek Vokal <rvokal@redhat.com> - 2.6.18-1
270- upgrade to upstream 2.6.18
271- initcwnd patch merged
272- bug fix for xfrm monitor
273- alignment fixes for cris
274- documentation corrections
275       
276* Mon Oct  2 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-7
277- fix ip.8 man page, add initcwnd option
278
279* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-6
280- rebuilt for unwind info generation, broken in gcc-4.1.1-21
281
282* Tue Sep 19 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-5
283- fix crash when resolving ip address
284
285* Mon Aug 21 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-4
286- add LOWER_UP and DORMANT flags (#202199)
287- use dist tag
288
289* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-3.1
290- rebuild
291
292* Mon Jun 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-3
293- improve handling of initcwnd value (#179719)
294
295* Sun May 28 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-2
296- fix BuildRequires: flex (#193403)
297
298* Sun Mar 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-1
299- upgrade to 2.6.16-060323
300- don't hardcode /usr/lib in tc (#186607)
301
302* Wed Feb 22 2006 Radek Vokál <rvokal@redhat.com> - 2.6.15-2
303- own /usr/lib/tc (#181953)
304- obsoletes shapecfg (#182284)
305
306* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.2
307- bump again for double-long bug on ppc(64)
308
309* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.1
310- rebuilt for new gcc4.1 snapshot and glibc changes
311
312* Tue Jan 17 2006 Radek Vokal <rvokal@redhat.com> 2.6.15-1
313- upgrade to 2.6.15-060110
314
315* Mon Dec 12 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-11
316- rebuilt
317
318* Fri Dec 09 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-10
319- remove backup of config files (#175302)
320
321* Fri Nov 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-9
322- use tc manpages and cbq.init from source tarball (#172851)
323
324* Thu Nov 10 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-8
325- new upstream source
326
327* Mon Oct 31 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-7
328- add warning to ip tunnel add command (#128107)
329
330* Fri Oct 07 2005 Bill Nottingham <notting@redhat.com> 2.6.14-6
331- update from upstream (appears to fix #170111)
332
333* Fri Oct 07 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-5
334- update from upstream
335- fixed host_len size for memcpy (#168903) <Matt_Domsch@dell.com>
336
337* Fri Sep 23 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-4
338- add RPM_OPT_FLAGS
339
340* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-3
341- forget to apply the patch :(
342
343* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-2
344- make ip help work again (#168449)
345
346* Wed Sep 14 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-1
347- upgrade to ss050901 for 2.6.14 kernel headers
348
349* Fri Aug 26 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-3
350- added /sbin/cbq script and sample configuration files (#166301)
351
352* Fri Aug 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-2
353- upgrade to iproute2-050816
354
355* Thu Aug 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-1
356- update to snapshot for 2.6.13+ kernel
357
358* Tue May 24 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-2
359- removed useless initvar patch (#150798)
360- new upstream source
361
362* Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
363- update to iproute-2.6.11
364
365* Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
366- gcc4 rebuilt
367
368* Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
369- update to iproute-2.6.10
370
371* Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
372- added arpd into sbin
373
374* Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
375- debug info removed from makefile and from spec (#140891)
376
377* Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
378- source file updated from snapshot version
379- endian patch adding <endian.h>
380
381* Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
382- added installation of netem module for tc
383
384* Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
385- fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
386
387* Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
388- updated to iproute-2.6.9, spec file change, patches cleared
389
390* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
391- rebuilt
392
393* Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
394- Took tons of manpages from debian, much more complete (#123952).
395
396* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
397- rebuilt
398
399* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
400- Built security errata version for FC1.
401
402* Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
403- Fixed -f option for ss (#118355).
404- Small description fix (#110997).
405- Added initialization of some vars (#74961).
406- Added patch to initialize "default" rule as well (#60693).
407
408* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
409- rebuilt
410
411* Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
412- Security errata for netlink (CAN-2003-0856).
413
414* Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
415- Updated to latest version. Used by other distros, so seems stable. ;-)
416- Quite a few patches needed updating in that turn.
417- Added ss (#107363) and several other new nifty tools.
418
419* Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
420- rebuilt
421
422* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
423- rebuilt
424
425* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
426- rebuilt
427
428* Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
429- Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
430
431* Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
432- remove flags patch at author's request
433
434* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
435- automated rebuild
436
437* Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
438- Don't forcibly strip binaries
439
440* Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
441- Fixed missing diffserv and atm support in config (#57278).
442- Fixed inconsistent numeric base problem for command line (#65473).
443
444* Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
445- Added patch to fix crosscompiling by Adrian Linkins.
446
447* Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
448- Update to latest stable release 2.4.7-now-ss010824.
449- Added simple man page for ip.
450
451* Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
452- allow setting of allmulti & promisc flags (#48669)
453
454* Mon Jul 02 2001 Than Ngo <than@redhat.com>
455- fix build problem in beehive if kernel-sources is not installed
456
457* Fri May 25 2001 Helge Deller <hdeller@redhat.de>
458- updated to iproute2-2.2.4-now-ss001007.tar.gz
459- bzip2 source tar file
460- "License" replaces "Copyright"
461- added "BuildPrereq: tetex-latex tetex-dvips psutils"
462- rebuilt for 7.2
463
464* Tue May  1 2001 Bill Nottingham <notting@redhat.com>
465- use the system headers - the included ones are broken
466- ETH_P_ECHO went away
467
468* Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
469- test for specific KERNEL_INCLUDE directories.
470
471* Thu Oct 12 2000 Than Ngo <than@redhat.com>
472- rebuild for 7.1
473
474* Thu Oct 12 2000 Than Ngo <than@redhat.com>
475- add default configuration files for iproute (Bug #10549, #18887)
476
477* Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
478- fix include-glibc/ to cope with glibc 2.2 new resolver headers
479
480* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
481- automatic rebuild
482
483* Sun Jun 18 2000 Than Ngo <than@redhat.de>
484- rebuilt in the new build environment
485- use RPM macros
486- handle RPM_OPT_FLAGS
487
488* Sat Jun 03 2000 Than Ngo <than@redhat.de>
489- fix iproute to build with new glibc
490
491* Fri May 26 2000 Ngo Than <than@redhat.de>
492- update to 2.2.4-now-ss000305
493- add configuration files
494
495* Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
496- strip binaries
497
498* Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
499- first build
Note: See TracBrowser for help on using the repository browser.