source: projects/specs/branches/6/i/indent/indent-vl.spec @ 3509

Revision 3509, 4.0 KB checked in by owa, 13 years ago (diff)

rebuilt

Line 
1Summary:     A GNU program for formatting C code.
2Summary(ja): C のコードを整形する GNU プログラム
3Name:        indent
4Version:     2.2.9
5Release:     5%{?_dist_release}
6License:     GPL
7Group:       Applications/Text
8URL:         http://www.gnu.org/software/indent/
9Source:      ftp://ftp.gnu.org/pub/gnu/indent-%{version}.tar.gz
10Patch0:      indent-2.2.9-indent_h.patch
11Prereq:      /sbin/install-info
12BuildRoot:   %{_tmppath}/%{name}-%{version}-root
13
14
15%description
16Indent is a GNU program for beautifying C code, so that it is easier to
17read.  Indent can also convert from one C writing style to a different
18one.  Indent understands correct C syntax and tries to handle incorrect
19C syntax.
20
21Install the indent package if you are developing applications in C and
22you want a program to format your code.
23
24%description -l ja
25Indent は C のコードを読みやすく整形する GNU プログラムです.Indent を
26使うと,C コードのあるスタイルから別のスタイルへと返還することも出来ます.
27Indent は C 文法を理解しますので,間違った C の文法を可能な限り解釈しよう
28とします.
29
30C によるアプリケーション開発を行っていて,プログラムコードを整形したい
31場合には indent パッケージをインストールして下さい.
32
33
34%prep
35%setup -q
36%patch0 -p0 -b .indent_h
37
38%build
39%configure
40export PATH=$PATH:.
41make
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46
47%makeinstall
48rm -f $RPM_BUILD_ROOT/%{_infodir}/dir $RPM_BUILD_ROOT/usr/bin/texinfo2man \
49        $RPM_BUILD_ROOT/usr/doc/indent/indent.html
50
51%find_lang %name
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56
57%post
58/sbin/install-info %{_infodir}/indent.info.gz %{_infodir}/dir --entry="* indent: (indent).                              Program to format source code."
59
60
61%preun
62if [ "$1" = 0 ]; then
63        /sbin/install-info --delete %{_infodir}/indent.info.gz %{_infodir}/dir --entry="* indent: (indent).                      Program to format source code."
64
65fi
66
67%files -f %{name}.lang
68%defattr(-,root,root)
69%{_bindir}/indent
70%{_mandir}/*/*
71%{_infodir}/*
72
73
74%changelog
75* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.2.9-5
76- rebuilt with rpm-4.8.1-3
77
78* Tue Sep 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.9-4vl5
79- applied new versioning policy, spec in utf-8
80- added indent-2.2.9-indent_h.patch
81
82* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.2.9-3vl2
83- rebuilt for x86_64 architecture
84
85* Mon Jul 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3vl1
86- rebuild with new toolchains
87- based on Redhat Rawhide 2.2.9-3
88
89* Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
90- 2.2.6-1vl2
91- Oops the spec was in Shift_JIS. Fixed.
92
93* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
94- 2.2.6-1vl1
95- rebuilt for Vine Linux
96
97* Sun Nov 19 2000 Florian La Roche <Florian.LaRoche@redhat.de>
98- update to 2.2.6
99
100* Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
101- rebuild
102
103* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
104- automatic rebuild
105
106* Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
107- use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir}
108  and %%{_tmppath}
109- don't use %%{_prefix}
110
111* Wed May 10 2000 Trond Eivind Glomsr <teg@redhat.com>
112- added URL
113- remove manual stripping
114
115
116* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
117- man pages are compressed
118
119* Thu Jan 20 2000 Bill Nottingham <notting@redhat.com>
120- 2.2.5
121
122* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
123- 2.2.0
124
125* Fri Jul 16 1999 Bill Nottingham <notting@redhat.com>
126- update to 2.1.1
127
128* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
129- update to 1.10.0.
130
131* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
132- auto rebuild in the new build environment (release 11)
133
134* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
135- build for 6.0 tree
136
137* Thu Aug 13 1998 Jeff Johnson <jbj@redhat.com>
138- build root
139
140* Thu May 07 1998 Prospector System <bugs@redhat.com>
141- translations modified for de, fr, tr
142
143* Tue Oct 21 1997 Otto Hammersmith <otto@redhat.com>
144- use install-info
145
146* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
147- built against glibc
Note: See TracBrowser for help on using the repository browser.