source: projects/specs/branches/6/i/incron/incron-vl.spec @ 6138

Revision 6138, 4.0 KB checked in by tomop, 12 years ago (diff)

incron-0.5.10-1

Line 
1Summary:     Inotify cron system
2Name:        incron
3Version:     0.5.10
4Release:     1%{?_dist_release}
5
6Group:       System Environment/Base         
7License:     GPLv2
8URL:         http://inotify.aiken.cz
9Source0:     http://inotify.aiken.cz/download/incron/%{name}-%{version}.tar.bz2
10Source1:     incrond.init
11#Patch0:      incron-gcc44.patch
12Patch1:      incron-gcc47.patch
13BuildRoot:   %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15Requires(post):   /sbin/chkconfig
16Requires(preun):  /sbin/chkconfig, /sbin/service
17
18
19%description
20This program is an "inotify cron" system.
21It consists of a daemon and a table manipulator.
22You can use it a similar way as the regular cron.
23The difference is that the inotify cron handles
24filesystem events rather than time periods.
25
26%prep
27%setup -q
28#%patch0 -p1 -b .orig
29%patch1 -p0 -b .gcc47
30
31%build
32make %{?_smp_mflags} CXXFLAGS="%{optflags}"
33
34
35%install
36rm -rf %{buildroot}
37
38#install files manually since source Makefile tries to do it as root
39install -D -p incrond %{buildroot}%{_sbindir}/incrond
40install -D -p -m 4755 incrontab %{buildroot}%{_bindir}/incrontab
41install -d %{buildroot}%{_localstatedir}/spool/%{name}
42install -d %{buildroot}%{_sysconfdir}/%{name}.d
43install -D -p -m 0755 %{SOURCE1} %{buildroot}%{_initdir}/incrond
44install -D -p -m 0644 incron.conf.example %{buildroot}%{_sysconfdir}/%{name}.conf
45
46# install manpages
47make install-man MANPATH="%{buildroot}%{_mandir}" INSTALL="install -D -p"
48
49%post
50if [ $1 -eq 1 ]; then
51    /sbin/chkconfig --add incrond
52fi
53
54
55%preun
56if [ $1 -eq 0 ]; then
57        /sbin/service %{name} stop >/dev/null 2>&1 || :
58        /sbin/chkconfig --del incrond
59fi
60
61
62%postun
63if [ $1 -ge 1 ]; then
64        /sbin/service incrond condrestart >/dev/null 2>&1 || :
65fi
66
67
68%clean
69rm -rf %{buildroot}
70
71%files
72%defattr(-,root,root,-)
73%attr(4755,root,root) %{_bindir}/incrontab
74%{_sbindir}/incrond
75%{_initdir}/incrond
76%config(noreplace) %{_sysconfdir}/%{name}.conf
77%{_mandir}/man1/incrontab.1.gz
78%{_mandir}/man5/incrontab.5.gz
79%{_mandir}/man5/incron.conf.5.gz
80%{_mandir}/man8/incrond.8.gz
81%dir %{_localstatedir}/spool/%{name}
82%dir %{_sysconfdir}/%{name}.d
83%doc COPYING CHANGELOG README TODO LICENSE-GPL
84
85
86
87%changelog
88* Fri May 04 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.10-1
89- new upstream release.
90- built for Vine Linux.
91
92* Thu Feb 16 2012 Jon Ciesla <limburgher@gmail.com> - 0.5.9-4
93- Migrate to systemd, BZ 789688.
94- gcc47 patch.
95
96* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-3
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
98
99* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-2
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
101
102* Mon Dec 21 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.9-1
103- Upstream released new version
104
105* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.8-2
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
107
108* Wed Feb 25 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.8-1
109- Upstream released new version
110- GCC 4.4 fixes
111- Drop GCC 4.3 patch, fixed upstream
112
113* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.7-2
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
115
116* Sat Feb 09 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> - 0.5.7-1
117- Sync with upstream
118
119* Thu Mar 13 2007 <ruben@rubenkerkhof.com> 0.5.5-1
120- Sync with upstream
121* Mon Feb 12 2007 <ruben@rubenkerkhof.com> 0.5.4-1
122- Update to new upstream version
123- Upstream fixed permissions on pidfile
124- New manpage for incron.conf
125- Upstream fixed example conf file
126* Sun Feb 04 2007 <ruben@rubenkerkhof.com> 0.5.1-1
127- Updated to new upstream version
128- Upstream fixed the incorrect encoding of the LICENSE-GPL file
129* Sun Jan 27 2007 <ruben@rubenkerkhof.com> 0.5.0-1
130- Updated to new upstream version
131- Changed the service name in the scriptlets
132- Added a configuration file
133- Included GPL License
134* Sat Jan 27 2007 <ruben@rubenkerkhof.com> 0.4.0-1
135- First try at packaging it up
Note: See TracBrowser for help on using the repository browser.