source: projects/specs/branches/6/i/iksemel/iksemel-vl.spec @ 6364

Revision 6364, 5.1 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild or update packages

Line 
1Summary:        An XML parser library designed for Jabber applications
2Summary(ja):    Jabber アプリケーションのために設計された XML パーサ
3
4Name:           iksemel
5Version:        1.4
6Release:        1%{?_dist_release}
7
8Group:          System Environment/Libraries
9License:        LGPLv2+
10URL:            http://code.google.com/p/iksemel/
11Source0:        http://iksemel.googlecode.com/files/iksemel-%{version}.tar.gz
12
13Patch0:         0001-Fix-issues-compiling-with-newer-gnutls.patch
14Patch1:         0002-Strip-out-internal-SHA-code-and-use-functions-from-g.patch
15Patch2:         0003-Fix-alignment-on-architectures-where-doubles-are-64b.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18
19BuildRequires:  gnutls-devel > 2
20BuildRequires:  libgcrypt-devel
21BuildRequires:  autoconf
22BuildRequires:  automake
23BuildRequires:  libtool > 2
24BuildRequires:  texinfo
25
26%description
27An XML parser library designed for Jabber applications. It is coded in
28ANSI C for POSIX compatible environments, thus highly portable.
29
30%package devel
31Summary:        Development files for iksemel
32Summary(ja):    iksemel の開発ファイル
33Group:          Development/Libraries
34Requires:       %{name} = %{version}-%{release}
35Requires:       gnutls-devel
36Requires:       pkgconfig
37
38Requires(post): /sbin/install-info
39Requires(preun): /sbin/install-info
40
41%description devel
42Development files for iksemel.
43
44%package utils
45Summary:        Utilities for iksemel
46Summary(ja):    iksemel 用のユーティリティ
47Group:          Applications/Internet
48Requires:       %{name} = %{version}-%{release}
49
50%description utils
51Utlity programs for iksemel.
52
53%prep
54%setup0 -q
55%patch0 -p1
56%patch1 -p1
57%patch2 -p1
58
59# force rebuilding of the info file
60rm doc/iksemel
61
62%build
63# We need to re-run the autotools because the patch we apply modifies
64# the configure.ac and src/Makefile.am
65libtoolize --copy --force --automake
66aclocal
67autoheader
68automake --add-missing --force-missing --gnu --include-deps
69autoconf
70%configure --disable-static --disable-rpath
71make %{?_smp_mflags}
72
73%install
74rm -rf %{buildroot}
75make install DESTDIR=%{buildroot}
76
77rm -f %{buildroot}%{_libdir}/*.la
78
79mv %{buildroot}%{_infodir}/iksemel %{buildroot}%{_infodir}/iksemel.info
80
81%check
82%ifnarch ppc
83make check
84%endif
85
86%clean
87rm -rf %{buildroot}
88
89%postun -p /sbin/ldconfig
90
91%post -p /sbin/ldconfig
92
93%post devel
94/sbin/install-info --quiet %{_infodir}/%{name}.info %{_infodir}/dir || :
95
96%preun devel
97if [ "$1" = 0 ]; then
98    /sbin/install-info --quiet --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
99fi
100
101
102%files
103%defattr(-,root,root,-)
104%doc AUTHORS ChangeLog COPYING HACKING NEWS README TODO
105
106%{_libdir}/libiksemel.so.*
107
108%files devel
109%defattr(-,root,root,-)
110%doc COPYING
111
112%{_libdir}/libiksemel.so
113%{_includedir}/iksemel.h
114%{_libdir}/pkgconfig/iksemel.pc
115%{_infodir}/iksemel.info*
116
117%files utils
118%defattr(-,root,root,-)
119%doc COPYING
120
121%{_bindir}/ikslint
122%{_bindir}/iksperf
123%{_bindir}/iksroster
124
125%changelog
126* Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4-1
127- update to 1.4
128- remove old patches
129- add patches from fedora
130   - Patch0 (0001-Fix-issues-compiling-with-newer-gnutls.patch)
131   - Patch1 (0002-Strip-out-internal-SHA-code-and-use-functions-from-g.patch)
132   - Patch2 (0003-Fix-alignment-on-architectures-where-doubles-are-64b.patch)
133
134* Tue May 05 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3-2vl5
135- rebuild with gnutls 2.6.6, libtool 2.2.6
136
137* Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 1.3-1vl5
138- applied new versioning policy, spec in utf-8
139
140* Wed Dec 12 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-0vl1
141- initial build for Vine Linux
142
143* Sat Aug 25 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3-2
144- Disable "make check" on PPC again.
145
146* Sat Aug 25 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3-1
147- Update to 1.3
148- Don't need to BR pkgconfig because gnutls-devel now requires it properly.
149- Update license.
150- Run "make check" on PPC
151- Update patches so that they apply to 1.3
152- Update URLs
153
154* Thu Nov 16 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-13
155- ppp != ppc
156
157* Thu Nov 16 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-12
158- Don't run make check on PPC - tests failing.
159
160* Thu Nov 16 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-11
161- Add patch from Hans de Goede that fixes 64 bit issues
162- Re-enable "make check".
163- Remove tabs from specfile.
164
165* Mon Aug 28 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-10
166- Bump release and rebuild.
167
168* Wed Aug  2 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-6
169- Temporarily disable make check until problems with it can be figured out.
170
171* Thu Jul 27 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-5
172- Patch to use SHA1 hashing routines from libgcrypt rather than
173  broken internal code.  This means that we need to BR autoools
174  to regenerate comfigure script and makefiles.
175
176* Mon Jun 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-4
177- Don't re-run autotools, fix rpath in a different way.
178
179* Mon Jun 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-3
180- Add a %check section.
181- Add BR for libtool.
182
183* Tue May 30 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-2
184- Add texinfo BR
185
186* Mon May 29 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-1
187- First version for Fedora Extras.
188
Note: See TracBrowser for help on using the repository browser.