source: projects/specs/branches/6/i/ibus-el/ibus-el-vl.spec @ 5857

Revision 5857, 4.0 KB checked in by munepi, 12 years ago (diff)

updated ibus-el-vl.spec

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3%define origname ibus-el
4%define origver  0.3.2
5
6Summary:      a IBus client for GNU Emacs
7Summary(ja):  GNU Emacs 用 IBus クライアント
8Name:         %{origname}
9Version:      %{origver}
10Release:      1%{?_dist_release}
11
12# http://launchpad.net/ibus.el
13Source0:      http://launchpad.net/ibus.el/0.3/0.3.1/+download/ibus-el-%{version}.tar.gz
14Source1:      %{origname}-install.sh
15Source2:      %{origname}-remove.sh
16Source3:      vine-default-%{origname}.el
17Source4:      %{origname}-init.el
18
19# Patch0:       ibus-el-0.2.1-emacs-24.0.90.patch
20# Patch1:       ibus-el-0.3.0-disable-surrounding-text.patch
21
22License:      GPLv3
23Group:        Applications/Editors/Emacs
24URL:          http://www11.atwiki.jp/s-irie/pages/21.html
25BuildRoot:    %{_tmppath}/%{name}-%{version}-root
26BuildArch:    noarch
27
28Requires:     emacsen
29Requires(post):       emacsen
30%prereq_ge    emacsen-common
31Requires:     python >= 2.5
32Requires:     ibus >= 1.2
33Requires:     python-xlib
34
35Distribution: Vine Linux
36Vendor:       Project Vine
37Packager:     iwaim, munepi
38
39%description
40ibus.el is a IBus client for GNU Emacs. This program allows users
41on-the-spot style input with IBus. The input statuses are individually
42kept for each buffer, and prefix-keys such as C-x and C-c can be used
43even if IBus is active. So you can input various languages fast and
44comfortably by using it.
45
46%prep
47
48%setup -q -n %{origname}-%{origver}
49
50#%patch0 -p1 -b .emacs24
51#%if %{?_dist_release} == "vl6"
52#%patch1 -p1 -b .surrounding
53#%endif
54
55%build
56
57%install
58[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
59[ "%{buildroot}" != "/" ] && mkdir -p %{buildroot}
60
61mkdir -p %{buildroot}%{_datadir}/%{name}
62install -m 0755 ibus-el-agent %{buildroot}%{_datadir}/%{name}
63
64mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
65mkdir -p %{buildroot}%{emacsen_pkgdir}/install
66mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
67
68#
69# install el files
70#
71
72cp -p *.el %{SOURCE3} %{SOURCE4} %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
73
74
75#
76# install script (bytecompile el and install elc , remove)
77#
78
79%_installemacsenscript %{origname} %{SOURCE1}
80
81%_removeemacsenscript  %{origname} %{SOURCE2}
82
83
84%clean
85[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
86
87%post
88#
89# bytecompile and install
90#
91if [ "$1" = 2 ]; then
92
93%_emacsenPackageRemove %{origname}
94
95fi
96
97%_addemacsenlist %{origname}
98
99%_emacsenPackageInstall %{origname}
100
101
102%preun
103if [ "$1" = 0 ]; then
104
105%_emacsenPackageRemove %{origname}
106
107%_removeemacsenlist %{origname}
108
109fi
110
111
112%files
113%defattr(-,root,root)
114%doc README doc/COPYING doc/ChangeLog
115%{_datadir}/emacs/site-lisp/%{origname}
116%{emacsen_pkgdir}/install/%{origname}
117%{emacsen_pkgdir}/remove/%{origname}
118%dir %{_datadir}/%{name}
119%{_datadir}/%{name}/ibus-el-agent
120
121%changelog
122* Thu Mar  8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-1
123- new upstream release
124
125* Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.1-1
126- new upstream release
127
128* Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.0-3
129- apply ibus-el-0.3.0-disable-surrounding-text.patch (for vl6)
130
131* Mon Feb 13 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.0-2
132- fix a typo in ibus-el-init.el
133
134* Tue Jan 31 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.0-1
135- new upstream release
136- added "munepi" in Packager tag
137
138* Mon Oct  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.2.1-3
139- supported emacs-24.0.90
140- updated ibus-el-init.el
141  - output "Loading vine-default-ibus-el ..." to the buffer *Messages*
142
143* Tue Apr  5 2011 IWAI, Masaharu <iwai@alib.jp> 0.2.1-2vl6
144- fix <BTS:VineLinux:1117>
145 - update vine-default-ibus-el.el (Source3): sync [VineSeed:22997]
146
147* Wed Nov 24 2010 IWAI, Masaharu <iwai@alib.jp> 0.2.1-1
148- new upstream release
149
150* Tue Aug 31 2010 IWAI, Masaharu <iwai@alib.jp> 0.2.0-1
151- new upstream release
152
153* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.1-1
154- new upstream release
155
156* Mon Jun  7 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.0-1
157- first release for Vine Linux
Note: See TracBrowser for help on using the repository browser.