source: projects/specs/branches/6/h/htdig/htdig-vl.spec @ 3475

Revision 3475, 10.4 KB checked in by inagaki, 13 years ago (diff)

update: MySQL-ruby, darts, htdig, sary

Line 
1%define buildweb 1
2%define beta b6
3
4%define contentdir /var/www
5%define apachebin %{_sbindir}/apache2
6
7Name: htdig
8Summary: ht://Dig - Web search engine
9Summary(ja): ht://Dig Web 検索エンジン
10Version: 3.2.0
11Release: 8.%{beta}%{?_dist_release}
12
13License: GPLv2
14Group: Applications/Internet
15URL: http://www.htdig.org/
16
17Source: http://www.htdig.org/files/%{name}-%{version}%{beta}.tar.bz2
18Source1: htdig.conf
19Patch1: htdig-3.1.5-rh.patch
20Patch2: htdig-3.2.0b4-xopen.patch
21Patch4: htdig-3.2.0b5-overflow.patch
22Patch5: htdig-3.2.0b6-robots.patch
23Patch6: htdig-3.2.0b6-unescaped_output.patch
24Patch8: htdig-3.2.0b6-compile-fix.patch
25Patch9: htdig-3.2.0b6-opts.patch
26Patch11: htdig-3.2.0b6-incremental.patch
27Patch12: htdig-3.2-CVE-2007-6110.patch
28Patch13: htdig-3.2.0b6-htstat-segv.patch
29Patch14: htdig-3.2.0-external_parsers.patch
30Patch15: htdig-3.2.0-allow_numbers.patch
31
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33BuildRequires: flex >= 2.5.4a-13
34BuildRequires: zlib-devel
35BuildRequires: openssl-devel
36BuildRequires: apache2
37BuildRequires: autoconf automake libtool
38
39%package web
40Summary: Scripts and HTML code needed for using ht://Dig as a web search engine
41Group: Applications/Internet
42Requires: %{name} = %{version}
43Requires: webserver
44
45%description
46The ht://Dig system is a complete world wide web indexing and searching
47system for a small domain or intranet. This system is not meant to replace
48the need for powerful internet-wide search systems like Lycos, Infoseek,
49Webcrawler and AltaVista. Instead it is meant to cover the search needs for
50a single company, campus, or even a particular sub section of a web site. As
51opposed to some WAIS-based or web-server based search engines, ht://Dig can
52span several web servers at a site. The type of these different web servers
53doesn't matter as long as they understand the HTTP 1.0 protocol.
54ht://Dig is also used by KDE to search KDE's HTML documentation.
55
56ht://Dig was developed at San Diego State University as a way to search the
57various web servers on the campus network.
58
59%description web
60The ht://Dig system is a complete world wide web indexing and searching
61system for a small domain or intranet. This system is not meant to replace
62the need for powerful internet-wide search systems like Lycos, Infoseek,
63Webcrawler and AltaVista. Instead it is meant to cover the search needs for
64a single company, campus, or even a particular sub section of a web site. As
65opposed to some WAIS-based or web-server based search engines, ht://Dig can
66span several web servers at a site. The type of these different web servers
67doesn't matter as long as they understand the HTTP 1.0 protocol.
68
69The %{name}-web package includes CGI scripts and HTML code needed to use
70ht://Dig on a website.
71
72ht://Dig was developed at San Diego State University as a way to search the
73various web servers on the campus network.
74
75
76%prep
77%setup -q -n %{name}-%{version}%{beta}
78%patch1 -p1 -b .rh
79%patch2 -p1 -b .xopen
80%patch4 -p1 -b .overflow
81%patch5 -p1 -b .robots
82%patch6 -p1 -b .unescaped_output
83%patch8 -p1 -b .compile-fix
84%patch9 -p1 -b .opts
85%patch11 -p1 -b .incremental
86%patch12 -p1 -b .CVE-2007-6110
87%patch13 -p1 -b .htstat-segv
88%patch14 -p1 -b .external_parsers
89%patch15 -p1 -b .allow_numbers
90
91autoreconf -fiv
92
93%build
94%configure \
95        --enable-shared \
96        --enable-tests \
97        --enable-bigfile \
98        --with-config-dir=%{_sysconfdir}/htdig \
99        --with-common-dir=%{contentdir}/html/htdig \
100        --with-database-dir=/var/lib/htdig \
101        --localstatedir=/var/lib/htdig \
102        --with-cgi-bin-dir=%{contentdir}/cgi-bin \
103        --with-image-dir=%{contentdir}/html/htdig \
104        --with-search-dir=%{contentdir}/html/htdig \
105        --with-default-config-file=%{_sysconfdir}/htdig/htdig.conf \
106        --with-apache=%{apachebin} \
107        --with-zlib=%{_prefix} \
108        --with-ssl
109make
110
111%install
112rm -rf $RPM_BUILD_ROOT
113make install DESTDIR=$RPM_BUILD_ROOT
114
115ln $RPM_BUILD_ROOT%{contentdir}/cgi-bin/htsearch $RPM_BUILD_ROOT%{_bindir}
116
117chmod 644 $RPM_BUILD_ROOT%{contentdir}/html/htdig/*
118ln -sf search.html $RPM_BUILD_ROOT%{contentdir}/html/htdig/index.html
119# now get rid of the $RPM_BUILD_ROOT paths in the conf files
120for i in %{_sysconfdir}/htdig/htdig.conf /usr/bin/rundig ; do
121        perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT/$i
122done
123mkdir -p $RPM_BUILD_ROOT%{_prefix}/share
124mv $RPM_BUILD_ROOT%{contentdir}/html/htdig $RPM_BUILD_ROOT%{_prefix}/share
125mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d/
126install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/conf.d/htdig.conf
127
128rm -rf $RPM_BUILD_ROOT%{_includedir}
129rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig/*.a
130rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig/*.la
131rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig_db/*.a
132rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig_db/*.la
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%files
138%defattr(-,root,root)
139%doc htdoc/*
140%dir %{_sysconfdir}/htdig
141%config %{_sysconfdir}/htdig/htdig.conf
142%config %{_sysconfdir}/htdig/cookies.txt
143%{_sysconfdir}/htdig/HtFileType-magic.mime
144%{_sysconfdir}/htdig/mime.types
145%dir /var/lib/htdig
146%{_bindir}/*
147%{_libdir}/htdig
148%{_libdir}/htdig_db
149%{_mandir}/man1/*
150
151%if %buildweb
152%files web
153%defattr(-,root,root)
154%{contentdir}/cgi-bin/*
155%config %{_sysconfdir}/httpd/conf.d/htdig.conf
156%dir %{_datadir}/htdig
157%{_datadir}/htdig/*
158%{_mandir}/man8/*
159%endif
160
161%changelog
162* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.0-8.b6
163- rebuilt with current VineSeed
164- replaced Patch100 to Patch8
165- added --with-ssl option to %%configure
166
167* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 3.2.0-7.b6vl5
168- applied new versioning policy
169
170* Sun Sep  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.0-6.1vl1.b6
171- new upstream release
172- added Patch100 for building with gcc4
173
174* Thu Mar 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-6.1vl1.b5
175- rebuild for VineSeedPlus
176
177* Thu Mar 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-6.1vl0.b5
178- build for VinePlus/2.6
179- remove commented lines
180- change configure options for apache of Vine
181
182* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
183- rebuilt
184
185* Thu Feb 26 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-6
186- Removed buildroot cruft from HtFileFype (#116442).
187- Use mktemp in HtFileFype to create temporary file (#116443).
188
189* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
190- rebuilt
191
192* Thu Jan 15 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-4
193- Fixed missing & in if clause.
194
195* Tue Jan 13 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-3
196- Fixed latin1 char translation (#71921).
197- Fixed overflow bug in WordDBPage.cc (#110802).
198
199* Mon Jan 12 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-2
200- Moved /usr/share/htdig files to web package (#111938).
201
202* Fri Dec 12 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-1
203- Update to latest stable upstream version htdig-3.2.0b5.
204
205* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
206- rebuilt
207
208* Wed Jun 04 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0-18.20030601
209- Update to htdig-3.2.0b4-20030601 snapshot.
210- Fixed build problems.
211
212* Thu Mar 06 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0-17.20030302
213- Update to htdig-3.2.0b4-20030302 snapshot.
214
215* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
216- rebuilt
217
218* Wed Jan  8 2003 Jeff Johnson <jbj@redhat.com> 3.2.0-15.20021103
219- don't include -debuginfo files in package.
220
221* Tue Dec 17 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-14.20021103
222- Forgot to create conf.d directory. Fixed.
223- Fixed wrong files section.
224
225* Tue Dec 10 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-13.20021103
226- Removed symlink from %{contentdir}/html and replaced it with httpd.d conf
227  file (#73518).
228
229* Tue Dec 10 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-12.20021103
230- Added webserver requirement for htdig-web package (#73986).
231
232* Wed Dec 04 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-11.20021103
233- Fix for autoFOO patch.
234- Fix x64_64 build.
235
236* Wed Nov 27 2002 Tim Powers <timp@redhat.com> 3.2.0-9.20021103
237- rebuild on all arches
238
239* Fri Nov 08 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-8.20021103
240- Updated to htdig-3.2.0b4-20021103.
241- Fixed %files section errors.
242
243* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 3.2.0-7.20020505
244- rebuilt with gcc-3.2 (we hope)
245
246* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 3.2.0-6.20020505
247- build using gcc-3.2-0.1
248
249* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 3.2.0-5.20020505
250- automated rebuild
251
252* Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-4.20020505
253- Don't forcibly strip binaries
254
255* Thu May 23 2002 Tim Powers <timp@redhat.com>
256- automated rebuild
257
258* Mon May  6 2002 Bernhard Rosenkraenzer <bero@linux-easy.com> 3.2.0-2.20020505
259- Fix build with current toolchain (automake 1.6, autoconf 2.53 changes)
260- Update snapshot, fixes some more problems
261
262* Thu Jan 24 2002 Phil Knirsch <pknirsch@redhat.com>
263- Updated to latest snapshot to fix several problems.
264- Fixed a problem with htdig segfaulting on s390 (#58202).
265
266* Fri Jul 20 2001 Philipp Knirsch <pknirsch@redhat.de>
267- Added missing BuildRequires: zlib-devel (#49500)
268
269* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
270- Bump release + rebuild.
271
272* Fri Apr 27 2001 Bill Nottingham <notting@redhat.com>
273- rebuild for C++ exception handling on ia64
274
275* Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.2.0-0.b3.4
276- move pictures etc. to base package and to a directory outside of
277  /var/www - The current KDevelop search function doesn't work without
278  them.
279
280* Mon Mar  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
281- Add htsearch to the base package, kdevelop needs it
282
283* Wed Jan 10 2001 Bernhard Rosenkraenzer <bero@redhat.com>
284- Move the web related files to a separate package
285
286* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
287- 3.2.0b2
288- fix build with glibc 2.2 and gcc 2.96
289
290* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
291- fix syntax error introduced in our patch (#16598)
292
293* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
294- fixed group to be a valid one
295
296* Mon Jul 24 2000 Prospector <prospector@redhat.com>
297- rebuilt
298
299* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
300- rebuild for Power Tools
301
302* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
303- rebuild for Power Tools
304
305* Sat Feb 26 2000 Nalin Dahyabhai <nalin@redhat.com>
306- 3.1.5
307
308* Wed Jan 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
309- 3.1.4
310- fix URL and source location
311
312* Tue Sep 28 1999 Preston Brown <pbrown@redhat.com>
313- 3.1.3 for SWS 3.1
314
315* Wed May 05 1999 Preston Brown <pbrown@redhat.com>
316- updates for SWS 3.0
317
318* Mon Aug 31 1998 Preston Brown <pbrown@redhat.com>
319- Updates for SWS 2.0
320
321* Sat Feb 07 1998 Cristian Gafton <gafton@redhat.com>
322- built against glibc
323- build all the fuzzy databases before packaging, because it is time
324  consuming operation and we don't want the user to be impatient
Note: See TracBrowser for help on using the repository browser.