source: projects/specs/branches/6/h/hplip/hplip-vl.spec @ 8127

Revision 8127, 11.2 KB checked in by iwamoto, 10 years ago (diff)

hplip: security fixes

Line 
1# %define python_platlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
2Summary:        HP printer drivers & utilities for Linux
3Summary(ja):    HP プリンタ用の Linux 向けドライバとユーティリティ
4Name:           hplip
5Version:        3.11.5
6Release:        5%{?_dist_release}
7Source0:        %{name}-%{version}.tar.gz
8Source1:        hplip.desktop.vine
9Patch0:         hplip-3.11.5-gksu.patch
10Patch1:         hplip-udev-rules.patch
11
12Patch100:       hplip-CVE-2013-4325.patch
13Patch110:       hplip-CVE-2013-0200.patch
14Patch120:       hplip-CVE-2013-6402.patch
15
16License:        GPL/MIT
17Group:          Applications/Publishing
18URL:            http://hplipopensource.com/hplip-web/index.html
19
20Requires:       cups
21Requires:       dbus
22Requires:       foomatic
23Requires:       ghostscript
24Requires:       libjpeg
25Requires:       openssl
26Requires:       python-imaging
27Requires:       dbus-python
28Requires:       %{name}-libs = %{version}-%{release}
29Requires:       gksu
30BuildRequires:  cups-devel
31BuildRequires:  dbus-devel
32BuildRequires:  libusb-devel
33BuildRequires:  libjpeg-devel
34BuildRequires:  net-snmp-devel
35BuildRequires:  openssl-devel
36BuildRequires:  python-devel >= 2.3
37BuildRequires:  sane-devel
38BuildRequires:  PyQt4
39# to force to use PyQt4
40BuildConflicts: PyQt
41
42Provides:       hpijs
43Obsoletes:      hpijs < 3.10
44
45BuildRoot:      %{_tmppath}/%{name}-%{version}-root
46
47Packager:       kazutaka
48Vendor:         Project Vine
49Distribution:   Vine Linux
50
51
52# When below files are included in %files section,
53# find-requires shows strange error.
54#  %{_datadir}/hplip/base/kirbybase.py and pexpect.py
55# So, below option is added to aboid this.
56#AutoReq:       False
57
58%description
59HPLIP is an HP developed solution for printing, scanning, and
60faxing with HP inkjet and laser based printers in Linux.
61
62The HPLIP project provides printing support for 1,151 printer
63models, including Deskjet, Officejet, Photosmart, PSC (Print Scan
64Copy), Business Inkjet, LaserJet, Edgeline MFP, and LaserJet MFP.
65
66%description -l ja
67HPLIP は HP が開発した HP インクジェット及びレーザープリンタ向けの、
68プリンタ/スキャナ/FAX 機能を Linux 上で利用する為のソリューション
69です。
70
71HPLIP プロジェクトでは1,151種類のプリンタをサポートしています。
72これには Deskjet、 Officejet、 Photosmart、 PSC (Print Scan Copy)、
73Business Inkjet、 LaserJet、 Edgeline MFP 及び LaserJet MFP が
74含まれます。
75
76#---------------------------------------------------------------------
77
78%package libs
79Summary:        HPLIP libraries
80Summary(ja):    HPLIP ライブラリ
81Group:          System Environment/Libraries
82License:        GPL/MIT
83
84%description libs
85Libraries needed by HPLIP.
86
87%description libs -l ja
88HPLIP 用のライブラリです。
89
90#---------------------------------------------------------------------
91
92%package gui
93Summary:        HPLIP graphical tools
94Summary(ja):    HPLIP 用 GUI ツール
95Group:          Applications/System
96License:        GPL/MIT
97Requires:       %{name} = %{version}-%{release}
98Requires:       PyQt4
99Requires:       notify-python
100
101%description gui
102HP Device manager (toolbox) is a graphical utility including
103maintenance tools, supplies levels, and status information.
104
105%description gui -l ja
106HP デバイスマネージャ (toolbox) は、各種設定やインクや紙の残量確
107認、ステータス情報の確認が行える HPLIP 用の GUI ユーティリティです。
108
109#---------------------------------------------------------------------
110
111%package -n libsane-hpaio
112Summary:        SANE driver for scanners in HP's multi-function devices
113Summary(ja):    HP 複合機のスキャナ用 SANE ドライバ
114Group:          System Environment/Libraries
115License:        GPL/MIT
116Requires:       %{name}-libs = %{version}-%{release}
117Requires:       sane
118
119%description -n libsane-hpaio
120SANE driver for scanners in HP inkjet and laser based multi-function
121printers.
122
123%description -n libsane-hpaio -l ja
124HP インクジェット及びレーザープリンタ複合機のスキャナ機能を利用する
125為の SANE ドライバです。
126
127#---------------------------------------------------------------------
128
129%prep
130%setup -q
131%patch0 -p1 -b .gksu
132%patch1 -p1 -b .udev-rules
133
134%patch100 -p1 -b .CVE-2013-4325
135%patch110 -p1 -b .CVE-2013-0200
136%patch120 -p1 -b .CVE-2013-6402
137
138%build
139%configure --enable-doc-build \
140           --enable-network-build \
141           --disable-pp-build \
142           --enable-scan-build \
143           --enable-gui-build \
144           --enable-fax-build \
145           --enable-dbus-build \
146           --enable-qt4 \
147           --disable-qt3 \
148           --enable-hpijs-install \
149           --enable-hpcups-install \
150           --enable-cups-drv-install \
151           --enable-foomatic-drv-install \
152           --disable-cups-ppd-install \
153           --disable-foomatic-ppd-install \
154           --with-cupsbackenddir=%{_libdir}/cups/backend \
155           --with-cupsfilterdir=%{_libdir}/cups/filter \
156           --with-hpppddir=%{_datadir}/foomatic/db/source/PPD/HP
157%{__make}
158
159
160%install
161%{__rm} -rf ${RPM_BUILD_ROOT}
162%{__make} install DESTDIR=${RPM_BUILD_ROOT}
163
164# install modified .desktop
165%{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/applications/hplip.desktop
166
167# remove unpacked files.
168%{__rm} -rf ${RPM_BUILD_ROOT}/%{_sysconfdir}/sane.d
169
170# remove unnecessary files.
171%{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/libhpip.la
172%{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/libhpmud.la
173%{__rm} -rf ${RPM_BUILD_ROOT}/%{python_sitearch}/cupsext.la
174%{__rm} -rf ${RPM_BUILD_ROOT}/%{python_sitearch}/hpmudext.la
175%{__rm} -rf ${RPM_BUILD_ROOT}/%{python_sitearch}/pcardext.la
176%{__rm} -rf ${RPM_BUILD_ROOT}/%{python_sitearch}/scanext.la
177%{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/sane/libsane-hpaio.la
178
179%clean
180%__rm -rf ${RPM_BUILD_ROOT}
181
182
183%post libs
184/sbin/ldconfig
185
186%postun libs
187/sbin/ldconfig
188
189%post gui
190/usr/bin/update-desktop-database &>/dev/null ||:
191
192%postun gui
193/usr/bin/update-desktop-database &>/dev/null ||:
194
195%post -n libsane-hpaio
196/sbin/ldconfig
197if [ -f /etc/sane.d/dll.conf ] && \
198   ! grep ^hpaio /etc/sane.d/dll.conf >/dev/null 2>/dev/null ; then \
199        echo hpaio >> /etc/sane.d/dll.conf; \
200fi
201
202%files
203%defattr(-,root,root)
204%doc %{_datadir}/doc/%{name}-%{version}
205%{_bindir}/hp-align
206%{_bindir}/hp-check
207%{_bindir}/hp-clean
208%{_bindir}/hp-colorcal
209%{_bindir}/hp-devicesettings
210%{_bindir}/hp-fab
211%{_bindir}/hp-faxsetup
212%{_bindir}/hp-firmware
213%{_bindir}/hp-info
214%{_bindir}/hp-levels
215%{_bindir}/hp-linefeedcal
216%{_bindir}/hp-makecopies
217%{_bindir}/hp-makeuri
218%{_bindir}/hp-mkuri
219%{_bindir}/hp-plugin
220%{_bindir}/hp-pqdiag
221%{_bindir}/hp-pkservice
222%{_bindir}/hp-printsettings
223%{_bindir}/hp-probe
224%{_bindir}/hp-query
225%{_bindir}/hp-scan
226%{_bindir}/hp-sendfax
227%{_bindir}/hp-setup
228%{_bindir}/hp-systray
229%{_bindir}/hp-testpage
230%{_bindir}/hp-timedate
231%{_bindir}/hp-unload
232%{_bindir}/hp-wificonfig
233%{_bindir}/hpijs
234%{_datadir}/hal/fdi/preprobe/10osvendor/20-hplip-devices.fdi
235%{_datadir}/hplip/__init__.py
236%{_datadir}/hplip/align.py
237%{_datadir}/hplip/base
238%{_datadir}/hplip/check.py
239%{_datadir}/hplip/clean.py
240%{_datadir}/hplip/colorcal.py
241%{_datadir}/hplip/copier
242%{_datadir}/hplip/data/ldl
243%{_datadir}/hplip/data/models
244%{_datadir}/hplip/data/pcl
245%{_datadir}/hplip/data/ps
246%{_datadir}/hplip/devicesettings.py
247%{_datadir}/hplip/fax
248%{_datadir}/hplip/faxsetup.py
249%{_datadir}/hplip/firmware.py
250%{_datadir}/hplip/hpdio.py
251%{_datadir}/hplip/hpssd.py
252%{_datadir}/hplip/info.py
253%{_datadir}/hplip/installer
254%{_datadir}/hplip/levels.py
255%{_datadir}/hplip/linefeedcal.py
256%{_datadir}/hplip/makecopies.py
257%{_datadir}/hplip/makeuri.py
258%{_datadir}/hplip/pcard
259%{_datadir}/hplip/pkservice.py
260%{_datadir}/hplip/plugin.py
261%{_datadir}/hplip/pqdiag.py
262%{_datadir}/hplip/printsettings.py
263%{_datadir}/hplip/prnt
264%{_datadir}/hplip/probe.py
265%{_datadir}/hplip/query.py
266%{_datadir}/hplip/scan
267%{_datadir}/hplip/testpage.py
268%{_datadir}/hplip/timedate.py
269%{_datadir}/hplip/unload.py
270%{_datadir}/hplip/wificonfig.py
271%{_datadir}/cups/drv/hp/hpcups.drv
272%{_datadir}/cups/drv/hp/hpijs.drv
273%{_datadir}/foomatic/db/source/PPD/HP
274%{_libdir}/cups/backend/hp
275%{_libdir}/cups/backend/hpfax
276%{_libdir}/cups/filter/hpcups
277%{_libdir}/cups/filter/hpcac
278%{_libdir}/cups/filter/hpcupsfax
279%{_libdir}/cups/filter/hplipjs
280%{_libdir}/cups/filter/hpps
281%{_libdir}/cups/filter/pstotiff
282%config(noreplace) %{_sysconfdir}/hp/hplip.conf
283%{_sysconfdir}/cups/pstotiff.convs
284%{_sysconfdir}/cups/pstotiff.types
285%{_sysconfdir}/udev/rules.d/55-hpmud.rules
286%{_sysconfdir}/udev/rules.d/56-hpmud_support.rules
287%{_localstatedir}/lib/hp
288
289%files libs
290%defattr(-,root,root)
291%{_libdir}/libhpip.so*
292%{_libdir}/libhpmud.so*
293%{python_sitearch}/cupsext.so
294%{python_sitearch}/hpmudext.so
295%{python_sitearch}/pcardext.so
296%{python_sitearch}/scanext.so
297
298%files gui
299%defattr(-,root,root)
300%{_bindir}/hp-fab
301%{_bindir}/hp-print
302%{_bindir}/hp-scan
303%{_bindir}/hp-sendfax
304%{_bindir}/hp-setup
305%{_bindir}/hp-toolbox
306%{_datadir}/hplip/data/images
307%{_datadir}/hplip/data/localization
308%{_datadir}/hplip/fab.py
309%{_datadir}/hplip/print.py
310%{_datadir}/hplip/scan.py
311%{_datadir}/hplip/sendfax.py
312%{_datadir}/hplip/setup.py
313%{_datadir}/hplip/systray.py
314%{_datadir}/hplip/toolbox.py
315%{_datadir}/hplip/ui4
316%{_datadir}/applications/hplip.desktop
317%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
318
319%files -n libsane-hpaio
320%defattr(-,root,root)
321%{_libdir}/sane/libsane-hpaio*
322
323
324%changelog
325* Tue Jan  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.11.5-5
326- add patch110 for fix CVE-2013-0200
327- add patch120 for fix CVE-2013-6402
328  (These patches are from debian, Thanks to debian team)
329- add Vendor/Distri tags
330
331* Fri Oct 11 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.11.5-4
332- added Patch100 to fix CVE-2013-4325
333
334* Mon Jun 13 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.11.5-3
335- add Obsoletes: hpijs < 3.10
336
337* Sun Jun 12 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.11.5-2
338- change configure option to --enable-hpijs-install
339- add Provides: hpijs
340- change ppd installation path to %{_datadir}/foomatic/db/source/PPD/HP
341- update Source1 (hplip.desktop.vine)
342- update Patch0 (hplip-3.11.5-gksu.patch)
343- add Patch1 to fix udev old syntax (hplip-udev-rules.patch)
344
345* Tue Mar 15 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.11.5-1
346- new upstream release
347- change configure option: disable qt3 and enable qt4
348- add configure option: --enable-foomatic-drv-install
349- add BuildRequires: openssl-devel
350- add Requires: dbus-python
351- add Requires: notify-python (gui)
352- change Requires: PyQt to PyQt4 (gui)
353- add BuildConflicts: PyQt
354- add ppds below %{_datadir}/cups/model/foomatic/hp-*
355  because foomatic (>= 4.0.3) drop PPDs for HP printers.
356
357* Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.9.4b-3
358- add Patch0 to require root privilege (via gksu) when adding printer
359- add Requires: gksu
360
361* Mon Jun 08 2009 Shu KONNO <owa@bg.wakwak.com> 3.9.4b-2
362- added --with-cupsfilterdir to configure option
363- use python_sitearch macro instead of python_platlib
364
365* Sun Jun 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.9.4b-1
366- new upstream release
367- split libraries to -libs sub package
368- update configure option
369  add --enable-dbus-build, --enable-qt3, --disable-qt4
370
371* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 2.7.12-1vl5
372- rebuilt with python-2.5.2
373- added python_platlib macro
374- applied new versioning policy and spec in utf-8
375
376* Sun Jan  6 2008 Shu KONNO <owa@bg.wakwak.com> 2.7.12-0vl2
377- added --with-cupsbackenddir=%%{_libdir}/cups/backend to configure
378
379* Thu Jan  3 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.7.12-0vl1
380- new upstream release
381- build with net-snmp-5.4.1
382
383* Thu Jun 28 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.7.6-0vl1
384- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.