source: projects/specs/branches/6/h/hfsutils/hfsutils-vl.spec @ 521

Revision 521, 6.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Tools for reading and writing Macintosh HFS volumes.
2Summary(ja): Macintosh HFS ボリュームの読み書きを行うツール
3Name: hfsutils
4Version: 3.2.6 
5Release: 8%{?_dist_release}
6Group: Applications/System
7License: GPL
8Source: ftp://ftp.mars.org/pub/hfs/%{name}-%{version}.tar.gz
9Patch0: hfsutils-3.2.6-errno.patch
10Patch1: hfsutils-3.2.6-largefile.patch
11
12## Vine Source(s)/Patch(es)
13Source100: hfsutils-man-ja.tar.gz
14Patch100: hfsutils-3.2.6-Makefile.patch
15
16URL: http://www.mars.org/home/rob/proj/hfs/
17BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-root
18Requires: tcl
19BuildRequires: tcl tk
20
21%package devel
22Summary: A C library for reading and writing Macintosh HFS volumes.
23Summary(ja): Macintosh HFS ボリュームの読み書きを行う為の C ライブラリ
24Group: Development/Libraries
25
26%package x11
27Summary: A Tk-based front end for browsing and copying files on Macintosh HFS volumes.
28Summary(ja): Macintosh HFS ボリュームアクセス用 Tk フロントエンド
29Group: Applications/System
30Requires: tcl tk
31Obsoletes: xhfs
32
33
34%description
35HFS (Hierarchical File System) is the native volume format found on
36modern Macintosh computers.  Hfsutils provides utilities for accessing
37HFS volumes from Linux and UNIX systems.  Hfsutils contains several
38command-line programs which are comparable to mtools.
39
40%description -l ja
41HFS (Hierarchical File System) は Macintosh コンピュータ用の
42ボリュームフォーマットです.hfsutils は Linux や UNIX から
43この HFS ボリュームにアクセスする為のツールを提供します.
44mtools と互換性のあるコマンドラインプログラムを含んでいます.
45
46
47%description devel
48The hfsutils-devel package provides a C library for low-level access
49to Macintosh volumes. HFS (Hierarchical File System) is the native
50volume format found on modern Macintosh computers.  The C library can
51be linked with other programs to allow them to manipulate Macintosh
52files in their native format.  Other HFS accessing utilities, which
53are comparable to mtools, are included in the hfsutils package.
54
55%description devel -l ja
56hfsutils-devel パッケージは Macintosh ボリュームへの低レベル
57アクセスの為の C ライブラリを提供します.HFS (Hierarchical
58File System) は Macintosh コンピュータ用のボリュームフォーマット
59です.C ライブラリはリンク可能で,いろいろなプログラムから
60Macintosh ボリューム上のファイルへのアクセスが可能になります.
61mtools と互換性のあるいろいろなユーティリティは hfsutils パッケージに
62納められています.
63
64
65%description x11
66The hfsutils-x11 package includes a Tk-based front end for browsing
67and copying files, and a Tcl package and interface for scriptable access
68to volumes.  A C library for low-level access to volumes is included in the
69hfsutils-devel package.
70
71%description x11 -l ja
72hfsutils-x11 パッケージには、Macintosh HFS ボリュームにアクセスするための
73Tk ベースのフロントエンドが収録されています。
74
75
76%prep
77%setup -q -a 100
78%patch0 -p1
79%patch1 -p0
80
81
82%build
83%{configure} --with-tcl=%{_libdir}  --with-tk=%{_libdir}
84make
85make hfsck/hfsck
86
87
88%install
89rm -rf $RPM_BUILD_ROOT
90mkdir -p $RPM_BUILD_ROOT%{_bindir}
91mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
92mkdir -p $RPM_BUILD_ROOT%{_includedir}
93mkdir -p $RPM_BUILD_ROOT%{_libdir}
94make    BINDEST=$RPM_BUILD_ROOT%{_bindir} \
95        LIBDEST=$RPM_BUILD_ROOT%{_libdir} \
96        INCDEST=$RPM_BUILD_ROOT%{_includedir} \
97        MANDEST=$RPM_BUILD_ROOT%{_mandir} \
98        install install_lib
99install -m0755 hfsck/hfsck $RPM_BUILD_ROOT/%{_bindir}
100ln -sf hfsck $RPM_BUILD_ROOT/%{_bindir}/fsck.hfs
101
102# install Japanese man pages
103mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/ja/man1
104install -m 644 hfsutils-man-ja/* ${RPM_BUILD_ROOT}%{_mandir}/ja/man1/.
105
106gzip -9nvf ${RPM_BUILD_ROOT}%{_mandir}/man1/*
107gzip -9nvf ${RPM_BUILD_ROOT}%{_mandir}/ja/man1/*
108
109find $RPM_BUILD_ROOT -type f -or -type l | \
110        sed -e "s|$RPM_BUILD_ROOT||" |
111        grep -v 'xhfs' | \
112        grep -v '%{_includedir}' | \
113        grep -v '%{_libdir}' > hfsutils.filelist
114
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119
120%files -f hfsutils.filelist
121%defattr(-,root,root)
122%doc CHANGES COPYING COPYRIGHT CREDITS INSTALL README TODO
123
124%files x11
125%defattr(-,root,root)
126%{_bindir}/xhfs
127%{_mandir}/man1/xhfs.1.*
128%{_mandir}/ja/man1/xhfs.1.*
129
130%files devel
131%defattr(-,root,root)
132%{_libdir}/libhfs.a
133%{_libdir}/librsrc.a
134%{_includedir}/hfs.h
135%{_includedir}/rsrc.h
136
137%changelog
138* Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 3.2.6-8vl5
139- applied new versioning policy and spec in utf-8
140
141* Mon May 21 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.2.6-7vl3
142- rebuilt with new toolchain
143
144* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.6-7vl2
145- changed Group to Applications/System
146
147* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.2.6-7vl1
148- import errno/largefile patches into 3.2.6-3vl6
149
150* Wed Mar 2 2005 David Woodhouse <dwmw2@redhat.com> 3.2.6-7
151- Rebuild with gcc 4
152
153* Sun Feb 20 2005 David Woodhouse <dwmw2@redhat.com> 3.2.6-6
154- Handle files larger than 2GiB
155- Include hfsck
156
157* Mon Feb 14 2005 David Woodhouse <dwmw2@redhat.com> 3.2.6-5
158- s/Copyright:/License:/ (sic)
159
160* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 3.2.6-4
161- rebuilt
162
163* Mon Apr 19 2004 David Woodhouse  <dwmw2@redhat.com> 3.2.6-3
164- BuildRequires tk-devel
165
166* Sun Apr 11 2004 David Woodhouse  <dwmw2@redhat.com> 3.2.6-2.1
167- Adjust configure invocation to find tcl in %%{_libdir}
168
169* Sun Apr 11 2004 David Woodhouse  <dwmw2@redhat.com> 3.2.6-2
170- Require tcl
171
172* Fri Apr 09 2004 David Woodhouse  <dwmw2@redhat.com> 3.2.6-1
173- Fix BuildRequires, include errno.h in tclhfs.c, use %%{configure}
174
175* Wed Oct 02 2002 Dan Burcaw <dburcaw@terrasoftsolutions.com>
176- Anubis rebuild
177
178* Fri Mar 30 2001 Dan Burcaw <dburcaw@terrasoftsolutions.com>
179- split xhfs into its own package
180
181* Fri Feb 11 2000 Tim Powers <timp@redhat.com>
182- gzip manpages, strip binaries
183
184* Thu Jul 15 1999 Tim Powers <timp@redhat.com>
185- added %defattr
186- rebuilt for 6.1
187
188* Thu Apr 15 1999 Michael Maher <mike@redhat.com>
189- built package for 6.0
190- updated source
191
192* Thu Aug 20 1998 Michael Maher <mike@redhat.com>
193- built package
194
Note: See TracBrowser for help on using the repository browser.