source: projects/specs/branches/6/h/herqq/herqq-vl.spec @ 4445

Revision 4445, 2.5 KB checked in by inagaki, 13 years ago (diff)

update: akonadi, shared-desktop-ontologies
NEW: herqq, qtsoap

Line 
1%define _qt4_ver 4.7.2
2%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
3%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_version})
4%define _qt4_libdir %(pkg-config --variable libdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/lib)
5%define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
6
7
8Name:           herqq
9Summary:        A software library for building UPnP devices and control points
10Version:        1.0.0
11Release:        2%{?_dist_release}
12
13# test application is GPLv3 but we do not ship it
14License:        LGPLv3+
15URL:            http://herqq.org/
16Source0:        http://downloads.sourceforge.net/project/hupnp/hupnp/%{name}-%{version}.zip
17Patch2:         herqq-1.0.0-qtsoap-library.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires:  desktop-file-utils
21BuildRequires:  qt4-devel
22BuildRequires:  qtsoap-devel
23Requires: qt4 >= %{_qt4_version}
24
25%description
26Herqq UPnP (HUPnP) is a software library for building UPnP
27devices and control points conforming to the UPnP Device
28Architecture version 1.1.
29
30%package devel
31Summary:  Development files for %{name}
32Requires: %{name} = %{version}-%{release}
33Requires: qt4-devel = %{_qt4_version}
34
35%description devel
36Header files for developing applications using %{name}.
37
38%prep
39%setup -q
40
41# lQtSolutions to lqtsoap
42%patch2 -p1 -b .qtsoap-library
43
44%build
45# we have to disable bundled QtSOAP library
46qmake PREFIX=%{_prefix} -config DISABLE_QTSOAP \
47    -config DISABLE_TESTAPP -config USE_QT_INSTALL_LOC
48make %{?_smp_mflags}
49
50%install
51make INSTALL_ROOT=%{buildroot} install
52
53
54%post -p /sbin/ldconfig
55%postun -p /sbin/ldconfig
56
57
58%files
59%doc hupnp/ChangeLog hupnp/LICENSE_LGPLv3.txt
60%{_qt4_libdir}/libHUpnp.so.1*
61
62%files devel
63%{_qt4_libdir}/libHUpnp.so
64%{_qt4_headerdir}/HUpnpCore/
65
66%changelog
67* Sat Jul 31 2011 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-2
68- Initial build for Vine Linux
69
70* Wed Jul 20 2011 Jaroslav Reznik <jreznik@redhat.com> - 1.0.0-1
71- post-review update to 1.0.0
72
73* Wed Jul 20 2011 Jaroslav Reznik <jreznik@redhat.com> - 0.9.1-3
74- fix license to LGPLv3+
75- qt4 header dir for consistency
76- shlib soname tracked in %files
77- -devel should not duplicate COPYING
78
79* Tue Jul 19 2011 Jaroslav Reznik <jreznik@redhat.com> - 0.9.1-2
80- qtsoap library
81- cleanup SPEC file
82
83* Tue Feb 22 2011 Jaroslav Reznik <jreznik@redhat.com> - 0.9.1-1
84- Initial spec file
Note: See TracBrowser for help on using the repository browser.