source: projects/specs/branches/6/h/hdf/hdf-vl.spec @ 521

Revision 521, 3.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: hdf
2Version: 4.2r2
3Release: 1%{?_dist_release}
4Summary: A general purpose library and file format for storing scientific data
5Source0: ftp://ftp.ncsa.uiuc.edu/HDF/HDF/HDF_Current/src/HDF%{version}.tar.gz
6#Source1: ftp://ftp.ncsa.uiuc.edu/HDF/HDF/HDF_Current/src/patches/4.2r1-hrepack-patch.tar
7Patch0: hdf-4.2r1p4-maxavailfiles.patch
8Patch1: hdf-4.2r2-ppc.patch
9License: BSD-ish
10Group: System Environment/Libraries
11URL: http://hdf.ncsa.uiuc.edu/hdf4.html
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: autoconf flex byacc libjpeg-devel zlib-devel
15BuildRequires: gcc-gfortran
16
17
18%description
19HDF is a general purpose library and file format for storing scientific data.
20HDF can store two primary objects: datasets and groups. A dataset is
21essentially a multidimensional array of data elements, and a group is a
22structure for organizing objects in an HDF file. Using these two basic
23objects, one can create and store almost any kind of scientific data
24structure, such as images, arrays of vectors, and structured and unstructured
25grids. You can also mix and match them in HDF files according to your needs.
26
27%package devel
28Summary: HDF development files
29Group: Development/Libraries
30Requires: %{name} = %{version}-%{release}
31Requires: libjpeg-devel zlib-devel
32
33%description devel
34HDF development headers and libraries.
35
36
37%prep
38%setup -q -n HDF%{version}
39#tar xf %{SOURCE1} --directory mfhdf/hrepack
40#mv mfhdf/hrepack/4.2r1-hrepack-patch/*.[ch] mfhdf/hrepack
41#rm -r mfhdf/hrepack/4.2r1-hrepack-patch
42%patch -p1 -b .maxavailfiles
43%patch1 -p1 -b .ppc
44
45chmod a-x *hdf/*/*.c hdf/*/*.h
46
47
48%build
49rm config/*linux-gnu
50export CFLAGS="$RPM_OPT_FLAGS -fPIC"
51export FFLAGS="$RPM_OPT_FLAGS -ffixed-line-length-none"
52%configure F77=gfortran --disable-production \
53 --includedir=%{_includedir}/%{name} --libdir=%{_libdir}/%{name}
54make
55
56
57%install
58rm -rf $RPM_BUILD_ROOT
59%makeinstall includedir=${RPM_BUILD_ROOT}%{_includedir}/%{name} \
60             libdir=$RPM_BUILD_ROOT%{_libdir}/%{name}
61#Don't conflict with netcdf
62rm $RPM_BUILD_ROOT%{_bindir}/nc* $RPM_BUILD_ROOT%{_mandir}/man1/nc*
63
64
65%check
66make check
67
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72
73%files
74%defattr(-,root,root,0755)
75%doc COPYING MANIFEST README release_notes/*.txt
76%{_bindir}/*
77%{_mandir}/man1/*.gz
78
79
80%files devel
81%defattr(-,root,root,0755)
82%{_includedir}/%{name}/
83%{_libdir}/%{name}/
84
85
86%changelog
87* Sat Oct 25 2008 Shu KONNO <owa@bg.wakwak.com> 4.2r2-1vl5
88- applied new versioning policy
89
90* Fri Feb 01 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2r2-0vl1
91- updated to 4.2r2 (imported patches from 4.2r2-2.fc8)
92
93* Thu Dec 20 2007 Shu KONNO <owa@bg.wakwak.com> 4.2r1-0vl2
94- s/gcc-g77/gcc-gfortran/
95
96* Sat Oct 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2r1-0vl1
97- initial build for Vine Linux
98
99* Wed Oct 05 2005 Orion Poplawski <orion@cora.nwra.com> 4.2r1-5
100- Add Requires: libjpeg-devel zlib-devel to -devel package
101
102* Tue Aug 23 2005 Orion Poplawski <orion@cora.nwra.com> 4.2r1-4
103- Use -fPIC
104- Fix project URL
105
106* Fri Jul 29 2005 Orion Poplawski <orion@cora.nwra.com> 4.2r1-3
107- Exclude ppc/ppc64 - HDF does not recognize it
108
109* Wed Jul 20 2005 Orion Poplawski <orion@cora.nwra.com> 4.2r1-2
110- Fix BuildRequires to have autoconf
111
112* Fri Jul 15 2005 Orion Poplawski <orion@cora.nwra.com> 4.2r1-1
113- inital package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.