source: projects/specs/branches/6/h/havp/havp-vl.spec @ 9853

Revision 9853, 4.1 KB checked in by tomop, 8 years ago (diff)

havp-0.92a-3

  • Property svn:executable set to *
Line 
1%define clamav_version 0.96
2
3Summary: HAVP - HTTP Anti Virus Proxy
4Name: havp
5Version: 0.92a
6Release: 3%{_dist_release}
7License: GPL
8Group: Applications/System
9URL: http://www.server-side.de/
10Source0: http://www.server-side.de/download/havp-%{version}.tar.gz
11Patch0: havp.patch
12BuildRequires: libstdc++-devel, zlib-devel, bzip2-devel
13BuildRequires: gmp-devel, openssl-devel
14BuildRequires: clamav-devel => %{clamav_version}
15BuildRoot: %{_tmppath}/%{name}-%{version}-root/
16#Requires: libstdc++, zlib, bzip2, gmp
17Requires: clamav => %{clamav_version}
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: tomop
21
22
23%description
24HAVP (HTTP AntiVirus proxy) is a proxy with an anti-virus filter.
25It does not cache or filter content. At the moment the complete
26traffic is scanned. The reason for this is the chance of malicious
27code in nearly every filetype e.g. HTML (JavaScript) or Jpeg. I aim
28to stop especially dialer or browser exploits. But writing a http
29Anti Virus Proxy is a real dilemma! Huge downloads are a problem
30for virus scanning proxies. A Client should not receive data which
31is unchecked by the virus scanner, but big downloads should not timeout.
32
33%prep
34
35%setup -q
36%patch0 -p0
37#%patch1 -p1
38
39%build
40%configure --with-scanner=libclamav --enable-ssl-tunnel
41make %{?_smp_mflags}
42
43%install
44rm -rf %{buildroot}
45mkdir -p %{buildroot}%{_sbindir}
46mkdir -p %{buildroot}%{_sysconfdir}/havp/templates
47mkdir -p %{buildroot}%{_localstatedir}/log/havp
48mkdir -p %{buildroot}%{_localstatedir}/tmp/havp
49mkdir -p %{buildroot}%{_localstatedir}/run/havp
50mkdir -p %{buildroot}%{_initdir}
51
52install -m755 havp/havp %{buildroot}%{_sbindir}
53install -m755 etc/init.d/havp %{buildroot}%{_initdir}
54install -m644 etc/havp/havp.config %{buildroot}%{_sysconfdir}/havp/havp.config
55install -m644 etc/havp/whitelist %{buildroot}%{_sysconfdir}/havp/whitelist
56install -m644 etc/havp/blacklist %{buildroot}%{_sysconfdir}/havp/blacklist
57cp -r etc/havp/templates/* %{buildroot}%{_sysconfdir}/havp/templates
58chmod -R a+rX %{buildroot}/etc/havp/templates
59
60%clean
61rm -rf %{buildroot}
62
63%pre
64if ! grep -q '^havp:' /etc/group; then
65    /usr/sbin/groupadd -r havp
66fi
67if ! grep -q '^havp:' /etc/passwd; then
68    /usr/sbin/useradd -M -r -s /sbin/nologin -g havp havp || :
69fi
70
71%postun
72/sbin/ldconfig
73if [ $1 = 0 ]; then
74    if [ `grep havp /etc/passwd | wc -l` = 1 ]; then
75        /usr/sbin/userdel havp
76    fi
77    if [ `grep havp /etc/group | wc -l` = 1 ]; then
78        /usr/sbin/groupdel havp
79    fi
80fi
81
82%post -p /sbin/ldconfig
83
84%files
85%defattr(-,root,root,-)
86%doc INSTALL COPYING ChangeLog
87%{_initdir}/havp
88%{_sbindir}/havp
89%config(noreplace) %{_sysconfdir}/havp/havp.config
90%config(noreplace) %{_sysconfdir}/havp/whitelist
91%config(noreplace) %{_sysconfdir}/havp/blacklist
92%{_sysconfdir}/havp/templates/*
93%attr(750,havp,havp) %dir /var/log/havp
94%attr(750,havp,havp) %dir /var/tmp/havp
95%attr(750,havp,havp) %dir /var/run/havp
96
97%changelog
98* Thu Dec  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92a-3
99- built with clamav-0.99.
100
101* Sun Jan 12 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92a-2
102- rebuilt with current environment.
103
104* Sun Dec 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92a-1
105- new upstream release.
106
107* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92-1
108- new upstream release.
109
110* Thu Jun 11 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.90-1
111- new upstream release.
112
113* Tue Mar 24 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.89-1
114- new upstream release.
115- built with clamav-0.95.
116
117* Tue Apr 15 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.87-2
118- rebuild with clamav-0.93.
119
120* Mon Apr 14 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.87-1
121- rebuilt with VineSeed.
122
123* Sat Mar  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.87-0vl1
124- new upstream release.
125
126* Sun Mar 11 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.85-0vl2
127- built with clamav-0.90.1.
128
129* Mon Feb 26 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.85-0vl1
130- new upstream release.
131
132* Thu Oct 19 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.82-0vl1
133- new upstream release.
134
135* Thu Jul 20 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.81-0vl1
136- initial build.
Note: See TracBrowser for help on using the repository browser.