source: projects/specs/branches/6/h/hal/hal-vl.spec @ 2387

Revision 2387, 19.0 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%define expat_version           1.95.5
2%define glib2_version           2.20.0
3%define dbus_version            1.2
4%define dbus_glib_version       0.80
5%define dbus_python_version     0.80
6%define pygtk2_version          2.8.0
7%define gnome_python            2.14.0
8%define udev_version            145
9%define util_linux_ng_version   2.14
10%define gettext_version         0.14.5
11%define libusb_version          0.1.10a
12%define consolekit_version      0.3.0
13%define acl_version             2.2.39
14%define policykit_version       0.9
15%define pciutils_version        2.2.1
16%define dmidecode_version       2.7
17%define gperf_version           3.0.1
18# %define parted_version                1.8.8
19%define parted_version          2.3
20
21%define hal_user_uid           68
22
23%define _localstatedir %{_var}
24
25Summary: Hardware Abstraction Layer
26Summary(ja): ハードウエア抽象化レイヤ
27Name: hal
28Version: 0.5.14
29Release: 1%{?_dist_release}
30
31Group: System Environment/Libraries
32URL: http://www.freedesktop.org/Software/hal
33License: AFL/GPL
34
35Source0: %{name}-%{version}.tar.bz2
36
37Patch2: hal-0.5.11-change-priority.patch
38
39# https://bugzilla.redhat.com/show_bug.cgi?id=488177
40Patch4: hal-remove-dell-killswitch.patch
41
42# http://lists.freedesktop.org/archives/hal/2009-March/013125.html
43Patch9: hal-KVM-evdev.patch
44
45# http://bugs.freedesktop.org/show_bug.cgi?id=22442
46Patch11: hal-HDAPS-blacklist.patch
47
48Patch100: hal-use-at-console.patch
49
50Patch200: hal-0.5.13-disable-keyboard-hotplug.patch
51
52BuildRoot: %{_tmppath}/%{name}-%{version}-root
53BuildRequires: expat-devel >= %{expat_version}
54BuildRequires: glib2-devel >= %{glib2_version}
55BuildRequires: dbus-devel  >= %{dbus_version}
56BuildRequires: python-devel
57BuildRequires: hwdata
58BuildRequires: gettext >= %{gettext_version}
59%ifnarch s390 s390x
60BuildRequires: libusb-devel >= %{libusb_version}
61%endif
62BuildRequires: desktop-file-utils >= 0.9
63BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
64BuildRequires: pciutils-devel >= %{pciutils_version}
65BuildRequires: zlib-devel
66BuildRequires: gperf >= %{gperf_version}
67BuildRequires: parted-devel >= %{parted_version}
68BuildRequires: e2fsprogs-devel
69BuildRequires: libblkid-devel
70BuildRequires: libuuid-devel
71
72Requires: dbus >= %{dbus_version}
73Requires: dbus-glib >= %{dbus_glib_version}
74Requires: glib2 >= %{glib2_version}
75Requires: udev >= %{udev_version}
76Requires: util-linux-ng >= %{util_linux_ng_version}
77%ifnarch s390 s390x
78Requires: libusb >= %{libusb_version}
79%endif
80Requires: ConsoleKit >= %{consolekit_version}
81Requires: acl >= %{acl_version}
82Requires: hal-info
83Requires(pre): shadow-utils
84Requires(post): chkconfig
85Requires(preun): chkconfig, initscripts
86
87Obsoletes: hal-gnome
88
89%description
90HAL is daemon for collection and maintaining information from several
91sources about the hardware on the system. It provdes a live device
92list through D-BUS.
93
94%package gnome
95Summary: GNOME based device manager for HAL
96Group: Applications/System
97Requires: %name = %{version}-%{release}
98Requires: dbus-python >= %{dbus_python_version}
99Requires: pygtk2 >= %{pygtk2_version}
100Requires: pygtk2-libglade >= %{pygtk2_version}
101Requires: gnome-python >= %{gnome_python}
102
103%description gnome
104GNOME program for displaying the devices detected by HAL
105
106
107%package devel
108Summary: Libraries and headers for HAL
109Group: Development/Libraries
110Requires: %{name} = %{version}-%{release}
111Requires: dbus-devel >= %{dbus_version}
112
113%description devel
114Headers, static libraries and API docs for HAL.
115
116
117%prep
118%setup -q -n %{name}-%{version}
119%patch2 -p1 -b .priority
120
121%patch4 -p1 -b .dell-killswitch
122%patch9 -p1 -b .kvm-evdev
123%patch11 -p1 -b .hdaps-blacklist
124
125%patch100 -p1 -b .drop-polkit
126
127%patch200 -p1 -b .disable-keyboard-hotplug
128
129%build
130
131autoreconf -f -i
132
133%configure \
134        --with-os-type=redhat \
135        --docdir=%{_docdir}/%{name}-%{version} \
136        --with-udev-prefix=/etc \
137        --disable-docbook-docs \
138        --enable-pcmcia-support \
139        --enable-umount-helper \
140        --disable-console-kit \
141        --disable-policy-kit \
142        --disable-acpi-ibm \
143        --disable-smbios \
144        --enable-parted \
145        --enable-acpi-toshiba \
146        --without-usb-csr \
147        --without-cpufreq \
148        --with-eject=/usr/sbin/eject
149
150%__make %{?_smp_mflags}
151
152
153%install
154rm -rf %{buildroot}
155make install DESTDIR=$RPM_BUILD_ROOT
156
157rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
158
159
160%clean
161rm -rf $RPM_BUILD_ROOT
162
163
164%pre
165# Add the "haldaemon" user
166/usr/sbin/useradd -c 'HAL daemon' -u %{hal_user_uid} \
167        -s /sbin/nologin -r -d '/' haldaemon 2> /dev/null || :
168
169%post
170/sbin/ldconfig
171/sbin/chkconfig --add haldaemon
172
173
174%preun
175if [ $1 = 0 ]; then
176    service haldaemon stop > /dev/null 2>&1
177    /sbin/chkconfig --del haldaemon
178fi
179
180
181%postun
182/sbin/ldconfig
183#if [ "$1" -ge "1" ]; then
184#  service haldaemon condrestart > /dev/null 2>&1
185#fi
186
187
188%triggerpostun -- hal < 0.5.7
189#remove lingering fstab-sync entries from /etc/fstab
190/bin/cp -f /etc/fstab /etc/fstab.hal-save
191(IFS="
192"; while read line; do echo $line | awk '{print $4}' | grep -q managed || echo $line | grep -q "^#.*fstab-sync" || echo $line; done < /etc/fstab > fstab.replace)
193
194if [ -s fstab.replace ]; then
195  /bin/cp -f fstab.replace /etc/fstab
196fi
197
198%triggerpostun -- hal < 0.5.11-3
199# reset priorities
200if [ -f /etc/rc3.d/S98haldaemon ]; then
201  /sbin/chkconfig haldaemon resetpriorities
202fi
203
204
205%files
206%defattr(-,root,root,-)
207%doc AUTHORS COPYING ChangeLog HACKING INSTALL README NEWS
208#doc examples
209
210%dir %{_sysconfdir}/dbus-1/system.d
211%{_sysconfdir}/dbus-1/system.d/*
212
213%config %{_sysconfdir}/rc.d/init.d/haldaemon
214
215%dir %{_sysconfdir}/hal
216%{_sysconfdir}/hal/*
217
218/sbin/umount.hal
219%{_sbindir}/hald
220%{_bindir}/*
221
222%{_libexecdir}/*
223
224%{_libdir}/*hal*.so.*
225
226%dir %{_datadir}/hal
227%dir %{_datadir}/hal/fdi
228%{_datadir}/hal/fdi/*
229
230%{_mandir}/man1/*
231%{_mandir}/man8/*
232
233%{_sysconfdir}/udev/rules.d/90-hal.rules
234
235%attr(0700,haldaemon,haldaemon) %dir %{_localstatedir}/cache/hald
236%attr(0700,haldaemon,haldaemon) %dir %{_localstatedir}/run/hald
237
238
239%files devel
240%defattr(-,root,root)
241%{_libdir}/lib*.so
242%{_libdir}/pkgconfig/*
243%{_includedir}/*
244%{_datadir}/gtk-doc/html/*
245
246#%files gnome
247#%defattr(-,root,root)
248#%dir %{_datadir}/hal/device-manager
249#%{_datadir}/hal/device-manager/*
250#%{_bindir}/hal-device-manager
251#%{_datadir}/applications/*.desktop
252
253
254%changelog
255* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.14-1
256- update to 0.5.14
257- delete Patch12 (hal-mdfind.patch)
258
259* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.13-6
260- add BuildRequires: zlib-devel
261
262* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.5.13-5
263- rebuilt with parted 2.3
264
265* Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.13-4
266- rebuilt with rpm-4.8.1 for pkg-config
267
268* Mon Feb 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.13-3
269- add BuildRequires: libuuid-devel
270
271* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 0.5.13-2
272- rebuilt with python-2.6.4-3
273
274* Wed Oct 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.13-1
275- new upstream release
276- merge patches from fedora
277- disable ConsoleKit and PolicyKit support
278- disable acl management, this is now handled by udev
279- disable csr,ibm and cpufreq which is obsolete.
280
281* Sat Oct 03 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5.12-2.rc1
282- add patch11 to disable acl for unpartitioned volumes (such as audio CDs)
283  ([vine-users:079605])
284
285* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5.12-1.rc1
286- added BuildRequires: e2fsprogs-devel
287
288* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.12-0.rc1
289- update to 0.5.12rc1
290- add patch5 to allow introspection and Device.KillSwitch access
291  https://bugs.freedesktop.org/show_bug.cgi?id=18985
292
293* Wed Dec 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-6
294- rebuild with udev-135-1
295
296* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-5
297- add 10-x11-input.fdi again
298- add patch10 to disable x11 keyaboard hotplugging
299
300* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-4
301- rebuild with parted-1.8.8
302- add BuildRequires: util-linux-ng instead of util-linux
303
304* Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-3
305- rebuild with new ConsoleKit/PolicyKit
306- change start/stop priority earlier
307
308* Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.11-2
309- spec in UTF-8
310- Drop 99-redhat-storage-policy-fixed-drives.fdi; this is now
311  controlled by PolicyKit
312- Remove /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi which
313  effectively disables xorg input hotplugging again: this is only a
314  temporary workaround until a better solution is available
315  (see: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=447666)
316
317* Sat May 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.11-1
318- updated to 0.5.11
319- drop gnome subpackage - obsoleted in the upstream
320  (but separated into gnome-desktop-manager)
321- drop use of find_lang - all translations dropped in the upstream
322
323* Sat Mar 08 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5.9-0vl5
324- add Patch1001 to get proper LCD max brightness with pcc-acpi.
325
326* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.9-0vl4
327- rebuild with expat-2.0.1
328- add BuildRequires: dbus-glib-devel >= %%{dbus_glib_version}
329- update %%{SOURCE2} (drop extension from Icon entry)
330
331* Thu Oct 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.5.9-0vl3
332- add Patch600 to fix severe memory leak on the system with apm
333  initially discussed at:
334    https://bugzilla.redhat.com/show_bug.cgi?id=244995
335  then more comprehensive fixes posted at:
336    http://lists.freedesktop.org/archives/hal/2007-September/009642.html
337
338* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.9-0vl2
339- add Requires: hal-info
340
341* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.9-0vl1
342- new upstream release
343- add Patch1000 to revert kernel-2.6.17 specific changes
344
345* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl4
346- rebuild with dbus-1.0
347
348* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.7.1-0vl3
349- changed hal-gnome Group to Applications/System
350
351* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl2
352- add Patch10 to detecting usb optical drives
353  (https://bugs.freedesktop.org/show_bug.cgi?id=5558)
354
355* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl1
356- new upstream release
357- add Patch1 to fix confusing lid state. (<BTS:0091>)
358
359* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl3
360- add Source1 for workaround policy file to ignore fixed
361  (non-hotpluggable) disk from FC.
362
363* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
364- do not restart haldaemon in %%postun script
365
366* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
367- new upstream release
368- disable fstab-sync, clear fstab-sync entries from fstab
369- import changes from FC
370
371* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
372- remove Requires: gnome-python-* from hal-gnome
373  gnome-python sub packages are obsoleted.
374
375* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
376- new upstream release
377
378* Wed Jul 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.3-0vl1
379- new upstream release
380- add Requires: pygtk2-libglade for hal-gnome
381
382* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
383- new upstream release
384- import patches from FC
385
386* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.7-2vl1
387- initiual build for Vine Linux based on FC package.
388
389* Thu Jan 27 2005 David Zeuthen <davidz@redhat.com> 0.4.7-2
390- Add patch that should close #146316
391
392* Mon Jan 24 2005 David Zeuthen <davidz@redhat.com> 0.4.7-1
393- New upstream release.
394- Should close #145921, #145750, #145293, #145256
395
396* Mon Jan 24 2005 John (J5) Palmieri <johnp@redhat.com> 0.4.6-3
397- Update required dbus version to 0.23
398
399* Thu Jan 20 2005 David Zeuthen <davidz@redhat.com> 0.4.6-2
400- Fix parameters to configure
401
402* Thu Jan 20 2005 David Zeuthen <davidz@redhat.com> 0.4.6-1
403- New upstream release
404- Should close #145099, #144600, #140150, #145223, #137672
405
406* Wed Jan 12 2005 David Zeuthen <davidz@redhat.com> 0.4.5-1
407- New upstream release.
408- Should close #142834, #141771, #142183
409
410* Fri Dec 12 2004 David Zeuthen <davidz@redhat.com> 0.4.2.cvs20041210-1
411- Snapshot from stable branch of upstream CVS
412
413* Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-8
414- Forgot to add some diffs in hal-0.4.0-pcmcia-net-support.patch
415
416* Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-7
417- Change default policy such that non-hotpluggable fixed disks are not
418  added to the /etc/fstab file because a) ATARAID detection in hal is
419  incomplete (e.g. RAID members from ATARAID controllers might be added
420  to /etc/fstab); and b) default install wont corrupt multiboot
421  systems on fixed drives (#137072)
422
423* Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-6
424- Fix hotplug timeout handling (#136626)
425- Detect ATARAID devices and do not add /etc/fstab entry for them
426- Probe for ext3 before ntfs (#136966)
427- Use fstype 'auto' for optical drives instead of 'iso9660,udf'
428- Properly detect wireless ethernet devices  (#136591)
429- Support 16-bit PCMCIA networking devices (by Dan Williams) (#136658)
430
431* Tue Oct 19 2004 David Zeuthen <davidz@redhat.com> 0.4.0-5
432- Make hal work with PCMCIA IDE hotpluggable devices (#133943)
433- Fixup URL listed from rpm -qi (#136396)
434- Add Portuguese translations for hal
435- Fix addition of Russian and Hungarian translations
436
437* Mon Oct 18 2004 David Zeuthen <davidz@redhat.com> 0.4.0-4
438- Make hald cope with missing hotplug events from buggy drivers (#135202)
439- Fix the order of mount options in fstab-sync (#136191)
440- Allow x86 legacy floppy drives in default policy (#133777)
441- Fix fstab-sync crashing without any options and not run from hald (#136214)
442- man page for fstab-sync references non-existing files (#136026)
443- Add Russian translations for hal (#135853)
444- Add Hungarian translations for hal
445
446* Fri Oct 15 2004 David Zeuthen <davidz@redhat.com> 0.4.0-3
447- Fix bad use of O_NONBLOCK as the 2.6.8-1.624 kernel exposes this (#135886)
448- Never use the UUID as mount point candidate in the default policy
449  as it is unfriendly (#135907)
450- Fix a trivial bug in fstab-sync so the syslog messages actually expose
451  the device name instead of just the word foo
452
453* Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-2
454- Fix issue with fstab-sync not cleaning /etc/fstab on startup
455
456* Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-1
457- Update to upstream stable version 0.4.0
458- Remove patch for libhal shutdown since that is now upstream
459- fstab-sync: man page, adds comment in /etc/fstab pointing to man page
460
461* Fri Oct 01 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-3
462- Fix a bug so libhal actually invoke callback functions when needed
463
464* Fri Oct 01 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.98.cvs20040929-2
465- Use "user" mount flag for now until "pamconsole" flag gets into mount
466
467* Wed Sep 29 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-1
468- Update to upstream CVS version
469- Enable libselinux again
470
471* Mon Sep 27 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040927-1
472- Update to upstream CVS version
473
474* Fri Sep 24 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040923-1
475- Update to upstream CVS release
476- Include libhal-storage library
477- Should close bug #132876
478
479* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-4
480- Rebuilt
481
482* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-3
483- Rebuilt
484
485* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-2
486- Temporarily disable explicit requirement for libselinux
487
488* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-1
489- Update to upstream release 0.2.98.
490- Use --with-pid-file so we don't depend on /etc/redhat-release
491
492* Wed Sep 01 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040901-1
493- Update to upstream CVS HEAD
494
495* Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-3
496- Add UID for haldaemon user
497
498* Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-2
499- Rebuilt with a newer snapshot.
500
501* Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-3
502- Rebuilt
503
504* Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-2
505- Rebuilt
506- Closes RH Bug #130971
507
508* Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-1
509- Update to upstream CVS HEAD.
510- Should close RH Bug #130588
511
512* Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-3
513- Rebuilt
514
515* Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-2
516- Apply a patch so hald doesn't hang on startup.
517
518* Mon Aug 23 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-1
519- Update to upstream CVS HEAD
520- Remove symlinking of fstab-sync from specfile since this is now being
521  done in the package
522
523* Mon Aug 23 2004 Florian La Roche <Florian.LaRoche@redhat.de>
524- change the %%define names to not use "-"
525
526* Thu Aug 19 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040819-1
527- Update to upstream CVS HEAD
528- Remove suid patch as it is fixed upstream
529- Fix some dependency issues (RH Bug #130202)
530
531* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.97-2
532- Add stopgap patch to remove suid from mount flags (RH Bug #130290)
533
534* Mon Aug 16 2004 David Zeuthen <davidz@redhat.com> 0.2.97-1
535- update to upstream release 0.2.97
536- use kudzu option in fstab-sync since updfstab is now disabled
537
538* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.96-2
539- fixed Requires lines to use %{} instead of ${}
540- made dbus related requires lines use the = condition instead of =<
541  because the dbus API is still in flux
542
543* Thu Aug 12 2004 David Zeuthen <davidz@redhat.com> 0.2.96
544- Update to upstream release 0.2.96
545- Symlink fstab-sync into /etc/hal/device.d on install
546
547* Fri Aug 06 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-2
548- Base hal package no longer requires python
549
550* Mon Aug 02 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-1
551- Update to CVS head
552- Remove Dan's patches as they were commited to CVS
553
554* Fri Jul 30 2004 Dan Williams <dcbw@redhat.com> 0.2.93.cvs.20040712-2
555- Fix netlink sockets pointer arithmetic bug
556
557* Mon Jul 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.93.cvs.20040712-1
558- Update to new CVS version as of 7-12-2004
559
560* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-2
561- take out fstab-update.sh from install
562- add to rawhide
563 
564* Fri Jun 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-1
565- update to CVS head as of 6-11-2004 which contains dcbw's
566  network link status fix
567
568* Wed Jun 9 2004 Ray Strode <rstrode@redhat.com> 0.2.91.cvs20040527-2
569- added dependency on udev
570
571* Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.91.cvs20040527-1
572- update to CVS head as of 5-27-2004 which contains fixes for PCMCIA
573  and wireless network devices.
574
575* Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-3
576- added hal-0.2.90.cvs20040511.callbackscripts.patch which installs
577  the file system mounting script in /etc/hal/device.d
578
579* Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-2
580- added the %{_sysconfigdir}/hal directory tree to %files
581
582* Tue May 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-1
583- update to CVS head as of 5-11-2004
584
585* Wed May 5 2004 Christopher Blizzard <blizzard@redhat.com> 0.2.90-2
586- Install hal.dev from /etc/dev.d/default/
587
588* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90-1
589- upstream update
590
591* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2-1
592- initial checkin to package repository
593- added dependency to the dbus-python package
594- added %{_libexecdir}/hal.dev to teh %files section
Note: See TracBrowser for help on using the repository browser.