source: projects/specs/branches/6/g/guile/guile-vl.spec @ 2013

Revision 2013, 11.6 KB checked in by inagaki, 14 years ago (diff)

update: guile

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define mver 1.8
3
4Name: guile
5Summary: A GNU implementation of Scheme for application extensibility.
6Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
7Version: 1.8.7
8Release: 2%{?_dist_release}
9
10Group: Development/Languages
11License: GPLv2+ and LGPLv2+ and GFDL and OFSFDL
12URL: http://www.gnu.org/software/guile/
13
14Source: ftp://ftp.gnu.org/gnu/guile-%{version}.tar.gz
15
16# following patchs are imported from fedora-dev
17Patch1: guile-1.8.7-multilib.patch
18Patch2: guile-1.8.7-testsuite.patch
19Patch3: guile-1.8.7-ia64jmp.patch
20Patch4: guile-1.8.6-deplibs.patch
21Patch5: guile-1.8.7-linemarkers.patch
22Patch6: guile-1.8.7-testsuite2.patch
23
24Buildroot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: libtool libtool-ltdl-devel >= 2.2.6a
26BuildRequires: gmp-devel readline-devel emacs
27Requires(post): /sbin/install-info
28Requires(preun): /sbin/install-info
29Requires: coreutils
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33Packager:       yasumichi
34
35%description
36GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
37implementation of the Scheme programming language, written in C.  GUILE
38provides a machine-independent execution platform that can be linked in
39as a library during the building of extensible programs.
40
41Install the guile package if you'd like to add extensibility to programs
42that you are developing.
43
44%package devel
45Summary: Libraries and header files for the GUILE extensibility library.
46Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
49Requires: gmp-devel
50
51%description devel
52The guile-devel package includes the libraries, header files, etc.,
53that you'll need to develop applications that are linked with the
54GUILE extensibility library.
55
56You need to install the guile-devel package if you want to develop
57applications that will be linked to GUILE.  You'll also need to
58install the guile package.
59
60%package -n compat32-%{name}
61Summary: A GNU implementation of Scheme for application extensibility.
62Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
63Group: Development/Languages
64Requires: %{name} = %{version}-%{release}
65
66%description -n compat32-%{name}
67GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
68implementation of the Scheme programming language, written in C.  GUILE
69provides a machine-independent execution platform that can be linked in
70as a library during the building of extensible programs.
71
72Install the guile package if you'd like to add extensibility to programs
73that you are developing.
74
75%package -n compat32-%{name}-devel
76Summary: Libraries and header files for the GUILE extensibility library.
77Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
78Group: Development/Libraries
79Requires: %{name}-devel = %{version}-%{release}
80Requires: compat32-%{name} = %{version}-%{release}
81Requires: compat32-gmp-devel
82
83%description -n compat32-%{name}-devel
84The guile-devel package includes the libraries, header files, etc.,
85that you'll need to develop applications that are linked with the
86GUILE extensibility library.
87
88You need to install the guile-devel package if you want to develop
89applications that will be linked to GUILE.  You'll also need to
90install the guile package.
91
92%prep
93%setup -q
94%patch1 -p1 -b .multilib
95%patch2 -p1 -b .testsuite
96%patch3 -p1 -b .ia64jmp
97%patch4 -p1 -b .deplibs
98%patch5 -p1 -b .linemarkers
99%patch6 -p1 -b .testsuite2
100
101%build
102%configure --disable-static --disable-error-on-warning
103
104# Remove RPATH
105sed -i 's|" $sys_lib_dlsearch_path "|" $sys_lib_dlsearch_path %{_libdir} "|' \
106    {,guile-readline/}libtool
107
108make %{?_smp_mflags}
109
110
111%install
112rm -rf $RPM_BUILD_ROOT
113
114make DESTDIR=$RPM_BUILD_ROOT install
115
116mkdir -p $RPM_BUILD_ROOT%{_datadir}/guile/site
117
118rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.la
119rm -f $RPM_BUILD_ROOT%{_infodir}/dir
120
121# Compress large documentation
122bzip2 NEWS
123
124for i in ${RPM_BUILD_ROOT}%{_infodir}/goops.info; do
125    iconv -f iso8859-1 -t utf-8 < $i > $i.utf8 && mv -f ${i}{.utf8,}
126done
127
128touch $RPM_BUILD_ROOT%{_datadir}/guile/%{mver}/slibcat
129ln -s ../../slib $RPM_BUILD_ROOT%{_datadir}/guile/%{mver}/slib
130
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%post
136/sbin/ldconfig
137/sbin/install-info  %{_infodir}/guile.info.gz %{_infodir}/dir
138/sbin/install-info  %{_infodir}/r5rs.info.gz %{_infodir}/dir
139/sbin/install-info  %{_infodir}/goops.info.gz %{_infodir}/dir
140/sbin/install-info  %{_infodir}/guile-tut.info.gz %{_infodir}/dir
141
142%postun -p /sbin/ldconfig
143
144%preun
145if [ "$1" = 0 ]; then
146    /sbin/install-info --delete %{_infodir}/guile.info.gz %{_infodir}/dir
147    /sbin/install-info --delete %{_infodir}/r5rs.info.gz %{_infodir}/dir
148    /sbin/install-info --delete %{_infodir}/goops.info.gz %{_infodir}/dir
149    /sbin/install-info --delete %{_infodir}/guile-tut.info.gz %{_infodir}/dir
150fi
151:
152
153%post -n compat32-%{name} -p /sbin/ldconfig
154
155%postun -n compat32-%{name} -p /sbin/ldconfig
156
157%files
158%defattr(-,root,root,-)
159%doc AUTHORS COPYING* ChangeLog HACKING NEWS.bz2 README THANKS
160%{_bindir}/guile
161%{_bindir}/guile-tools
162%{_libdir}/libguile*.so.*
163%{_libdir}/libguilereadline-*.so
164%{_libdir}/libguile-srfi-srfi-*.so
165%dir %{_datadir}/guile
166%dir %{_datadir}/guile/%{mver}
167%{_datadir}/guile/%{mver}/ice-9
168%{_datadir}/guile/%{mver}/lang
169%{_datadir}/guile/%{mver}/oop
170%{_datadir}/guile/%{mver}/scripts
171%{_datadir}/guile/%{mver}/srfi
172%{_datadir}/guile/%{mver}/guile-procedures.txt
173%ghost %{_datadir}/guile/%{mver}/slibcat
174%ghost %{_datadir}/guile/%{mver}/slib
175%dir %{_datadir}/guile/site
176%dir %{_datadir}/emacs/site-lisp
177%{_datadir}/emacs/site-lisp/*.el
178%{_infodir}/*
179%{_mandir}/man1/guile.1*
180
181%files devel
182%defattr(-,root,root,-)
183%{_bindir}/guile-config
184%{_bindir}/guile-snarf
185%{_datadir}/aclocal/*
186%{_libdir}/libguile.so
187%{_libdir}/pkgconfig/*.pc
188%{_includedir}/guile
189%{_includedir}/libguile
190%{_includedir}/libguile.h
191
192# compat32
193%if %{build_compat32}
194%files -n compat32-%{name}
195%defattr(-,root,root,-)
196%{_libdir}/libguile*.so.*
197%{_libdir}/libguilereadline-*.so
198%{_libdir}/libguile-srfi-srfi-*.so
199
200%files -n compat32-%{name}-devel
201%defattr(-,root,root,-)
202%{_libdir}/libguile.so
203%{_libdir}/pkgconfig/*.pc
204%endif
205
206%changelog
207* Sat Oct 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-2
208- rebuilt with rpm-4.8.1
209- added Patch1, 2, 3, 5 and 6 from Fedora
210
211* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.8.7-1
212- new upstream release.
213- comment out Patch11,12.
214
215* Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-4
216- added Requires: gmp-devel to guile-devel
217
218* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-3
219- added compat32 package for x86_64 arch support
220
221* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-2
222- rebuild with libtool-2.2.6a
223
224* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.6-1
225- new upstream release
226- import some patches from fedora development
227- drop some old patches
228- update spec based on fedora package
229- spec in utf-8
230
231* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-6vl5
232- use macro for Release
233
234* Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-5vl5
235- apply new virsioning policy.
236- remove *.la
237
238* Sun Apr 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl2
239- rebuilt with readline 5.1
240
241* Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl1
242- added Patches from Fedora
243  * Fri Sep 02 2005 Phil Knirsch <pknirsch@redhat.com> 5:1.6.7-4
244  - Fix dynamic linking on 64bit archs (#159971)
245  * Tue Dec 21 2004 Phil Knirsch <pknirsch@redhat.com> 5:1.6.4-16
246  - Moved info files to base package as they are not devel related (#139948)
247  - Moved static guilereadline and guile-srfi-srfi libs to devel package (#140893)
248  - Fixed guile-tools not finding guile lib dir (#142642)
249  - Added some nice tools (#142642)
250  - Removed smp build, seems to be broken atm
251
252* Fri Jan  7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-0vl1
253- new upstream release
254- dropped patch2, 4, 6
255- added BuildPrereq: perl
256
257* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl2
258- rebuild with new toolchains
259- s/Copyright/License/
260- added srfi libs
261- patch for ppc64 from Fedora package
262
263* Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl1
264- update to 1.6.4
265
266* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.6.3-0vl3
267- rebuild with readline-4.3
268
269* Thu Feb 13 2003 Ryoichi INAGAKI <ryo1i@bc.wakwak.com> 1.6.3-0vl2
270- based on Rawhide 1.6.0-4
271  - Included s390 as working arch as well, switch to general unknown arch patch
272  - rebuild to fix broken deps
273  - fix continuations.h on ia64
274- new upstream 1.6.3
275
276* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.3.4-9vl1
277- porting for Vine Linux
278- remove 1.3 patches( not required  so that upstream upgrade )
279
280* Fri Jul 14 2000 Nalin Dahyabhai <nalin@redhat.com>
281- Add version number to prereq for umb-scheme to get the post-install to
282  work properly.
283
284* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
285- Add an Epoch = 1 in case anyone happened to have 1.4 installed.
286
287* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
288- automatic rebuild
289
290* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
291- Back down to 1.3.4.
292- Fix to actually link against the version of libguile in the package.
293
294* Sun Jun  4 2000 Nalin Dahyabhai <nalin@redhat.com>
295- FHS fixups using the %%{makeinstall} macro.
296
297* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
298- fix preun-devel
299- call ldconfig directly in postun
300
301* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
302- rebuild with new readline
303- update to 1.3.4
304
305* Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
306- using the same catalog as umb-scheme makes umb-scheme a prereq
307
308* Thu Feb 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
309- readline is needed for %post
310
311* Tue Feb  8 2000 Nalin Dahyabhai <nalin@redhat.com>
312- use the same catalog as umb-scheme
313
314* Thu Sep  2 1999 Jeff Johnson <jbj@redhat.com>
315- fix broken %postun
316
317* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
318- auto rebuild in the new build environment (release 6)
319
320* Wed Mar 17 1999 Michael Johnson <johnsonm@redhat.com>
321- added .ansi patch to fix #endif
322
323* Wed Feb 10 1999 Cristian Gafton <gafton@redhat.com>
324- add patch for the scm stuff
325
326* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
327- integrate changes from rhcn version (#640)
328
329* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
330- call libtoolize first to get it to compile on the arm
331
332* Sat Jan  9 1999 Todd Larason <jtl@molehill.org>
333- Added "Requires: guile" at suggestion of Manu Rouat <emmanuel.rouat@wanadoo.fr>
334
335* Fri Jan  1 1999 Todd Larason <jtl@molehill.org>
336- guile-devel does depend on guile
337- remove devel dependancy on m4
338- move guile-snarf from guile to guile-devel
339- Converted to rhcn
340
341* Wed Oct 21 1998 Jeff Johnson <jbj@redhat.com>
342- update to 1.3.
343- don't strip libguile.so.*.0.0. (but set the execute bits).
344
345* Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
346- spec file fixups
347
348* Wed Sep  2 1998 Michael Fulbright <msf@redhat.com>
349- Updated for RH 5.2
350
351* Mon Jan 26 1998 Marc Ewing <marc@redhat.com>
352- Started with spec from Tomasz Koczko <kloczek@idk.com.pl>
353- added slib link
354
355* Thu Sep 18 1997 Tomasz Koczko <kloczek@idk.com.pl>          (1.2-3)
356- added %attr(-, root, root) for %doc,
357- in %post, %postun ldconfig runed as parameter "-p",
358- removed /bin/sh from requires,
359- added %description,
360- changes in %files.
361
362* Fri Jul 11 1997 Tomasz Koczko <kloczek@rudy.mif.pg.gda.pl>  (1.2-2)
363- all rewrited for using Buildroot,
364- added %postun,
365- removed making buid logs,
366- removed "--inclededir", added "--enable-dynamic-linking" to configure
367  parameters,
368- added striping shared libs and /usr/bin/guile,
369- added "Requires: /bin/sh" (for guile-snarf) in guile package and
370  "Requires: m4" for guile-devel,
371- added macro %{PACKAGE_VERSION} in "Source:" and %files,
372- added %attr macros in %files.
Note: See TracBrowser for help on using the repository browser.