source: projects/specs/branches/6/g/gtkwave/gtkwave-vl.spec @ 1233

Revision 1233, 13.7 KB checked in by inagaki, 14 years ago (diff)

updated: gtkwave

Line 
1Summary:        Waveform Viewer
2Summary(ja):    波形ビューワ
3Name:           gtkwave
4Version:        3.3.7
5Release:        4%{?_dist_release}
6License:        GPLv2+
7Group:          Applications/Engineering
8URL:            http://gtkwave.sourceforge.net/
9Source0:        http://gtkwave.sourceforge.net/gtkwave-%{version}.tar.gz
10Source1:        gtkwave.desktop
11Source2:        gtkwave-16.png
12Source3:        gtkwave-32.png
13Source4:        gtkwave-48.png
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  gtk2-devel
17BuildRequires:  bzip2-devel
18BuildRequires:  Judy-devel
19%if %{?_dist_release} != "vl4" && %{?_dist_release} != "vl5"
20BuildRequires:  xz-devel
21%endif
22BuildRequires:  zlib-devel
23BuildRequires:  gperf
24BuildRequires:  flex
25BuildRequires:  desktop-file-utils
26
27BuildRequires:  tk
28BuildRequires:  tcl >= 8.4
29
30%description
31GTKWave is a waveform viewer that can view VCD files produced by most Verilog
32simulation tools, as well as LXT files produced by certain Verilog simulation
33tools.
34
35%prep
36%setup -q -n gtkwave-%{version}%{?prerel}
37%{__cp} -p .gtkwaverc gtkwaverc.sample
38
39%build
40%configure \
41    --disable-dependency-tracking \
42%if %{?_dist_release} == "vl4" || %{?_dist_release} == "vl5"
43    --disable-xz \
44%endif
45    --enable-judy
46
47make %{?_smp_mflags}
48
49%install
50%{__rm} -rf %{buildroot}
51make install \
52    DESTDIR=%{buildroot} \
53    pkgdatadir=%{_docdir}/gtkwave-%{version} \
54    INSTALL="%{__install} -p"
55
56# Icons and desktop entry
57/usr/bin/desktop-file-install --vendor "" \
58    --dir %{buildroot}%{_datadir}/applications \
59    %{SOURCE1}
60%{__install} -D -m 644 -p %{SOURCE2} %{buildroot}%{_datadir}/icons/hicolor/16x16/apps/gtkwave.png
61%{__install} -D -m 644 -p %{SOURCE3} %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/gtkwave.png
62%{__install} -D -m 644 -p %{SOURCE4} %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/gtkwave.png
63
64# Include extra docs
65for extradoc in \
66        gtkwaverc.sample \
67        ANALOG_README.TXT \
68        CHANGELOG.TXT \
69        GNU.TXT \
70        LICENSE.TXT \
71        MIT.TXT \
72        SYSTEMVERILOG_README.TXT
73do
74        %{__install} -p -m 644 ${extradoc} %{buildroot}%{_docdir}/gtkwave-%{version}/
75done
76
77%clean
78%{__rm} -rf %{buildroot}
79
80%post
81touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
82
83%postun
84if [ $1 -eq 0 ] ; then
85        touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
86        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
87fi
88
89%posttrans
90gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
91
92%files
93%defattr(-,root,root,-)
94%doc %{_docdir}/gtkwave-%{version}/
95%{_bindir}/evcd2vcd
96%{_bindir}/fst2vcd
97%{_bindir}/ghwdump
98%{_bindir}/gtkwave
99%{_bindir}/lxt2miner
100%{_bindir}/lxt2vcd
101%{_bindir}/rtlbrowse
102%{_bindir}/shmidcat
103%{_bindir}/twinwave
104%{_bindir}/vcd2fst
105%{_bindir}/vcd2lxt
106%{_bindir}/vcd2lxt2
107%{_bindir}/vcd2vzt
108%{_bindir}/vermin
109%{_bindir}/vzt2vcd
110%{_bindir}/vztminer
111%{_datadir}/applications/gtkwave.desktop
112%{_datadir}/icons/hicolor/16x16/apps/gtkwave.png
113%{_datadir}/icons/hicolor/32x32/apps/gtkwave.png
114%{_datadir}/icons/hicolor/48x48/apps/gtkwave.png
115%{_mandir}/man1/evcd2vcd.1*
116%{_mandir}/man1/fst2vcd.1*
117%{_mandir}/man1/ghwdump.1*
118%{_mandir}/man1/gtkwave.1*
119%{_mandir}/man1/lxt2miner.1*
120%{_mandir}/man1/lxt2vcd.1*
121%{_mandir}/man1/rtlbrowse.1*
122%{_mandir}/man1/shmidcat.1*
123%{_mandir}/man1/twinwave.1*
124%{_mandir}/man1/vcd2fst.1*
125%{_mandir}/man1/vcd2lxt.1*
126%{_mandir}/man1/vcd2lxt2.1*
127%{_mandir}/man1/vcd2vzt.1*
128%{_mandir}/man1/vermin.1*
129%{_mandir}/man1/vzt2vcd.1*
130%{_mandir}/man1/vztminer.1*
131%{_mandir}/man5/gtkwaverc.5*
132
133%changelog
134* Tue Jun 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-4
135- BR: tk instead of /usr/include/tcl.h /usr/include/tk.h
136  (Thanks to takemikaduchi-san)
137
138* Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-3
139- added --disable-xz at Vine Linux 5
140
141* Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-2
142- Initial build for Vine Linux
143
144* Sun Jun  6 2010 Paul Howarth <paul@city-fan.org> 3.3.7-1
145- update to 3.3.7 (general bug and compiler warning fixes)
146- -n option not needed in desktop file
147
148* Tue May  4 2010 Paul Howarth <paul@city-fan.org> 3.3.6-1
149- update to 3.3.6 (see CHANGELOG.TXT for details)
150- add desktop file and icons based on Mandriva package
151- BR: desktop-file-utils
152- add scriptlets to update icon cache
153- no longer need to fix permissions of lzma wrapper code
154
155* Sat Mar 20 2010 Paul Howarth <paul@city-fan.org> 3.3.5-1
156- update to 3.3.5 (see CHANGELOG.TXT for details)
157- add Judy-devel buildreq for improved memory usage efficiency
158
159* Mon Mar  8 2010 Paul Howarth <paul@city-fan.org> 3.3.4-1
160- update to 3.3.4 (see CHANGELOG.TXT for details)
161
162* Fri Feb 19 2010 Paul Howarth <paul@city-fan.org> 3.3.3-1
163- update to 3.3.3
164- drop upstreamed dlopen linking patch
165- drop obsolete helper apps mvl2lxt, mvl2vcd, tex2vcd and tla2vcd
166
167* Mon Feb 15 2010 Paul Howarth <paul@city-fan.org> 3.3.2-2
168- fix FTBFS due to missing -ldl linking for dlopen function (#565173)
169
170* Tue Jan  5 2010 Paul Howarth <paul@city-fan.org> 3.3.2-1
171- update to 3.3.2 (speed up operation on networked filesystems)
172
173* Sat Dec 26 2009 Paul Howarth <paul@city-fan.org> 3.3.0-1
174- update to 3.3.0
175- added tk support
176- bundled old liblzma replaced by system xz (add BR: xz-devel)
177- tcl/tk support require Fedora >= 2 or RHEL >= 4 (tcl 8.4)
178
179* Fri Sep  4 2009 Paul Howarth <paul@city-fan.org> 3.2.3-1
180- update to 3.2.3
181- fix permissions in bundled liblzma for debuginfo
182
183* Thu Aug  6 2009 Paul Howarth <paul@city-fan.org> 3.2.2-3
184- drop patch for #515672, not needed with gcc 4.4.1-4
185
186* Thu Aug  6 2009 Paul Howarth <paul@city-fan.org> 3.2.2-2
187- add patch to work around #515672 (internal compiler error on PPC)
188
189* Wed Aug  5 2009 Paul Howarth <paul@city-fan.org> 3.2.2-1
190- update to 3.2.2 (new tools evcd2vcd/fst2vcd/vcd2fst)
191- drop print-to-file patch, no longer needed
192
193* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-2.1
194- rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
195
196* Wed Jul 15 2009 Paul Howarth <paul@city-fan.org> 3.2.1-2
197- add upstream patch for crash on print to file (#511858)
198
199* Tue Apr 14 2009 Paul Howarth <paul@city-fan.org> 3.2.1-1
200- update to 3.2.1
201
202* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 3.2.0-1.1
203- rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
204
205* Tue Feb 17 2009 Paul Howarth <paul@city-fan.org> 3.2.0-1
206- update to 3.2.0
207
208* Mon Feb  2 2009 Paul Howarth <paul@city-fan.org> 3.2.0-0.2.RC5
209- update to 3.2.0RC5
210
211* Fri Jan 29 2009 Paul Howarth <paul@city-fan.org> 3.2.0-0.1.RC4
212- update to 3.2.0RC4 (#481264)
213- new upstream URLs
214- buildreq /usr/include/tcl.h for embedded tcl support
215
216* Thu Aug 21 2008 Paul Howarth <paul@city-fan.org> 3.1.13-1
217- update to 3.1.13
218
219* Mon Jul 14 2008 Paul Howarth <paul@city-fan.org> 3.1.12-1
220- update to 3.1.12
221
222* Thu Jun 19 2008 Paul Howarth <paul@city-fan.org> 3.1.11-1
223- update to 3.1.11
224
225* Thu May 15 2008 Paul Howarth <paul@city-fan.org> 3.1.10-1
226- update to 3.1.10
227
228* Tue Apr 22 2008 Paul Howarth <paul@city-fan.org> 3.1.9-1
229- update to 3.1.9
230
231* Mon Apr  7 2008 Paul Howarth <paul@city-fan.org> 3.1.8-1
232- update to 3.1.8
233
234* Tue Mar 25 2008 Paul Howarth <paul@city-fan.org> 3.1.7-1
235- update to 3.1.7
236
237* Wed Feb 27 2008 Paul Howarth <paul@city-fan.org> 3.1.6-1
238- update to 3.1.6
239
240* Fri Feb  1 2008 Paul Howarth <paul@city-fan.org> 3.1.4-1
241- update to 3.1.4
242
243* Tue Jan 15 2008 Paul Howarth <paul@city-fan.org> 3.1.3-1
244- update to 3.1.3
245
246* Wed Jan  2 2008 Paul Howarth <paul@city-fan.org> 3.1.2-1
247- update to 3.1.2
248
249* Fri Sep 28 2007 Paul Howarth <paul@city-fan.org> 3.1.1-1
250- update to 3.1.1
251
252* Tue Sep  4 2007 Paul Howarth <paul@city-fan.org> 3.1.0-1
253- update to 3.1.0
254
255* Fri Aug 24 2007 Paul Howarth <paul@city-fan.org> 3.0.30-3
256- clarify license as GPL, version 2 or later
257
258* Fri Jul 27 2007 Paul Howarth <paul@city-fan.org> 3.0.30-1
259- update to 3.0.30
260
261* Fri Jun  8 2007 Paul Howarth <paul@city-fan.org> 3.0.29-1
262- update to 3.0.29
263- spec file much-simplified as gtkwave is now fully autotooled
264- try to retain upstream timestamps as far as possible
265- use parallel make
266
267* Tue May  1 2007 Paul Howarth <paul@city-fan.org> 3.0.28-1
268- update to 3.0.28
269- update source URL to master source
270
271* Mon Apr 30 2007 Paul Howarth <paul@city-fan.org> 3.0.27-1
272- update to 3.0.27
273- rename "vertex" to "vermin" to avoid conflict with Vertex 3D Model Assembler
274  (http://wolfpack.twu.net/Vertex/index.html)
275
276* Fri Apr 20 2007 Paul Howarth <paul@city-fan.org> 3.0.26-1
277- update to 3.0.26
278
279* Wed Apr 11 2007 Paul Howarth <paul@city-fan.org> 3.0.25-1
280- update to 3.0.25
281
282* Thu Apr  5 2007 Paul Howarth <paul@city-fan.org> 3.0.24-1
283- update to 3.0.24
284
285* Tue Mar 20 2007 Paul Howarth <paul@city-fan.org> 3.0.23-1
286- update to 3.0.23
287
288* Mon Feb 26 2007 Paul Howarth <paul@city-fan.org> 3.0.22-1
289- update to 3.0.22
290
291* Mon Feb  5 2007 Paul Howarth <paul@city-fan.org> 3.0.21-1
292- update to 3.0.21
293
294* Wed Jan 24 2007 Paul Howarth <paul@city-fan.org> 3.0.20-1
295- update to 3.0.20
296
297* Tue Jan  2 2007 Paul Howarth <paul@city-fan.org> 3.0.19-1
298- update to 3.0.19
299
300* Tue Dec  5 2006 Paul Howarth <paul@city-fan.org> 3.0.18-1
301- update to 3.0.18
302
303* Tue Nov 28 2006 Paul Howarth <paul@city-fan.org> 3.0.17-1
304- update to 3.0.17
305
306* Tue Nov 14 2006 Paul Howarth <paul@city-fan.org> 3.0.16-1
307- update to 3.0.16
308
309* Mon Oct 30 2006 Paul Howarth <paul@city-fan.org> 3.0.15-1
310- update to 3.0.15
311
312* Wed Oct 18 2006 Paul Howarth <paul@city-fan.org> 3.0.14-1
313- update to 3.0.14
314
315* Mon Oct  9 2006 Paul Howarth <paul@city-fan.org> 3.0.13-1
316- update to 3.0.13
317
318* Tue Oct  3 2006 Paul Howarth <paul@city-fan.org> 3.0.12-2
319- rebuilt for unwind info generation, broken in gcc-4.1.1-21
320
321* Fri Sep 22 2006 Paul Howarth <paul@city-fan.org> 3.0.12-1
322- update to 3.0.12
323- create dummy libz/libbz2 Makefile.in files to ensure that config.h gets
324  generated
325
326* Thu Sep 14 2006 Paul Howarth <paul@city-fan.org> 3.0.11-1
327- update to 3.0.11
328
329* Mon Aug 21 2006 Paul Howarth <paul@city-fan.org> 3.0.10-1
330- update to 3.0.10
331
332* Fri Aug 11 2006 Paul Howarth <paul@city-fan.org> 3.0.9-1
333- update to 3.0.9
334- tarball is now .tar.gz rather than .tgz
335
336* Mon Aug  7 2006 Paul Howarth <paul@city-fan.org> 3.0.8-1
337- update to 3.0.8
338- new program and manpage: shmidcat
339
340* Fri Jul 21 2006 Paul Howarth <paul@city-fan.org> 3.0.7-1
341- update to 3.0.7
342- new program and manpage: twinwave
343
344* Mon Jul 17 2006 Paul Howarth <paul@city-fan.org> 3.0.6-1
345- update to 3.0.6
346
347* Wed Jun 28 2006 Paul Howarth <paul@city-fan.org> 3.0.5-1
348- update to 3.0.5
349- new program and manpage: ghwdump
350
351* Fri Jun  2 2006 Paul Howarth <paul@city-fan.org> 3.0.4-1
352- update to 3.0.4
353
354* Tue May 30 2006 Paul Howarth <paul@city-fan.org> 3.0.3-1
355- update to 3.0.3
356
357* Sun May 28 2006 Paul Howarth <paul@city-fan.org> 3.0.2-2
358- adding missing buildreq flex
359
360* Wed May 10 2006 Paul Howarth <paul@city-fan.org> 3.0.2-1
361- update to 3.0.2
362
363* Tue May  9 2006 Paul Howarth <paul@city-fan.org> 3.0.1-1
364- update to 3.0.1
365
366* Tue May  2 2006 Paul Howarth <paul@city-fan.org> 3.0.0-1
367- update to 3.0.0
368- add examples directory as %%doc
369- add new buildreq gperf
370- tweak Makefile.in edits to handle Makefiles under contrib/
371- add new binaries rtlbrowse and vertex
372- add new manpages for rtlbrowse, vertex, and gtkwaverc
373- %%{_mandir} no longer needs to be created manually
374- configure script now accepts --libdir
375
376* Tue Mar  7 2006 Paul Howarth <paul@city-fan.org> 1.3.86-1
377- update to 1.3.86
378
379* Mon Feb 27 2006 Paul Howarth <paul@city-fan.org> 1.3.85-1
380- update to 1.3.85
381
382* Tue Feb 21 2006 Paul Howarth <paul@city-fan.org> 1.3.84-1
383- update to 1.3.84
384- INSTALL now called INSTALL.TXT
385
386* Thu Feb 16 2006 Paul Howarth <paul@city-fan.org> 1.3.83-2
387- rebuild
388
389* Tue Jan 31 2006 Paul Howarth <paul@city-fan.org> 1.3.83-1
390- update to 1.3.83
391
392* Thu Jan 19 2006 Paul Howarth <paul@city-fan.org> 1.3.82-1
393- update to 1.3.82
394
395* Tue Dec 13 2005 Paul Howarth <paul@city-fan.org> 1.3.81-1
396- update to 1.3.81
397
398* Sun Nov 27 2005 Paul Howarth <paul@city-fan.org> 1.3.80-1
399- update to 1.3.80
400
401* Wed Nov 23 2005 Paul Howarth <paul@city-fan.org> 1.3.79-2
402- fix file permissions in debuginfo package
403
404* Mon Nov 21 2005 Paul Howarth <paul@city-fan.org> 1.3.79-1
405- update to 1.3.79
406
407* Wed Nov  9 2005 Paul Howarth <paul@city-fan.org> 1.3.78-1
408- update to 1.3.78
409
410* Tue Nov  8 2005 Paul Howarth <paul@city-fan.org> 1.3.77-1
411- update to 1.3.77
412- GHDL ghw support now included upstream, so remove patches
413
414* Mon Nov  7 2005 Paul Howarth <paul@city-fan.org> 1.3.76-3
415- clean up for Fedora Extras:
416  - don't support GTK1 builds
417  - unconditionally remove buildroot in %%clean and %%install
418  - remove redundant glib2-devel buildreq
419  - add dist tag
420
421* Mon Nov  7 2005 Thomas Sailer <t.sailer@alumni.ethz.ch> - 1.3.76-2
422- add GHDL ghw support
423
424* Thu Oct 27 2005 Paul Howarth <paul@city-fan.org> 1.3.76-1
425- update to 1.3.76
426
427* Thu Oct 13 2005 Paul Howarth <paul@city-fan.org> 1.3.73-1
428- update to 1.3.73
429
430* Mon Oct 10 2005 Paul Howarth <paul@city-fan.org> 1.3.72-1
431- update to 1.3.72
432
433* Fri Oct  7 2005 Paul Howarth <paul@city-fan.org> 1.3.71-1
434- update to 1.3.71
435
436* Thu Sep 15 2005 Paul Howarth <paul@city-fan.org> 1.3.70-1
437- update to 1.3.70
438- new program tla2vcd (with manpage)
439
440* Mon Sep  5 2005 Paul Howarth <paul@city-fan.org> 1.3.69-1
441- update to 1.3.69
442- honour %%{optflags}
443- use system bzip and zlib libraries
444
445* Fri Sep  2 2005 Paul Howarth <paul@city-fan.org> 1.3.68-1
446- update to 1.3.68
447
448* Wed Aug 25 2005 Paul Howarth <paul@city-fan.org> 1.3.67-1
449- update to 1.3.67
450
451* Wed Aug 10 2005 Paul Howarth <paul@city-fan.org> 1.3.64-1
452- update to 1.3.64
453- new programs lxt2miner & vztminer (with manpages)
454
455* Tue Jul 26 2005 Paul Howarth <paul@city-fan.org> 1.3.63-1
456- update to 1.3.63
457
458* Mon Jul 11 2005 Paul Howarth <paul@city-fan.org> 1.3.62-1
459- update to 1.3.62
460
461* Thu Apr 21 2005 Paul Howarth <paul@city-fan.org> 1.3.58-1
462- update to 1.3.58
463- include sample .gtkwaverc in doc area
464- update URL to point to new project home page
465
466* Wed Apr 13 2005 Paul Howarth <paul@city-fan.org> 1.3.57-1
467- update to 1.3.57
468- add support for building with gtk version 1 (build using: --without gtk2)
469
470* Tue Apr 12 2005 Paul Howarth <paul@city-fan.org> 1.3.56-1
471- initial RPM build
Note: See TracBrowser for help on using the repository browser.