source: projects/specs/branches/6/g/gtkhtml/gtkhtml-vl.spec @ 521

Revision 521, 7.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        gtkhtml library
2Name:           gtkhtml
3Version:        1.1.9
4Release:        5vl2
5License:        LGPL
6Group:          System Environment/Libraries
7BuildRoot:      %{_tmppath}/%{name}-%{version}-root
8
9Source:         ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.1/%{name}-%{version}.tar.bz2
10Source1: pohack.awk
11Patch0: gtkhtml-1.1.7-bequiet.patch
12Patch1: gtkhtml-1.1.7-fixfont.patch
13Patch2: gtkhtml-1.1.9-textslave.patch
14Patch3: gtkhtml-1.1-nocapplet.patch
15Patch4: gtkhtml-1.1.9-gcc34_fixes.patch
16
17Requires: libgnomeprint15 >= 0.24
18Requires: gdk-pixbuf >= 0.8.0
19Requires: bonobo >= 0.32
20BuildRequires: gdk-pixbuf-devel >= 0.8.0
21BuildRequires: libgnomeprint-devel >= 0.24
22BuildRequires: gal-devel >= 0.24
23BuildRequires: gnome-libs-devel libcapplet0-devel libxml-devel libglade-devel
24BuildRequires: bonobo-devel >= 0.32
25
26%description
27This is GtkHTML, a lightweight HTML rendering/printing/editing engine.
28It was originally based on KHTMLW, but is now being developed
29independently of it.
30
31
32%package devel
33Summary: Libraries, includes, etc to develop gtkhtml applications
34Group: Development/Libraries
35Requires: gtkhtml = %{version}-%{release} gnome-libs-devel
36Requires: libgnomeprint-devel >= 0.25
37Requires: gdk-pixbuf-devel >= 0.8.0
38Requires: libglade-devel libxml-devel
39Requires: bonobo-devel
40Requires: gal-devel >= 0.24
41
42%description devel
43Libraries, include files, etc you can use to develop gtkhtml applications.
44
45
46%prep
47%setup -q
48%patch0 -p1
49%patch1 -p1
50%patch2 -p1 -b .textslave
51%patch3 -p1
52%patch4 -p1
53
54%build
55%configure
56# Patch1: hack to modify po. (ugly!)
57function pohack() {
58POHACKTMP=`mktemp /tmp/pohack.XXXXXX` || exit 1
59POHACKNEW=`mktemp /tmp/pohack.XXXXXX` || exit 1
60awk -v tempfile=${POHACKTMP} -v tempnewfile=${POHACKNEW} -v key="\"$1\"" -v val="$2" -f %{SOURCE1} $3 > $3.new
61mv $3.new $3
62rm -f $POHACKTMP $POHACKNEW
63}
64
65(cd po
66make update-po
67pohack '-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' '-*-kochi gothic-*-*-*-*-14-*-*-*-*-*-*-*' ja.po
68pohack '-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' '-*-kochi gothic-*-*-*-*-14-*-*-*-*-*-*-*' ja.po
69pohack 'font_variable_print=-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' 'font_variable_print=-*-kochi gothic-*-*-*-*-14-*-*-*-*-*-*-*' ja.po
70pohack 'font_fixed_print=-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' 'font_fixed_print=-*-kochi gothic-*-*-*-*-14-*-*-*-*-*-*-*' ja.po
71pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-helvetica-*-*-*-*-14-*-*-*-*-*-%s-%s,-alias-*-*-r-*' ja.po
72pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-courier-*-*-*-*-14-*-*-*-*-*-%s-%s,-alias-*-*-r-*' ja.po
73pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-*-*' '-*-helvetica-*-*-*-*-14-*-*-*-*-*-*-*,-alias-*-*-r-*' ja.po
74pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-*-*' '-*-courier-*-*-*-*-14-*-*-*-*-*-*-*,-alias-*-*-r-*' ja.po
75pohack '-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' '-*-baekmuk gulim-*-*-*-*-12-*-*-*-*-*-*-*' ko.po
76pohack '-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' '-*-baekmuk gulim-*-*-*-*-12-*-*-*-*-*-*-*' ko.po
77pohack 'font_variable_print=-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' 'font_variable_print=-*-baekmuk gulim-*-*-*-*-12-*-*-*-*-*-*-*' ko.po
78pohack 'font_fixed_print=-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' 'font_fixed_print=-*-baekmuk gulim-*-*-*-*-12-*-*-*-*-*-*-*' ko.po
79pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-helvetica-*-*-*-*-12-*-*-*-*-*-%s-%s,-*-baekmuk gulim-*-r-*' ko.po
80pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-courier-*-*-*-*-12-*-*-*-*-*-%s-%s,-*-baekmuk gulim-*-r-*' ko.po
81pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-*-*' '-*-helvetica-*-*-*-*-12-*-*-*-*-*-*-*,-*-baekmuk gulim-*-r-*' ko.po
82pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-*-*' '-*-courier-*-*-*-*-12-*-*-*-*-*-*-*,-*-baekmuk gulim-*-r-*' ko.po
83pohack '-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' '-*-ar pl sungtil gb-*-*-*-*-10-*-*-*-*-*-*-*' zh_CN.po
84pohack '-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' '-*-ar pl sungtil gb-*-*-*-*-10-*-*-*-*-*-*-*' zh_CN.po
85pohack 'font_variable_print=-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' 'font_variable_print=-*-ar pl sungtil gb-*-*-*-*-10-*-*-*-*-*-*-*' zh_CN.po
86pohack 'font_fixed_print=-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' 'font_fixed_print=-*-ar pl sungtil gb-*-*-*-*-10-*-*-*-*-*-*-*' zh_CN.po
87pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-helvetica-*-*-*-*-12-*-*-*-*-*-%s-%s,*-r-*' zh_CN.po
88pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-courier-*-*-*-*-12-*-*-*-*-*-%s-%s,*-r-*' zh_CN.po
89pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-*-*' '-*-helvetica-*-*-*-*-12-*-*-*-*-*-*-*,*-r-*' zh_CN.po
90pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-*-*' '-*-courier-*-*-*-*-12-*-*-*-*-*-*-*,*-r-*' zh_CN.po
91pohack '-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' '-*-ar pl mingti2l big5-*-*-*-*-10-*-*-*-*-*-*-*' zh_TW.po
92pohack '-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' '-*-ar pl mingti2l big5-*-*-*-*-10-*-*-*-*-*-*-*' zh_TW.po
93pohack 'font_variable_print=-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' 'font_variable_print=-*-ar pl mingti2l big5-*-*-*-*-10-*-*-*-*-*-*-*' zh_TW.po
94pohack 'font_fixed_print=-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' 'font_fixed_print=-*-ar pl mingti2l big5-*-*-*-*-10-*-*-*-*-*-*-*' zh_TW.po
95pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-helvetica-*-*-*-*-12-*-*-*-*-*-%s-%s,*-r-*' zh_TW.po
96pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-courier-*-*-*-*-12-*-*-*-*-*-%s-%s,*-r-*' zh_TW.po
97pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-*-*' '-*-helvetica-*-*-*-*-12-*-*-*-*-*-*-*,*-r-*' zh_TW.po
98pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-*-*' '-*-courier-*-*-*-*-12-*-*-*-*-*-*-*,*-r-*' zh_TW.po
99)
100make
101
102
103%install
104[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
105
106make DESTDIR=$RPM_BUILD_ROOT install
107
108# remove things for new gnomecc that we don't have
109rm -rf $RPM_BUILD_ROOT/%{_libdir}/control-center/capplets
110rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
111rm -rf $RPM_BUILD_ROOT/%{_libdir}/bonobo
112
113rm -rf $RPM_BUILD_ROOT/%{_datadir}/control-center
114rm -rf $RPM_BUILD_ROOT/%{_datadir}/gnome/apps
115
116%find_lang %{name}
117
118
119%clean
120[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
121
122
123%post -p /sbin/ldconfig
124
125%postun -p /sbin/ldconfig
126
127
128%files -f %{name}.lang
129%defattr(-, root, root)
130%doc AUTHORS ChangeLog NEWS README COPYING TODO
131%{_bindir}/*
132%{_libdir}/*.so.*
133%{_datadir}/gnome/*
134%{_datadir}/gtkhtml-1.1/*
135%{_datadir}/oaf/*
136
137%files devel
138%defattr(-, root, root)
139%{_includedir}/gtkhtml-1.1
140%{_libdir}/*.a
141%{_libdir}/*.so
142#%{_libdir}/*.sh
143%{_libdir}/pkgconfig/*.pc
144
145%changelog
146* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.9-5vl2
147- rebuilt with db4-4.2.52, gdk-pixbuf-0.22.0-0vl5, gal-0.24-1vl2
148- s/Copyright/License/
149- added Patched from Fedora
150  * Mon Jun 21 2004 David Malcolm <dmalcolm@redhat.com> - 1.1.9-10
151  - Added fix for gcc 3.4
152  * Tue Mar 16 2004 Bill Nottingham <notting@redhat.com> 1.1.9-7
153  - don't build the capplet
154
155* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.9-5vl1
156- based on Fedora 1.1.9-5
157  * Fri Sep  5 2003 Bill Nottingham <notting@redhat.com> 1.1.9-5
158  - don't buildprereq libunicode-devel
159  * Wed Aug 20 2003 Havoc Pennington <hp@redhat.com> 1.1.9-4.1
160  - fix crash in htmltextslave.c
161- rebuilt with new toolchains
162
163* Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.9-3vl1
164- based on Rawhide 1.1.9-3
165- rebuilt with new toolchains
166- removed BuildPreReq gnome-core-devel, control-center-devel
167- added BuildPrereq /usr/lib/libcapples.so
168  (for compatible control-center-devel and libcapplet0-devel :p)
169- added Requires pkgconfig
170
171* Sun Sep 15 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.4-0vl1
172- updated to new upstream release
173
174* Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
175- New upstream release.
176
177* Tue Dec 18 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
178- New upstream release.
179
180* Tue May  8 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.9.2-0vl1
181- New upstream release.
182
183* Tue Apr  3 2001 Shoji Matsumoto <shom@vinelinux.org> 0.8.3-0vl1
184- updated to 0.8.3
185- add may BuildPrereq: and Requires:
186- add fontencfix / fontset patch
187
188* Wed Mar 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.8.2-0vl1
189- New upstream Release.
190
Note: See TracBrowser for help on using the repository browser.