source: projects/specs/branches/6/g/gtk3/gtk3-vl.spec @ 10705

Revision 10705, 9.8 KB checked in by tomop, 8 years ago (diff)

gtk3-3.0.9-2

Line 
1# Note that this is NOT a relocatable package
2
3%define glib2_base_version 2.28.6
4%define glib2_version %{glib2_base_version}-1
5%define pango_base_version 1.28.3
6%define pango_version %{pango_base_version}-1
7%define atk_base_version 1.32.0
8%define atk_version %{atk_base_version}-1
9%define cairo_base_version 1.10.0
10%define cairo_version %{cairo_base_version}-1
11%define gdkpixbuf2_base_version 2.22.1
12%define gdkpixbuf2_version %{gdkpixbuf2_base_version}-1
13%define gobject_introspection_version 0.10.0
14
15
16%define base_version 3.0.9
17%define bin_version 3.0.0
18
19# biarch support
20%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
21%define _query_suffix %{nil}
22%if %{build_compat32}
23%define _query_suffix -32
24%endif
25
26Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
27Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
28Name: gtk3
29Version: %{base_version}
30Release: 2%{?_dist_release}
31License: LGPL
32Group: System Environment/Libraries
33
34Source: gtk+-%{version}.tar.bz2
35
36Patch100: gtk+-2.99.3-vine-default-theme.patch
37
38Patch1000: CVE-2013-1881-compat.patch
39
40BuildRequires: atk-devel >= %{atk_version}
41BuildRequires: pango-devel >= %{pango_version}
42BuildRequires: glib2-devel >= %{glib2_version}
43BuildRequires: cairo-devel >= %{cairo_version}
44BuildRequires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
45BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
46BuildRequires: libtiff-devel >= 3.7
47BuildRequires: libjpeg-turbo-devel
48BuildRequires: libpng-devel
49BuildRequires: jasper-devel
50BuildRequires: gtk-doc
51#BuildRequires: automake17, autoconf
52BuildRequires: gamin-devel
53BuildRequires: cups-devel
54BuildRequires: libICE-devel
55BuildRequires: libXext-devel
56BuildRequires: libXi-devel
57BuildRequires: libXrandr-devel >= 1.3.0
58BuildRequires: libXrender-devel
59BuildRequires: libXcursor-devel
60BuildRequires: libXfixes-devel
61BuildRequires: libXinerama-devel
62BuildRequires: libXcomposite-devel
63BuildRequires: libXdamage-devel
64
65BuildRoot: %{_tmppath}/gtk-%{version}-root
66
67URL: http://www.gtk.org
68
69# required for icon themes apis to work
70Requires: hicolor-icon-theme
71
72# We need to prereq these so we can run gtk-query-immodules-2.0
73Requires(post): glib2 >= %{glib2_version}
74Requires(post): atk >= %{atk_version}
75Requires(post): pango >= %{pango_version}
76Requires(post): libSM >= 1.1.0
77# We need to prereq libtiff >= 3.7 to run gdk-pixbuf-query-loaders
78Requires(post): libtiff >= 3.7
79Requires: libXrandr >= 1.3.0
80
81Vendor: Project Vine
82Distribution: Vine Linux
83Packager: Takemikaduchi
84
85
86%description
87GTK+ is a multi-platform toolkit for creating graphical user
88interfaces. Offering a complete set of widgets, GTK+ is suitable for
89projects ranging from small one-off tools to complete application
90suites.
91
92%package devel
93Summary: Development tools for GTK+ applications.
94Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
95Group: Development/Libraries
96Requires: %{name} = %{version}-%{release}
97Requires: pango-devel >= %{pango_version}
98Requires: atk-devel >= %{atk_version}
99Requires: glib2-devel >= %{glib2_version}
100Requires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
101Requires: libX11-devel, libXcursor-devel, libXinerama-devel
102Requires: libXext-devel, libXi-devel, libXrandr-devel
103Requires: libXfixes-devel, libXcomposite-devel
104Requires: libpng-devel
105
106%description devel
107The gtk+-devel package contains the header files and developer
108docs for the GTK+ widget toolkit. 
109
110#######################################################################
111# compat32
112%package -n compat32-%{name}
113Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
114Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
115Group: System Environment/Libraries
116Requires(post): compat32-glib2 >= %{glib2_version}
117Requires(post): compat32-atk >= %{atk_version}
118Requires(post): compat32-pango >= %{pango_version}
119Requires(post): compat32-libSM >= 1.1.0
120Requires(post): compat32-libtiff >= 3.7
121Requires: compat32-libXrandr >= 1.3.0
122
123%description -n compat32-%{name}
124GTK+ is a multi-platform toolkit for creating graphical user
125interfaces. Offering a complete set of widgets, GTK+ is suitable for
126projects ranging from small one-off tools to complete application
127suites.
128
129%package -n compat32-%{name}-devel
130Summary: Development tools for GTK+ applications.
131Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
132Group: Development/Libraries
133Requires: compat32-%{name} = %{version}-%{release}
134Requires: %{name}-devel = %{version}
135Requires: compat32-libX11-devel, compat32-libXcursor-devel, compat32-libXinerama-devel
136Requires: compat32-libXext-devel, compat32-libXi-devel, compat32-libXrandr-devel
137Requires: compat32-libXfixes-devel, compat32-libXcomposite-devel
138Requires: compat32-libpng-devel
139
140%description -n compat32-%{name}-devel
141The gtk+-devel package contains the header files and developer
142docs for the GTK+ widget toolkit. 
143
144
145%prep
146%setup -q -n gtk+-%{version}
147%patch100 -p1 -b .vine-default-theme
148
149%patch1000 -p1 -b .CVE-2013-1881-compat
150
151#for i in config.guess config.sub ; do
152#       test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
153#done
154
155%build
156
157# if ! pkg-config --exists pangoxft ; then
158#         echo "No pangoxft.pc!"
159#         exit 1
160# fi
161
162#libtoolize --force --copy
163#autoreconf -i
164
165%configure --enable-gtk-doc \
166        --enable-man \
167        --enable-debug=minimum \
168        --disable-rebuilds \
169        --disable-glibtest \
170        --enable-introspection=yes \
171        --enable-xrandr \
172        --enable-xfixes \
173        --enable-xcomposite \
174        --enable-xdamage \
175        --enable-x11-backend
176
177make ARCH=%{_arch}
178#make
179
180%install
181rm -rf $RPM_BUILD_ROOT
182
183make install DESTDIR=$RPM_BUILD_ROOT RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false
184
185%find_lang gtk30
186%find_lang gtk30-properties
187
188cat gtk30.lang gtk30-properties.lang > all.lang
189
190mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gtk-3.0
191#
192# Make cleaned-up versions of examples and tutorial for installation
193#
194mkdir -p tmpdocs/tutorial
195# install -m 0644 docs/html/gtk_tut.html docs/html/gtk_tut-[0-9]*.html docs/html/*.gif tmpdocs/tutorial
196for dir in examples/* ; do
197    if [ -d $dir ] ; then
198       mkdir -p tmpdocs/$dir
199       for file in $dir/* ; do
200          case $file in
201             *pre1.2.7)
202                ;;
203             *)
204                install -m 0644 $file tmpdocs/$dir
205                ;;
206          esac
207       done
208    fi
209done
210
211
212# We need to have separate 32-bit and 64-bit binaries
213# for places where we have two copies of the GTK+ package installed.
214# (we might have x86_64 and i686 packages on the same system, for example.)
215%if %{build_compat32}
216   cp $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0 \
217      $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
218%endif
219touch $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{bin_version}/immodules.cache
220
221mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules
222mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/immodules
223
224# Remove unpackaged files
225rm $RPM_BUILD_ROOT%{_libdir}/*.la
226rm -rf $RPM_BUILD_ROOT%{_datadir}/themes/Raleigh
227rm $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules/lib*.la
228
229%clean
230rm -rf $RPM_BUILD_ROOT
231
232%post
233/sbin/ldconfig
234%{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
235
236%postun
237/sbin/ldconfig
238if [ $1 -gt 0 ]; then
239  %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
240fi
241glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
242
243%posttrans
244glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
245
246%if %{build_compat32}
247%post -n compat32-%{name}
248/sbin/ldconfig
249%{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
250
251%postun -n compat32-%{name}
252/sbin/ldconfig
253if [ $1 = 0 ]; then
254  %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
255fi
256%endif
257
258%files -f all.lang
259%defattr(-, root, root)
260%doc AUTHORS COPYING ChangeLog NEWS README
261%{_bindir}/gtk3-demo
262%{_bindir}/gtk-query-immodules-3.0
263%exclude %{_bindir}/gtk-update-icon-cache
264%{_libdir}/libgtk-3.so.*
265%{_libdir}/libgdk-3.so.*
266%{_libdir}/libgailutil-3.so.*
267%dir %{_libdir}/gtk-3.0
268%{_libdir}/gtk-3.0/%{bin_version}
269%dir %{_libdir}/gtk-3.0/modules
270%{_libdir}/gtk-3.0/modules/lib*.so
271%{_libdir}/girepository-1.0/*.typelib
272%{_datadir}/gtk-3.0
273%{_datadir}/themes/Default
274%{_datadir}/themes/Emacs
275%dir %{_sysconfdir}/gtk-3.0
276%{_sysconfdir}/gtk-3.0/im-multipress.conf
277%{_datadir}/glib-2.0/schemas/*.xml
278
279%files devel
280%defattr(-, root, root)
281%{_libdir}/lib*.so
282%dir %{_libdir}/gtk-3.0
283%{_datadir}/gtk-doc/
284%{_datadir}/gir-1.0/*.gir
285%{_mandir}/man1/*
286%exclude %{_mandir}/man1/gtk-update-icon-cache.1.gz
287%{_includedir}/*
288%{_datadir}/aclocal/*
289%{_libdir}/pkgconfig/*
290%doc tmpdocs/tutorial
291
292# compat32
293%if %{build_compat32}
294%files -n compat32-%{name}
295%defattr(-, root, root)
296%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
297%{_libdir}/libgtk-3.so.*
298%{_libdir}/libgdk-3.so.*
299%{_libdir}/libgailutil-3.so.*
300%dir %{_libdir}/gtk-3.0
301%{_libdir}/gtk-3.0/%{bin_version}
302%dir %{_libdir}/gtk-3.0/modules
303%{_libdir}/gtk-3.0/modules/lib*.so
304%dir %{_sysconfdir}/gtk-3.0
305
306%files -n compat32-%{name}-devel
307%defattr(-, root, root)
308%{_libdir}/lib*.so
309%dir %{_libdir}/gtk-3.0
310%{_libdir}/pkgconfig/*
311%endif
312
313%changelog
314* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.9-2
315- added Patch1000 for regression bug caused by CVE-2013-1881-patched librsvg.
316
317* Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-1
318- new upstream release
319
320* Sun Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8-1
321- new upstream release
322
323* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
324- new upstream release
325
326* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
327- new upstream release
328
329* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
330- new upstream release
331
332* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
333- new upstream release
334
335* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
336- new upstream release
337
338* Fri Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
339- new upstream release
340
341* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
342- initial build for Vine Linux
343
Note: See TracBrowser for help on using the repository browser.