source: projects/specs/branches/6/g/gtk-vnc/gtk-vnc-vl.spec @ 2762

Revision 2762, 7.2 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1# Plugin isn't ready for real world use yet - it needs
2# a security audit at very least
3%define with_plugin 0
4
5Summary: A GTK widget for VNC clients
6Summary(ja): VNCクライアント用 GTK ウィジェット
7
8Name: gtk-vnc
9Version: 0.4.3
10Release: 1%{?_dist_release}
11License: LGPLv2+
12Group: Development/Libraries
13Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
14Patch100: gtk-vnc-0.3.8-fast.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17URL: http://gtk-vnc.sf.net/
18BuildRequires: gtk2-devel pygtk2-devel python-devel zlib-devel
19BuildRequires: gnutls-devel gtkglext-devel cyrus-sasl-devel
20%if %{with_plugin}
21BuildRequires: xulrunner-devel
22%endif
23
24%description
25gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
26allowing it to be completely asynchronous while remaining single threaded.
27
28%package devel
29Summary: Development filesdor gtk-vnc library
30Summary(ja): gtk-vnc ライブラリの開発ファイル
31Group: Development/Libraries
32Requires: %{name} = %{version}-%{release}
33Requires: pkgconfig
34Requires: pygtk2-devel gtk2-devel gnutls-devel
35
36%description devel
37gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
38allowing it to be completely asynchronous while remaining single threaded.
39
40Libraries, includes, etc. to compile with the gtk-vnc library
41
42%package python
43Summary: Python bindings for the gtk-vnc library
44Summary(ja): gtk-vnc ライブラリの python バインディング
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
47
48%description python
49gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
50allowing it to be completely asynchronous while remaining single threaded.
51
52A module allowing use of the GTK-VNC widget from python
53
54%if %{with_plugin}
55%package plugin
56Summary: Mozilla plugin for the gtk-vnc library
57Summary(ja): gtk-vnc ライブラリの mozilla プラグイン
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60
61%description plugin
62gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
63allowing it to be completely asynchronous while remaining single threaded.
64
65This package provides a web browser plugin for Mozilla compatible
66browsers.
67%endif
68
69%prep
70%setup -q
71## %patch100 -p1
72
73%build
74%if %{with_plugin}
75%configure --enable-plugin=yes
76%else
77%configure
78%endif
79%__make %{?_smp_mflags}
80
81%install
82rm -fr %{buildroot}
83%__make install DESTDIR=%{buildroot}
84rm -f %{buildroot}%{_libdir}/*.a
85rm -f %{buildroot}%{_libdir}/*.la
86rm -f %{buildroot}%{_libdir}/python*/site-packages/*.a
87rm -f %{buildroot}%{_libdir}/python*/site-packages/*.la
88%if %{with_plugin}
89rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.a
90rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.la
91%endif
92
93%find_lang %{name}
94
95%clean
96rm -fr %{buildroot}
97
98%post -p /sbin/ldconfig
99
100%postun -p /sbin/ldconfig
101
102%files -f %{name}.lang
103%defattr(-, root, root)
104%doc AUTHORS ChangeLog NEWS README COPYING.LIB
105%{_bindir}/gvnccapture
106%{_libdir}/lib*.so.*
107%{_libdir}/girepository-1.0/*.typelib
108%{_mandir}/man1/gvnccapture.1.gz
109
110%files devel
111%defattr(-, root, root)
112%doc examples/gvncviewer.c
113%{_libdir}/lib*.so
114%dir %{_includedir}/%{name}-1.0/
115%dir %{_includedir}/gvnc-1.0/
116%{_includedir}/%{name}-1.0/*.h
117%{_includedir}/gvnc-1.0/*.h
118%{_libdir}/pkgconfig/%{name}-1.0.pc
119%{_libdir}/pkgconfig/gvnc-1.0.pc
120%{_datadir}/gir-1.0/*.gir
121
122%files python
123%defattr(-, root, root)
124%doc examples/gvncviewer.py
125%{_libdir}/python*/site-packages/gtkvnc.so
126
127%if %{with_plugin}
128%files plugin
129%defattr(-, root, root)
130%{_libdir}/mozilla/plugins/%{name}-plugin.so
131%endif
132
133%changelog
134* Thu Feb 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.3-1
135- new upstream release
136
137* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.1-2
138- rebuild with rpm-4.8.1 for pkg-config file
139
140* Sun Jul 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.1-1
141- new upstream release
142- drop Patch100
143- fix %files
144
145* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.10-1
146- new upstream release
147
148* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.9-2
149- rebuild with python-2.6
150
151* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.9-1
152- new upstream release
153- add Patch100 to speed up
154- add BR: cyrus-sasl-devel
155
156* Mon Jan 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-2
157- rebuild with gnutls-2.6.3
158
159* Wed Dec 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-1
160- new upstream release
161
162* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.7-1
163- initial build for Vine Linux
164
165* Fri Sep  5 2008 Matthias Clasen  <mclasen@redhat.com> - 0.3.7-1
166- Update to 0.3.7
167
168* Thu Aug 28 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-4.fc9
169- Fix key/mouse event propagation (rhbz #454627)
170
171* Mon Jul  7 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.3.6-3
172- fix conditional comparison
173
174* Wed Jun 25 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-2.fc10
175- Rebuild for GNU TLS ABI change
176
177* Wed May  7 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-1.fc10
178- Updated to 0.3.6 release
179
180* Fri Apr 25 2008 Matthias Clasen <mclasen@redhat.com> - 0.3.5-1.fc9
181- Update to 0.3.5
182
183* Fri Apr  4 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-4.fc9
184- Remove bogus chunk of render patch
185
186* Thu Apr  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-3.fc9
187- Fix OpenGL rendering artifacts (rhbz #440184)
188
189* Thu Apr  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-2.fc9
190- Fixed endianness conversions
191- Fix makecontext() args crash on x86_64
192- Fix protocol version negotiation
193
194* Thu Mar  6 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-1.fc9
195- Update to 0.3.4 release
196- Fix crash with OpenGL scaling code
197
198* Sun Feb  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.3-1.fc9
199- Update to 0.3.3 release
200
201* Mon Jan 14 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-2.fc9
202- Track keystate to avoid stuck modifier keys
203
204* Mon Dec 31 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-1.fc9
205- Update to 0.3.2 release
206- Added dep on zlib-devel
207
208* Thu Dec 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.1-1.fc9
209- Update to 0.3.1 release
210
211* Thu Oct 10 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-4.fc8
212- Fixed coroutine cleanup to avoid SEGV (rhbz #325731)
213
214* Thu Oct  4 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-3.fc8
215- Fixed coroutine caller to avoid SEGV
216
217* Wed Sep 26 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-2.fc8
218- Remove use of PROT_EXEC for coroutine stack (rhbz #307531 )
219
220* Thu Sep 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-1.fc8
221- Update to 0.2.0 release
222
223* Wed Aug 29 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-5.fc8
224- Fixed handling of mis-matched client/server colour depths
225
226* Wed Aug 22 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-4.fc8
227- Fix mixed endian handling & BGR pixel format (rhbz #253597)
228- Clear widget areas outside of framebuffer (rhbz #253599)
229- Fix off-by-one in python demo
230
231* Thu Aug 16 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-3.fc8
232- Tweaked post scripts
233- Removed docs from sub-packages
234- Explicitly set license to LGPLv2+
235- Remove use of macro for install rule
236
237* Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-2.fc8
238- Added gnutls-devel requirement to -devel package
239
240* Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-1.fc8
241- Initial official release
Note: See TracBrowser for help on using the repository browser.