source: projects/specs/branches/6/g/gtk-engines/gtk-engines-vl.spec @ 521

Revision 521, 7.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define ver     0.12
2%define rel     2%{?_dist_release}
3
4%define extra_builds buffy-0.2 gtk-thinice-theme-1.0.4 notif2-1.0
5
6# We ignore this - gtkstep screws up things
7%define screwed_up_builds gtkstep-1.7 gtkstep-pastel-0.9.1
8
9Summary:        Theme engines for GTK+.
10Summary(ja):    GTK+ 用 テーマエンジン
11Name:           gtk-engines
12Version:        %{ver}
13Release:        %{rel}
14License:        GPL
15Group:          System Environment/Libraries
16Source:         ftp://ftp.gnome.org/pub/GNOME/source/%{name}/%{name}-%{PACKAGE_VERSION}.tar.gz
17Source1:        gtk-themes-extra-4.tar.gz
18
19Source2:        GTKstep.tar.gz
20Source3:        Notif2-1.0.tar.gz
21Source4:        http://prdownloads.sourceforge.net/thinice/gtk-thinice-theme-1.0.4.tar.gz
22Source5:        buffy-0.2.tar.gz
23Source6:        gtkstep-pastel.tar.gz
24
25# Fixes pixmap resource leak
26Patch1: gtk-engines-0.11-memleak.patch
27# Fixes compiling error (adhoc patch)
28Patch2: gtk-engines-0.12-draw.patch
29
30# The sum total of gtk.themes.org
31Source10:       5.tar.gz
32Source11:       AbsoluteE.tar.gz
33Source12:       Aspen.tar.gz
34Source13:       Basic.tar.gz
35Source14:       BeOS.tar.gz
36Source15:       Beta.tar.gz
37Source16:       Blue-n-Gray.tar.gz
38Source17:       BlueSteel.tar.gz
39Source18:       BlueTheme.tar.gz
40Source19:       Bluish.tar.gz
41Source20:       Bluthe-1.0.tar.gz
42Source21:       BrushedMarbles.tar.gz
43Source22:       BrushedMetal.tar.gz
44Source23:       BrushedMetalClean.tar.gz
45Source24:       Cheese.tar.gz
46Source25:       Chrome.tar.gz
47Source26:       CoolIce.tar.gz
48Source27:       Coolness.tar.gz
49Source28:       E-Default.tar.gz
50Source29:       Expensive.tar.gz
51Source30:       Forest-Green.tar.gz
52Source31:       GTK_LCARS.tar.gz
53Source32:       Gradient.tar.gz
54Source33:       IceBerg.tar.gz
55Source34:       Jander.tar.gz
56Source35:       JedEye.tar.gz
57Source36:       LCARS.tar.gz
58Source37:       LCD.tar.gz
59Source38:       Macos-Blue-8.6.tar.gz
60Source39:       Marble.tar.gz
61Source40:       Metallic.tar.gz
62Source41:       Metallic_Plum.tar.gz
63Source42:       MorphiusX.tar.gz
64Source43:       Muffy.tar.gz
65Source44:       Odo.tar.gz
66Source45:       OldWood.tar.gz
67Source46:       PalmOS.tar.gz
68Source47:       Porcelain.tar.gz
69Source48:       QNX-Photon.tar.gz
70Source49:       Rats.tar.gz
71Source50:       Red-and-Blue.tar.gz
72Source51:       Rocks.tar.gz
73Source52:       Scalpel.tar.gz
74Source53:       ShinyMetal.tar.gz
75Source54:       Skiberg.tar.gz
76Source55:       Smoke-full.tar.gz
77Source56:       Smoke.tar.gz
78Source57:       SoulTrip.tar.gz
79Source58:       ThinSki.tar.gz
80Source59:       Tiger.tar.gz
81Source60:       Tildouf.tar.gz
82Source61:       Turismo.tar.gz
83Source62:       WoodenScraps.tar.gz
84Source63:       Yell-O.tar.gz
85Source64:       Zap5.tar.gz
86Source65:       eMac-GTK.tar.gz
87Source66:       lauxes.tar.gz
88Source67:       photon.tar.gz
89
90URL:            http://gtk.themes.org
91BuildRoot:      %{_tmppath}/%{name}-%{version}-root
92BuildRequires:  automake14
93BuildRequires:  gtk+-devel
94BuildRequires:  imlib-devel
95
96%description
97The gtk-engines package contains shared objects and configuration
98files that implement a number of GTK+ theme engines.  Theme engines
99provide different looks for GTK+, so that it can resemble other
100toolkits or operating systems.  The gtk-engines package contains
101graphical engines for various GTK+ toolkit themes, including Notif,
102Redmond95, Pixmap and Metal (swing-like).
103
104%description -l ja
105gtk-engines パッケージは共有のオブジェクトとGTK+テーマエンジンの
106幾つかの設定ファイルを含んでいます。テーマエンジンはGTK+にて違っ
107た概観を提供します。このパッケージにはさまざまなGTK+ツールキット
108テーマ Notif,Redmond95,Pixmap,Metal(swing-like )を含めてあります。
109加えて、それ以外にもたくさんの物を収めてあります。
110
111
112%prep
113%setup -q -a 2 -a 3 -a 4 -a 5 -a 6
114%patch1 -p1 -b .memleak
115%patch2 -p0 -b .draw
116
117%build
118rm acinclude.m4
119libtoolize --force --copy
120aclocal-1.4
121automake-1.4
122autoconf
123%configure
124make
125for I in `echo %{extra_builds}`; do
126        cd $I
127        libtoolize --force --copy
128        aclocal-1.4
129        automake-1.4
130        autoconf
131        %configure --cache-file=../config.cache
132        make
133        cd ..
134done
135
136
137%install
138[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
139mkdir -p $RPM_BUILD_ROOT
140#
141# makefile is broken, sets exec_prefix explicitely.
142#
143%makeinstall
144
145for I in `echo %{extra_builds}`; do
146        cd $I
147        %makeinstall
148        cd ..
149done
150
151# expand extra themes
152cd $RPM_BUILD_ROOT%{_datadir}/themes; tar xzvf %{SOURCE1}
153
154for I in 5 AbsoluteE Basic BeOS Beta Blue-n-Gray BlueSteel \
155BlueTheme Bluish Bluthe-1.0 BrushedMarbles BrushedMetal \
156BrushedMetalClean Cheese Chrome CoolIce Coolness E-Default Expensive \
157Forest-Green GTK_LCARS Gradient IceBerg Jander JedEye LCARS LCD \
158Macos-Blue-8.6 Marble Metallic Metallic_Plum MorphiusX Muffy Odo OldWood \
159PalmOS Porcelain QNX-Photon Rats Red-and-Blue Rocks Scalpel ShinyMetal \
160Skiberg Smoke-full Smoke SoulTrip ThinSki Tiger Tildouf Turismo \
161WoodenScraps Yell-O Zap5 eMac-GTK lauxes photon; do
162        tar -C $RPM_BUILD_ROOT%{_datadir}/themes -xzf $RPM_SOURCE_DIR/$I.tar.gz
163done
164
165(cd $RPM_BUILD_ROOT%{_datadir}/themes;
166# Here's where I get to give themes dumb names because of possible
167# trademarks
168mv QNX-Photon LightSpeed
169mv photon Torpedo
170mv macos8.6-blue MockMack
171mv BeOS BeCool
172mv PalmOS LCD
173mv eMac eMock
174rm -rf BrushedMetalBlue
175# remove unnecessary .xvpics directory
176find . -type d -name .xvpics | xargs rm -rf
177)
178
179# remove Odo its broke
180rm -rf $RPM_BUILD_ROOT%{_datadir}/themes/Odo
181
182# remove unuse *.la files
183rm -f $RPM_BUILD_ROOT%{_libdir}/gtk/themes/engines/lib*.la
184
185%clean
186[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
187
188
189%files
190%defattr(644, root, root, 755)
191%doc COPYING README ChangeLog
192%attr (755, root, root) %{_libdir}/gtk/themes/engines/*
193%{_datadir}/themes/*
194
195
196%changelog
197* Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12-2vl5
198- added BuildRequires: gtk+-devel, imlib-devel
199
200* Sun Sep 07 2008 Shu KONNO <owa@bg.wakwak.com> 0.12-1vl5
201- applied new versioning policy, spec in utf-8
202- added gtk-engines-0.12-draw.patch
203- remove lib*.la
204
205* Thu Aug 21 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12-0vl5
206- update Source4
207- add Patch1 from Rawhide
208- add BuildPrereq: automake14
209- spec file fixed based on Rawhide 0.12-1
210- rebuild with new toolchains
211
212* Sat Mar 16 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.12-0vl4
213- spec file typo fixed ( -f %%{name}.lang was missing
214  although %%find_lang was used in the %%install section)
215- remove unnecessary and wasting .xvpics directories
216
217* Mon Jul 16 2001 <sagami@vinelinux.org>
218- 0.12-0vl3: added ./autogen.sh on notif2-1.0 and quit disabling libtoolize
219
220* Sat Jul 14 2001 <sagami@vinelinux.org>
221- 0.12-0vl2: ugly treatment to disable libtoolize on notif2-1.0
222
223* Tue Apr  3 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.12-0vl1
224- New upstream release.
225- Use find_lang macro.
226
227* Fri Mar  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.11-0vl1
228- New upstream release.
229- Use rpmmacros.
230
231* Thu Feb 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
232- updated to 0.10
233
234* Fri Sep 17 1999 Kazuhito Nishi <nishi@imasy.or.jp>
235- added japanese Summary and description for Vine
236
237* Wed Sep 15 1999 Elliot Lee <sopwith@redhat.com>
238- Misc fixes from DrMike suggestions
239
240* Thu Sep 09 1999 Elliot Lee <sopwith@redhat.com>
241- Update to 0.6, etc.
242
243* Wed Apr 14 1999 Michael Fulbright <drmike@redhat.com>
244- removed Odo (has issues)
245
246* Fri Apr 9 1999 The Rasterman <raster@redhat.com>
247- patched metal theme - fixed handlebox redraw.
248
249* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
250- removed some themes that were misbehaving
251
252* Tue Mar 16 1999 Michael Fulbright <drmike@redhat.com>
253- removed enlightened themes, seems to be defective
254
255* Thu Mar 11 1999 Michael Fulbright <drmike@redhat.com>
256- removed Default theme data, this comes with gtk+ package
257
258* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
259- added extra gtk themes
260
261* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
262- version 0.5
263
264* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
265- version 0.4
266
267* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
268- version 0.3
269
270* Mon Dec 18 1998 Michael Fulbright <drmike@redhat.com>
271- version 0.2
272
273* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
274- rebuild because gtk+ version changed
275
276* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
277- in preparation for GNOME freeze
278
279* Fri Nov 20 1998 Michael Fulbright <drmike@redhat.com>
280- First try at a spec file
Note: See TracBrowser for help on using the repository browser.