source: projects/specs/branches/6/g/gtest/gtest-vl.spec @ 1948

Revision 1948, 4.1 KB checked in by kudoh, 14 years ago (diff)
Line 
1Summary:        Google C++ testing framework
2Summary(ja):    Google C++ テスティングフレームワーク
3Name:           gtest
4Version:        1.5.0
5Release:        2%{?_dist_release}
6License:        New BSD
7Group:          Development/Tools
8URL:            http://code.google.com/p/googletest/
9Source0:        http://googletest.googlecode.com/files/%{name}-%{version}.tar.bz2
10
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13BuildRequires:  chrpath
14BuildRequires:  python >= 2.3
15
16%description
17Google's framework for writing C++ tests on a variety of platforms (GNU/Linux,
18Mac OS X, Windows, Windows CE, and Symbian). Based on the xUnit architecture.
19Supports automatic test discovery, a rich set of assertions, user-defined
20assertions, death tests, fatal and non-fatal failures, various options for
21running the tests, and XML test report generation.
22
23%package devel
24Summary:        Development files for %{name}
25Summary(ja):    %{name} の開発ファイル
26Group:          Development/Libraries
27
28Requires:       automake
29Requires:       %{name} = %{version}-%{release}
30
31%description devel
32This package contains development files for %{name}.
33
34%prep
35%setup -q
36
37# Keep a clean copy of samples.
38cp -pr ./samples ./samples.orig
39
40%build
41%configure --disable-static
42
43# Omit unused direct shared library dependencies.
44sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
45
46make %{?_smp_mflags}
47
48%check
49# Two tests fail here, unclear as to why.
50make check
51
52# Restore the clean copy of samples.
53# To be later listed against %doc.
54rm -rf ./samples
55mv ./samples.orig ./samples
56
57%install
58rm -rf $RPM_BUILD_ROOT
59
60make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
61find $RPM_BUILD_ROOT -type f -name "*.la" -delete
62
63# Remove rpaths.
64chrpath --delete $RPM_BUILD_ROOT%{_libdir}/libgtest_main.so.0.0.0
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%post -p /sbin/ldconfig
70
71%postun -p /sbin/ldconfig
72
73%files
74%defattr(-,root,root,-)
75%doc CHANGES
76%doc CONTRIBUTORS
77%doc COPYING
78%doc README
79%{_libdir}/libgtest.so.*
80%{_libdir}/libgtest_main.so.*
81
82%files devel
83%defattr(-,root,root,-)
84%doc samples
85%{_bindir}/%{name}-config
86%{_datadir}/aclocal/%{name}.m4
87%{_libdir}/libgtest.so
88%{_libdir}/libgtest_main.so
89
90%dir %{_includedir}/%{name}
91%{_includedir}/%{name}/*.h
92%{_includedir}/%{name}/internal
93
94%changelog
95* Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-2
96- rebuilt with rpm-4.8.1 for pkg-config
97
98* Sun May 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-1
99- initial build for VineSeed
100
101* Sat Nov 14 2009 Debarshi Ray <rishi@fedoraproject.org> - 1.4.0-1
102- Version bump to 1.4.0.
103  * New feature: the event listener API.
104  * New feature: test shuffling.
105  * New feature: the XML report format is closer to junitreport and can
106    be parsed by Hudson now.
107  * New feature: elapsed time for the tests is printed by default.
108  * New feature: comes with a TR1 tuple implementation such that Boost
109    is no longer needed for Combine().
110  * New feature: EXPECT_DEATH_IF_SUPPORTED macro and friends.
111  * New feature: the Xcode project can now produce static gtest libraries in
112    addition to a framework.
113  * Compatibility fixes for gcc and minGW.
114  * Bug fixes and implementation clean-ups.
115
116* Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 1.3.0-2.20090601svn257
117- Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
118
119* Mon Jun 01 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.3.0-1
120- Version bump to 1.3.0.
121  * New feature: ability to use Google Test assertions in other testing
122    frameworks.
123  * New feature: ability to run disabled test via
124    --gtest_also_run_disabled_tests.
125  * New feature: the --help flag for printing the usage.
126  * New feature: access to Google Test flag values in user code.
127  * New feature: a script that packs Google Test into one .h and one .cc file
128    for easy deployment.
129  * New feature: support for distributing test functions to multiple machines
130    (requires support from the test runner).
131  * Bug fixes and implementation clean-ups.
132
133* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
134- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
135
136* Sat Jul 05 2008 Debarshi Ray <rishi@fedoraproject.org> - 1.0.0-1
137- Initial build.
Note: See TracBrowser for help on using the repository browser.