source: projects/specs/branches/6/g/gstreamer/gstreamer-vl.spec @ 2547

Revision 2547, 15.3 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1# keep in sync with the VERSION.  gstreamer can append a .0.1 to CVS snapshots.
2%define major           0.10
3
4%define _glib2_ver      2.20.0
5%define _libxml2_ver    2.6.15
6%define _gtk_doc_ver    1.3
7%define _check_ver      0.9.2
8%define _python_ver     2.1
9
10%define po_package      %{name}-%{major}
11
12%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
13
14Name:           gstreamer
15Summary:        GStreamer streaming media framework runtime.
16Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
17Version:        0.10.32
18Release:        1%{?_dist_release}
19
20Group:          System Environment/Libraries
21License:        LGPL
22URL:            http://gstreamer.freedesktop.org/
23Source:         http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.bz2
24
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26BuildRequires:  glib2-devel >= %{_glib2_ver}
27BuildRequires:  libxml2-devel >= %{_libxml2_ver}
28BuildRequires:  bison
29BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
30BuildRequires:  flex
31BuildRequires:  ghostscript
32BuildRequires:  check >= %{_check_ver}
33BuildRequires:  python >= %{_python_ver}, python-pyxml
34BuildRequires:  gobject-introspection-devel
35Requires:       glib2 >= %{_glib2_ver}
36Requires:       libxml2 >= %{_libxml2_ver}
37Obsoletes:      gstreamer-tools
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41Packager:       inagaki
42
43%description
44GStreamer is a streaming-media framework, based on graphs of filters which
45operate on media data. Applications using this library can do anything
46from real-time sound processing to playing videos, and just about anything
47else media-related.  Its plugin-based architecture means that new data
48types or processing capabilities can be added simply by installing new
49plugins.
50
51%package devel
52Summary:        Libraries/header files for GStreamer streaming media framework.
53Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
54Group:          Development/Libraries
55Requires:       %{name} = %{version}-%{release}
56Requires:       glib2-devel >= %{_glib2_ver}
57Requires:       libxml2-devel >= %{_libxml2_ver}
58
59%description devel
60GStreamer is a streaming-media framework, based on graphs of filters which
61operate on media data. Applications using this library can do anything
62from real-time sound processing to playing videos, and just about anything
63else media-related.  Its plugin-based architecture means that new data
64types or processing capabilities can be added simply by installing new   
65plugins.
66
67This package contains the libraries and includes files necessary to develop
68applications and plugins for GStreamer.
69
70# compat32
71%package -n compat32-%{name}
72Summary:        GStreamer streaming media framework runtime.
73Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
74Group:          System Environment/Libraries
75
76%description -n compat32-%{name}
77GStreamer is a streaming-media framework, based on graphs of filters which
78operate on media data. Applications using this library can do anything
79from real-time sound processing to playing videos, and just about anything
80else media-related.  Its plugin-based architecture means that new data
81types or processing capabilities can be added simply by installing new
82plugins.
83
84%package -n compat32-%{name}-devel
85Summary:        Libraries/header files for GStreamer streaming media framework.
86Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
87Group:          Development/Libraries
88Requires:       compat32-%{name} = %{version}-%{release}
89Requires:       %{name}-devel = %{version}-%{release}
90Requires:       compat32-glib2-devel >= %{_glib2_ver}
91Requires:       compat32-libxml2-devel >= %{_libxml2_ver}
92
93%description -n compat32-%{name}-devel
94GStreamer is a streaming-media framework, based on graphs of filters which
95operate on media data. Applications using this library can do anything
96from real-time sound processing to playing videos, and just about anything
97else media-related.  Its plugin-based architecture means that new data
98types or processing capabilities can be added simply by installing new   
99plugins.
100
101This package contains the libraries and includes files necessary to develop
102applications and plugins for GStreamer.
103
104%prep
105%setup -q
106
107%build
108%configure \
109        --with-package-name='Vine Linux gstreamer package' \
110        --with-cachedir=%{_var}/cache/gstreamer-%{major} \
111        --enable-introspection=yes \
112        --disable-docbook --enable-gtk-doc \
113        --disable-static --disable-examples \
114        --disable-tests --disable-debug
115
116make %{?_smp_mflags}
117
118%install
119[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
120
121make install DESTDIR=$RPM_BUILD_ROOT
122
123mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
124
125rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
126rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
127#rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
128
129%find_lang %{po_package}
130
131%clean
132[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
133
134%post -p /sbin/ldconfig
135
136%postun -p /sbin/ldconfig
137
138%post -n compat32-%{name} -p /sbin/ldconfig
139
140%postun -n compat32-%{name} -p /sbin/ldconfig
141
142%files -f %{po_package}.lang
143%defattr(-, root, root)
144%doc AUTHORS ChangeLog COPYING README NEWS RELEASE
145%doc TODO ABOUT-NLS
146%{_bindir}/*
147%dir %{_libdir}/gstreamer-%{major}
148%{_libdir}/gstreamer-%{major}/*.so*
149%{_libdir}/*.so.*
150%{_libdir}/girepository-1.0/*.typelib
151%dir %{_libexecdir}/gstreamer-%{major}
152%{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
153%{_mandir}/man1/*
154%dir %{_var}/cache/gstreamer-%{major}
155
156%files devel
157%defattr(-, root, root)
158%dir %{_includedir}/%{name}-%{major}
159%{_includedir}/%{name}-%{major}/*
160#{_libdir}/*.a
161%{_libdir}/*.so
162%{_libdir}/pkgconfig/gstreamer*.pc
163%{_datadir}/aclocal/*.m4
164%{_datadir}/gtk-doc/html/gstreamer-%{major}
165%{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
166%{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
167%{_datadir}/gir-1.0/*.gir
168
169# compat32
170%if %{build_compat32}
171%files -n compat32-%{name}
172%defattr(-, root, root)
173%dir %{_libdir}/gstreamer-%{major}
174%{_libdir}/gstreamer-%{major}/*.so*
175%{_libdir}/*.so.*
176
177%files -n compat32-%{name}-devel
178%defattr(-, root, root)
179#{_libdir}/*.a
180%{_libdir}/*.so
181%{_libdir}/pkgconfig/gstreamer*.pc
182%endif
183
184%changelog
185* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.32-1
186- new upstream release
187
188* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.31-1
189- new upstream release
190
191* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.30.2-1
192- new upstream release
193- add BuildRequires: gobject-introspection-devel
194- add configure option (--enable-introspection=yes)
195- fix %files
196
197* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.10.30-2
198- build with rpm-4.8.1-1 for pkg-config file
199
200* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.30-1
201- new upstream release
202
203* Sat May 01 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.29-1
204- new upstream release
205
206* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
207- new upstream release
208- used make install instead of %%makeinstall
209
210* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
211- new upstream release
212- built with new toolchain
213
214* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
215- new upstream release
216
217* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
218- new upstream release
219
220* Sat May 16 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.10.23-2
221- added compat32 package for x86_64 arch support
222
223* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
224- new upstream release
225- removed static librairies from devel package
226- added Packager tag
227
228* Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
229- new upstream release
230- changed Group to System Environment/Libraries
231
232* Wed Oct  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1vl5
233- new upstream release
234- spec in UTF-8
235
236* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1vl5
237- new upstream release
238
239* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
240- new upstream release
241
242* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
243- new upstream release
244
245* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
246- new upstream release
247
248* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
249- new upstream release
250
251* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
252- new upstream release
253
254* Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
255- new upstream release
256- add Vendor/Distribution tag
257- add '-with-package-name' option to %%configure
258- use more macros
259
260* Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
261- new upstream release
262
263* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
264- new upstream release
265
266* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
267- new upstream release
268
269* Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
270- new upstream release
271
272* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.6-0vl1
273- new upstream release
274
275* Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.comp> 0.10.5-0vl1
276- new upstream release
277
278* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
279- new upstream release
280
281* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
282- new upstream release
283
284* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
285- new upstream release
286
287* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
288- new upstream release
289  - change major to 0.10
290- update URLs
291- update versions: glibc >= 2.8, gtk-doc >= 1.3
292- add BuildRequires: check >= 0.9.2, python >= 2.1, python-pyxml
293- remove from BuildRequires: popt, zlib-devel
294- remove obsolete options from %%configure
295- add --enable-gtk-doc to %%configure
296- add gtk-doc/html/gstreamer-* to gstreamer-devel package
297- add RELEASE to %%doc
298- remove REQUIREMENTS DOCBUILDING from %%doc
299- not exec gst-register-%%{major} at %%post
300
301* Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
302- new upstream release
303
304* Thu May  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
305- new upstream release
306
307* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
308- new upstream release
309- removed dependancy related to documentaion build
310
311* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
312- new upstream release
313
314* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
315- new upstream release
316
317* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
318- update alpha-noWerror patch (Patch10)
319
320* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
321- new upstream release
322
323* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
324- new upstream release
325
326* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
327- new upstream release
328
329* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
330- build without -Werror on alpha (Patch10)
331
332* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
333- new upstream release
334
335* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
336- merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
337
338* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
339- fix broken %files entries..
340
341* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
342- new upstream release
343
344* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
345- build for Vine Linux
346
347* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
348- Add patch1 to fix C++ plugins on ia64
349
350* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
351- %post -p was wrong
352
353* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
354- explicitly add %{_libdir}/libgstreamer-{major}.so
355- explicitly add %{_libdir}/libgstcontrol-{major}.so
356
357* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
358- bump release
359
360* Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
361- move .so files out of -devel
362
363* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
364- new version 0.5.0
365- require docbook-style-xsl
366- add gstreamer-tools package too
367- New patch to use the right docbook prefix.
368
369* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
370- downgrade to a release candidate.  Should work better on other arches
371- build without Werror
372
373* Mon Dec  9 2002 Jonathan Blandford <jrb@redhat.com>
374- update to new version.  Remove ExcludeArch
375
376* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
377- excludearch some arches
378
379* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
380- import into CVS and build "officially"
381- use smp_mflags
382- temporarily disable docs build, doesn't seem to work
383
384* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
385- 0.4.2
386
387* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
388- 0.4.1
389
390* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
391- minor cleanups
392
393* Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
394- moved header location
395
396* Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
397- added popt
398- removed .la
399
400* Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
401- added release of gstreamer to req of gstreamer-devel
402- changed location of API docs to be in gtk-doc like other gtk-doc stuff
403- reordered SPEC file
404
405* Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
406- moved html docs to gtk-doc standard directory
407
408* Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
409- move version defines of glib2 and libxml2 to configure.ac
410- add BuildRequires for these two libs
411
412* Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
413- put html docs in canonical place, avoiding %doc erasure
414- added devhelp support, current install of it is hackish
415
416* Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
417- Added documentation to build
418
419* Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
420- added libgstbasicscheduler
421- renamed libgst to libgstreamer
422
423* Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
424- Added configdir parameter as it seems the configdir gets weird otherwise
425
426* Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
427- split off gstreamer-editor from core
428- removed gstreamer-gnome-apps
429
430* Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
431- Cleaned up the spec file for the gstreamer core/plug-ins split
432- Improve spec file
433
434* Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
435- Split of more plugins from the core and put them into their own modules
436- Includes colorspace, xfree and wav
437- Improved package Require lines
438- Added mp3encode (lame based) to the SPEC
439
440* Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
441- Thomas merged mpeg plugins into one
442* Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
443- More minor cleanups including some fixed descriptions from Andrew Mitchell
444
445* Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
446- Added logging to the make statement
447
448* Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
449- Updated in preparation for 0.3.0 release
450
451* Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
452- Updated for 0.2.1 release
453- Split out the GUI packages into their own RPM
454- added new plugins (FLAC, festival, quicktime etc.)
455
456* Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
457- Visualisation plugins bundled out togheter
458- Moved files sections up close to their respective descriptions
459
460* Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
461- Split the package into separate RPMS,
462  putting most plugins out by themselves.
463
464* Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
465- Updated with change suggestions from Dennis Bjorklund
466
467* Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
468- updated to build -devel package as well
469
470* Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
471- first draft of spec file
472
Note: See TracBrowser for help on using the repository browser.