source: projects/specs/branches/6/g/gsoap/gsoap-vl.spec @ 1985

Revision 1985, 10.4 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1Summary: Generator Tools for Coding SOAP/XML Web Services in C and C++
2Name: gsoap
3Version: 2.7.12
4Release: 2%{?_dist_release}
5License: GPLv2+
6Group: Development/Tools
7URL: http://gsoap2.sourceforge.net
8Source0: http://downloads.sourceforge.net/gsoap2/gsoap_2.7.12.tar.gz
9Patch0: use_libtool-2.7.12.patch
10Patch1: unused_args.patch
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12
13BuildRequires: flex
14BuildRequires: bison
15BuildRequires: findutils
16BuildRequires: nkf
17BuildRequires: openssl-devel
18BuildRequires: autoconf
19BuildRequires: automake
20BuildRequires: libtool
21
22Requires: openssl
23
24
25%description
26The gSOAP Web services development toolkit offers an XML to C/C++
27language binding to ease the development of SOAP/XML Web services in C
28and C/C++.
29
30
31%package devel
32Summary: Devel libraries and headers for linking with gSOAP generated stubs
33Group: Development/System
34Requires: %name = %version-%release
35Requires: pkgconfig
36
37
38%description devel
39gSOAP libraries, headers and generators for linking with and creating
40gSOAP generated stubs
41
42
43%prep
44%setup -q -n gsoap-2.7
45
46# enable use of libtool in configure.in and a few Makefile.am files
47%patch0 -p1
48
49%patch1 -p1
50
51# a number of ~ files are distribute, but we do not want them
52find . -name "*~" -exec rm {} \;
53
54# we want all txt files to have unix end-of-line encoding
55nkf --unix --in-place README.txt LICENSE.txt NOTES.txt
56
57
58%build
59# patches change autoconf and automake files, so we must reconfigure
60autoreconf --install --force
61
62%configure --disable-static --prefix=/usr
63
64# dependencies are not declared properly
65#make %{?_smp_mflags}
66make
67
68# during the build a number of files that we should not distribute are
69# created in soapcpp2/samples/ (a doc directory), we must remove them
70#find soapcpp2/samples/ -name ".deps" -prune -exec rm -rf {} \;
71
72# we do not want to bother distributing samples for Windows or OS X
73#rm -rf soapcpp2/samples/magic_VC
74#rm -rf soapcpp2/samples/quote_VC
75#rm -rf soapcpp2/samples/quote_MAC_ProjBuild
76
77# samples do not need to be executable by default
78#chmod a-x soapcpp2/samples/ssl/root.sh
79#chmod a-x soapcpp2/samples/ssl/cacerts.pem
80
81
82%install
83rm -rf %{buildroot}
84make install DESTDIR=%{buildroot}
85rm -f %{buildroot}/%_libdir/*.la
86
87
88%clean
89rm -rf %{buildroot}
90
91
92%check
93make check
94
95
96%files
97%defattr(-,root,root,-)
98%doc README.txt NOTES.txt LICENSE.txt
99%_libdir/libgsoapck.so.0
100%_libdir/libgsoapck++.so.0
101%_libdir/libgsoapck.so.0.0.0
102%_libdir/libgsoapck++.so.0.0.0
103%_libdir/libgsoap.so.0
104%_libdir/libgsoap++.so.0
105%_libdir/libgsoap.so.0.0.0
106%_libdir/libgsoap++.so.0.0.0
107%_libdir/libgsoapssl.so.0
108%_libdir/libgsoapssl++.so.0
109%_libdir/libgsoapssl.so.0.0.0
110%_libdir/libgsoapssl++.so.0.0.0
111
112
113%files devel
114%defattr(-,root,root,-)
115%doc README.txt NOTES.txt LICENSE.txt
116%_bindir/soapcpp2
117%_bindir/wsdl2h
118%_libdir/libgsoapck.so
119%_libdir/libgsoapck++.so
120%_libdir/libgsoap.so
121%_libdir/libgsoapssl.so
122%_libdir/libgsoapssl++.so
123%_libdir/libgsoap++.so
124%_includedir/stdsoap2.h
125%dir %_datadir/gsoap
126%dir %_datadir/gsoap/import
127%_datadir/gsoap/import/c14n.h
128%_datadir/gsoap/import/dom.h
129%_datadir/gsoap/import/ds2.h
130%_datadir/gsoap/import/ds.h
131%_datadir/gsoap/import/README.txt
132%_datadir/gsoap/import/soap12.h
133%_datadir/gsoap/import/stldeque.h
134%_datadir/gsoap/import/stl.h
135%_datadir/gsoap/import/stllist.h
136%_datadir/gsoap/import/stlset.h
137%_datadir/gsoap/import/stlvector.h
138%_datadir/gsoap/import/wsa3.h
139%_datadir/gsoap/import/wsa4.h
140%_datadir/gsoap/import/wsa5.h
141%_datadir/gsoap/import/wsa.h
142%_datadir/gsoap/import/WS-example.c
143%_datadir/gsoap/import/WS-example.h
144%_datadir/gsoap/import/WS-Header.h
145%_datadir/gsoap/import/wsp.h
146%_datadir/gsoap/import/wsrp.h
147%_datadir/gsoap/import/wsse2.h
148%_datadir/gsoap/import/wsse.h
149%_datadir/gsoap/import/wsu.h
150%_datadir/gsoap/import/xlink.h
151%_datadir/gsoap/import/xmime4.h
152%_datadir/gsoap/import/xmime5.h
153%_datadir/gsoap/import/xmime.h
154%_datadir/gsoap/import/xml.h
155%_datadir/gsoap/import/xmlmime5.h
156%_datadir/gsoap/import/xmlmime.h
157%_datadir/gsoap/import/xop.h
158%dir %_datadir/gsoap/WS
159%_datadir/gsoap/WS/README.txt
160%_datadir/gsoap/WS/WS-Addressing.xsd
161%_datadir/gsoap/WS/WS-Addressing03.xsd
162%_datadir/gsoap/WS/WS-Addressing04.xsd
163%_datadir/gsoap/WS/WS-Addressing05.xsd
164%_datadir/gsoap/WS/WS-Discovery.wsdl
165%_datadir/gsoap/WS/WS-Enumeration.wsdl
166%_datadir/gsoap/WS/WS-Policy.xsd
167%_datadir/gsoap/WS/WS-Routing.xsd
168%_datadir/gsoap/WS/WS-typemap.dat
169%_datadir/gsoap/WS/discovery.xsd
170%_datadir/gsoap/WS/ds.xsd
171%_datadir/gsoap/WS/enumeration.xsd
172%_datadir/gsoap/WS/typemap.dat
173%_datadir/gsoap/WS/wsse.xsd
174%_datadir/gsoap/WS/wsu.xsd
175%dir %_datadir/gsoap/custom
176%_datadir/gsoap/custom/README.txt
177%_datadir/gsoap/custom/long_double.c
178%_datadir/gsoap/custom/long_double.h
179%_datadir/gsoap/custom/struct_timeval.c
180%_datadir/gsoap/custom/struct_timeval.h
181%_datadir/gsoap/custom/struct_tm.c
182%_datadir/gsoap/custom/struct_tm.h
183%dir %_datadir/gsoap/extras
184%_datadir/gsoap/extras/README.txt
185%_datadir/gsoap/extras/ckdb.c
186%_datadir/gsoap/extras/ckdb.h
187%_datadir/gsoap/extras/ckdbtest.c
188%_datadir/gsoap/extras/ckdbtest.h
189%_datadir/gsoap/extras/fault.cpp
190%_datadir/gsoap/extras/logging.cpp
191%_datadir/gsoap/extras/soapdefs.h
192%dir %_datadir/gsoap/plugin
193%_datadir/gsoap/plugin/README.txt
194%_datadir/gsoap/plugin/cacerts.c
195%_datadir/gsoap/plugin/cacerts.h
196%_datadir/gsoap/plugin/httpda.c
197%_datadir/gsoap/plugin/httpda.h
198%_datadir/gsoap/plugin/httpdatest.c
199%_datadir/gsoap/plugin/httpdatest.h
200%_datadir/gsoap/plugin/httpform.c
201%_datadir/gsoap/plugin/httpform.h
202%_datadir/gsoap/plugin/httpget.c
203%_datadir/gsoap/plugin/httpget.h
204%_datadir/gsoap/plugin/httpgettest.c
205%_datadir/gsoap/plugin/httpgettest.h
206%_datadir/gsoap/plugin/httpmd5.c
207%_datadir/gsoap/plugin/httpmd5.h
208%_datadir/gsoap/plugin/httpmd5test.c
209%_datadir/gsoap/plugin/httpmd5test.h
210%_datadir/gsoap/plugin/httppost.c
211%_datadir/gsoap/plugin/httppost.h
212%_datadir/gsoap/plugin/logging.c
213%_datadir/gsoap/plugin/logging.h
214%_datadir/gsoap/plugin/md5evp.c
215%_datadir/gsoap/plugin/md5evp.h
216%_datadir/gsoap/plugin/plugin.c
217%_datadir/gsoap/plugin/plugin.h
218%_datadir/gsoap/plugin/smdevp.c
219%_datadir/gsoap/plugin/smdevp.h
220%_datadir/gsoap/plugin/threads.c
221%_datadir/gsoap/plugin/threads.h
222%_datadir/gsoap/plugin/wsaapi.c
223%_datadir/gsoap/plugin/wsaapi.h
224%_datadir/gsoap/plugin/wsse2api.c
225%_datadir/gsoap/plugin/wsse2api.h
226%_datadir/gsoap/plugin/wsseapi.c
227%_datadir/gsoap/plugin/wsseapi.h
228%_libdir/pkgconfig/gsoapck.pc
229%_libdir/pkgconfig/gsoapck++.pc
230%_libdir/pkgconfig/gsoap.pc
231%_libdir/pkgconfig/gsoap++.pc
232%_libdir/pkgconfig/gsoapssl.pc
233%_libdir/pkgconfig/gsoapssl++.pc
234# Additions in 2.7.12-1
235%_datadir/gsoap/WS/WS-ReliableMessaging.wsdl
236%_datadir/gsoap/WS/WS-ReliableMessaging.xsd
237%_datadir/gsoap/WS/reference-1.1.xsd
238%_datadir/gsoap/WS/ws-reliability-1.1.xsd
239%_datadir/gsoap/import/ref.h
240%_datadir/gsoap/import/wsrm.h
241%_datadir/gsoap/import/wsrm4.h
242%_datadir/gsoap/import/wsrx.h
243
244
245%post -p /sbin/ldconfig
246
247
248%postun -p /sbin/ldconfig
249
250
251%changelog
252* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.7.12-2
253- rebuilt with rpm-4.8.1 for pkg-config
254
255* Sat May 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.12-1
256- initial build for Vine Linux
257
258* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.12-3
259- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
260
261* Fri Jan 16 2009 Tomas Mraz <tmraz@redhat.com> - 2.7.12-2
262- rebuild with new openssl
263
264* Wed Dec 24 2008  <matt@redhat> - 2.7.12-1
265- Updated to gsoap 2.7.12:
266-  Numerous bug fixes - xml:lang, maxOccurs="unbounded", SSL, xmlns="", ...
267-  New features, maintaining backward compatibility - MinGW, wsseapi, multi-endpoint connect, ...
268- Patches removed (incorporated upstream):
269-  datadir_importpath-2.7.10.patch
270-  install_soapcpp2_wsdl2h_aux-2.7.10.patch
271-  no_locale.patch as default off, enable by defining WITH_C_LOCALE
272- Patches added (sent upstream):
273-  unused_args.patch - eliminate many unused param warnings
274
275* Thu Feb 21 2008  <mfarrellee@redhat> - 2.7.10-4
276- Applied upd patch from upstream. It fixes glibc C locale issues,
277  hp-ux h_errno definition, and xsd:dateTime timezone processing for
278  WS-I
279- Removed tru64_hp_ux patches, they are present in upstream's upd
280  patch
281- Added no_locale.patch to stop configure from checking for locale
282  version of functions
283
284* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.7.10-3
285- Autorebuild for GCC 4.3
286
287* Mon Feb 18 2008  <mfarrellee@redhat> - 2.7.10-2
288- Removed --disable-namespaces from configure, result is code compiled
289  against gsoap does not need to call set_soap_namespaces
290
291* Sun Jan 27 2008  <mfarrellee@redhat> - 2.7.10-1
292- Upgraded to 2.7.10 release
293- Stopped hosting patches on grid.et.redhat.com
294- Removed import_dom_h patch, it was integrated
295- Removed large autotools patch, replaced with patch
296  (use_libtool-2.7.10.patch) changing configure.in, gsoap/Makefile.am
297  and gsoap/wsdl/Makefile.am, which enable libtool use, and a
298  call to autoreconf
299- Changed soapcpp2 references to gsoap as per new layout of source
300  distribution
301- Updated tru64_hp_up_c/pp patches to handle new source layout
302- Install of soapcpp2/import with cp removed in favor of a patch to
303  gsoap/Makefile.am (install_soapcpp2_wsdl2h_aux-2.7.10.patch)
304- No pre-generated Makefiles are distributed, no longer removing them
305- stdsoap2_cpp.cpp not in distribution, no longer removing it
306- Added datadir_importpath-2.7.10.patch to set SOAPCPP2_IMPORT_PATH
307  and WSDL2H_IMPORT_PATH, useful defaults, using ${datadir} instead of
308  `pwd`
309- Added autoconf, automake and libtool to BuildRequires, because
310  configure.in and gsoap/Makefile.am are patched
311- Added ?dist to Release
312
313* Fri Nov 30 2007  <mfarrellee@redhat> - 2.7.9-0.4.l
314- Added OpenSSL requirement
315
316* Tue Nov 27 2007  <mfarrellee@redhat> - 2.7.9-0.3.l
317- Decided soapcpp2/import/ files should be in /usr/share instead of
318  /usr/include because they are not really headers gcc can
319  process. Also, this is likely the location new versions of gsoap
320  will install the import headers. People should use -I
321  /usr/share/gsoap/import
322
323* Mon Nov 26 2007  <mfarrellee@redhat> - 2.7.9-0.2.l
324- Changed license tag to GPLv2+, which is more accurate
325- Resolved bz399761 by adding soapcpp2/import/*.h to the -devel
326  package as /usr/include/gsoap, users will need to add -I
327  /usr/include/gsoap to their soapcpp2 line
328
329* Sun Sep 30 2007  <mfarrellee@redhat> - 2.7.9-0.1.l
330- Updated to 2.7.9l (2.7.9k patches still apply)
331- Added patch for import/dom.h missing xsd__anyAttribute definitions
332- Removed removal of .deps directories and autom4te.cache
333
334* Mon Sep 24 2007  <mfarrellee@redhat> - 2.7.9-0.2.k
335- Moved pkgconfig requirement to -devel package
336
337* Tue Sep 11 2007  <mfarrellee@redhat> - 2.7.9-0.1.k
338- Initial release
339
Note: See TracBrowser for help on using the repository browser.