source: projects/specs/branches/6/g/gsm/gsm-vl.spec @ 3495

Revision 3495, 6.5 KB checked in by inagaki, 13 years ago (diff)

update: gnuchess, gsm

Line 
1Summary:        Shared libraries for GSM speech compressor
2
3Name:           gsm
4Version:        1.0.12
5Release:        2%{?_dist_release}
6
7Group:          System Environment/Libraries
8License:        MIT
9URL:            http://kbs.cs.tu-berlin.de/~jutta/toast.html
10
11Source:         http://kbs.cs.tu-berlin.de/~jutta/gsm/%{name}-%{version}.tar.gz
12Patch0:         %{name}-makefile.patch
13Patch1:         %{name}-warnings.patch
14Patch2:         %{name}-64bit.patch
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16
17%define srcver 1.0-pl12
18
19%description
20Contains runtime shared libraries for libgsm, an implementation of
21the European GSM 06.10 provisional standard for full-rate speech
22transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
23excitation/long term prediction) coding at 13 kbit/s.
24
25GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
26rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
27with typical UNIX applications, our implementation turns frames of 160
2816-bit linear samples into 33-byte frames (1650 Bytes/s).
29The quality of the algorithm is good enough for reliable speaker
30recognition; even music often survives transcoding in recognizable
31form (given the bandwidth limitations of 8 kHz sampling rate).
32
33The interfaces offered are a front end modelled after compress(1), and
34a library API.  Compression and decompression run faster than realtime
35on most SPARCstations.  The implementation has been verified against the
36ETSI standard test patterns.
37
38%package        tools
39Summary:        GSM speech compressor tools
40Group:          Applications/Multimedia
41
42%description    tools
43Contains command line utilities for libgsm, an implementation of
44the European GSM 06.10 provisional standard for full-rate speech
45transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
46excitation/long term prediction) coding at 13 kbit/s.
47
48%package        devel
49Summary:        Header files and development libraries for libgsm
50Group:          Development/Libraries
51Requires:       %{name} = %{version}-%{release}
52
53%description    devel
54Contains header files and development libraries for libgsm, an
55implementation of the European GSM 06.10 provisional standard for
56full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
57(residual pulse excitation/long term prediction) coding at 13 kbit/s.
58
59%prep
60%setup -n gsm-%{srcver} -q
61%patch0 -p1 -b .mk
62%patch1 -p1 -b .warn
63%patch2 -p1 -b .64bit
64
65%build
66export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC";
67make %{?_smp_mflags} all
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72mkdir -p $RPM_BUILD_ROOT%{_bindir}
73mkdir -p $RPM_BUILD_ROOT%{_includedir}/gsm
74mkdir -p $RPM_BUILD_ROOT%{_libdir}
75mkdir -p $RPM_BUILD_ROOT%{_mandir}/{man1,man3}
76
77make install \
78        INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix} \
79        GSM_INSTALL_INC=$RPM_BUILD_ROOT%{_includedir}/gsm \
80        GSM_INSTALL_LIB=$RPM_BUILD_ROOT%{_libdir}
81
82cp -p $RPM_BUILD_DIR/gsm-%{srcver}/lib/libgsm.so.%{version} $RPM_BUILD_ROOT%{_libdir}
83ln -s libgsm.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgsm.so.1
84ln -s libgsm.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgsm.so
85
86# some apps look for this in /usr/include
87ln -s gsm/gsm.h $RPM_BUILD_ROOT%{_includedir}
88
89rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
90
91
92%check
93# This is to ensure that the patch creates the proper library version.
94[ -f $RPM_BUILD_ROOT%{_libdir}/libgsm.so.%{version} ]
95make addtst
96
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post -p /sbin/ldconfig
102
103%postun -p /sbin/ldconfig
104
105%files
106%defattr(-,root,root,-)
107%doc ChangeLog COPYRIGHT MACHINES README
108%{_libdir}/libgsm.so.*
109
110%files tools
111%{_bindir}/tcat
112%{_bindir}/toast
113%{_bindir}/untoast
114%{_mandir}/man1/toast.1*
115
116%files devel
117%defattr(-,root,root,-)
118%dir %{_includedir}/gsm
119%{_includedir}/gsm/gsm.h
120%{_includedir}/gsm.h
121%{_libdir}/libgsm.so
122%{_mandir}/man3/*
123
124%changelog
125* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-2
126- rebuilt with current VineSeed
127
128* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
129- initial build for Vine Linux
130
131* Mon Feb 11 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.0.12-6
132- Rebuild for GCC 4.3
133
134* Sun Aug 26 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-5
135- install symlinks instead of binaries in -devel
136
137* Sat Aug 25 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-4
138- rebuild for BuildID
139- specfile cleanups
140
141* Sun May 13 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-3
142- fix parallel make
143
144* Fri May 11 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-2
145- fix some warnings
146- fix 64bit testsuite issue as described at gsm homepage
147- add compatibility header symlink
148- split off binaries into a separate package
149
150* Sun Apr 15 2007 Michael Schwendt <mschwendt[AT]users.sf.net> 1.0.12-1
151- Update to Release 1.0 Patchlevel 12.
152- Build with -fPIC not just for non-ix86.
153- Add check section to ensure proper library version.
154- Remove static library.
155
156* Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.0.10-12
157- rebuilt for unwind info generation, broken in gcc-4.1.1-21
158
159* Tue Sep 26 2006 Thomas Vander Stichele <thomas at apestaart dot org>
160- 1.0.10-11
161- rebuild for FC6
162
163* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
164- switch to new release field
165
166* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
167- add dist
168
169* Mon Jun 27 2005 David Woodhouse <dwmw2@infradead.org>
170- 1.0.10-0.lvn.10: Clean up installation
171
172* Sat Jun 25 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
173- 1.0.10-0.lvn.9: mv libgsm.a only when needed
174
175* Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
176- 1.0.10-0.lvn.8: Use -fPIC on non ix86
177
178* Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
179- 1.0.10-0.lvn.7: moved to rpm.livna.org
180
181* Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
182- 1.0.10-0.fdr.7: applied patch from Ville, remove epoch since it's allowed
183
184* Sat Sep 13 2003 Thomas Vander Stichele <thomas at apestaart dot org>
185- 0:1.0.10-0.fdr.6: remove second makeinstall
186
187* Sun Sep 07 2003 Thomas Vander Stichele <thomas at apestaart dot org>
188- 0:1.0.10-0.fdr.5
189- added back epochs, I surrender
190- fix RPM_OPT_FLAGS hackery
191
192* Fri Jul 18 2003 Thomas Vander Stichele <thomas at apestaart dot org>
193- 1.0.10-0.fdr.4: remove epoch mentions
194
195* Sat Jul 05 2003 Thomas Vander Stichele <thomas at apestaart dot org>
196- 1.0.10-0.fdr.3
197- pull in RPM_OPT_FLAGS in patch instead of using perl to wedge it in
198- fix group
199- -p'ize ldconfig
200
201* Tue Jun 10 2003 Thomas Vander Stichele <thomas at apestaart dot org>
202- 1.0.10-0.fdr.2
203- Fix libgsm.so.* being files instead of symlinks
204
205* Thu May 29 2003 Thomas Vander Stichele <thomas at apestaart dot org>
206- 0:1.0.10-0.fdr.1: initial RPM release
Note: See TracBrowser for help on using the repository browser.