source: projects/specs/branches/6/g/grep/grep-vl.spec @ 7739

Revision 7739, 12.1 KB checked in by Takemikaduchi, 11 years ago (diff)

rebuild packages & security fix

Line 
1Summary: The GNU versions of grep pattern matching utilities.
2Summary(ja): GNU版 grep パターンマッチングユーティリティ
3Name: grep
4Version: 2.7
5Release: 2%{?_dist_release}
6
7License: GPLv3+
8Group: System Environment/Base
9URL: http://www.gnu.org/software/grep/
10
11Source: ftp://ftp.gnu.org/pub/gnu/grep/grep-%{version}.tar.xz
12Source1: colorgrep.sh
13Source2: colorgrep.csh
14Source3: GREP_COLORS
15Patch0: grep-2.7-const-range-exp.patch
16Patch1: grep-2.7-mem-exhausted.patch
17
18Requires(post): install-info
19Requires(preun): install-info
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: pcre-devel, texinfo, gettext, gzip
22
23%description
24The GNU versions of commonly used grep utilities.  Grep searches
25through textual input for lines which contain a match to a specified
26pattern and then prints the matching lines.  GNU's grep utilities
27include grep, egrep and fgrep.
28
29You should install grep on your system, because it is a very useful
30utility for searching through text.
31
32%description -l ja
33一般に使われるgrepユーティリティのGNU版です。Grep は指定したパターンと一致
34する行を入力ファイルから捜し出して、その行を表示します。GNUのgrepユーティリ
35ティにはgrep, egrep, fgrepが入っています。
36
37テキストファイルの検索や、システム管理にとても役に立つので、是非インストール
38してください。
39
40%prep
41%setup -q
42%patch0 -p1 -b .const-range-exp
43%patch1 -p1 -b .cve-2012-5667
44
45%build
46%configure CPPFLAGS="-I%{_includedir}/pcre" \
47        --without-included-regex
48%__make %{?_smp_mflags}
49
50%install
51[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
52%__make DESTDIR=$RPM_BUILD_ROOT install
53gzip $RPM_BUILD_ROOT%{_infodir}/grep*
54rm -f $RPM_BUILD_ROOT%{_infodir}/dir
55mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
56install -pm 644 %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
57install -pm 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
58mkdir -p $RPM_BUILD_ROOT/bin
59mv $RPM_BUILD_ROOT%{_prefix}/bin/* $RPM_BUILD_ROOT/bin/
60rm -rf $RPM_BUILD_ROOT%{_bindir}
61
62
63%find_lang %{name}
64
65%check
66make check
67
68%clean
69[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
70
71%post
72[ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/grep.info.gz || :
73
74%preun
75if [ $1 = 0 ]; then
76        [ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/grep.info.gz
77fi
78
79%files -f %{name}.lang
80%defattr(-,root,root)
81%doc ABOUT-NLS AUTHORS THANKS TODO NEWS README ChangeLog COPYING
82/bin/*
83%config(noreplace) %{_sysconfdir}/profile.d/colorgrep.*sh
84%config(noreplace) %{_sysconfdir}/GREP_COLORS
85%{_infodir}/*.info.gz
86%{_mandir}/*/*
87
88%changelog
89* Sat Jul 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7-2
90- add Patch1 (grep-2.7-mem-exhausted.patch)
91   (including security fix for CVE-2012-5667)
92
93* Tue Feb 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
94- new upstream release
95- drop unneeded old patches
96- add BR: pcre-devel
97
98* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-60
99- rebuilt against current toolchain
100- fix license tag
101- use CPPFLAGS= argument to configure to add an -I option.
102- Do not set LDFLAGS=-s for "make install".
103
104* Wed Sep 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-57
105- rebuilt for VineSeed (previous version in VineSeed was 2.5.1-50 somehow)
106  - Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.1-50vl5
107  - applied new versioning policy, spec in utf-8
108
109* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl0.1
110- rebuild for Vine Linux 4.x
111
112* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl1
113- add Patch100 to fix infinite loop with 'grep -F'
114  thanks to M.H (<BTS:484>)
115- based on Fedora devel 2.5.1-57
116  * Mon Jan 22 2007 Tim Waugh <twaugh@redhat.com> 2.5.1-57
117  - Make preun scriptlet unconditionally succeed (bug #223697).
118  * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-56
119  - Fixed count of patterns when the last is an empty string (bug #204255).
120  * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-55
121  - Fix 'memory exhausted' errors by limiting in-memory buffer (bug #198165).
122  * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-54.1
123  - rebuild
124  * Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-54
125  - Applied upstream patch to fix '-D skip' (bug #189580).
126  * Mon Feb 20 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-53
127  - Applied Tim Robbins' patch for 'grep -w' (bug #179698).
128  * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.2
129  - bump again for double-long bug on ppc(64)
130  * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.1
131  - rebuilt for new gcc4.1 snapshot and glibc changes
132  * Fri Feb  3 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-52
133  - Prevent 'grep -P' from segfaulting (bug #171379).
134
135* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl2
136- changed Group to System Environment/Base
137
138* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl1
139- based on Fedora development 2.5.1-50
140  * Tue Jun 28 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-50
141  - Futher fixing for bug #161700.
142  * Mon Jun 27 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-49
143  - Fix 'grep -Fw' for encodings other than UTF-8 (bug #161700).
144  * Wed Apr 13 2005 Tim Waugh <twaugh@redhat.com>
145  - Build requires recent pcre-devel (bug #154626).
146  * Fri Jan  7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-47
147  - Run 'make check'.
148  - Fixed -w handling for EGexecute.  Now 'make check' passes.
149  - Cache MB_CUR_MAX value in egf-speedup patch.
150  - Fixed variable shadowing in egf-speedup patch.
151  - Removed redundant (and incorrect) code in prline.
152  * Fri Jan  7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-46
153  - More -w tests from Jakub Jelinek.
154  - Rebased on 2.5.1a.
155  * Fri Dec 31 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-45
156  - More tests (Jakub Jelinek).
157  - Jakub Jelinek's much improved -Fi algorithm.
158  - Removed bogus part of grep-2.5.1-fgrep patch.
159  * Tue Dec 21 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-44
160  - Fixed -Fi for multibyte input (bug #143079).
161  * Thu Dec 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-43
162  - Bypass kwset matching when ignoring case and processing multibyte input
163    (bug #143079).
164  * Tue Dec 14 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-42
165  - Further UTF-8 processing avoided since a '\n' byte is always an
166    end-of-line character in that encoding.
167  * Fri Dec  3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-41
168  - Fixed a busy loop in the egf-speedup patch (bug #140781).
169  * Thu Nov 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-40
170  - Fixed a bug in the fgrep patch, exposed by the dfa-optional patch
171    (bug #138558).
172  * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-39
173  - Fixed last patch.
174  * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-38
175  - Applied patch from Karsten Hopp to fix background colour problems with
176    --color output (bug #138913).
177  * Wed Nov 10 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-37
178  - Prevent false matches when DFA is disabled (bug #138558).
179  * Mon Nov  8 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-36
180  - Automatically disable DFA when processing multibyte input.  GREP_USE_DFA
181    environment variable overrides.
182  * Fri Nov  5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-35
183  - Fixes to egf-speedup patch: now it does not change any functionality,
184    as intended.
185  - GREP_NO_DFA now turns off the DFA engine, for performance testing.
186  * Thu Nov  4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-34
187  - More improvements to egf-speedup patch (bug #138076).
188  * Thu Nov  4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-33
189  - Small improvements to egf-speedup patch.
190  * Wed Nov  3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-32
191  - Remove mb-caching hack.
192  - Better multibyte handling in EGexecute() and Fexecute().
193  - Don't need regex.c changes in grep-2.5-i18n.patch.
194  * Wed Oct 13 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-31
195  - Make 'grep -F' avoid UTF-8 processing if the pattern contains no
196    multibyte characters (bug #133932).
197  * Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-30
198  - Applied patch from Robert Scheck to tidy spec file and add a URL
199    tag (bug #135185).
200
201* Sun Sep  5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-29vl1
202- based on Fedora development 2.5.1-29
203  * Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com>
204  - More build requirements (bug #125323).
205  * Tue May 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-27
206  - Fix dfa multibyte character class matching when -i is used (bug #123363).
207  - Use bracket patch before i18n patch to make it clear that the bug exists
208    upstream.
209  * Thu Feb 26 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-26
210  - Fix fgrep (bug #116909).
211  * Mon Jan  5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-24
212  - Work around glibc bug #112869 (segfault in re_compile_pattern).
213  - Avoid patching Makefile.am, to avoid automake/autoconf weirdness.
214  * Wed Dec 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-23
215  - Another multibyte efficiency bug-fix (bug #111800).
216  * Mon Dec  8 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-22
217  - Fixed [:alpha:]-type character classes (bug #108484).
218  - Fixed -o -i properly (bug #111489).
219  * Sat Dec  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-21
220  - Fixed 'fgrep -i' (bug #111614).
221  * Fri Nov 21 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-20
222  - Another two multibyte efficiency bug-fixes (bug #110524).
223  * Thu Nov  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-19
224  - Fixed a multibyte efficiency bug.
225  * Thu Nov  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-18
226  - Turn on multibyte efficiency patch again to shake out bugs.
227  * Wed Oct  8 2003 Tim Waugh <twaugh@redhat.com>
228  - Fixed man page bug (bug #106267).
229  * Thu Sep 18 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-17
230  - Use symlinks for egrep/fgrep, rather than shell script wrappers.
231  * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com>
232  - Fix debuginfo package.
233  * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-16
234  - Finally give up on making grep go fast. :-(
235  * Thu Jun 26 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-15
236  - Fixed grep -i bug introduced by cache.
237  * Mon Jun 23 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-14
238  - Redo the gofast patch (bug #97785).
239  * Thu Jun 12 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-13
240  - Fixed a bug in the gofast patch (bug #97266).
241  * Tue Jun 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-12
242  - Go faster (bug #69900).
243  - Fix man page.
244  * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-10
245  - Use system regex again.
246  * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-9
247  - Fixed bug in go-fast patch.
248  * Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-8
249  - Go fast (bug #69900).
250  - Run test suite.
251- rebuild with new toolchains
252- build with --disable-prel-regexp option
253
254* Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-7vl3
255- based on Rawhide 2.5.1-7
256  - Don't install /usr/share/info/dir.
257  - Fix -o -i (bug #72641).
258  - i18n patch.
259
260* Sat Jul  6 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
261- 2.5-0vl1
262- update to 2.5
263- change i18n patch
264
265* Sat Jan 20 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
266- 2.5-0vl1
267- update to 2.5
268- change i18n patch
269
270* Sat Jan 20 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
271- 2.4.2-4vl1
272- usr better macros (%%configure/%%makeinstall)
273
274* Mon Jun 19 2000 Jun Nishii <jun@vinelinux.org>
275- 2.4-3vl1
276- merge ja patch
277
278* Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
279- gzip info pages (Bug #9035)
280
281* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
282- fix description
283
284* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
285- update to 2.4.
286
287* Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
288- prereq install-info
289
290* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
291- auto rebuild in the new build environment (release 2)
292
293* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
294- upgraded to grep 2.3, added install-info %post/%preun for info
295
296* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
297- Injected new description and group.
298
299* Sat May 09 1998 Prospector System <bugs@redhat.com>
300- translations modified for de, fr, tr
301
302* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
303- updated to 2.2
304
305* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
306- updated from 2.0 to 2.1
307- spec file cleanups
308- added BuildRoot
309
310* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
311- built against glibc
Note: See TracBrowser for help on using the repository browser.