source: projects/specs/branches/6/g/grantlee/grantlee-vl.spec @ 2781

Revision 2781, 3.7 KB checked in by inagaki, 13 years ago (diff)

update: grantlee

Line 
1%define apidocs 0
2
3# apidocs disabled until we agree on a standard path.
4
5Name:           grantlee
6Summary:        Qt string template engine based on the Django template system
7Version:        0.1.8
8Release:        2%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.gitorious.org/grantlee/pages/Home
13
14Source0:        http://downloads.%{name}.org/%{name}-%{version}.tar.gz
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  qt4-devel qt4-designer cmake
18
19%if 0%{?apidocs}   
20BuildRequires:  doxygen
21%endif
22
23%description
24Grantlee is a plug-in based String Template system written
25using the Qt framework. The goals of the project are to make it easier for
26application developers to separate the structure of documents from the
27data they contain, opening the door for theming.
28
29The syntax is intended to follow the syntax of the Django template system,
30and the design of Django is reused in Grantlee.
31Django is covered by a BSD style license.
32
33Part of the design of both is that application developers can extend
34the syntax by implementing their own tags and filters. For details of
35how to do that, see the API documentation.
36
37For template authors, different applications using Grantlee will present
38the same interface and core syntax for creating new themes. For details of
39how to write templates, see the documentation.
40
41%package        devel
42Summary:        Development files for %{name}
43Group:          Development/Libraries
44Requires:       %{name} = %{version}-%{release}
45
46%description    devel
47The %{name}-devel package contains libraries and header files for
48developing applications that use %{name}.
49
50%package apidocs
51Group: Documentation
52Summary: Grantlee API documentation
53BuildArch: noarch
54
55%description apidocs
56This package includes the Grantlee API documentation in HTML
57format for easy browsing.
58
59%prep
60%setup -q -n %{name}-%{version}
61
62sed -i 's,${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX},%{_libdir},' CMakeLists.txt
63
64%build
65mkdir -p %{_target_platform}
66pushd %{_target_platform}
67%cmake .. -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=%{_prefix}
68popd
69
70make %{?_smp_mflags} -C %{_target_platform}
71
72%if 0%{?apidocs}
73make docs -C %{_target_platform}
74%endif
75
76%install
77rm -rf %{buildroot}
78make install -C %{_target_platform} DESTDIR=%{buildroot}
79
80%if 0%{?apidocs}
81mkdir -p %{buildroot}%{_docdir}/HTML/en/grantlee-apidocs
82cp -prf %{_target_platform}/apidocs/html/* %{buildroot}%{_docdir}/HTML/en/grantlee-apidocs
83%endif
84
85%clean
86rm -rf %{buildroot}
87
88%post -p /sbin/ldconfig
89
90%postun -p /sbin/ldconfig
91
92%files
93%defattr(-,root,root,-)
94%doc AUTHORS CHANGELOG COPYING.LIB README GOALS
95%{_libdir}/lib%{name}*.so.*
96%{_libdir}/%{name}
97
98%files devel
99%defattr(-,root,root,-)
100%{_includedir}/%{name}
101%{_includedir}/%{name}_core.h
102%{_includedir}/%{name}_templates.h
103%{_libdir}/lib%{name}*.so
104
105# %files apidocs
106# %{_docdir}/HTML/en/grantlee-apidocs
107
108%changelog
109* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.8-2
110- added BR: qt4-designer
111
112* Mon Jan 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.8-1
113- Initial build for VineSeed
114
115* Mon Sep 27 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.6-1
116- grantlee 0.1.6
117
118* Fri Aug 27 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.5-1
119- grantlee 0.1.5
120
121* Sun Jul 04 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.2-1
122- grantlee 0.1.2
123
124* Tue May 18 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.1-3
125- disabled apidocs until we find a standard path
126
127* Tue May 11 2010 Jaroslav Reznik <jreznik@redhat.com> 0.1.1-2
128- added -apidocs subpackage
129
130* Sun May 09 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.1-1
131- grantlee 0.1.1
132- fixed Group
133
134* Thu Apr 15 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.0-1
135- initial fedora release
Note: See TracBrowser for help on using the repository browser.