source: projects/specs/branches/6/g/gpsd/gpsd-vl.spec @ 1942

Revision 1942, 9.5 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3
4Summary: Service daemon for mediating access to a GPS
5Summary(ja): GPS にアクセスするためのサービスデーモン
6
7Name: gpsd
8Version: 2.95
9Release: 2%{?_dist_release}
10
11Group: System Environment/Daemons
12License: BSD
13URL: http://developer.berlios.de/projects/gpsd/
14Source0: http://download.berlios.de/gpsd/%{name}-%{version}.tar.gz
15Source10: gpsd.init
16Source11: gpsd.sysconfig
17Patch0: gpsd-2.95-silentmake.patch
18Patch1: gpsd-2.95-hotplugvars.patch
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
22BuildRequires: libusb1-devel desktop-file-utils
23BuildRequires: libudev-devel
24
25Requires: udev
26Requires(post): /sbin/ldconfig
27Requires(post): /sbin/chkconfig
28Requires(preun): initscripts
29Requires(preun): /sbin/chkconfig
30Requires(postun): /sbin/ldconfig
31
32%description
33gpsd is a service daemon that mediates access to a GPS sensor
34connected to the host computer by serial or USB interface, making its
35data on the location/course/velocity of the sensor available to be
36queried on TCP port 2947 of the host computer.  With gpsd, multiple
37GPS client applications (such as navigational and wardriving software)
38can share access to a GPS without contention or loss of data.  Also,
39gpsd responds to queries with a format that is substantially easier to
40parse than NMEA 0183. 
41
42%package devel
43Summary: Client libraries in C and Python for talking to a running gpsd or GPS
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Requires: pkgconfig
47
48%description devel
49This package provides C header files and python modules for the gpsd shared
50libraries that manage access to a GPS for applications
51
52%package clients
53Summary: Clients for gpsd
54Summary(ja): gpsd 用クライアント
55Group: Applications/System
56
57%description clients
58xgps is a simple test client for gpsd with an X interface. It displays
59current GPS position/time/velocity information and (for GPSes that
60support the feature) the locations of accessible satellites.
61
62xgpsspeed is a speedometer that uses position information from the GPS.
63It accepts an -h option and optional argument as for gps, or a -v option
64to dump the package version and exit. Additionally, it accepts -rv
65(reverse video) and -nc (needle color) options.
66
67cgps resembles xgps, but without the pictorial satellite display.  It
68can run on a serial terminal or terminal emulator.
69
70
71%prep
72%setup -q
73%patch0 -p1 -b .silentmake
74%patch1 -p1 -b .hotplugvars
75
76
77%build
78%configure --enable-dbus --disable-static --disable-libQgpsmm
79sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
80sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
81make %{?_smp_mflags}
82
83
84%install
85rm -rf %{buildroot}
86make DESTDIR=%{buildroot} install
87
88# init scripts
89%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/init.d
90%{__install} -p -m 0755 %{SOURCE10} \
91        %{buildroot}%{_sysconfdir}/init.d/gpsd
92
93%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
94%{__install} -p -m 0644 %{SOURCE11} \
95        %{buildroot}%{_sysconfdir}/sysconfig/gpsd
96
97# udev rules
98%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/udev/rules.d
99%{__install} -p -m 0644 gpsd.rules \
100        %{buildroot}%{_sysconfdir}/udev/rules.d/99-gpsd.rules
101
102# hotplug script
103%{__install} -d -m 0755 %{buildroot}/lib/udev
104%{__install} -p -m 0755 gpsd.hotplug gpsd.hotplug.wrapper %{buildroot}/lib/udev
105
106# remove .la files
107find %{buildroot} -name '*.la' -exec rm -f {} ';'
108
109# fix non-executable python script
110%{__chmod} +x %{buildroot}%{python_sitearch}/gps/gps.py
111
112# Install the .desktop files
113desktop-file-install --vendor fedora \
114        --dir %{buildroot}%{_datadir}/applications \
115        --add-category X-Fedora \
116        packaging/X11/xgps.desktop
117desktop-file-install --vendor fedora \
118        --dir %{buildroot}%{_datadir}/applications \
119        --add-category X-Fedora \
120        packaging/X11/xgpsspeed.desktop
121
122# Install logo icon for .desktop files
123%{__install} -d -m 0755 %{buildroot}%{_datadir}/gpsd
124%{__install} -p -m 0644 packaging/X11/gpsd-logo.png %{buildroot}%{_datadir}/gpsd/gpsd-logo.png
125
126
127%clean
128rm -rf %{buildroot}
129
130%post
131/sbin/ldconfig
132/sbin/chkconfig --add %{name}
133
134%preun
135if [ $1 = 0 ]; then
136        /sbin/service %{name} stop > /dev/null 2>&1 || true
137        /sbin/chkconfig --del %{name}
138fi
139
140%postun -p /sbin/ldconfig
141
142
143%files
144%defattr(-,root,root,-)
145%doc README INSTALL COPYING
146%config(noreplace) %{_sysconfdir}/init.d/%{name}
147%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
148%config(noreplace) %{_sysconfdir}/udev/rules.d/*
149%{_sbindir}/gpsd
150%{_bindir}/gpsprof
151%{_bindir}/gpsmon
152%{_bindir}/gpsctl
153%{_libdir}/libgps*.so.*
154/lib/udev/gpsd*
155%{python_sitearch}/gps*
156%exclude %{python_sitearch}/gps/fake*
157%ifarch x86_64
158%{python_sitelib}/gps*
159%endif
160%{_mandir}/man8/gpsd.8*
161%{_mandir}/man1/gpsprof.1*
162%{_mandir}/man1/gpsmon.1*
163%{_mandir}/man1/gpsctl.1*
164
165%files devel
166%defattr(-,root,root,-)
167%doc TODO
168%{_bindir}/gpsfake
169%{_libdir}/libgps*.so
170%{_libdir}/pkgconfig/*.pc
171%{python_sitearch}/gps/fake*
172%{_includedir}/gps.h
173%{_includedir}/libgpsmm.h
174%{_includedir}/gpsd.h
175%{_mandir}/man1/gpsfake.1*
176%{_mandir}/man3/libgps.3*
177%{_mandir}/man3/libgpsmm.3*
178%{_mandir}/man3/libgpsd.3*
179%{_mandir}/man5/rtcm-104.5*
180%{_mandir}/man5/srec.5*
181
182%files clients
183%defattr(-,root,root,-)
184%{_bindir}/cgps
185%{_bindir}/gpscat
186%{_bindir}/gpsdecode
187%{_bindir}/gpspipe
188%{_bindir}/gpxlogger
189%{_bindir}/lcdgps
190%{_bindir}/xgps
191%{_bindir}/xgpsspeed
192%{_mandir}/man1/gps.1*
193%{_mandir}/man1/gpsdecode.1*
194%{_mandir}/man1/gpspipe.1*
195%{_mandir}/man1/lcdgps.1*
196%{_mandir}/man1/xgps.1*
197%{_mandir}/man1/xgpsspeed.1*
198%{_mandir}/man1/cgps.1*
199%{_mandir}/man1/gpscat.1*
200%{_datadir}/applications/*.desktop
201%dir %{_datadir}/gpsd
202%{_datadir}/gpsd/gpsd-logo.png
203
204
205%changelog
206* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.95-2
207- rebuilt with rpm-4.8.1 for pkg-config
208
209* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
210- new upstream release
211- merge spec, patch, source from fedora
212
213* Mon Feb 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.37-3
214- add BuildRequires: libXp-devel
215
216* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.37-2
217- rebuilt with python-2.6.4
218
219* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.37-1
220- initial build for Vine Linux
221
222* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.37-3
223- Rebuild for Python 2.6
224
225* Wed Mar 19 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-2
226- moving gpspacket.so python lib to main package
227- adding zero.patch to make ZEROIZE error go away on fedora 7
228
229* Wed Feb 27 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-1
230- update to 2.37
231- removed install-gpsd_config.h.patch
232- installed pkgconfig files in devel package
233- added patch to install python modules in sitearch
234- removing rpath from inclucded libtool
235- moving X11 app-defaults to datadir
236- using macros for commands in install; using install instead of cp and mkdir
237- cleaning up spaces/tabs for rpmlint
238
239* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.34-9
240- Autorebuild for GCC 4.3
241
242* Sun Aug 19 2007 Matthew Truch <matt at truch.net> - 2.34-8
243- Patch Makefile to also install gpsd_config.h as needed by
244  libgpsmm.h.  Redhat BZ 253433.
245
246* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-7
247- Make sure the logo is actually included (via the spec file).
248  I need to wake up before I try even trivial updates. 
249
250* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-6
251- Learn how to use search and replace (aka fix all instances of
252  gpsd-logo.png spelled incorrectly as gspd-logo.png).
253
254* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-5
255- Fix desktop file and logo file name.
256
257* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-4
258- Include icon for .desktop files per BZ 241428
259
260* Tue Mar 20 2007 Michael Schwendt <mschwendt[AT]users.sf.net> - 2.34-3
261- Bump release for FE5 -> Fedora 7 upgrade path.
262
263* Tue Feb 27 2007 Matthew Truch <matt at truch.net> - 2.34-2
264- BR python-devel instead of python to make it build. 
265
266* Tue Feb 27 2007 Matthew Truch <matt at truch.net> - 2.34-1
267- Upgrade to 2.34.
268- Get rid of %%makeinstall (which was never needed).
269- Possibly fix hotplug issuses (BZ 219750).
270- Use %%python_sitelib for python site-files stuff.
271
272* Sat Dec 9 2006 Matthew Truch <matt at truch.net> - 2.33-6
273- Rebuild to pull in new version of python.
274
275* Tue Sep 26 2006 Matthew Truch <matt at truch.net> - 2.33-5
276- Remove openmotif requirment, and switch to lesstif.
277
278* Mon Aug 28 2006 Matthew Truch <matt at truch.net> - 2.33-4
279- Bump release for rebuild in prep. for FC6.
280
281* Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-3
282- Actually, was a missing BR glib-dbus-devel. Ooops.
283
284* Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-2
285- Missing BR glib-devel
286
287* Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-1
288- Update to version 2.33
289
290* Wed Apr 19 2006 Matthew Truch <matt at truch.net> - 2.32-5
291- Don't --enable-tnt in build as it causes some gpses to not work
292  properly with sattelite view mode.  See bugzilla bug 189220.
293
294* Thu Apr 13 2006 Matthew Truch <matt at truch.net> - 2.32-4
295- Add dbus-glib to BuildRequires as needed for build.
296
297* Sun Apr 9 2006 Matthew Truch <matt at truch.net> - 2.32-3
298- Include xmlto and python in buildrequires so things build right.
299- Don't package static library file. 
300
301* Wed Apr 5 2006 Matthew Truch <matt at truch.net> - 2.32-2
302- Use ye olde %%{?dist} tag.
303
304* Wed Apr 5 2006 Matthew Truch <matt at truch.net> - 2.32-1
305- Initial Fedora Extras specfile
Note: See TracBrowser for help on using the repository browser.