source: projects/specs/branches/6/g/gprolog/gprolog-vl.spec @ 3753

Revision 3753, 4.7 KB checked in by inagaki, 13 years ago (diff)

update: gprolog

Line 
1Summary: GNU Prolog is a free Prolog compiler with constraint solving over Finite Domains
2Summary(ja): GNU Prolog: 有限領域の制約解決に適したフリーな Prolog コンパイラ
3Name: gprolog
4Version: 1.3.1
5Release: 2%{?_dist_release}
6
7License: GPLv2
8Group: Development/Languages
9URL: http://gprolog.inria.fr/
10
11Source: ftp://ftp.inria.fr/Projects/loco/%{name}/%{name}-%{version}.tar.gz
12
13Buildroot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: sed
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19Packager: inagaki
20
21%description
22GNU Prolog is a native Prolog compiler with constraint solving over finite
23domains (FD) developed by Daniel Diaz (http://loco.inria.fr/~diaz).
24
25GNU Prolog is a very efficient native compiler producing (small) stand-alone
26executables. GNU-Prolog also offers a classical top-level+debugger.
27
28GNU Prolog conforms to the ISO standard for Prolog but also includes a lot
29of extensions (global variables, DCG, sockets, OS interface,...).
30
31GNU Prolog also includes a powerful constraint solver over finite domains
32with many predefined constraints+heuristics.
33
34More information can be found at http://www.gnu.org/software/prolog
35or better at http://gprolog.inria.fr.
36
37%description -l ja
38GNU Prolog は有限領域 (FD) の制約解決に適したネイティブ Prolog コンパイラで、
39Daniel Diaz (http://loco.inria.fr/~diaz) によって開発されました。
40GNU Prolog は (小さな) スタンドアロンの実行可能形式を生成する、非常に効率の
41良いネイティブコンパイラです。
42GNU Prolog は Prolog の ISO 規格に準拠しているだけでなく、多くの拡張
43(グローバル変数、DCG、ソケット、OS インタフェース、……) も含んでいます。
44GNU Prolog は多くの定義済の制約条件と発見的手法を用いて、有限領域の問題に
45対して強力な制約解決機能も提供します。
46詳しい情報は http://www.gnu.org/software/prolog や http://gprolog.inria.fr
47(こちらの方が良い)で見つけることができます。
48
49%prep
50%setup -q
51
52%build
53cd src
54
55# gprolog only acccept -O0 and don't like -fomit-frame-pointer
56
57CFLG="$(echo $RPM_OPT_FLAGS | sed -s "s/\-O2/-O1/g" \
58                    | sed -e "s/\-fomit-frame-pointer//")"
59
60# Based on a gentoo ebuild (??)
61CFLG="$CFLG -funsigned-char"
62
63./configure \
64    --with-install-dir=$RPM_BUILD_ROOT%{_libdir}/%{name}-%{version} \
65    --without-links-dir \
66    --with-examples-dir=$RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/examples \
67    --with-doc-dir=dist-doc \
68    --with-c-flags="$CFLG"
69
70make
71
72%check
73cd src
74#
75export PATH=$RPM_BUILD_ROOT%{_bindir}:$PATH
76#
77make check
78
79%install
80rm -rf $RPM_BUILD_ROOT
81rm -rf dist-doc
82
83pushd src
84make install-strip
85popd
86mkdir $RPM_BUILD_ROOT%{_bindir}
87pushd $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/bin
88for i in *; do
89        ln -s ../lib/%{name}-%{version}/bin/$i $RPM_BUILD_ROOT%{_bindir}/$i
90done
91
92#rm -rf docs_to_install
93#mkdir -p docs_to_install
94#mv $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/doc/* docs_to_install
95#rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/{COPYING,ChangeLog,NEWS,VERSION}
96
97rm -f dist-doc/*.{chm,dvi,ps}
98rm -f dist-doc/compil-scheme.pdf
99rm -f dist-doc/debug-box.pdf
100
101for file in ChangeLog COPYING NEWS VERSION
102do
103    rm -f $RPM_BUILD_ROOT%{_libdir}/gprolog-%{version}/$file
104done
105
106popd
107
108
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files
114%defattr(-,root,root)
115%doc README COPYING ChangeLog NEWS PROBLEMS VERSION
116%doc src/dist-doc/*
117%{_bindir}/*
118%{_libdir}/%{name}-%{version}/bin
119%{_libdir}/%{name}-%{version}/examples
120%{_libdir}/%{name}-%{version}/include
121%{_libdir}/%{name}-%{version}/lib
122
123%changelog
124* Sun May  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.1-2
125- rebuilt with current VineSeed
126- fixed compile option
127
128* Wed Mar 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.1-1
129- updated to 1.3.1
130- applied new versioning policy
131- spec in UTF-8
132
133* Tue Aug 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.17-0vl3
134- rebuild for VinePlus/3.0 and VineSeedPlus
135- updated Japanese Summary and description
136- merged VinePlus/2.5 spec file
137  * Fri Jul 23 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.16-1vl2
138  - Added Summary(ja) and %%description -l ja.
139
140* Sat Feb 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.17-0vl2
141- merged VinePlus spec file
142  * Thu Feb 12 2004 by IKEDA Katsumi <ikedak@rg8.so-net.ne.jp>
143  - 1.2.161vl1
144  - Modified %Vendor, %Buildroot and %build.
145  - Add %Distribution.
146  - Remove %Packager and %Prefix.
147- added --with-examples-dir to ./configure
148- fixed %files section to exclude %{_libdir}/%{name}-%{version}/doc
149
150* Fri Feb 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.17-0vl1
151- rebuild for Vine Linux
152- s/Copyright/License/
153- use more rpm macros
154
155* Tue Jul 25 2000 Daniel Diaz <Daniel.Diaz@inria.fr>
156- initial specfile
Note: See TracBrowser for help on using the repository browser.