source: projects/specs/branches/6/g/gpgme/gpgme-vl.spec @ 8903

Revision 8903, 5.7 KB checked in by iwamoto, 10 years ago (diff)

gpgme: fix CVE-2014-3564

Line 
1%define _gnupg_ver              1.4.0
2%define _libgpg_error_ver       1.4
3
4Name:           gpgme
5Summary:        GPGME - GnuPG Made Easy
6Summary(ja):    GPGME - GnuPG Made Easy
7Version:        1.3.0
8Release:        2%{?_dist_release}
9
10License:        LGPL
11Group:          System Environment/Libraries
12URL:            http://www.gnupg.org/related_software/gpgme/
13Source:         ftp://ftp.gnupg.org/gcrypt/gpgme/%{name}-%{version}.tar.bz2
14Patch10:        gpgme-1.3.0_CVE-2014-3564.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  gnupg >= %{_gnupg_ver}
18BuildRequires:  libgpg-error-devel >= %{_libgpg_error_ver}
19BuildRequires:  libassuan-devel >= 2
20Requires:       gnupg >= %{_gnupg_ver}
21Requires:       libgpg-error >= %{_libgpg_error_ver}
22
23Obsoletes:      gpgme10
24Provides:       gpgme10
25
26Vendor:         Project Vine
27Distribution:   Vine Linux
28
29%description
30GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
31for applications. It provides a High-Level Crypto API for encryption,
32decryption, signing, signature verification and key management. Currently it
33uses GnuPG as it's backend but the API isn't restricted to this engine; in
34fact it is planned to add other backends to it.
35
36%description -l ja
37GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
38るように設計されたライブラリです。暗号化や復号、署名、署名の検証、鍵の管理の
39ための高レベルの暗号 API を提供します。
40現在のところ、バックエンドとして GnuPG を使用しますが、API はこのエンジンに限
41定されません。実際、他のバックエンドを追加することが計画されています。
42
43%package devel
44Summary:        GnuPG Made Easy (GPGME) Header files and libraries for development
45Summary(ja):    GnuPG Made Easy (GPGME) 開発用ヘッダーファイル・ライブラリ
46Group:          Development/Libraries
47Requires:       %{name} = %{version}
48Requires:       libgpg-error-devel >= 0.5
49Requires:       libassuan-devel >= 2
50Requires(post): install-info
51Requires(preun): install-info
52Obsoletes:      %{name} < 0.3.16-0vl2
53Obsoletes:      gpgme10-devel
54Provides:       gpgme10-devel
55
56%description devel
57GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
58for applications.
59
60Install this package if you want to develop applications that will use the
61gpgme library.
62
63%description -l ja devel
64GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
65るように設計されたライブラリです。
66
67GPGME ライブラリを使用するアプリケーションを開発するのであれば、このパッケー
68ジをインストールしてください。
69
70%prep
71%setup -q
72%patch10 -p1 -b .CVE-2014-3564
73
74%build
75%configure --without-gpgsm
76%__make
77
78%install
79%__rm -rf %{buildroot}
80%{makeinstall}
81
82# remove unneeded files
83%__rm -rf %{buildroot}%{_datadir}/common-lisp
84%__rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
85%__rm -f $RPM_BUILD_ROOT%{_infodir}/dir
86
87%clean
88%__rm -rf %{buildroot}
89
90%post -p /sbin/ldconfig
91
92%postun -p /sbin/ldconfig
93
94%triggerun -- %{name} < 0.3.16-0vl2
95/sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
96
97%post devel
98/sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
99
100%preun devel
101if [ "$1" = 0 ] ; then
102        /sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
103fi
104
105%triggerpostun devel -- %{name} < 0.3.16-0vl2, gpgme10-devel
106/sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
107
108%files
109%defattr(-,root,root)
110%doc AUTHORS COPYING* ChangeLog INSTALL NEWS README THANKS TODO
111%{_libdir}/libgpgme*.so.*
112
113%files devel
114%defattr(-,root,root)
115%{_bindir}/gpgme-config
116%{_libdir}/libgpgme*.so
117%{_datadir}/aclocal/gpgme.m4
118%{_includedir}/*
119%{_infodir}/*
120
121%changelog
122* Fri Aug 15 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.0-2
123- add patch10 for fix CVE-2014-3564
124
125* Tue Apr  5 2011 IWAI, Masaharu <iwai@alib.jp> 1.3.0-1
126- new upstream release
127- add BuildRequires: libassuan-devel >= 2
128- add Requires: libassuan-devel >= 2 for devel subpackage
129- update GnuPG min version
130
131* Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.8-1
132- new upstream release
133
134* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-2vl5
135- removed *.la
136- spec in utf-8
137
138* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-1vl5
139- applied new versioning policy
140
141* Fri Mar 09 2007 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.1.4-0vl1
142- upstream release
143- add new macros: %%_gnupg_ver, %%_libgpg_error_ver
144- update %%_gnupg_ver to 1.3.0
145- update %%_libgpg_error_ver to 1.4
146
147* Tue Sep 27 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.3-0vl1
148- upstream release
149
150* Sat Mar 12 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.2-0vl3
151- add Obsoletes/Provides: gpgme10{,-devel}
152
153* Sun Feb 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
154- fix spec file's encoding from iso-2022-jp to euc-jp
155- add PreReq: ldconfig
156- add PreReq: install-info (devel)
157- change group to System Environment/Libraries (main)
158- add poor Japanese description
159
160* Tue Feb 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
161- upstream release
162- change license from GPL to LGPL
163- update {Build,}Requires for GnuPG (>= 1.2.2)
164- add (Build)Requires: libgpg-error(-devel) >= 0.5
165- add docs
166- run ldconfig at post/postun
167- separate devel package
168  - Requires: libgpg-error-devel
169  - Obsoletes: gpgme <= 0.3.16
170
171* Sun Apr 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.3.16-0vl1
172- update to 0.3.16
173- s/Copyright/License/
174- update URL
175
176* Fri Mar  7 2003 IWAI Masaharu <iwai@alib.jp> 0.3.15-0vl1
177- update to 0.3.15
178- update {Build,}Requires for GnuPG
179
180* Mon Sep 23 2002 IWAI Masaharu <iwai@alib.jp> 0.3.11-0vl1
181- update to 0.3.11
182- added {Build,}Requires: gnupg = 1.0.7
183- added info files
184- added %%post and %%preun section for info files
185- fixed %%install section (executing rm command)
186
187* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.1-0vl1
188- initial release
189
Note: See TracBrowser for help on using the repository browser.