source: projects/specs/branches/6/g/google-perftools/google-perftools-vl.spec @ 521

Revision 521, 2.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Very fast malloc and performance analysis tools
2Summary(ja):    超高速な malloc と性能分析ツール
3Name:           google-perftools
4Version:        1.4
5Release:        1%{?_dist_release}
6License:        BSD
7Group:          Development/Tools
8URL:            http://code.google.com/p/google-perftools/
9Source0:        http://google-perftools.googlecode.com/files/google-perftools-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11# Still broken, RH bz 238390
12ExcludeArch:    ppc64
13%ifnarch ppc ppc64
14BuildRequires:  libunwind-devel
15%endif
16
17%description
18Perf Tools is a collection of performance analysis tools, including a
19high-performance multi-threaded malloc() implementation that works
20particularly well with threads and STL, a thread-friendly heap-checker,
21a heap profiler, and a cpu-profiler.
22
23%package devel
24Summary:        Development libraries and headers for google-perftools
25Group:          Development/Libraries
26Requires:       %{name} = %{version}-%{release}
27
28%description devel
29Libraries and headers for developing applications that use google-perftools.
30
31%prep
32%setup -q
33
34%build
35%configure --disable-static
36# Bad rpath!
37sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
38sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
39# Can't build with smp_mflags
40make
41
42%install
43rm -rf $RPM_BUILD_ROOT
44make DESTDIR=$RPM_BUILD_ROOT docdir=%{_docdir}/%{name}-%{version}/ install
45find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
46
47# Zero files
48rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/NEWS
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%check
54# The libraries aren't installed on the system yet. :P
55# The tests work fine for me locally, but some of them fail inside mock.
56# LD_LIBRARY_PATH=./.libs make check
57
58%post -p /sbin/ldconfig
59
60%postun -p /sbin/ldconfig
61
62%files
63%defattr(-,root,root,-)
64%{_bindir}/pprof
65%{_mandir}/man1/*
66%{_docdir}/%{name}-%{version}/
67%{_libdir}/*.so.*
68
69%files devel
70%defattr(-,root,root,-)
71%{_includedir}/google
72%{_libdir}/*.so
73
74%changelog
75* Wed Oct 14 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4-1
76- new upstream release
77
78* Tue Jun 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.91-0vl1
79- initial build for Vine Linux
80
81* Sun Apr 29 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.91-3
82- The tests work fine for me locally, but some of them fail inside mock.
83
84* Sun Apr 29 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.91-2
85- no support for ppc yet
86
87* Mon Apr 23 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.91-1
88- alright, lets see if this works now.
89
90* Wed Oct 13 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.3-2
91- change group to Development/Tools
92
93* Mon Oct 10 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.3-1
94- initial package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.