source: projects/specs/branches/6/g/google-gadgets/google-gadgets-vl.spec @ 4671

Revision 4671, 8.5 KB checked in by yasumichi, 13 years ago (diff)

xulrunner-2.0 でビルドできないことへの対処

Line 
1#define svnrev   1449
2#define alphatag 20090430svn%{svnrev}
3
4Name:           google-gadgets
5Summary:        Google Gadgets platform for Linux
6Version:        0.11.2
7Release:        2%{?_dist_release}
8
9Group:          User Interface/Desktops
10License:        ASL 2.0
11URL:            http://code.google.com/p/google-gadgets-for-linux/
12
13Source0:        http://google-gadgets-for-linux.googlecode.com/files/google-gadgets-for-linux-%{version}.tar.bz2
14#Source0:        %{name}-%{version}-r%{svnrev}.tar.bz2
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  curl-devel libxml2-devel zlib-devel libtool-ltdl-devel
19# still needed even if we're not buliding gtkmoz element, for JavaScript
20#%%if %{?_dist_release} == "vl5"
21#BuildRequires:  xulrunner-devel-unstable
22#%%else
23#BuildRequires:  xulrunner-devel
24#%%endif
25BuildRequires:  WebKit-gtk-devel
26BuildRequires:  dbus-devel gstreamer-devel gstreamer-plugins-base-devel
27BuildRequires:  cairo-devel gtk2-devel librsvg2-devel
28BuildRequires:  qt4-devel zip
29# Desktop integration
30BuildRequires:  NetworkManager-devel startup-notification-devel
31# libxml2-devel needed for desktop file generation
32BuildRequires:  libxml2-devel desktop-file-utils
33BuildRequires:  pkgconfig
34Requires:       %{name}-frontend = %{version}-%{release}
35Requires:       hicolor-icon-theme
36
37%description
38Google Gadgets for Linux provides a platform for running desktop
39gadgets under Linux, catering to the unique needs of Linux users. It
40can run, without modification, many Google Desktop gadgets as well as
41the Universal Gadgets on iGoogle.
42
43
44%package        gtk
45Summary:        GTK+ front-end for %{name}
46Summary(ja):    Google Gadgets の GTK+ 版フロントエンド
47Group:          User Interface/Desktops
48Requires:       %{name} = %{version}-%{release}
49Provides:       %{name}-frontend = %{version}-%{release}
50
51%description    gtk
52The %{name}-gtk package contains the GTK+ front-end for %{name}.
53
54
55%package        qt
56Summary:        Qt front-end for %{name}
57Summary(ja):    Google Gadgets の Qt 版フロントエンド
58Group:          User Interface/Desktops
59Requires:       %{name} = %{version}-%{release}
60Provides:       %{name}-frontend = %{version}-%{release}
61
62%description    qt
63The %{name}-qt package contains the Qt front-end for %{name}.
64
65
66%package        devel
67Summary:        Development files for %{name}
68Summary(ja):    %{name} の開発用ファイル
69Group:          Development/Libraries
70Requires:       %{name} = %{version}-%{release}
71Requires:       pkgconfig dbus-devel gtk2-devel qt4-devel
72Requires:       %{name}-gtk
73Requires:       %{name}-qt
74
75%description    devel
76The %{name}-devel package contains libraries and header files for
77developing applications that use %{name}.
78
79
80%prep
81%setup -q -n %{name}-for-linux-%{version}
82# Permission fixes
83chmod -x ggadget/qt/utilities.h
84# Fix invalid desktop file MIME type
85# http://code.google.com/p/google-gadgets-for-linux/issues/detail?id=360
86for f in hosts/*/ggl-*.desktop.in; do
87    sed -i 's|;app/gg;|;|' $f
88done
89
90
91%build
92#autotools/bootstrap.sh
93#ln -s %{_datadir}/automake-*/mkinstalldirs libltdl/
94
95%configure --disable-static \
96           --with-browser-plugins-dir=%{_libdir}/mozilla/plugins \
97           --disable-gtkmoz-browser-element --disable-smjs-script-runtime
98
99# Rpath fix by Mamoru Tasaka
100# we don't want to obliterate all RPATHs, since it is used during build
101# Add library search path
102sed -i.libdir_syssearch -e \
103 '/sys_lib_dlsearch_path_spec/s|/usr/lib |/usr/lib /usr/lib64 /lib /lib64 |' \
104 configure
105# Remove the redundant RPATH for %%{_libdir}, already searched by Fedora libtool
106sed -i.extra_R -e \
107 's|-R\$(libdir)||' \
108 hosts/*/Makefile.in
109
110# default compile flags are impossibly strict
111make %{?_smp_mflags} DEFAULT_COMPILE_FLAGS=
112
113# Remove quotes from .pc files
114find . -name '*.pc' -exec sed -i 's|\"||g' '{}' \;
115
116
117%install
118rm -rf $RPM_BUILD_ROOT
119make install DESTDIR=$RPM_BUILD_ROOT \
120     INSTALL="install -p" CPPROG="cp -p"
121find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
122
123# reinstall desktop files
124for i in gtk qt; do
125  desktop-file-install \
126    --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
127    --delete-original \
128    $RPM_BUILD_ROOT%{_datadir}/applications/ggl-$i.desktop
129done
130
131# wipe prematurely-generated MIME info
132rm -rf $RPM_BUILD_ROOT%{_datadir}/mime
133rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
134
135%clean
136rm -rf $RPM_BUILD_ROOT
137
138
139%post
140/sbin/ldconfig
141touch --no-create %{_datadir}/icons/hicolor || :
142
143%postun
144/sbin/ldconfig
145if [ $1 -eq 0 ] ; then
146    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
147    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
148fi
149
150%posttrans
151gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
152
153%post gtk
154/sbin/ldconfig
155update-desktop-database &> /dev/null || :
156
157%postun gtk
158/sbin/ldconfig
159update-desktop-database &> /dev/null || :
160
161%post qt
162/sbin/ldconfig
163update-desktop-database &> /dev/null || :
164
165%postun qt
166/sbin/ldconfig
167update-desktop-database &> /dev/null || :
168
169
170%files
171%defattr(-,root,root,-)
172%doc AUTHORS COPYING README
173%{_libdir}/google-gadgets
174#%%exclude %{_libdir}/google-gadgets/gtkmoz-browser-child
175%exclude %{_libdir}/google-gadgets/modules/gtk*.so
176%exclude %{_libdir}/google-gadgets/modules/qt*.so
177%exclude %{_libdir}/google-gadgets/include
178%{_libdir}/lib*.so.*
179%exclude %{_libdir}/lib*gtk*
180%exclude %{_libdir}/lib*qt*
181%{_datadir}/google-gadgets
182%{_datadir}/pixmaps/google-gadgets.png
183%{_datadir}/icons/hicolor/*/*/*.png
184
185%files gtk
186%defattr(-,root,root,-)
187%{_bindir}/ggl-gtk
188%{_libdir}/libggadget-gtk*.so.*
189#%%{_libdir}/google-gadgets/gtkmoz-browser-child
190%{_libdir}/google-gadgets/modules/gtk*.so
191%{_datadir}/applications/*gtk.desktop
192%{_datadir}/applications/*designer.desktop
193
194%files qt
195%defattr(-,root,root,-)
196%{_bindir}/ggl-qt
197%{_libdir}/libggadget-qt*.so.*
198%{_libdir}/google-gadgets/modules/qt*.so
199%{_datadir}/applications/*qt.desktop
200
201%files devel
202%defattr(-,root,root,-)
203%{_includedir}/google-gadgets
204%{_libdir}/lib*.so
205%{_libdir}/google-gadgets/include
206%{_libdir}/pkgconfig/*.pc
207
208
209%changelog
210* Thu Aug 18 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.11.2-2
211- not work with xulrunner 2.0, remove from BR.
212- add --disable-gtkmoz-browser-element , --disable-smjs-script-runtime
213
214* Thu Sep 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.2-1
215- new upstream release
216- built with rpm-4.8.1 for pkg-config
217- dropt Patch0
218- added BR: WebKit-gtk-devel
219- removed invalid MIME entry from .desktop files
220
221* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.1-1
222- new upstream release
223
224* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.0-2
225- Initial build for Vine Linux
226
227* Wed Jul  1 2009 Michel Salim <michel@erdos.localdomain> - 0.11.0-1
228- Update to 0.11.0
229
230* Sat May  2 2009 Michel Salim <salimma@fedoraproject.org> - 0.10.6-0.1.20090430svn1449%{?dist}
231- Update to SVN checkout, for xulrunner 1.9.1 compatibility
232
233* Mon Apr 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-6
234- Rebuild against newer gecko
235
236* Fri Mar 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-4
237- Rebuild against newer gecko
238
239* Fri Mar 06 2009 Jan Horak <jhorak@redhat.com> - 0.10.5-3
240- Rebuild against newer gecko
241
242* Wed Feb 04 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-2
243- Rebuild against newer gecko
244
245* Wed Jan 14 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.10.5-1
246- 0.10.5, req'd by kde
247
248* Tue Dec 30 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.4-2
249- BR: Network-Manager-devel, startup-notification-devel
250- Pass the browser plugin directory to ./configure
251- Move designer desktop entry to -gtk subpackage
252
253* Sat Dec 20 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.4-1
254- Update to 0.10.4 (#477251)
255- -devel: Requires: %%name-gtk %%name-qt (devel symlinks)
256- BR: pkgconfig (automatic pkgconfig deps)
257
258* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.3-1
259- Update to 0.10.3
260
261* Sat Nov  8 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.1-5
262- s/qt-devel/qt4-devel/
263- -qt: fix summary
264
265* Tue Sep  2 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-4
266- Unquote version strings in .pc files
267
268* Thu Aug 28 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-3
269- RPATH and timestamp fixes from Mamoru Tasaka
270
271* Tue Aug 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-2
272- Fix desktop file creation
273
274* Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-1
275- Update to 0.10.1
276
277* Mon Jul 14 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.0-1
278- Update to 0.10.0
279- Add missing dependencies for -devel subpackage
280
281* Sun Jul  6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.3-1
282- Update to 0.9.3
283
284* Fri Jun  6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.1-1
285- Initial package
Note: See TracBrowser for help on using the repository browser.